Author Topic: Canon EOS M  (Read 1475888 times)

kolen

  • New to the forum
  • *
  • Posts: 22
Re: EOSM-Updated ML for 2.02 firmware
« Reply #250 on: June 27, 2014, 08:40:53 AM »
Thanks.
For the PDAF pixel problem, I mean those pixel will show up in the RAW video like a hot pixel and requires clean up.

velihukka

  • New to the forum
  • *
  • Posts: 9
Re: EOSM-Updated ML for 2.02 firmware
« Reply #251 on: June 27, 2014, 09:26:38 AM »
Thanks.
For the PDAF pixel problem, I mean those pixel will show up in the RAW video like a hot pixel and requires clean up.

Oh, I get it. Yes, it does have it, though again, I can't really shoot RAW because of my card.
I always seem to get the crappy stuff and somehow make them great.

2blackbar

  • Hero Member
  • *****
  • Posts: 503
Re: EOSM-Updated ML for 2.02 firmware
« Reply #252 on: June 28, 2014, 04:27:54 AM »
So is the 5 second ML menu timeout eliminated in new builds? I guess not ?

lochmorie

  • New to the forum
  • *
  • Posts: 3
Re: EOSM-Updated ML for 2.02 firmware
« Reply #253 on: June 29, 2014, 05:19:18 AM »
Sadly, the menu still pops off after about 5 seconds.

Phener

  • Just arrived
  • *
  • Posts: 1
Re: EOSM-Updated ML for 2.02 firmware
« Reply #254 on: June 29, 2014, 02:32:46 PM »
What is the last build without the 5 second menu timeout?

kareemery

  • Just arrived
  • *
  • Posts: 1
Re: EOSM-Updated ML for 2.02 firmware
« Reply #255 on: June 29, 2014, 06:35:11 PM »
I have my eos-m running the latest nightly. Trying to figure out how to enable audio to run out through usb. Is there an option buried in the menu, or is the audio functions tab a work in progress?

velihukka

  • New to the forum
  • *
  • Posts: 9
Re: EOSM-Updated ML for 2.02 firmware
« Reply #256 on: June 29, 2014, 07:06:01 PM »
I have my eos-m running the latest nightly. Trying to figure out how to enable audio to run out through usb. Is there an option buried in the menu, or is the audio functions tab a work in progress?

I think there's no audio menu possibility(at least yet).
I always seem to get the crappy stuff and somehow make them great.

canoneer

  • New to the forum
  • *
  • Posts: 39
Re: EOSM-Updated ML for 2.02 firmware
« Reply #257 on: June 30, 2014, 06:26:41 PM »
I wonder....

After using the ML lightly for some time on the 60d and M, my M suddenly showed all (almost) the ML menues on one page as selectable box images - this during one of my hectic 5 second sessions fighting against the shortlived menu.

But since I have no clue to why I got the one page menu, I can not get back to the full one. The boxed onepage is not complete.

Could one of you help a lost one, please?

velihukka

  • New to the forum
  • *
  • Posts: 9
Re: EOSM-Updated ML for 2.02 firmware
« Reply #258 on: June 30, 2014, 07:51:03 PM »
I wonder....

After using the ML lightly for some time on the 60d and M, my M suddenly showed all (almost) the ML menues on one page as selectable box images - this during one of my hectic 5 second sessions fighting against the shortlived menu.

But since I have no clue to why I got the one page menu, I can not get back to the full one. The boxed onepage is not complete.

Could one of you help a lost one, please?

Press Menu.
I always seem to get the crappy stuff and somehow make them great.

canoneer

  • New to the forum
  • *
  • Posts: 39
Re: EOSM-Updated ML for 2.02 firmware
« Reply #259 on: June 30, 2014, 08:36:52 PM »
Thanks!

Wynand

  • New to the forum
  • *
  • Posts: 14
Re: EOSM-Updated ML for 2.02 firmware
« Reply #260 on: July 01, 2014, 02:59:43 PM »
What ML settings should I look at (change) to get the "best" video out of my EOS M using the 22mm lens??  Regards and tx for the fantastic work!!

velihukka

  • New to the forum
  • *
  • Posts: 9
Re: EOSM-Updated ML for 2.02 firmware
« Reply #261 on: July 02, 2014, 10:36:02 AM »
What ML settings should I look at (change) to get the "best" video out of my EOS M using the 22mm lens??  Regards and tx for the fantastic work!!

Bitrate doesn't really change anything on the EOS M. FPS Override may be useful, but it disables sound. Movie crop mode makes for less noise and other weird stuff by just using the middle of the sensor.

Of course, you can experiment with RAW video, but for that you should check out the subforum dedicated to it.
I always seem to get the crappy stuff and somehow make them great.

Oswald

  • Freshman
  • **
  • Posts: 67
  • 7D & Eos M & 100D.100B
Re: EOSM-Updated ML for 2.02 firmware
« Reply #262 on: July 02, 2014, 01:27:45 PM »
Movie crop mode makes for less noise and other weird stuff by just using the middle of the sensor.
It increases noise. It is true, I have tested it. Crop mode reduces aliasing and moire. because there is no lineskipping.
7D, EOS-M & 100D.100b ΒΆ  Sigma 18-35mm, Canon 50mm F1.8, 22 STM, 8-48mm f1.0, 18-55 EF-M STM

cdi1325

  • Just arrived
  • *
  • Posts: 1
Re: EOSM-Updated ML for 2.02 firmware
« Reply #263 on: July 03, 2014, 02:03:28 PM »
Hi every ones,

Many thanks for the job !

I am new... could you please confirm that with EOS M and new FW 2.0.2 and with nighlty last ML, HDR and RAW are available for video recording ?

I am close to buy EOS M and I need to know...

Thx for your help !

Wynand

  • New to the forum
  • *
  • Posts: 14
Re: EOSM-Updated ML for 2.02 firmware
« Reply #264 on: July 03, 2014, 02:18:02 PM »
Bitrate doesn't really change anything on the EOS M. FPS Override may be useful, but it disables sound. Movie crop mode makes for less noise and other weird stuff by just using the middle of the sensor.

Of course, you can experiment with RAW video, but for that you should check out the subforum dedicated to it.

I bumped up the FPS but even going to as little as 35 FPS makes the camera "hang" - only way to rectify then is to take out the battery.  The "crop" mode is blanked out....  Any ideas?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: EOSM-Updated ML for 2.02 firmware
« Reply #265 on: July 03, 2014, 02:27:13 PM »
It means the FPS timer limits are wrong. Find out the safe values by changing the timers manually, and I'll update them.

RavingRover

  • New to the forum
  • *
  • Posts: 23
Re: EOSM-Updated ML for 2.02 firmware
« Reply #266 on: July 04, 2014, 10:35:28 AM »
It increases noise. It is true, I have tested it. Crop mode reduces aliasing and moire. because there is no lineskipping.

I do not see increased noise, actually next to none, but then I use higher bit rates, usually 2.0x CBR. 1 example of this was taking a still of the same shot of same scene of crop vid, the video was much better in shadows (details & low noise) and less geometric distortion.

I do hope the 'next' M (M3? or Pro model) will address the fairly poor H.264 encoder used by Canon (or Texas Instruments - their DSP (DIGIC) suppliers - I assume f/w encoders as well?)

The M3 could be a BMPCC fighter but it has to have much more attention to the video, if not 4k at least state of the art H.264 encoding with higher bit rates and true raw &/or HDMI output & 4:4:2 as well ?

Wynand

  • New to the forum
  • *
  • Posts: 14
Re: EOSM-Updated ML for 2.02 firmware
« Reply #267 on: July 04, 2014, 10:37:38 AM »
It means the FPS timer limits are wrong. Find out the safe values by changing the timers manually, and I'll update them.

Thanks - will do and let you know.  (By saying "timers" you mean manually upping the FPS till it creates issues?)

oenopion

  • New to the forum
  • *
  • Posts: 15
Re: EOSM-Updated ML for 2.02 firmware
« Reply #268 on: July 05, 2014, 01:05:20 AM »
I had a 4.1 Gb h.264 file come out of my eos-m as a .dat file today?
I've read something about this coming from going over 4 gb, or something I may not have had set right?
Anyway, can that file be retrieved, salvaged, or is it toast?
Thanks.

RavingRover

  • New to the forum
  • *
  • Posts: 23
Re: EOSM-Updated ML for 2.02 firmware
« Reply #269 on: July 05, 2014, 02:11:20 AM »
I had a 4.1 Gb h.264 file come out of my eos-m as a .dat file today?
I've read something about this coming from going over 4 gb, or something I may not have had set right?
Anyway, can that file be retrieved, salvaged, or is it toast?
Thanks.

Have you simply tried to change the file type to .MOV, .mov or .mp4 ?  A diff file extension/type means NOTHING to the content (many times) just the 'packaging' of the contents!  Do not erase until you check a few things!

ex. - .3gp is just .mp4/H.264, aac audio, etc contents in a file wrapper.

Good Luck!

oenopion

  • New to the forum
  • *
  • Posts: 15
Re: EOSM-Updated ML for 2.02 firmware
« Reply #270 on: July 05, 2014, 02:49:57 PM »
Yes, I tried a few different tricks. I'm thinking something may not have been fully compiled?
I may try starting a dedicated thread, for this may have also happened on another model?
Mods, can I break my question off into a separate thread?

cpreston

  • New to the forum
  • *
  • Posts: 23
Re: EOSM-Updated ML for 2.02 firmware
« Reply #271 on: July 05, 2014, 06:12:31 PM »
The creation of a DAT file instead of a .mov file happened to me on a 6D using tragic lantern last year.  I figured it might have something to do with the automatic restart function of ML and continuous file creation in the newer Canon cameras.  I changed a couple of settings and no longer had a problem with the 6D.  I've never had problems with the EOS-M.  In any case, I've never really trusted the 4GB threshold automatic file creation on the Canon cameras with ML installed since then.

oenopion

  • New to the forum
  • *
  • Posts: 15
Re: EOSM-Updated ML for 2.02 firmware
« Reply #272 on: July 05, 2014, 07:34:25 PM »
Hi cpreston,
I think your incident was the one I had read through. I rarely exceed the limit, but have never had any problems with the restart on my 600D, and a couple times on my 50D. It might have just been a fluke. Were you able to salvage the file? Or have any ideas to try? And what settings did you change, just curious?
Thanks, Sean

supertsai

  • New to the forum
  • *
  • Posts: 2
Re: EOSM-Updated ML for 2.02 firmware
« Reply #273 on: July 06, 2014, 09:17:19 PM »
First time poster here, but LONG TIME camera user.

I installed the ML build from July 2nd, 2014 and found it had tons of amazing features, but it pretty much rendered my camera useless.  I cannot reliably take still photos when running ML, and it's a struggle to get the intervalvometer to function.  It seems that I have to power cycle the camera 3-4 times before the camera will take photos and then once I power the EOS M down again, all bets are off.

I'm surprised to not see more people complaining about this - is there something wrong with my camera / build?

Stedda

  • Hero Member
  • *****
  • Posts: 504
Re: EOSM-Updated ML for 2.02 firmware
« Reply #274 on: July 06, 2014, 09:26:59 PM »
I'm surprised to not see more people complaining about this - is there something wrong with my camera / build?

Shutter Bug, all 12 pages

http://www.magiclantern.fm/forum/index.php?topic=8347.msg95683#msg95683
5D Mark III -- 7D   SOLD -- EOS M 22mm 18-55mm STM -- Fuji X-T1 18-55 F2.8-F4 & 35 F1.4
Canon Glass   100L F2.8 IS -- 70-200L F4 -- 135L F2 -- 85 F1.8 -- 17-40L --  40 F2.8 -- 35 F2 IS  Sigma Glass  120-300 F2.8 OS -- 50 F1.4 -- 85 F1.4  Tamron Glass   24-70 2.8 VC   600EX-RT X3