Author Topic: Canon EOS M  (Read 1475116 times)

kosmarnik

  • New to the forum
  • *
  • Posts: 13
Re: EOSM-Updated ML for 2.02 firmware
« Reply #300 on: August 01, 2014, 05:56:14 PM »
Hi!
I installed ML just fine. 2.02 FW, magiclantern-Nightly.2014Jul30.EOSM202.

All video and interface tweaks work fine, except I can't shoot regular photos.
In photo or intelligent photo mode the the camera just focuses but won't fire with a full press.
If I turn on the 'touch to shoot' it will try to shoot and lock up the interface, no button or screen presses work, only taking out the battery.

Any ideas?
Using a sdcard without ML it works fine.
I can post dumps/logs later when I get home.

EVVK

  • New to the forum
  • *
  • Posts: 24
Re: EOSM-Updated ML for 2.02 firmware
« Reply #301 on: August 01, 2014, 08:11:32 PM »
...just focuses but won't fire with a full press.
Any ideas?
Using a sdcard without ML it works fine.
I can post dumps/logs later when I get home.
Hey, welcome!

It's called shutter-bug, just browse in previous posts. It appears with EF-M zoom lenses, not fixed (22mm) primes or with EF-adapter. There are atleast two known? work-arounds when it appears, either quickly reboot your camera by pressing powerbutton twice, or just twist the lens and reseat it again while the camera is on.

I'm not sure if we still have any clues what triggers this bug, as it appears mostly to be random. Sometimes it wierdly seems to work fine for a while in a row.

gmr20

  • New to the forum
  • *
  • Posts: 4
Re: EOSM-Updated ML for 2.02 firmware
« Reply #302 on: August 02, 2014, 07:29:52 PM »
When I use FPS Override to shoot a video at night with very low FPS (about 1),
the first few frames (of both video file and LCD when shooting) will go very dark, then very bright, and then normal.
Is this a bug? Or can you make an adjustment for it? Thanks.

Meanwhile I need to use EV -3 for a correct brightness video at daylight with a ND8. That's quite weird too.

tob

  • New to the forum
  • *
  • Posts: 21
Re: EOSM-Updated ML for 2.02 firmware
« Reply #303 on: August 03, 2014, 11:43:36 AM »
Anyone using ETTR+DUALISO?



ganselm

  • New to the forum
  • *
  • Posts: 8
Re: EOSM-Updated ML for 2.02 firmware
« Reply #304 on: August 03, 2014, 05:52:28 PM »
I tried ETTR but it just seems to generate random exposure times, most of the time much too long (several seconds in sunny daylight). The same happens when combined with dualiso

DiamondGeezer

  • New to the forum
  • *
  • Posts: 6
Re: EOSM-Updated ML for 2.02 firmware
« Reply #305 on: August 05, 2014, 11:44:45 AM »
Hello,

Few questions on the EOS-M when going into ML if you don't touch anything for 6-7 seconds it comes out of the ML Menu, can this be changed?

With ML installed power saving options do not appear to work, I'm set to 1 min but is there something in ML overriding this?

How do I remove ML, I'm go to format, only option I have is format card, Keep ML. I tap the screen to toggle but nothing happens.

TIA

vertigopix

  • Senior
  • ****
  • Posts: 281
  • EOS 6D - EOS M
Re: EOSM-Updated ML for 2.02 firmware
« Reply #306 on: August 05, 2014, 11:51:43 AM »
Format you card in your computer et voilĂ  !

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: EOSM-Updated ML for 2.02 firmware
« Reply #307 on: August 05, 2014, 12:00:58 PM »

vertigopix

  • Senior
  • ****
  • Posts: 281
  • EOS 6D - EOS M
Re: EOSM-Updated ML for 2.02 firmware
« Reply #308 on: August 05, 2014, 12:28:20 PM »
Or report the bug...

https://bitbucket.org/hudson/magic-lantern/issues?q=eos-m

It's effectively impossible to tap to switch.
Bug report done.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564

DiamondGeezer

  • New to the forum
  • *
  • Posts: 6
Re: EOSM-Updated ML for 2.02 firmware
« Reply #310 on: August 06, 2014, 11:45:36 AM »
Can't seem the option to shoot in video in Raw, is this an option on the EOS M ?

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8287
Re: EOSM-Updated ML for 2.02 firmware
« Reply #311 on: August 06, 2014, 11:46:55 AM »
You have to load RAW_REC.MO or MLV_REC.MO first. See Module tab.

DiamondGeezer

  • New to the forum
  • *
  • Posts: 6
Re: EOSM-Updated ML for 2.02 firmware
« Reply #312 on: August 06, 2014, 12:08:01 PM »
You have to load RAW_REC.MO or MLV_REC.MO first. See Module tab.

RAW_REC.MO enable and camera restarted, still can't see an option to enable raw

If I don't touch anything with 7 secs the camera comes out of ML, not giving me enough time to have a proper read through options

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8287
Re: EOSM-Updated ML for 2.02 firmware
« Reply #313 on: August 06, 2014, 12:38:54 PM »
Movie tab

DiamondGeezer

  • New to the forum
  • *
  • Posts: 6
Re: EOSM-Updated ML for 2.02 firmware
« Reply #314 on: August 06, 2014, 01:26:48 PM »
Movie tab

Nope not showing, just glanced through the whole thread and noticed a linky to TL, stuck that on and now have the raw option after enabling the modules.

I'm was using the latest ML nightly builds

Also the same also with duel iso, enable the ML IOS  module but it does not show under the expo tab but shows using TL

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: EOSM-Updated ML for 2.02 firmware
« Reply #315 on: August 06, 2014, 02:00:04 PM »
Just noticed the EOS-M build was missing some modules and recompiled it.

Make sure you didn't disable all the modules by mistake from the Debug menu.

jerrykil

  • Member
  • ***
  • Posts: 207
Re: EOSM-Updated ML for 2.02 firmware
« Reply #316 on: August 06, 2014, 03:03:42 PM »
Sometimes when enabling a module and restarting, I don't give the camera enough time to fully power off. The camera flashes orange a few seconds after hitting the power button, wait until then to start up again.

vertigopix

  • Senior
  • ****
  • Posts: 281
  • EOS 6D - EOS M
Re: EOSM-Updated ML for 2.02 firmware
« Reply #317 on: August 06, 2014, 03:04:28 PM »
Just noticed the EOS-M build was missing some modules

I was thinking that is "normal" and didn't report it... My bad.
Thank you a1ex !

vertigopix

  • Senior
  • ****
  • Posts: 281
  • EOS 6D - EOS M
Re: EOSM-Updated ML for 2.02 firmware
« Reply #318 on: August 06, 2014, 03:07:30 PM »
Tried with my EOS-M, no problems, all modules loading perfectly.

The "ML menu dissapearing after 5-7 sec." bug is still present.

DiamondGeezer

  • New to the forum
  • *
  • Posts: 6
Re: EOSM-Updated ML for 2.02 firmware
« Reply #319 on: August 06, 2014, 05:26:53 PM »
Tried with my EOS-M, no problems, all modules loading perfectly.

The "ML menu dissapearing after 5-7 sec." bug is still present.

I've just tried the latest build, can see more modules now and enabled Dual ISO and the raw videos ones but still not joy

My guess is they are not loading, with TL if I pull the battery out then startup there is an error saying camera was not shutdown properly... modules not loading, using the on / off switch then its ok. With ML if I pull the battery I do not see this error hence I'm guessing they are not loading and that's why I can't play with raw video / dual ISO

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: EOSM-Updated ML for 2.02 firmware
« Reply #320 on: August 06, 2014, 05:30:14 PM »
Paste a screenshot of the "modified settings" menu (the one with a Delta icon).

vertigopix

  • Senior
  • ****
  • Posts: 281
  • EOS 6D - EOS M
Re: EOSM-Updated ML for 2.02 firmware
« Reply #321 on: August 06, 2014, 05:33:15 PM »
Stop using TL, it is not longer maintened.
With the latest ML there is no problem !

DiamondGeezer

  • New to the forum
  • *
  • Posts: 6
Re: EOSM-Updated ML for 2.02 firmware
« Reply #322 on: August 07, 2014, 09:28:11 AM »
low level format, latest build and all ok now

leicatill

  • New to the forum
  • *
  • Posts: 6
Re: EOSM-Updated ML for 2.02 firmware
« Reply #323 on: August 09, 2014, 03:58:06 PM »
I own a Canon EOS-m with the Tamron lens E-M 18-200mm VS. After installing ML I can't take a photo. Changing to Canon 18-55mm all is ok. Anyone can help?

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8287
Re: EOSM-Updated ML for 2.02 firmware
« Reply #324 on: August 09, 2014, 04:06:43 PM »
Shutter bug again, I suppose. Do a search about
Shutter bug twist lens
and test the procedure. Please post results.