Author Topic: Canon 650D / T4i  (Read 1437408 times)

renfes130

  • New to the forum
  • *
  • Posts: 4
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1000 on: January 05, 2014, 05:46:34 PM »
Ok, I've done that. It creates a "Autoexec.bin" file and now the camera does not start up. I extract the battery, re-insert it and the camera does not start up either.


 ??? ? ? ?

Midas

  • New to the forum
  • *
  • Posts: 6
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1001 on: January 05, 2014, 07:10:29 PM »
I see there has been a small amount of progress on the Canon 700D with audio functions.

This would be so good if they could be implemented on the 650D.

I'm not trolling.... Love ML.... But it would be Happy Days to have some audio functions!

I've been eagerly awaiting some news on this... getting ready to move on now and buy the new Zoom H6

Magic lantern for Prime minister!

RenatoPhoto

  • Moderators
  • Hero Member
  • *****
  • Posts: 1509
  • 5DM3 / 7D
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1002 on: January 05, 2014, 08:28:26 PM »
Ok, I've done that. It creates a "Autoexec.bin" file and now the camera does not start up. I extract the battery, re-insert it and the camera does not start up either.

If EOScard.exe installs wrong ML files, just delete them and put the latest ML files, that is autoexec.exe and ML folder
http://www.pululahuahostal.com  |  EF 300 f/4, EF 100-400 L, EF 180 L, EF-S 10-22, Samyang 14mm, Sigma 28mm EX DG, Sigma 8mm 1:3.5 EX DG, EF 50mm 1:1.8 II, EF 1.4X II, Kenko C-AF 2X

renfes130

  • New to the forum
  • *
  • Posts: 4
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1003 on: January 05, 2014, 10:32:03 PM »
Thanks bro!!! ;D ;D ;D That worked! At last!!!

Solved, thanks everyone ;) :D

HrRaiko

  • New to the forum
  • *
  • Posts: 16
  • 650D
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1004 on: January 06, 2014, 09:59:21 PM »
Hey
Why i dont have RAW video option on my 650D 1.0.4 with newest ML?

And is there any way to get audio meter on my display?
Canon EOS 650D | Sigma 18-35mm F1.8 DC HSM Art + CPL Filter | Samyang 14mm F2.8 IF ED UMC AS | Canon EF 50mm F1.8 II | Kamerar SD-1 Slider/Dolly + Velbon PH-368 | YONGNUO YN-568 TTL | Benro KH25 | Sennheiser ME2 Mic

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8296
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1005 on: January 06, 2014, 10:02:03 PM »
Because you have to access the Module tab, activate RAW_REC, restart the cam to enable this option.

HrRaiko

  • New to the forum
  • *
  • Posts: 16
  • 650D
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1006 on: January 06, 2014, 10:04:48 PM »
Because you have to access the Module tab, activate RAW_REC, restart the cam to enable this option.
Thanks man! :P
Canon EOS 650D | Sigma 18-35mm F1.8 DC HSM Art + CPL Filter | Samyang 14mm F2.8 IF ED UMC AS | Canon EF 50mm F1.8 II | Kamerar SD-1 Slider/Dolly + Velbon PH-368 | YONGNUO YN-568 TTL | Benro KH25 | Sennheiser ME2 Mic

mk11174

  • Contributor
  • Hero Member
  • *****
  • Posts: 809
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1007 on: January 07, 2014, 04:50:29 PM »
Just curious if these changes I did on the 700D will get the beep, meters and mlv_snd going on your 650D, I don't have a 650D, but I did have the firmware to get the stubs made for it.

On the 700D we have Beep, and meters, but only when recording, and it allows mlv_snd to record sound in mlv_rec module.

UPDATE: Link no longer good, but should be in nightly soon since I commited everything needed and was merged. 8]
https://bitbucket.org/mk11174/magic-lantern/downloads/ML_650D_ML_Audio_Jan_7_2014.zip
500D/T1i  550D/T2i  600D/T3i  700D/T5i

Felipe

  • Senior
  • ****
  • Posts: 275
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1008 on: January 07, 2014, 10:34:08 PM »
Yes Sir does work, as you said only while recording but before recording I adjusted levels in the native Canon Audio control. Thank you if any bug I'll let you know
External mic works like a charm
By the way the sensor shortcut to adjust levels while recording doesn't work :-*
650D-700D

mk11174

  • Contributor
  • Hero Member
  • *****
  • Posts: 809
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1009 on: January 07, 2014, 11:06:15 PM »
Yes Sir does work, as you said only while recording but before recording I adjusted levels in the native Canon Audio control. Thank you if any bug I'll let you know
External mic works like a charm :-*
Wow, that is great news! Thanks for letting me know it worked ok!

I have not had any issues yet, but since both 700D and 650 are new ports there will always be some, but so far seem stable. Never would of thought we would be at a point to record 1280x720 in Raw using mlv_rec and now having sound with it is even more exciting.

Beep I guess is not exciting news, but I use it with the Bolt Trigger so it is vital for my needs when I am not close to camera.
500D/T1i  550D/T2i  600D/T3i  700D/T5i

glassescreditsroll

  • Freshman
  • **
  • Posts: 55
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1010 on: January 08, 2014, 07:12:24 AM »
oh my god mk11174 im a long time reader but i just made an account just to say thank you so much for this audio module! ive been waiting for this and it works great!! ;D ;D ;D ;D ;D

mk11174

  • Contributor
  • Hero Member
  • *****
  • Posts: 809
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1011 on: January 08, 2014, 07:54:37 AM »
oh my god mk11174 im a long time reader but i just made an account just to say thank you so much for this audio module! ive been waiting for this and it works great!! ;D ;D ;D ;D ;D
Thats great!
Here are the Audio Stubs I added, not all are used for just the meters and mlv_snd but I found them anyway just in case needed in future if someone gets the patches made up to turn on more ML Audio features.

Maybe someone can add them to the repo so will be available in nightly builds?

stubs.s
/** Audio **/
NSTUB(0xFF335394, _audio_ic_write)
NSTUB(0xFF3359E0, _audio_ic_read)

NSTUB(0xFF10A9D0, sounddev_task )
NSTUB(   0x239E4, sounddev )
NSTUB(0xFF10AEBC, sounddev_active_in)

NSTUB(0xFF10B6F4, SoundDevStopIn)
NSTUB(0xFF10B7C4, SoundDevStopOut)

NSTUB(0xFF10AEBC, SoundDevActiveIn)
NSTUB(0xFF10B118, SoundDevActiveOut)
NSTUB(0xFF10B0D8, SoundDevShutDownIn)

NSTUB(0xFF1326EC, send_audio)

NSTUB(0xFF7F27F4, audio_thresholds)

internals.h
#define CONFIG_BEEP

features.h
#define FEATURE_AUDIO_METERS
#define FEATURE_BEEP

Also need to remove defined(CONFIG_650D) from audio-common.c  in line 8 to correct threshold error when compiling.

UPDATE: I already merged changes 8]
500D/T1i  550D/T2i  600D/T3i  700D/T5i

HrRaiko

  • New to the forum
  • *
  • Posts: 16
  • 650D
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1012 on: January 08, 2014, 09:07:06 AM »
Just curious if these changes I did on the 700D will get the beep, meters and mlv_snd going on your 650D, I don't have a 650D, but I did have the firmware to get the stubs made for it.

On the 700D we have Beep, and meters, but only when recording, and it allows mlv_snd to record sound in mlv_rec module.

https://bitbucket.org/mk11174/magic-lantern/downloads/ML_650D_ML_Audio_Jan_7_2014.zip

This is perfect! Thanks a lot ;)
When its added to Nightly Builds updates?
Canon EOS 650D | Sigma 18-35mm F1.8 DC HSM Art + CPL Filter | Samyang 14mm F2.8 IF ED UMC AS | Canon EF 50mm F1.8 II | Kamerar SD-1 Slider/Dolly + Velbon PH-368 | YONGNUO YN-568 TTL | Benro KH25 | Sennheiser ME2 Mic

mk11174

  • Contributor
  • Hero Member
  • *****
  • Posts: 809
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1013 on: January 08, 2014, 10:25:43 AM »
I went and committed the changes, if it merges maybe will be ready to go in the nightly as well.
500D/T1i  550D/T2i  600D/T3i  700D/T5i

glassescreditsroll

  • Freshman
  • **
  • Posts: 55
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1014 on: January 08, 2014, 01:04:00 PM »
is there anyway well be seeing any other audio updates from this? analog gain and such? or is that not needed with the in camera canon menu on the t4i?

mk11174

  • Contributor
  • Hero Member
  • *****
  • Posts: 809
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1015 on: January 08, 2014, 01:29:59 PM »
is there anyway well be seeing any other audio updates from this? analog gain and such? or is that not needed with the in camera canon menu on the t4i?
Probably not for awhile, I believe only 1% has been working on other cameras with the same audio chip, code needs to be re-written to make all those features work with ML.

Adding the stubs was just a tiny first step, but at least we will have sound with mlv_rec, that is huge in my eyes.

But yeah, we do have the audio features in Canon menu, so not really needed I guess.
500D/T1i  550D/T2i  600D/T3i  700D/T5i

Felipe

  • Senior
  • ****
  • Posts: 275
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1016 on: January 08, 2014, 02:38:29 PM »
Probably not for awhile, I believe only 1% has been working on other cameras with the same audio chip, code needs to be re-written to make all those features work with ML.

Adding the stubs was just a tiny first step, but at least we will have sound with mlv_rec, that is huge in my eyes.

But yeah, we do have the audio features in Canon menu, so not really needed I guess.
Meters are a huge advancement for me , do you think adjusting levels while recording is possible in the near future ? Again thanks.
650D-700D

brewerrj

  • New to the forum
  • *
  • Posts: 19
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1017 on: January 08, 2014, 07:59:34 PM »
Just curious if these changes I did on the 700D will get the beep, meters and mlv_snd going on your 650D, I don't have a 650D, but I did have the firmware to get the stubs made for it.

On the 700D we have Beep, and meters, but only when recording, and it allows mlv_snd to record sound in mlv_rec module.

https://bitbucket.org/mk11174/magic-lantern/downloads/ML_650D_ML_Audio_Jan_7_2014.zip

YEAH! Thank you!! 8)

Roger2004

  • New to the forum
  • *
  • Posts: 19
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1018 on: January 08, 2014, 08:04:20 PM »
Just to say i froze my 650d just by zooming in raw mode (digital zoom to focus) and launched the recording, it froze it & i had to remove the battery and power off / on. I hope this helps if this isn't a know bug. Thanks a lot anyway to the ML team for their unbelievable work...!

mk11174

  • Contributor
  • Hero Member
  • *****
  • Posts: 809
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1019 on: January 08, 2014, 10:29:10 PM »
Just to say i froze my 650d just by zooming in raw mode (digital zoom to focus) and launched the recording, it froze it & i had to remove the battery and power off / on. I hope this helps if this isn't a know bug. Thanks a lot anyway to the ML team for their unbelievable work...!
I don't think it is known, I can't make it happen myself by using that procedure, so that for sure could be anything causing it. Thanks for the update! Ooops, wrong thread for me, I have 700D and was trying to use that procedure to make it freeze with no luck, or I guess that would be good luck for me 8] Don't think it would be audio related at least, but could be anything for sure.
500D/T1i  550D/T2i  600D/T3i  700D/T5i

kazeone

  • Member
  • ***
  • Posts: 119
  • 650D
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1020 on: January 09, 2014, 06:49:26 AM »
I have to also say my thanks in this big leap for the movie side of Magic Lantern, getting those audio meters to work, thank you thank you thank you.

Not to say that all the amazing work that the other devs have done has gone un-noticed I use many of them on a daily basis so a big thanks to you guys as well. ^_^

glassescreditsroll

  • Freshman
  • **
  • Posts: 55
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1021 on: January 09, 2014, 06:55:02 AM »
I went and committed the changes, if it merges maybe will be ready to go in the nightly as well.
they put the audio meters and beep into the nightly but the auido for raw is missing

mk11174

  • Contributor
  • Hero Member
  • *****
  • Posts: 809
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1022 on: January 09, 2014, 10:17:59 AM »
they put the audio meters and beep into the nightly but the auido for raw is missing
you just need the mlv_snd module, stay up to date on the latest here.
http://www.magiclantern.fm/forum/index.php?topic=7122.msg59525#msg59525
500D/T1i  550D/T2i  600D/T3i  700D/T5i

claudelec

  • New to the forum
  • *
  • Posts: 7
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1023 on: January 09, 2014, 11:06:12 AM »
For last Nightly build: Sound menu returned... :) :) :).. but module menu disappeared :( :( :(
Body: 70D112 , 650D
Lenses: EFS 15-85 IS USM, Tamron SP 70-300 Di VC USD, Tamron SP 90 Macro Di VC USD, EF 100-400 IS USM MKll and some old...

glassescreditsroll

  • Freshman
  • **
  • Posts: 55
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #1024 on: January 09, 2014, 11:57:10 AM »
For last Nightly build: Sound menu returned... :) :) :).. but module menu disappeared :( :( :(
ive noticed my mod menu often chooses when to show itself i usually just restart my camera and itll be there again