Author Topic: Danne's crop_rec_4k experiments for EOS M  (Read 213223 times)

cedricp

  • New to the forum
  • *
  • Posts: 27
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3175 on: July 07, 2022, 03:02:34 PM »
I use C-mount lenses in 2.5K mode on EOS-M, I really love that mode. I currently use the canon-gui arrrows to shift the crop area and center the lens, it's OK, but I was wondering if those X-Y shift values could be read from the camera registers, dumped in the crop_rec config file then restored at startup ?
It's something I can do if someone tell me how to do.

dpjpandone

  • Senior
  • ****
  • Posts: 287
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3176 on: July 13, 2022, 12:51:13 AM »
Hey guys,

after a long hiatus I am back...

I picked up another M yesterday and I'm really pleased to see all the progress that's been made in the last few years. Previously I did some early development on the M and the 7d. I have not been active since 2017. A lot has changed. I could use some help getting back on my feet.

Is there an updated guide on how to setup the development environment on windows? I tried running through the original guide and a lot of the links are now dead.

The MLV app is only finding pixel maps for HD 1080p, where is the repository that has the maps for 5k anamorphic and other new modes?

cedricp

  • New to the forum
  • *
  • Posts: 27
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3177 on: July 13, 2022, 10:51:35 AM »
I use those maps successfully (5K anamorphic, 2.5K, 1080...): https://github.com/ilia3101/MLV-App/tree/master/pixel_maps

gabriielangel

  • Freshman
  • **
  • Posts: 77
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3178 on: July 13, 2022, 11:42:24 PM »
About the focus pixel maps:
Launch MLV App while connected to the Internet. When you open your first EOS-M clip, the program will ask you if you want to download a map for the selected clip or all the maps. Those will be downloaded automatically once you make your choice.

dpjpandone

  • Senior
  • ****
  • Posts: 287
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3179 on: July 14, 2022, 02:19:42 PM »
About the focus pixel maps:
Launch MLV App while connected to the Internet. When you open your first EOS-M clip, the program will ask you if you want to download a map for the selected clip or all the maps. Those will be downloaded automatically once you make your choice.
'

This is not working on multiple computers

"Update of focus pixel maps failed"


masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 2007
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3180 on: July 14, 2022, 04:42:35 PM »
'
This is not working on multiple computers

"Update of focus pixel maps failed"
Then you block MLVApps internet connection on multiple computers. Check firewall and/or antivirus. Or install the maps manually. Find them on MLVApp repository.
5D3.113 | EOSM.202

samzkri

  • New to the forum
  • *
  • Posts: 2
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3181 on: July 22, 2022, 08:43:33 AM »
Hello everyone,
What's the crop factor of 2.5k and 2.8k?

I remember Zeek saying it's 3~3.2x crop
but I'm seeing x5 crop in the menu?

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7368
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3182 on: July 30, 2022, 05:40:57 PM »
Hi Danne, look, I'm experimenting with registers in advanced mode dropdown menu and found somesing interest with cmos6 register. When I set it in 0xe8d, refresh, and waiting for around 1-2 minutes vertical stripes from preview are gone, I'm record footage, then when I open it in MLV app and set to off any raw corrections I don't see any focus dots in Frame.

I'm not a developer, but maybe you can to recheck it and to do a testing build?

Example:
Regular 1080p, last build, 14 bits, fix focus dots is off, chroma smooth is off,bad pixel Mapp is off


And what I think, we try fixed not a Focus dots, its seems more like a Exposition Metter pixels, becouse if you look in front of sensor you see it.
Inreresting. Applies to other presets as well?

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8431
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3183 on: July 30, 2022, 09:40:47 PM »
Hello everyone,
What's the crop factor of 2.5k and 2.8k?

I remember Zeek saying it's 3~3.2x crop
but I'm seeing x5 crop in the menu?

Answered in r/magiclantern

pepper_chip

  • New to the forum
  • *
  • Posts: 4
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3184 on: August 02, 2022, 07:30:24 PM »
Inreresting. Applies to other presets as well?

I'm stop experimenting with this cmos reg becouse waiting moderate my massage, look at data 03 July
Doesn't work in another modes/presets

pepper_chip

  • New to the forum
  • *
  • Posts: 4
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3185 on: August 02, 2022, 07:41:31 PM »
Inreresting. Applies to other presets as well?

I'm almost sure our "focus pixels" in fact exposure meter dots. But I can't recheck it becouse dont understand how I can "catch" moment what register is off "metering" (I'm trying edit regs from ADTG.mo
I'm just not a developer so I could be wrong in my "theory"

gabriielangel

  • Freshman
  • **
  • Posts: 77
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3186 on: August 06, 2022, 12:52:53 AM »
Hello, I tried the latest build (Aug 04 2022) and the camera froze twice in a row.
I loaded the 2.5K tap preset, then I selected the 3K preset (In the internal menu). Set 25 fps was on. (So I could get 23.976 fps)

I pressed the Menu button a few times and Crash! Needed to remove the battery.

Tried a second time, Crash again.

Then I could not get it to crash anymore.

Here are the crash logs. Because I filmed two full days with the previous build last weekend, and I only got 1 buffer error and 1 pink frame (Total 180 clips), maybe this crash is significant.

Code: [Select]

ASSERT: err == SUCCESS
at GUI.c:683, MainCtrl:ff0d7274
lv:0 mode:3

MainCtrl stack: 191308 [1913d8-1903d8]
0xUNKNOWN  @ ff0ceed0:1913b8
0xFF0CDBD0 @ ff144638:191388
0xFF0D7674 @ ff0ccac4:191360
0x00001900 @ ff0d7270:191340
0x0009E558 @ 9e864:191308

Magic Lantern version : Nightly.2022Aug04.EOSM202
Mercurial changeset   : 5b3193b29ac1 (crop_rec_4k_mlv_snd_raw_only) tip
Built on 2022-08-04 08:20:58 UTC by daniel@Daniels-MacBook-Pro.local.
Free Memory  : 220K + 1911K

ASSERT: err == SUCCESS
at GUI.c:683, notifybox_task:ff0d7274
lv:0 mode:3

notifybox_task stack: 1f0d98 [1f0e18-1efe18]
0x000D4A84 @ bd990:1f0df0
0x00001900 @ ff0d7270:1f0dd0
0x0009E558 @ 9e864:1f0d98

Magic Lantern version : Nightly.2022Aug04.EOSM202
Mercurial changeset   : 5b3193b29ac1 (crop_rec_4k_mlv_snd_raw_only) tip
Built on 2022-08-04 08:20:58 UTC by daniel@Daniels-MacBook-Pro.local.
Free Memory  : 220K + 1908K

I remember that at some point, I could get the cam to write a detailed log of every event in a file on the SD card, but I could not find that function today. Anyone knows how to make it happen?

CalculatinGenius

  • Just arrived
  • *
  • Posts: 1
(first time posting, excuse any weirdness)
My EOS M on the Danne build from May is behaving really strangely. On my camera, it won't let me change the ISO consistently. It seems to only randomly change when I spin the dial. The shutter also won't go higher than 1/150th for some reason?
link to a video of my problem: https://photos.app.goo.gl/iuJn2wAsSkg31TgQ8
Kill canon GUI is on, i dont know how to check for modules loaded but I haven't modified the build myself. shooting at 25fps with the standard 1080p mode 10 bit raw (to avoid pink frames.)
the overexposure issue in the video was fixed by turning off 25fps and restarting the camera and turning it back on? i really don't know and ended up just stopping down the lens a lot for some scenes. also removing the battery and SD card changed nothing.
recording video itself seems to work fine though and i got plenty of usable footage, but losing ISO and good shutter control was a pain.

far.in.out

  • Freshman
  • **
  • Posts: 66
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3188 on: August 20, 2022, 11:27:10 AM »
I was thinking about pinhole again today... And I think that one can try to make a stereoscopic camera with two isolated pinholes on a single camera. What do you think?

What is new in the latest build? Is there some feature rollback? I think that I saw something about reverting in commit comments. Am I wrong?
EOS M (was 600D > 50D)

scriptmonkey

  • New to the forum
  • *
  • Posts: 3
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3189 on: August 21, 2022, 12:53:16 PM »
Hi, I just installed ML on EOS M and I am completely new to it. It was the experimental version crop_rec_4k_mlv_snd_raw_only_2022Aug04.EOSM202.zip. I did it in a hope of having 5k anamorphic frtp continuous, which is the only video mode which interests me at the moment (low light loss on the sensor and no aliasing). Before installing, I chose "clear camera settings".

So, in this fresh install, firstly I have set the mode:
Then the hacks:
As suggested in the mode description, UI kill ON. I have also set basic things as suggested in "display warnings", like the manual mode.

Then I got this strange preview:
It is not quite static, the colored fields move slowly.

When resetting the camera or pressing the lens button in the bottom right corner, the preview switches to this:
The top part shows now a clear preview (dark in the screenshot as there was actually no light) and the bottom part flickers fast random pattern/black.

I never got the nice preview from Zeek's video i.e. recording levels on the bottom. Additionally, when pressing the Menu button in ML menus, the camera sometimes bricks. After power cycling there is only the green led blinking. Removing the battery helps returning to ML.

I wonder if there are some settings, not shows in Zeek's video, which allow to obtain his results and stabilize ML?

Firmware 2.0.2, 512GB 120MB/s sd card. LM installed via "update firmware". Under Debug, there is something like this:
I do not know if it is a problem or if it was like that from the beginning or only after a number of freezes/debrickings.


2blackbar

  • Hero Member
  • *****
  • Posts: 507
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3190 on: August 21, 2022, 06:20:01 PM »
pinhole video is crap on M, you need very high iso to shoot with it, cool as one time experiment tho, try it, get disappointed and move on like most folks.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8431
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3191 on: August 24, 2022, 02:47:43 PM »
Firmware 2.0.2, 512GB 120MB/s sd card.

Could you load bench.mo, reboot? Access Debug tab -> Benchmarks -> Card Benchmarks -> Quick R/W benchmark (1 min).
Immediately after benchmark start press Play button to enter Review/Play mode. Share results.
I suppose Overclocking (in same tab) is adjusted to "192 MHz", right?

Judging by the number shown in first screenshot (16.5 MByte/s) your card is not well suited to run this overclocking speed. You may want to run a benchmark on your PC to verify card's native speed limit (without overclocking). Use a decent cardreader.
If write speed is substantial higher than 16.5 MByte/s you have to rerun benchmark number after adjusting overclocking to 160 MHz and a reboot to enable changes.

scriptmonkey

  • New to the forum
  • *
  • Posts: 3
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3192 on: August 24, 2022, 04:13:51 PM »
Could you load bench.mo, reboot? Access Debug tab -> Benchmarks -> Card Benchmarks -> Quick R/W benchmark (1 min).
Immediately after benchmark start press Play button to enter Review/Play mode. Share results.

at 192 MHz: write=23.6, read=19.9
at 160 MHz: write=54.3, read=57.2

I suppose Overclocking (in same tab) is adjusted to "192 MHz", right?

Yes. Could it have any meaning, even that I did not even record anything? It seems like I have some GUI problems. The mentioned flickering. Then, in Video mode there is always an indication that Zoom is either x5 or x10. I am not sure if there is really any, perhaps. I can only toggle between these two with the lens on-screen button.

If write speed is substantial higher than 16.5 MByte/s you have to rerun benchmark number after adjusting overclocking to 160 MHz and a reboot to enable changes.

Yes, as seen it's much better at the lower frequency of 160 MHz. But the flickering is still there. In 5k frtp bottom of the screen flickers if magnify x5, everything becomes garbage if magnify x10. As I said, no way of disabling the "magnification" completely.

gabriielangel

  • Freshman
  • **
  • Posts: 77
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3193 on: August 25, 2022, 03:17:01 AM »
@scriptmonkey, I see that you are using custom modes.
Try erasing all the files on the card and copy only the folders that come with the build.
(Erase the files on a computer reading the card. Do not reformat, otherwise you will have to make the card bootable again)

When loading ML, tap the screen to choose 5kfrtp.
Once it loads, shut down the camera.
Turn on the camera and tap the screen again, then choose 5k frtp.
Record a few clips.

Le me know i this resolves your UI problems...

grusochsten

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3194 on: August 27, 2022, 08:14:02 PM »
I'm having some difficulties with HDMI monitor to a Samsung Galaxy A52s phone on the latest build. I'm using a cheap capture card from Amazon.

HD 1080p: Completely black
HD 1080p 30fps: Fully functional*
2.5K centered: Fully functional*
2.5K 1:1: Fully functional*
3K 1:1: Fully functional*
4K: Fully functional*
5K anamorphic: Completely black
5K anamorphic: Completely black
2.8K 1:1: Fully functional*
2.5k centered frtp: Image goes either white/pink or freezes
2.5k centered frtp hdmi: Image goes either white/pink or freezes
2k 1:1: Fully functional*
5k Anamorphic frtp: Image goes either white/pink or freezes

* Framing does not work.

The only way I get any use out of a monitor with the far from optimal gear I'm using now is 2k 1:1. Could it be the capture card or is it perhaps my camera acting up?

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7368
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3195 on: September 08, 2022, 08:17:32 AM »
Hi guys!
DidnĀ“t test this yet but seems a nice boost for the eos m. Encourage users to help out here:
https://www.magiclantern.fm/forum/index.php?topic=26634.msg240127#msg240127

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7368
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3196 on: September 12, 2022, 11:32:55 AM »
New version in first post.

Added theBilalFakhouri nice little sd_uhs hack into this eos m version. Default install now is 240Mhz.
Commit:
https://bitbucket.org/Dannephoto/magic-lantern_jip_hop_git/commits/6db3b21863c86e9ac0cd208d7977b8b7f6431d24

Source:
https://www.magiclantern.fm/forum/index.php?topic=26634.0

Corallaro

  • New to the forum
  • *
  • Posts: 15
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3197 on: September 12, 2022, 11:51:11 PM »
Great work Danne!!! :)

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7368
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3198 on: September 13, 2022, 12:05:38 AM »
100% theBilalFakhouri's work here  8)

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7368
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3199 on: September 13, 2022, 12:29:51 PM »
New version.
3k now works with 24 or 25 fps with 240Mhz patch. Only 2.39:1 and 2.35:1 modes will work with 24 and 25 fps.