Author Topic: Magic Lantern Cinema Camera - Dual ISO without aliasing & without quality loss!  (Read 20419 times)

squig

  • Hero Member
  • *****
  • Posts: 518
  • Crash test dummy MK3
Uploaded two new builds.
1920x2320, fps23.976

Tried 10bit in daylight both dualiso and regular raw and footage looks ok. Tried some stress testing against a lamp but couldn't find any stripes.
Feel free to do some stress testing against either build.

Stripes still there on the 14bit build.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5717
Guess I´m out of options atm. If anyone wants to keep on testing these are the registers in crop_rec.c that I´ve been tweaking.
Code: [Select]
        case 0xC0F0713c:
            return 0x94e;
       
        case 0xC0F06804:
            return 0x94e011b;

        case 0xC0F06008:
        case 0xC0F0600C:
            return 0x1860186;

        case 0xC0F06010:
            return 0x186;

        case 0xC0F06014:
            return 0x9ff;

Not sure what´s related to wht and if/or something else is causing the issue. I recorded a lot of 10bit files which seems to work fine.

theBilalFakhouri

  • Contributor
  • Senior
  • *****
  • Posts: 351
@Danne

Maybe FPS Timer A in 1080p24 default in 5D3:
0xC0F06008= 0x1b701b7
0xC0F0600C= 0x1b701b7
0xC0F06010= 0x1b7

Your preset
0xC0F06008= 0x1860186
0xC0F0600C= 0x1860186
0xC0F06010= 0x186

Try:
0xC0F06008= 0x1870187
0xC0F0600C= 0x1870187
0xC0F06010= 0x187

It should be fixed I got vertical stripes when changing X values for FPS Timer A in 700D:
0x00X000X

So keep it as original one which is 7.
700D 1.1.5 | no more ISOless LV err 8

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5717
Like this Bilal? Gives 23.972 fps
Code: [Select]
        case 0xC0F0713c:
            return 0x94e;
       
        case 0xC0F06804:
            return 0x94e011b;

        case 0xC0F06008:
        case 0xC0F0600C:
            return 0x1870187;

        case 0xC0F06010:
            return 0x187;

        case 0xC0F06014:
            return 0x9f9;

/* correct liveview brightness */
case 0xC0F42744: return 0x4040404;


Posted versions here:
https://bitbucket.org/Dannephoto/magic-lantern/downloads/magiclantern_crop_rec_4k_mlv_snd_1x3_10bit_version2.zip
https://bitbucket.org/Dannephoto/magic-lantern/downloads/magiclantern_crop_rec_4k_mlv_snd_1x3_14bitversion2.zip

theBilalFakhouri

  • Contributor
  • Senior
  • *****
  • Posts: 351
Yes exactly, Is this working?
700D 1.1.5 | no more ISOless LV err 8

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5717
Well got word from 70mmm and still stripes. I think it's maybe too much to handle? If lowering fps override to 22 stripes are more or less gone.
Cutting off height more and still keeping 24 fps might do the trick. Working from 197 timer or so. For me the next latest build is stripefree enough for my needs.

Edit: still don't see a download of the 10bit version...

70MM13

  • Member
  • ***
  • Posts: 245
Here's the two latest 10 bit versions stress



tested at 22fps override:

V2 definitely has less stripes.  Precisely the same settings and conditions, straight from mlvapp.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5717
@70MM13
Hm, looks more like resolution loss in shadows than stripe issue in both examples. Are 14bit looking the same?

70MM13

  • Member
  • ***
  • Posts: 245
Fresh identical settings comparison of 10 and 14 bit versions...

The brightness difference is not my doing.
Interestingly, there's more aliasing in the 14 bit version.  Look closely at the modulation lever on the keyboard in the background.






theBilalFakhouri

  • Contributor
  • Senior
  • *****
  • Posts: 351
@70MM13

Turn OFF Fix Bad pixels in MLVApp, is that at 23.976 FPS?
700D 1.1.5 | no more ISOless LV err 8

70MM13

  • Member
  • ***
  • Posts: 245
You're right, that fixed the aliasing.  I never pay attention to that function...

22 FPS

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5717
Ok, just ran tests on both 10 and 14 bit versions and both seems to be working fine with or without dualiso enabled and with 23.976 fps. I erased the version2 for now.

dualiso 14bit


dualiso 10bit



10bit


14bit


70MM13

  • Member
  • ***
  • Posts: 245


They still only work for me at 22fps, but they're the least stripey yet.

The dark areas of the paintings showcase how much you lose with only 10 bits...





Edit: added another ISO 109 shot.  Used the same 35mm prime so I had to move the camera to get approximately the same framing.  Sorry, but 109 still is best for me, especially considering it's 3072 pix across.

But I was reminded of something that might be a clue about the stripes...

In the amplifier hacking mode, any settings change, including 1x/5x/10x liveview mode, requires waiting about 30 seconds for the amplifiers to settle, and during that time, the screen is full of vertical stripes that slowly fade away.

Maybe this is somehow related?

I don't know causes, these are only my observations.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5717
Resolution loss is expected with 10bits. That other anomaly with stripes showing should be fixed. At least here at 23.976. If you manage to record corrupted files please shorten the mlv and upload it.

squig

  • Hero Member
  • *****
  • Posts: 518
  • Crash test dummy MK3
Big improvement on the stripes with the latest 14bit build. I had to shoot 3200/200 DUAL ISO -3EV to see them.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5717
Yes, seems to work with latest builds. Note that right hand "amplified gain" stripes are something different from vertical stripes which seems non existent now with the same iso gain values.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5717

70MM13

  • Member
  • ***
  • Posts: 245
I gave it a quick test and it looks pretty clean at 22 FPS.  Nasty unusable stripes at default FPS on my camera.

vstrglv

  • Member
  • ***
  • Posts: 177
I have tried magiclantern_crop_rec_4k_mlv_snd_1x3_10bit.zip on 20 (21?).10.2018 and magiclantern_crop_rec_4k_mlv_snd_1x3_12bit.zip on 25.10.2018. How to use workflow mlv_dump -> cr2hdr->dng? I've got a gray image file as a result.
I have an issue with MLVApp 1.2 and magiclantern_crop_rec_4k_mlv_snd_1x3_10bit.zip version.

The same settings, but less brigthness.

https://www.magiclantern.fm/forum/index.php?topic=20025.2225
Canon 5D3,1.1.3 CF-SanDisk Extreme PRO,160MB/s, 256GB, SD-SanDisk Extreme, 90MB/s, 64GB.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5717
Not sure cr2hdr likes these 10/12 bit files. Bouncyball did a lot of changing in code to make it work with Mlv app. There are still issues it seems but getting better. Most important right now is tht you upload short mlv samples of your files.
One other thing to try is to change white level a little i Mlv App.

vstrglv

  • Member
  • ***
  • Posts: 177
https://cloud.mail.ru/public/CbRb/1JLJBAS26  190MB.
I do not know how to cut mlv file without changing data.
Canon 5D3,1.1.3 CF-SanDisk Extreme PRO,160MB/s, 256GB, SD-SanDisk Extreme, 90MB/s, 64GB.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5717
There is a cut function in MLV App up in the right corner. Just set it to export like 5 frames and the change export settings to MLV. See to it that you rename the shortened file. Can't be same as the original. Will overwrite.

vstrglv

  • Member
  • ***
  • Posts: 177
Canon 5D3,1.1.3 CF-SanDisk Extreme PRO,160MB/s, 256GB, SD-SanDisk Extreme, 90MB/s, 64GB.

vstrglv

  • Member
  • ***
  • Posts: 177
Some pictures from one MLV magiclantern_crop_rec_4k_mlv_snd_1x3_10bit.zip version ->MLVApp 1.2->H264, camera does down :
00:00:09

00:00:10 Brighter than 00:00:09

00:15:13

00:15:14

00:15:15
Canon 5D3,1.1.3 CF-SanDisk Extreme PRO,160MB/s, 256GB, SD-SanDisk Extreme, 90MB/s, 64GB.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5717
Just finished a preset which records 1920x3240(perfect 1920x1080 in 1x3). Caveat, it´s 17fps:
https://bitbucket.org/Dannephoto/magic-lantern/downloads/crop_rec_4k_mlv_snd_1x3_10bit.5D3113_presets.zip

There are presets for 10/12/14 bits as well but preview and white balance will be hard coded to 12bit so using other bits will have to account for this. I blame my lack of C-knowledge here. Stick to 12bit 1x3 presets and you´re fine.


Test MLV
https://bitbucket.org/Dannephoto/magic-lantern/downloads/short_M01-1712.MLV