Author Topic: Canon 50D  (Read 392040 times)

littlebobbytables

  • New to the forum
  • *
  • Posts: 36
Re: Canon 50D
« Reply #675 on: April 18, 2017, 05:16:45 PM »
1 & 2 / First of all, I have to reccomend you to use the latest nightlies. I had more stable recordings by sticking to the latest nightlies.
Thanks, good to know, do you have a specific nightly build you're comfortable with?

When I had this problem (happened to me several times) I found out that the "big" corrupted files were in fact recording that stopped at the beggining that I had to stop by removing the battery. These files are actually almost empty but are reported with a wrong size on the CF card. May be wrong, but that is what I think.

Well, I have those types of corrupt files too sometimes, but this looks like a different kind of corrution. The camera never indicates a problem or crashes, can review shot using MLV_play but cannot copy to computer(see details above).

3/ I use MLV_Rec more because the interface is more usable IMO. The latest MLV Lite is mor usable though. I'd reccomend both other the old raw_rec as MLV files are much easier to handle ;)
I'll try MLV, thanks!
50D, 300, BMPCC4K

justinbacle

  • New to the forum
  • *
  • Posts: 40
  • DP
Re: Canon 50D
« Reply #676 on: April 19, 2017, 04:50:04 PM »
Thanks, good to know, do you have a specific nightly build you're comfortable with?

I usually update ML as soon as I see an update available.
In the newer builds, both MLV_Lite (the old raw_rec updated) and MLV_rec record MLV files (can someone correct me if I'm wrong ?)
So no worries about that.

As there is development about new crop modes / lossless compression / 10/12bit recording I have to recommend you to update frequently ;)

justinbacle

  • New to the forum
  • *
  • Posts: 40
  • DP
Re: Canon 50D
« Reply #677 on: April 19, 2017, 07:07:54 PM »
Some time ago I played around with an dual iso video branch, that is supposed to work on the 50D and the 5D Mark II. I don't know why but it does not work on my 50D so far.
https://bitbucket.org/tecgen/magic-lantern/branch/5D2-50D-dualiso-video#diff

The good news is, I am able to record dual iso RAW video by changing the CMOS[0] manually to a value of 8, 18 or 28. (See also my post in the dual iso for 5D2 thread http://www.magiclantern.fm/forum/index.php?topic=16854.msg171694#msg171694)

Here you can find a MLV of an 50D dual iso RAW video and a dual iso DNG file that was created by MLVFS.
https://www.dropbox.com/sh/w2wemk17d5x95fu/AAAosfOCYFDQM4SPvoL4WHuda?dl=0

Can anyone help us to put these things together? It seams simple to get dual iso RAW video working even on the good old 50D.

I'd like to help on this subject. I had my VM ready for compiling and I'd like to try tweaking registers. But I have a problem.
When I try to load the ADTG_GUI module, the camera doesn't manage to load the modules. Am I missing something ?

jrm21

  • New to the forum
  • *
  • Posts: 9
Re: Canon 50D
« Reply #678 on: April 30, 2017, 08:02:54 PM »
The current "nightly" build still hangs my 50D when formatting the SD card. Requires the battery be pulled to turn off/restart camera. I know this is an old issue.

There used to be an older "stable" build that did not have this problem. However, I only see the nightly available on the download page.

An earlier post on this board made a reference to build 409 or earlier... looking at the available downloads, there it no "409" or similar. The naming conventions are all date based.

Where can I get the older version without the problem?
OR
Is there a workaround/solution for the crash on format issue? (Or does everyone simply remove their battery when formatting?)

Thanks.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6701
Re: Canon 50D
« Reply #679 on: April 30, 2017, 11:06:07 PM »
An earlier post on this board made a reference to build 409 or earlier... looking at the available downloads, there it no "409" or similar. The naming conventions are all date based.

https://builds.magiclantern.fm/jenkins/job/50D.109/
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

jrm21

  • New to the forum
  • *
  • Posts: 9
Re: Canon 50D
« Reply #680 on: May 01, 2017, 02:24:07 PM »
https://builds.magiclantern.fm/jenkins/job/50D.109/

Thank you. I'll give it a try.

edited - Now I see. The versions are listed down the side on that page. Based on the earlier post, I see that I need version 403 or earlier (not 409 and I originally typed).

I'm curious. If 403 (June 13, 2016) is the last build that doesn't freeze the camera on formatting, then the problem has existed for almost a year. Looks like there have been several updates since then. Is this a problem that can't be fixed? Does everyone using a more recent build simply remove the battery after they format?

jrm21

  • New to the forum
  • *
  • Posts: 9
Re: Canon 50D
« Reply #681 on: May 01, 2017, 05:16:33 PM »
Back again...

Perhaps I didn't ask the right question. I uninstalled the ML version from my camera. I then downloaded and installed the June 16, 2016 (#403) version, which I thought was supposed to fix the crash on format problem. It did not.

Can someone let me know which version of ML I can install that will not lock up the camera when formatting the SD card?

Thanks.

littlebobbytables

  • New to the forum
  • *
  • Posts: 36
Re: Canon 50D
« Reply #682 on: May 02, 2017, 10:44:53 AM »
Not aware of this issue, then again, using a much much older build. Will try to reproduce and report back.
50D, 300, BMPCC4K

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12200
  • Maintenance mode
Re: Canon 50D
« Reply #683 on: May 02, 2017, 11:06:48 AM »
I'm not sure if we can catch Canon's debug messages during this lock-up, but let's try. You can use this build:

https://builds.magiclantern.fm/jenkins/job/startup-log/

It logs everything that happens in the first 30 seconds (while the LED blinks), then it saves a log file. If you can catch such a log, that covers the card formatting process and the lock-up, please upload it.

Whether the lock-up can be caught by this logging code or not, depends on whether DryOS is still alive after the crash (which I don't know yet).

These logs would also help me emulate the 50D in QEMU, btw.

littlebobbytables

  • New to the forum
  • *
  • Posts: 36
Re: Canon 50D
« Reply #684 on: May 02, 2017, 11:38:35 AM »
Hello,

I have been reading through this thread looking for the best settings that the 50D can achieve. I currently have a 70D but the RAW recording is sort of limited (SD card write) as well as the occasional overheating/ERR70 messages.

I am now looking at picking up a secondhand 50D just for video.

What is the best resolution/FPS that can be achieved for RAW video? and how long would this record for? Taking into account any overheating?

Will any CF card rated 120mb/s be OK for this or tare there specific brands only?

Some of the RAW video tests I've seen posted look amazing.

Thanks!
See: https://docs.google.com/spreadsheets/d/16cgnRivbUv7nA9PUlCLmLdir3gXdIN3pqzCNAAybepc/edit#gid=5 for current capabilities. Can confirm those numbers with a good card. Best to buy a known good card, ratings don't mean much. If it needs to be cheap I've had good luck with 32gb 1000x KomputerBay cards.
50D, 300, BMPCC4K

littlebobbytables

  • New to the forum
  • *
  • Posts: 36
Re: Canon 50D
« Reply #685 on: May 02, 2017, 11:46:21 AM »
EDIT: Okay, so I decided to try and reformat the card and now it works fine. I apologize if this is a common fix that I wasn't aware of. But when this started to occur, the card (lexar 64gb 1066 card) was only about half full. Will this happen every time the card fills up, or was there just some kind of glitch that was fixed when I reformatted the card? Also, if I remember correctly, the problem occurred after I received a funky file that was pink and digitized... Could that have been the cause?
Might be that the card was not able to record fast enough before formatting. Formatting or erasing a card that's been used for a while can really help.
50D, 300, BMPCC4K

jrm21

  • New to the forum
  • *
  • Posts: 9
Re: Canon 50D
« Reply #686 on: May 02, 2017, 06:28:03 PM »
I'm not sure if we can catch Canon's debug messages during this lock-up, but let's try. You can use this build:

https://builds.magiclantern.fm/jenkins/job/startup-log/

It logs everything that happens in the first 30 seconds (while the LED blinks), then it saves a log file. If you can catch such a log, that covers the card formatting process and the lock-up, please upload it.

Whether the lock-up can be caught by this logging code or not, depends on whether DryOS is still alive after the crash (which I don't know yet).

These logs would also help me emulate the 50D in QEMU, btw.


Here's the log file.

https://www.dropbox.com/s/6abu1k1h4zolgfy/dm-0000.log.zip?dl=0

It's zipped and in DropBox. Can't see how to attach other than an image to a post in this forum.



edited to add: As expected the logging version also locks up the 50D after formatting a card. However, it also adds another issue. After the battery is removed, the camera will no longer start up from that card (removing and re-inserting the same card does not help). I need to insert a different CF card (which happens to be non-ML) and start up. After I shut down and re-insert the ML card, it will start up again.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12200
  • Maintenance mode
Re: Canon 50D
« Reply #687 on: May 02, 2017, 07:07:04 PM »
Thanks. For some reason, the emulation is stuck in an infinite loop trying to "send LensBP data" to the MPU - can you get the same log without the lens attached?

edit: nevermind, got the GUI working in QEMU!!!

The shutdown process appears to run normally, as far as I can understand from it. The display appears to turn off, but the blue LED keeps blinking, according to the log. Is this what you are seeing?

For the second lock-up issue, try removing the battery and putting it back, rather than swapping cards.

jrm21

  • New to the forum
  • *
  • Posts: 9
Re: Canon 50D
« Reply #688 on: May 03, 2017, 08:34:00 PM »
The shutdown process appears to run normally, as far as I can understand from it. The display appears to turn off, but the blue LED keeps blinking, according to the log. Is this what you are seeing?

Almost. After formatting the card, the camera attempts to restart. The display does turn off. At that point both the blue and red LEDs are solid (no blinking). Camera is completely unresponsive. "Off" switch does nothing. Battery must be removed and re-inserted.

Removing the battery shuts off camera (obviously). Re-inserting battery allows camera to start up normally.

This is all the "standard" freeze on format behavior I have experienced with all "nightly builds" I have tried.


a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12200
  • Maintenance mode
Re: Canon 50D
« Reply #689 on: May 06, 2017, 03:47:21 PM »
Added a change to startup-log in order to check this hypothesis again. Can you try?

jrm21

  • New to the forum
  • *
  • Posts: 9
Re: Canon 50D
« Reply #690 on: May 06, 2017, 08:43:41 PM »
Added a change to startup-log in order to check this hypothesis again. Can you try?

Sure, but where to do I find the new files? I only see the original May 2 version for the 50D.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12200
  • Maintenance mode
Re: Canon 50D
« Reply #691 on: May 06, 2017, 09:16:22 PM »
Sorry, didn't notice 50D has some stubs missing. Rebuilding now.

jrm21

  • New to the forum
  • *
  • Posts: 9
Re: Canon 50D
« Reply #692 on: May 06, 2017, 11:30:22 PM »
Here is a log file from the May 6 build session.

https://www.dropbox.com/s/khu85t3qxr1asa7/dm-0000.log?dl=0

Using this build of ML, the camera still freezes after formatting the CF card. However, this time, only the red LED stays lit. The blue LED is not lit and does not flash.


EDITED TO ADD: The above behavior is what should be reflected in the log file.  Just tried this again (turn camera on, take a photo, format card). First time it worked. Card formatted, camera restarted and did not lock up. Tried it a third time-- camera locked up with both red and blue LED solid. Fourth try and camera locked up with no blue LED/solid Red LED.

It seems that if the startup log process is still happening, it locks with only the red LED. If I wait for the startup log process to be done (blue stops blinking) I lock up with both LEDs solid. Not sure how/why it didn't lock up that one time.


zcream

  • New to the forum
  • *
  • Posts: 35
Re: Canon 50D
« Reply #693 on: July 03, 2017, 02:36:09 PM »
 :) Any idea is the cmos0 values can be checked into a build?
The ml iso only offer 1/2 stop Max as improvement. I would be Keen on trying dual iso to get the 14-15 stops


Some time ago I played around with an dual iso video branch, that is supposed to work on the 50D and the 5D Mark II. I don't know why but it does not work on my 50D so far.
https://bitbucket.org/tecgen/magic-lantern/branch/5D2-50D-dualiso-video#diff

The good news is, I am able to record dual iso RAW video by changing the CMOS[0] manually to a value of 8, 18 or 28. (See also my post in the dual iso for 5D2 thread http://www.magiclantern.fm/forum/index.php?topic=16854.msg171694#msg171694)

Here you can find a MLV of an 50D dual iso RAW video and a dual iso DNG file that was created by MLVFS.
https://www.dropbox.com/sh/w2wemk17d5x95fu/AAAosfOCYFDQM4SPvoL4WHuda?dl=0

Can anyone help us to put these things together? It seams simple to get dual iso RAW video working even on the good old 50D.

justinbacle

  • New to the forum
  • *
  • Posts: 40
  • DP
Re: Canon 50D
« Reply #694 on: July 04, 2017, 01:28:26 PM »
:) Any idea is the cmos0 values can be checked into a build?
The ml iso only offer 1/2 stop Max as improvement. I would be Keen on trying dual iso to get the 14-15 stops
I tried to help with the programming a few months ago but got stuck http://www.magiclantern.fm/forum/index.php?topic=9852.msg183402#msg183402
I'd love to see Dual Iso video work on the 50D too !

zcream

  • New to the forum
  • *
  • Posts: 35
Re: Canon 50D
« Reply #695 on: July 09, 2017, 10:32:22 PM »
@tecgen seems to have done it by hardwiring cmos0 values. I am in Mumbai at, with limited internet and unable to build.
Perhaps someone could consider posting a link to a build with these values.

favvomannen

  • Freshman
  • **
  • Posts: 86
Re: Canon 50D
« Reply #696 on: July 14, 2017, 05:33:01 PM »
im stuck at 16:9 1500×890 (something) i cant get the resolution to change after pressing zoom one time.
anyone know whats the deal?

(running latest ml version)

justinbacle

  • New to the forum
  • *
  • Posts: 40
  • DP
Re: Canon 50D
« Reply #697 on: August 30, 2017, 10:50:09 PM »
Did any one else noticed that the latest built (18 aug 2017) broke Raw recording with mlv_rec ?
Mlv_lite is still working though, but I cannot get to record anything with mlv_rec. The camera just freezes.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12200
  • Maintenance mode
Re: Canon 50D
« Reply #698 on: August 30, 2017, 11:17:09 PM »
Works fine here (5D3).

hg bisect, please.

justinbacle

  • New to the forum
  • *
  • Posts: 40
  • DP
Re: Canon 50D
« Reply #699 on: September 01, 2017, 10:54:41 PM »
Just tried again with the previous build I was using, 2017Jul28 is working fine.
What can I do to help debug ? I'd be glad to help :)