Canon 50D

Started by ayshih, January 07, 2014, 03:38:12 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


What about restarting the camera from the script?


Sorry I missed that.

The script reboots fine!

Mike JM

Is there still a RAW video recording add-on?


Quote from: ADJ on August 18, 2016, 11:23:44 PM
The script reboots fine!

Alright, so it's either some sort of memory overflow, or an issue in the memory backend. I'd like to diagnose it, but I need a tester on IRC who can compile ML.


I have been testing this issue tonight, been guided by A1ex on IRC.  Not solved yet, we will continue another day.


Quote from: josepvm on August 20, 2016, 11:31:23 PM
I have been testing this issue tonight, been guided by A1ex on IRC.
I'm glad to hear someone's able to help. I've never compiled ML nor have I used IRC so it would take me a while to get up to speed.


We have narrowed it down to dialog_redraw, and I guess it's related to a 50D quirk: unlike all other cameras, the 50D redraws its GUI continuously.

Here's a test anyone can run: load and run the redraw test. It's an infinite loop, and it may or may not be obvious whether it's actually running. If you run this test at the same time (in parallel) with the rectangle test, it will be obvious it's running, as the rectangles will disappear quickly.

While running this test, try to navigate Canon menus (it should not crash) and check whether the camera shuts down and restarts fine (without having to take the battery out).


Launching  the redraw test, that's what I see:

- The ML menu closes, Canon's normal status screen in photo mode appears. the blue led in liveview button blinks during several secons, and after that it stops blinking, so the redraw action starts. I can not see the effect of the redraw, because in this screen the 50D does not show any overlayed info (On a 500D doing the same test, I see the overlays blinking)
- I press the "menu" button, Canon menu appears, but the top icon raw, containing the taps to access every page in menu, is not shown, is all blank (this does not happen on 500D)
- When I move camera's main dial, the tabs start to show, but I only see two of them (the actually selected and the last one previously seen, the other icons seen before disappear when moving the dial away from them)
- I can come back to normal status screen half-pressing the shutter button, but I can't longer enter ML menu pressing trash button.
- I can shut down the camera  normally with the power switch, no need to extract battery.

If I enter the "format" function in Canon menu, the camera hangs when rebooting after format, as usual. Having the redraw test active does not make any difference.

If I launch the rectangle test and then the redraw test, I do not see any difference on 50D respect launching only the rectangle text. The rectangles get erased quickly anyway, so I can see parts of the underlying normal status screen. This is different behaviour that in 500D, on this camera the rectangle test launched alone fills all the screen so I can't longer see the underlying Canon status screen.



I'm deeply sorry for being a newbie on this forum, but my question is: what is the best, but not much expensive CF card for 50D?
Canon EOS 5D Mk III + Canon 24-105 F/4 L IS USM + SanDisk Exreme Pro 64 GB (SD, ML Nightly.2021Feb07.5D3113) + SanDisk Extreme Pro 128 GB (CF).

Walter Schulz

When it comes to performance/price Komputerbay is your choice. Make sure to use UDMA-7 compatible cardreader!


Thank you. What about Lexar x1066?
Canon EOS 5D Mk III + Canon 24-105 F/4 L IS USM + SanDisk Exreme Pro 64 GB (SD, ML Nightly.2021Feb07.5D3113) + SanDisk Extreme Pro 128 GB (CF).

Walter Schulz

Yes. And the question now is?


Thank you, that is all I needed to know about CF cards.
Canon EOS 5D Mk III + Canon 24-105 F/4 L IS USM + SanDisk Exreme Pro 64 GB (SD, ML Nightly.2021Feb07.5D3113) + SanDisk Extreme Pro 128 GB (CF).



I have been reading through this thread looking for the best settings that the 50D can achieve. I currently have a 70D but the RAW recording is sort of limited (SD card write) as well as the occasional overheating/ERR70 messages.

I am now looking at picking up a secondhand 50D just for video.

What is the best resolution/FPS that can be achieved for RAW video? and how long would this record for? Taking into account any overheating?

Will any CF card rated 120mb/s be OK for this or tare there specific brands only?

Some of the RAW video tests I've seen posted look amazing.




I`ve had this crash thing going on too using the powergrip. I stopped using the power grip and now its no longer happening.


EDITED: Arrgg... just read the last few posts. (After finding nothing in google and forum searched).

I am also having the freeze on card format in camera. Using the Aug 24 nightly build. Have reverted to an earlier version for now.


Hi, I am new to the forum and a new owner of a mint condition 50D. As soon as I received the camera I installed ML. First I want to thank all of the contributors and testers who have made Raw video on the 50D possible. It is a beautiful image. But, there's always a but, when I first started using ML Raw, I had no issues whatsoever, everything worked fine. Then, out of nowhere, it started freezing up on me. At first I thought it was because I have global draw on while recording, so I switched it off, didn't change a thing. Then I thought it was because ALO kept enabling itself. Actually after the camera freezes, the only way to unfreeze it is to take the battery out. Then when back on and running, the camera does not recognize the raw module, or actually the module screen. It requires an on/off cycle for it to be recognized again. I finally figured out how to disable ALO and I was ready to go, but nope, it still freezes. My only assumption is temperature. When I initially turn on the camera, it registers at 30 degrees Celsius, I guess it seems okay, but by the second or third take, the camera is freezing every time I hit record. By then the temperature is floating around 45 degrees. Anyway, I could really use some help here, because I don't know if this is a settings issue or my camera is just running hot or what, but this is unusable as is. I read earlier in this thread, about a basic 2.3 version, is that version more stable, or are there any plans to create a very basic build that only has the most relevant of tweaks... 24p (23.976) exposure override, manual controls, Raw recording, and any other basic settings? Am not a technical person, so I'm not even sure that would help with the stability? I have fallen in love with the image coming out of the 50D Raw, but now it seems like I won't be able to use it, but now I'm already hooked and I can't go back to generic consumer 4K. Please help.

EDIT: Okay, so I decided to try and reformat the card and now it works fine. I apologize if this is a common fix that I wasn't aware of. But when this started to occur, the card (lexar 64gb 1066 card) was only about half full. Will this happen every time the card fills up, or was there just some kind of glitch that was fixed when I reformatted the card? Also, if I remember correctly, the problem occurred after I received a funky file that was pink and digitized... Could that have been the cause?


I am planning to add audio recording to 50D by using a remote shutter and an audio recorder.
Pressing record on remote shutter would start video recording and audio recording.
For this you would need an on/off button to start/stop of audio device and the same for 50D through remote shutter.
ML cannot record/stop with remote shutter (ERR 99). It can only record. 50% of the problem is solved.
Is there any way to solve this issue ?

Another way is by using a follow focus solution ex. Aputure UFC-1S.
Dismantling of UFC-1S to get access to rec/stop button seems too much for this project.
The best solution is a ML workaround to stop video recording through remote shutter.


To use fat32 format with 64kb sector using a mac..

Anmols-MacBook-Pro:~ mac$ diskutil info /Volumes/EOS_DIGITAL/
   Device Identifier:        disk4s1
   Device Node:              /dev/disk4s1
   Part of Whole:            disk4
   Device / Media Name:      Untitled 1

   Volume Name:              EOS_DIGITAL
   Escaped with Unicode:     EOS_DIGITAL

   Mounted:                  Yes
   Mount Point:              /Volumes/EOS_DIGITAL
   Escaped with Unicode:     /Volumes/EOS_DIGITAL

   File System Personality:  MS-DOS FAT32
   Type (Bundle):            msdos
   Name (User Visible):      MS-DOS (FAT32)

   Partition Type:           Windows_FAT_32
   OS Can Be Installed:      No
   Media Type:               Generic
   Protocol:                 USB
   SMART Status:             Not Supported

   Total Size:               128.0 GB (128042901504 Bytes) (exactly 250083792 512-Byte-Blocks)
   Volume Free Space:        118.2 GB (118178643968 Bytes) (exactly 230817664 512-Byte-Blocks)
   Device Block Size:        512 Bytes

   Read-Only Media:          No
   Read-Only Volume:         No
   Ejectable:                Yes

   Whole:                    No
   Internal:                 No

UNMOUNT THE USB DRIVE using Disk Utility

Anmols-MacBook-Pro:~ mac$ sudo newfs_msdos -F 32 -v EOS_DIGITAL -c 128 /dev/disk4s1
newfs_msdos: warning: /dev/disk4s1 is not a character device
512 bytes per physical sector
/dev/disk4s1: 250053120 sectors in 1953540 FAT32 clusters (65536 bytes/cluster)
bps=512 spc=128 res=32 nft=2 mid=0xf8 spt=32 hds=255 hid=63 drv=0x80 bsec=250083792 bspf=15263 rdcl=2 infs=1 bkbs=6


Also, is there a way currently to get a beep on start and stop rec ?
The guide is for 2.3 and it mentions a beep choice in the movie menu, but my menu (nightly build current) does not show this option.
I can clap hands, but its way more efficient to get the beep in the beginning.


@andy600 - Can I check if tragic lantern 2.0 is the only way to get the speed hacks to go upto 84 mbps ?
Tragic Lantern 2.0 as it has more features and higher CF write speeds (It's bleeding edge code so use at your own risk)

You can download 'safer' unified builds here: -


@zcream - Sorry but TL builds are no longer maintained and are not supported here either in use or discussion. Please use the nightly builds.
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs -


Hi guys!

I have a 50D and i´m having trouble with the 4gb limit.
What can I do to minimize problems related to this?

Fat32 formated with 64k sectors. 128gb Toshiba 1000x

When I try to convert the Raw files, the video plays ok until it reaches the split, then it freezes the image or show bugged footage, flickering.
Plays ok until 1:17, then it bugs.

I have to close Mlvproducer, open the file again but transcode lets say from 1:18 to 2:00, then I can watch the transcoded footage ok.

tried to convert to other formats, not worked too, same error.

I´m testing MLVrawviewer and it seems to be a MLVProducer problem.
Will test some more and update...
50D + 600D


Thx @andy600 I went through a lot of your posts here and on other forums...

I have tried for a day to get my EF lens to AutoFocus before shooting RAW video.
Am I missing something ? I tried the half shutter press and it just lights up the screen.
I tried the AF ON button in the rear, and it fires the shutter.


Quick question to those that use this camera. I've purchased a KB CF 1000x card that has a Crystal Disk Mark score of 132.4mb read and 108.6mb write, but that only translates into ~71mbs in camera. I've read through this form and done the things that were suggested to improve speed (reformat to 64kb), which gave me 10+mb through CDM, but I cannot get anywhere near the ~80mb I need to record non crop without FPS override.

For anyone that knows from experience, is getting a card with a vastly higher rating going to give me the +10mb write I need in camera, or am I at a permanent loss. I'm already almost at 2x the camera benchmark through my PC.