Author Topic: Danne's crop_rec_4k & ISO experiments  (Read 73898 times)

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7019
Re: Danne's crop_rec_4k & ISO experiments
« Reply #600 on: August 15, 2020, 09:15:09 AM »
If you turn off lff crop rec you can turn off bitdepth options too. Instead use bitdepth handling in RAW video menu.

has_abandonment_issu

  • New to the forum
  • *
  • Posts: 28
Re: Danne's crop_rec_4k & ISO experiments
« Reply #601 on: August 15, 2020, 04:30:21 PM »
Thank you Danne.

For everyone’s reference I found that:

14 bit lossless with the bit depth menu off,

or 12 bit lossless from the raw video menu with 12 bit selected via the bit depth menu,

Both appeared to have the correct gain, so I would try those settings first if you’re trying to record without the crop modes.

12 bit lossless via the raw menu (nothing bit depth menu) appears to be underexposed, and 14 bit with 12 bit from the bit depth menu appears overexposed.


70MM13

  • Senior
  • ****
  • Posts: 492
Re: Danne's crop_rec_4k & ISO experiments
« Reply #602 on: August 20, 2020, 01:44:40 AM »
with the beautiful anamorphic mode giving such great results, i'm curious...

would it be possible to do it vertically also?  can it be just as "aliasing-free" vertically as it is horizontally?

the reason i'm asking is because i would love to be able to do some slow-motion with this quality.

i think everyone would benefit from this if it is achievable...

thanks!

wib

  • Freshman
  • **
  • Posts: 87
Re: Danne's crop_rec_4k & ISO experiments
« Reply #603 on: August 21, 2020, 11:50:04 AM »
I have to report that sometimes the liveview is stuck in x10 zoom (this seems to happen when I go in ML menu with the trash button) and I have to click on menu button 3-4 times to reset it and ML will load again the "normal" liveview.
EOS 5D3 123 crop_rec_4k_mlv_snd_isogain_1x3_presets_2020Dec11.5D3123

rinski

  • New to the forum
  • *
  • Posts: 41
Re: Danne's crop_rec_4k & ISO experiments
« Reply #604 on: August 22, 2020, 10:27:49 AM »
Hello, version 5d3 works very well for me, July 4 1.2.3, 88MB / s cf Lexar 128gb 1066x + 78 MB / s, extreme pro sandisk 170MB / s, 240 patching, more than 6 minutes voluntarily interrupted with parameters 1/166 iso 200 av 9.9, on the outside with the full anamorphic resolution 1.1, 1920x3760, the two cards in fat32 without restart problems when turning off and on and more or less maintained the speed, the 3x3 Binning pixels would be wonderful to obtain more than 15,003 fps no aliasing / moire.
Thank you.

GullRaDriel

  • New to the forum
  • *
  • Posts: 43
Re: Danne's crop_rec_4k & ISO experiments
« Reply #605 on: August 24, 2020, 09:34:49 PM »
Are you using Sticky DOF and 10x crop aid maybe ?

GullRaDriel

  • New to the forum
  • *
  • Posts: 43
Re: Danne's crop_rec_4k & ISO experiments
« Reply #606 on: August 24, 2020, 09:36:13 PM »
I'm on the August 15 built from Danne's repo (see the commits for the little changes between 14 and15 build)
Never experienced such a thing as a sticky x10.
Crop rec can force it to x5.
What settings were you using ?

Calussien

  • New to the forum
  • *
  • Posts: 3
Re: Danne's crop_rec_4k & ISO experiments
« Reply #607 on: August 25, 2020, 03:34:32 PM »
Hi 5d3 users. I just got a 5D3 AND usable cards for ML : SD Sandisk 128GB 170MB/s and CF Lexar Pro 128GB 160MB/s
I am discovering ML features one by one, doing many tests to understand the tools I could use in photo and video.

I have come with an issue using Danne's build. I can't record 12 bits lossless or 8-11 lossless in any crop preset.

Here are my settings for a UHD preset.

Build : Nightly.2020Aug14.5D3113

Presets : UHD 1:1

Raw video : On, 3664x1536, AR 16:9, Data format : 14-bit lossless (written in grey, can't change it in other lossless bit depths...), Preview : Framing, Crop   rec preview : auto mode, card spanning : on, kill GD : off

Bitdepth : 12

Ratio : off

FPS Override : off

SD overclock : on, 160MHz


Maybe there is something I am doing wrong. I saw older posts and some guys were using 3k preset in 12 bit lossless.

Many thanks for helping me :)

ABBATT

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k & ISO experiments
« Reply #608 on: August 25, 2020, 08:13:52 PM »

ihaveacamera

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k & ISO experiments
« Reply #609 on: August 27, 2020, 03:03:38 AM »
Okay, perhaps I'm doing something wrong but I'm having an issue with getting video that isn't choppy. I'm basically using the default setting for the anamorphic preset except for the resolution being set to 1600 and I have global draw off. I'm should mention I'm using a Lexar Pro 1066x. I've tried playing around with a few other settings but I haven't had much luck and just end up crashing.

Anyone mind pointing me in the right direction? Thank you!

sm105

  • New to the forum
  • *
  • Posts: 28
Re: Danne's crop_rec_4k & ISO experiments
« Reply #610 on: September 02, 2020, 01:01:28 AM »
I've been successfully using Danne's builds since earlier this summer (awesome work!), and I just started testing out dual iso raw video. I feel like I'm doing something wrong because I'm getting weird colors, lines, and regions of cyan. For the frame below, I used the 3K preset with the following settings:

Aug. 14 build (1.2.3)
2560x1440
16x9 AR
10-bit
Histogram and zebras enabled
Dual-iso enabled at 100/800
Slightly underexposed from ETTR
Dual-iso ON in MLV App

I also tried an earlier build and had the same issue. Any idea what I'm missing?


Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7019
Re: Danne's crop_rec_4k & ISO experiments
« Reply #611 on: September 02, 2020, 04:29:00 PM »
You can try "Switch". Uses a1ex updated cr2hdr code.

sm105

  • New to the forum
  • *
  • Posts: 28
Re: Danne's crop_rec_4k & ISO experiments
« Reply #612 on: September 03, 2020, 12:50:37 AM »
You can try "Switch". Uses a1ex updated cr2hdr code.

Thanks Danne! Switch worked. I was able to salvage some good shots that I otherwise would have deleted.

GullRaDriel

  • New to the forum
  • *
  • Posts: 43
Re: Danne's crop_rec_4k & ISO experiments
« Reply #613 on: September 06, 2020, 03:54:21 PM »
Everything is working so far for me.
I'm currently trying a timelapse with fps override @2.5 and raw 12bits video.
I've attached a photo for the stats, continuous.
And for the video itself, it is still recording atm.

Speed is a total of 179 MB/s

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7019
Re: Danne's crop_rec_4k & ISO experiments
« Reply #614 on: September 06, 2020, 03:58:02 PM »
That is brutal  8).

Bender@arsch

  • Freshman
  • **
  • Posts: 89
Re: Danne's crop_rec_4k & ISO experiments
« Reply #615 on: September 06, 2020, 04:10:51 PM »
@GullRaDriel

I think this is not the correct writespeed, see my test with different modes:

https://www.magiclantern.fm/forum/index.php?topic=12862.msg228848#msg228848

You can also test it at the same way.

GullRaDriel

  • New to the forum
  • *
  • Posts: 43
Re: Danne's crop_rec_4k & ISO experiments
« Reply #616 on: September 06, 2020, 04:47:31 PM »
Yeah, I agree that fps overriding is somewhat helping, not doing that much encoding.

First I used MLVapp and 60fps setting and generated a 32GB avi.

Then I used Handbrake and vimeo/youtube 4k setting and got a 171 MB video X-D

Anyway, the video itself (please note that ATM youtube is still processing the highres version):


GullRaDriel

  • New to the forum
  • *
  • Posts: 43
Re: Danne's crop_rec_4k & ISO experiments
« Reply #617 on: September 06, 2020, 05:10:08 PM »
I'll also try a normal and long record with audio, at the highest possible continuous setting for my set up.
Pretty sure that if the processors are busy doing audio and video encoding the write speed will lessen. That, and or the various bus's that can be more used and thus limiting bandwidth somewhere.

stef7

  • New to the forum
  • *
  • Posts: 6
Re: Danne's crop_rec_4k & ISO experiments
« Reply #618 on: September 12, 2020, 05:33:39 PM »
Question about anamorphic fullres mode:
Currently it is fixed to 15fps.  Is is possible to increase frame rate ? Tried to use FPS override but camera locks and freezes. Have to pull the battery out in order to make it operational again.

With SD card overclock + card spanning in theory can get 1800 x 2700 12 bit or even 1920 x 2880 10 bit running at 24fps for at least 10-15 sec, which is enough for me. 2:1 is my favorite aspect ratio. :)

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7019
Re: Danne's crop_rec_4k & ISO experiments
« Reply #619 on: September 13, 2020, 12:16:20 AM »
New builds:
https://www.magiclantern.fm/forum/index.php?topic=23041.msg216899#msg216899

- Expanded 3.5K 1:1 centered x5 preset height to 3584x1730(24fps)
Why this. Now we get cropped real time preview and framing instead of only framing preview when using 3K 1:1 preset for instance.
For 24fps you can use full 3584x1730 but for 25fps I had to reduce height to 3584x1660.
Needs some testing. Now we can get 16:9 3152x1730 with cropped realtime preview. Nice.

has_abandonment_issu

  • New to the forum
  • *
  • Posts: 28
Re: Danne's crop_rec_4k & ISO experiments
« Reply #620 on: September 13, 2020, 01:05:41 AM »
New builds:
https://www.magiclantern.fm/forum/index.php?topic=23041.msg216899#msg216899

- Expanded 3.5K 1:1 centered x5 preset height to 3584x1730
Why this. Now we get cropped real time preview and framing instead of only framing preview when using 3K 1:1 preset for instance.
For 24fps you can use full 3584x1730 but for 25fps I had to reduce height to 3584x1660.
Needs some testing. Now we can get 16:9 3152x1730 with cropped realtime preview. Nice.

I am already finding the ability to see real time focus (albeit cropped) extremely useful, and I have also found the 3.5k x5 preset to be the most stable whenever I've tested anything before (even with a knock off SD card) in general. Very excited.

I just tested it using a variety of settings on 3.113 (card spanning on, off, overclocking on, etc). I have yet to run into any issues. Seems very stable.

The inclusion of a "preferred card" toggle in the raw video menu was a nice touch. I tried just SD card using that setting in 14 bit 1080 and it also worked well with no issues.

The new 2.07 - 1 max aspect ratio in 3.5k is really nice. I may start shooting this aspect ratio a lot. Gives me a clear foreground, middle ground, and background without the feeling of too much vertical space. Anything between 1.77 - 1 to 2.4 - 1 is really up to taste, but this feels like just right to me. I can't wait to start designing some shots and feeling it out more.

Also at 3584 x 1730 we are getting a whopping 6.2 megapixels, which is even higher than UHD 3840x1536 at 5.9 megapixels. And with the ability to see focus with global draw off I can actually shoot that resolution continuously in a lot of lighting conditions!

This is a very big update. Ability to check focus in real time with global draw off means I can shoot at high resolutions and still take full advantage of the overclocked write speeds without being totally blind. Awesome.

Thanks Danne. I'm going to be playing with this new build all week.


Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7019
Re: Danne's crop_rec_4k & ISO experiments
« Reply #621 on: September 13, 2020, 01:29:55 AM »
Thanks for your testing and feedback. Appreciated.
I guess one could rework all the presets while in x5 zoom and it would be possible to find real time cropped preview for all presets like on eosm. Will take too long so this will be nice to have.

70MM13

  • Senior
  • ****
  • Posts: 492
Re: Danne's crop_rec_4k & ISO experiments
« Reply #622 on: September 13, 2020, 03:34:19 AM »
this is truly excellent!

there seems to be something indeed about the 3.5k mode that is extra stable.  i was recording at full 14 bits with a green indicator when exposed with very little clipping, and it stayed in the orange for a good 30 seconds before finally quitting when it was severely overexposed!

with overclocking and spanning of course :)

this feels like a new camera.  spectacular!  i really could have used this realtime preview during shooting earlier today!

i agree the extra vertical height is perfect.  sometimes 2.35:1 was just too short.  this is great!

hats off to you and bilal

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7019
Re: Danne's crop_rec_4k & ISO experiments
« Reply #623 on: September 13, 2020, 04:12:10 AM »
Great to hear it's working!

GullRaDriel

  • New to the forum
  • *
  • Posts: 43
Re: Danne's crop_rec_4k & ISO experiments
« Reply #624 on: September 13, 2020, 08:58:41 AM »
Hello Danne.

Thanks for the build. I'm on firmware 1.13 and with your latest build I have a flashing liveview, alternating from parts of what is in sight with strange colors to full colored pixel view (like a TV without a channel).

Whatever the mode set it's not working and generating corrupted messages and asserts logs if I try to record.

I've tried numerous settings (spanning on/off, various résolutions/bitdepth), no one working.

@70mm what firm are you using ? 1.13 ? Have you wiped the SD before putting the new build ?