Author Topic: 600D Audio TEST release - 2.3 based  (Read 141103 times)

klangdrang

  • New to the forum
  • *
  • Posts: 7
Re: 600D Audio TEST release - 2.3 based
« Reply #50 on: August 17, 2012, 01:48:13 PM »
Thanks for doing this!
I just tested 0.4. The audio monitoring works but there seems to be a problem with overriding audio and audio metering. When I activate Audio Override the sensitivity metering of the metering is extremely low but the input volume is normal. I have to increase the analog gain to 60db to get red bars in the metering. But audio starts popping at 15db. At 60db audio is much too sensitive and metering seems just right.
I use an external Rode Stereo Video Mic Pro and Headphones for monitoring which are connected to the canon A/V cable via two adapters. My setting for the POutput Volume is 11db.

klangdrang

  • New to the forum
  • *
  • Posts: 7
Re: 600D Audio TEST release - 2.3 based
« Reply #51 on: August 17, 2012, 03:30:49 PM »
...also following things are not working:
starting camera with audio override off, audio monitoring on and headphones connected: display keeps off
audio monitoring without audio override works only if first audio override is activated and afterwards deactivated. then you can monitor the sound without audio override till you are in the magic lantern menu and half press the shutter

miyake

  • Developer
  • Senior
  • *****
  • Posts: 394
Re: 600D Audio TEST release - 2.3 based
« Reply #52 on: August 17, 2012, 03:59:55 PM »
@klangdrang
Thank you for your testing.

1st meter sencivity thing. I will test it.
2nd monitor blackout thing. See this YouTube



MSG added
hmmmmmmmm...
It's a little difficult to finding reason for it.
Actually cpu is a little high load, then meter_task is slow down.But I can't find the reason yet.

miyake

  • Developer
  • Senior
  • *****
  • Posts: 394
Re: 600D Audio TEST release - 2.3 based
« Reply #53 on: August 17, 2012, 07:07:20 PM »
Nightly build 0.5 (test version)
http://chirari.ddo.jp/ml/600Daudio/autoexec5.bin
History
 -meter sencitivity issue . may be solved

Maybe solved it. Please Please test this build


MSG added
I forgot to update version number string on this autoexec.bin....

witchmaster

  • Just arrived
  • *
  • Posts: 2
Re: 600D Audio TEST release - 2.3 based
« Reply #54 on: August 19, 2012, 11:45:30 AM »
Really nice work with this, thank you all developers! I have a question though. I tested version 0.4 and when I override the audio settings I still get the same noise as when recording with override: off. Is there something I'm missing or does these changes not affect the poor audio recording quality of the 600D?

witchmaster

  • Just arrived
  • *
  • Posts: 2
Re: 600D Audio TEST release - 2.3 based
« Reply #55 on: August 19, 2012, 12:14:36 PM »
I couldn't get 0.5 to show anything on the audio meter and no audio being recorded whatsoever.

Rush

  • Member
  • ***
  • Posts: 159
  • 5D3, EOS M
Re: 600D Audio TEST release - 2.3 based
« Reply #56 on: August 19, 2012, 12:36:37 PM »
I couldn't get 0.5 to show anything on the audio meter and no audio being recorded whatsoever.
Enable audio recording in Canon menu, enable ML audio override, increase Analog gain, select internal mic or auto input
Greetings from Russia!

miyake

  • Developer
  • Senior
  • *****
  • Posts: 394
Re: 600D Audio TEST release - 2.3 based
« Reply #57 on: August 19, 2012, 03:13:17 PM »
@Rush
Thankyou

@wichmaster

Really nice work with this, thank you all developers! I have a question though. I tested version 0.4 and when I override the audio settings I still get the same noise as when recording with override: off. Is there something I'm missing or does these changes not affect the poor audio recording quality of the 600D?

 The normal canon menu is using "mic vol","Mic boost", "Digital gain" combination with only single control bar. and these parameters are fixed ratio.
So it's time to find best combination ratio for getting lesser hiss-noise. But we already know Juiced-link is one of better solution for it.
it's up to you.

Basically our codes are only provide more controlling ability on audio settings.

miyake

  • Developer
  • Senior
  • *****
  • Posts: 394
Re: 600D Audio TEST release - 2.3 based
« Reply #58 on: August 20, 2012, 07:46:44 AM »
600D audio autoexec.bin *BETA* Updated
http://chirari.ddo.jp/ml/600Daudio/autoexec6.bin (need rename to autoexec.bin)
History
 -Solved issue #15(taken picture preview in movie_mode)
 -startup/preview response up.

Rush

  • Member
  • ***
  • Posts: 159
  • 5D3, EOS M
Re: 600D Audio TEST release - 2.3 based
« Reply #59 on: August 20, 2012, 11:39:56 AM »
Thank you very much for your work!!!

Is it possible to solve problem with stuttering of audio in first seconds of record?
I thought that on 550D/60D there are no stuttering...
Greetings from Russia!

miyake

  • Developer
  • Senior
  • *****
  • Posts: 394
Re: 600D Audio TEST release - 2.3 based
« Reply #60 on: August 20, 2012, 11:48:59 AM »
Is it possible to solve problem with stuttering of audio in first seconds of record?
I thought that on 550D/60D there are no stuttering...

currently , I can't.


@scrax
Please add this picture and Headphone youtube to first post.

scrax

  • Developer
  • Hero Member
  • *****
  • Posts: 1417
  • Code monkey
Re: 600D Audio TEST release - 2.3 based
« Reply #61 on: August 20, 2012, 09:30:55 PM »
@scrax
Please add this picture and Headphone youtube to first post.
nanomad preceded me :)
I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus - EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX Lion, Photoshop & Lightroom -no video experience- MLTools

xaled

  • New to the forum
  • *
  • Posts: 38
Re: 600D Audio TEST release - 2.3 based
« Reply #62 on: August 20, 2012, 11:31:02 PM »
Thanks for the enabling audio controls on 600d!

Short question - is it possible to have different analog gains on the left and right channels?
Something like Juicelink does:

miyake

  • Developer
  • Senior
  • *****
  • Posts: 394
Re: 600D Audio TEST release - 2.3 based
« Reply #63 on: August 21, 2012, 03:25:32 AM »
@xaled
You can do by Digital gain LR.
But range width is tight.

Rush

  • Member
  • ***
  • Posts: 159
  • 5D3, EOS M
Re: 600D Audio TEST release - 2.3 based
« Reply #64 on: August 21, 2012, 11:23:47 AM »
@xaled
You can do by Digital gain LR.
But range width is tight.

Are you sure that it will affect clipping?
I think that if you get clipping sound with analog gain - you will get clipping even with applied "minus digital gain". Or am I wrong?
Greetings from Russia!

miyake

  • Developer
  • Senior
  • *****
  • Posts: 394
Re: 600D Audio TEST release - 2.3 based
« Reply #65 on: August 21, 2012, 12:07:28 PM »
Are you sure that it will affect clipping?
I think that if you get clipping sound with analog gain - you will get clipping even with applied "minus digital gain". Or am I wrong?

Does something different of analog and digital gain for final recorded volume?(Actually noise is different. )
I'm not expert of Audio.
Now we found only Digital gain is able to control LR separated.

And if you know good article of this thing. Please let me know URL.


xaled

  • New to the forum
  • *
  • Posts: 38
Re: 600D Audio TEST release - 2.3 based
« Reply #66 on: August 21, 2012, 02:18:41 PM »
@miyake

Thanks, I did not look at digital gain. I'm trying to avoid it.

May be one day the LR controls for analog gain will be found on the 600d audio chip.

Greetings,
xaled

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 600D Audio TEST release - 2.3 based
« Reply #67 on: August 21, 2012, 04:01:09 PM »
If its not in the data-sheet there isn't going to be any "finding".

miyake

  • Developer
  • Senior
  • *****
  • Posts: 394
Re: 600D Audio TEST release - 2.3 based
« Reply #68 on: August 22, 2012, 04:15:17 PM »
600D audio autoexec.bin *BETA* Updated
http://chirari.ddo.jp/ml/600Daudio/autoexec7.bin (need rename to autoexec.bin)
History
 -merge with current repo
 -reduce pop noise and responce up when setting audio chip.
 -monitoring lauch timing issue solved(startup related) (@klangdrang reported)
 -monitoring off is perfectly working.

funkysound

  • Freshman
  • **
  • Posts: 74
Re: 600D Audio TEST release - 2.3 based
« Reply #69 on: August 22, 2012, 07:50:35 PM »
Now I found a short time to check the test release (7) - great work!

But I found that the audio out could be a bit louder and I also felt that there were too much high frequencies. I tested it with different Headphones using the org. canon cable + adapter.
Using the digital department I couldn´t hear any difference when I pushed L/R over 0 - even +7 didn´t really push the volume.

I may have done something wrong because there was only short time -  I wanted to mention it anyway.
But it´s is a great step forward! :)
EOS 600d, Tamron 17-50mm 2,8 with stab., Tamron 70-300mm, Canon 50mm 1:1,8, Sigma 10-20mm 4-5,6, Sigma 30mm 1,4,  EOS M with 18-55mm, 22mm and EF adapter, tons of more glases incl. FD/FL, EOS 70D, Canon 18-135mm STM

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 600D Audio TEST release - 2.3 based
« Reply #70 on: August 22, 2012, 08:21:33 PM »
Digital gain did work for me... it made monitor louder. Its loud enough for me on 0 even with earbuds. It was actually ear shattering before if turned up too high. Everything depends on input volume, if that is quiet, the monitor will be too. I still have to test external mic and something more than tapping. Honestly its pretty good thus far and better than 550D/etc audio.


jonnyschanny

  • New to the forum
  • *
  • Posts: 8
Re: 600D Audio TEST release - 2.3 based
« Reply #71 on: August 22, 2012, 10:14:30 PM »
hi, i downloaded v6, and heres what i found. After using the camera for a bit in film mode and taking several short shots, i turned it off, but found out the red light at the bottom of my camera stayed on. I tried to turn it back on, and nothing happened. had to take the battery out. it only happened that once, so i dont know what the problem was. Dont know if anyone else has experienced that

Rush

  • Member
  • ***
  • Posts: 159
  • 5D3, EOS M
Re: 600D Audio TEST release - 2.3 based
« Reply #72 on: August 22, 2012, 10:47:12 PM »
the red light at the bottom of my camera stayed on.
I have such problem only when I eject my memory card before blinking of led stops
Greetings from Russia!

nanomad

  • Administrator
  • Hero Member
  • *****
  • Posts: 2918
  • All your websites are belong to us
Re: 600D Audio TEST release - 2.3 based
« Reply #73 on: August 22, 2012, 10:52:10 PM »
Could be. Never do that though as it could cause serious camera issues including bircks
EOS 1100D | EOS 650 (No, I didn't forget the D) | Ye Olde Canon EF Lenses ('87): 50 f/1.8 - 28 f/2.8 - 70-210 f/4 | EF-S 18-55 f/3.5-5.6 | Metz 36 AF-5

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 600D Audio TEST release - 2.3 based
« Reply #74 on: August 23, 2012, 01:15:12 AM »
600D has been having this issue on/off... I don't think its related to audio only