Author Topic: Canon 100D / SL1  (Read 676739 times)

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Canon 100D / SL1 (Alpha-2a / 20th Apr)
« Reply #325 on: April 24, 2016, 07:35:16 AM »
Let's try this one for 100D.100C:
https://drive.google.com/file/d/0B9Mu66yg5QzRVS1TeWQwMlNHV3c/view?usp=sharing

Does the LED blink?
70D.112 & 100D.101

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Canon 100D / SL1 (Alpha-2a / 20th Apr)
« Reply #326 on: April 24, 2016, 07:58:13 AM »
70D.112 & 100D.101

pauleri

  • New to the forum
  • *
  • Posts: 4
Re: Canon 100D / SL1 (Alpha-2a / 20th Apr)
« Reply #327 on: April 24, 2016, 08:51:44 AM »
Hey nikfreak,

I tried the newest one of the builds that you linked, (the Apr 24 one) and it was the only one that "installed." i have tried the 100A and 100B ones with no luck at all so i tried the 100c one. it got through the installation and had green text saying "please restart your camera". and so i did, and it then proceeded to act as it was off showing a black screen. The camera was fully functioning before this (i didn't install the Apr23 one), and now has only a black screen with the letters Err flashing in the viewfinder and A next to iso, also in the viewfinder. The only way that i could get my camera functioning was to take out the battery and sd card and put the battery back in without the sd card in. Putting that sd card in would proceed to show only a black screen like it was off. whats odd is that when you would put the sd card in the camera after taking out the battery and putting it back in, it would show nothing but pressing the shutter button would release the shutter for a second or two and proceed to act "off" after that. the led does not blink at all when the sd card is in, except when i take out and put the battery in. (it does that short blink to know that a battery was put in). i don't know if this helps u in any way but thats wut happened.....

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Canon 100D / SL1 (Alpha-2a / 20th Apr)
« Reply #328 on: April 24, 2016, 08:59:39 AM »
So no LED blinks, right? You can copy important contents from your card to your desktop pc and format the card over there to restore the cam functionality. But I would like this to get solved so stay tuned as I might provide some more test builds for 100D.100C today.
70D.112 & 100D.101

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Canon 100D / SL1 (Alpha-2a / 20th Apr)
« Reply #329 on: April 24, 2016, 10:12:39 AM »
Ok found 2 things. This is another one for 100D.100C:
https://drive.google.com/file/d/0B9Mu66yg5QzRVmhYMzEyRXlWdHc/view?usp=sharing

Awaiting fedback so we can continue...
70D.112 & 100D.101

pauleri

  • New to the forum
  • *
  • Posts: 4
Re: Canon 100D / SL1 (Alpha-2a / 20th Apr)
« Reply #330 on: April 24, 2016, 10:47:31 AM »
Ahh yes!!! finally got some Magical Lanterns on my camera! Installed the update, loaded the files and bam! straight into magic lantern! so far it looks working. UI is there and functions. I will test it further for anything specific problems that this camera might encounter. Thanks a bunch man! :)

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8659
Re: Canon 100D / SL1 (Alpha-2a / 20th Apr)
« Reply #331 on: April 24, 2016, 10:52:03 AM »
Please enter liveview and activate Stubs API test (Debug tab) after enabling Selftest in Modules.tab. Result = zero errors?

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Canon 100D / SL1 (Alpha-2a / 20th Apr)
« Reply #332 on: April 24, 2016, 11:05:43 AM »
STOP! DON'T HESITATE, We are not finished yet. Some more builds for 100D.100C needed. Thanx for chiming in @walter  ;D
  • You first load "selftest.mo" from Modules and restart the camera.
  • Be sure to disable powersaving completely in Canon menu before you continue (just tobe failsafe)
  • Then run in "Self Test" -> "Stubs API test"
  • After the test has finished it will place a logfile (.log) on your sdcard.
  • Post a link to that file for me
  • Afterwards I will post a new release for 100D.100C and instruct you what I additionally need...
  • Stay tuned
70D.112 & 100D.101

pauleri

  • New to the forum
  • *
  • Posts: 4
Re: Canon 100D / SL1 (Alpha-2a / 20th Apr)
« Reply #333 on: April 24, 2016, 11:20:02 AM »
ok, did the test and one test failed... see for your self:
https://drive.google.com/folderview?id=0B2AD3vpPoeeTU0NVRGI4bHptSTQ&usp=sharing

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Canon 100D / SL1 (Alpha-2a / 20th Apr)
« Reply #334 on: April 24, 2016, 12:17:44 PM »
Now download this:

https://drive.google.com/file/d/0B9Mu66yg5QzRb3pqZmQzYWRyQnc/view?usp=sharing

It will print "Hello, World" and on bottom of the LCD you will see the signature printed. Take a picture with your smartphone and post that for me here. We are going to re-create all the installers for 100D and try them afterwards.
70D.112 & 100D.101

pauleri

  • New to the forum
  • *
  • Posts: 4
Re: Canon 100D / SL1 (Alpha-2a / 20th Apr)
« Reply #335 on: April 24, 2016, 01:01:28 PM »

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Canon 100D / SL1 (Alpha-2a / 20th Apr)
« Reply #336 on: April 24, 2016, 01:08:47 PM »
Thanx. Stay tuned. I will release alpha-3a for all revisions within the next half hour and inform you again here once the first post is updated.
70D.112 & 100D.101

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Canon 100D / SL1 (Alpha-3a / 24th Apr) All Revisions
« Reply #337 on: April 24, 2016, 01:50:00 PM »
new release available. read first post.
70D.112 & 100D.101

Titou

  • New to the forum
  • *
  • Posts: 2
Re: Canon 100D / SL1 (Alpha-3a / 24th Apr) All Revisions
« Reply #338 on: April 24, 2016, 05:18:00 PM »
Finally the C revision ! Thanks Nikfreak ! I'm new to ML, still testing different features, everything seems working so far. One thing to report : when on ML menu the image is not very stable, it flickers and goes back to live view for a very short time before going back to ML menu...
 
100D.100C

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Canon 100D / SL1 (Alpha-3a / 24th Apr) All Revisions
« Reply #339 on: April 24, 2016, 06:06:03 PM »
That's a known issue on latest cams (6D/ 70D / 700D / 100D).

I welcome new / first time users to use the search function and also to take some time to read (not only) through this thread but also through module / topic / feature related threads. Enjoy ML !

I am happy that it finally works on all fw revisions.
70D.112 & 100D.101

samcameron

  • New to the forum
  • *
  • Posts: 8
Re: Canon 100D / SL1 (Alpha-3a / 24th Apr) All Revisions
« Reply #340 on: April 24, 2016, 08:39:46 PM »
It works, finally works :-) Thank you so much nikfreak, you're great. The only problem I notice is that the menus sometimes flashes randomly. I don't know why but is showing different menus rapidly for a second or so and the it gets stable, this happen quite frequently.

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Canon 100D / SL1 (Alpha-3a / 24th Apr) All Revisions
« Reply #341 on: April 24, 2016, 09:49:35 PM »
You will get used to it. It's a common bug happening in LV / movie mode on recent cameras like stated above. @dmilligan provided a timeout-fix weeks ago which makes it usable. Before that the menu would just close after seconds. Now it at least re-opens automatically again.
70D.112 & 100D.101

nextlabelindonesia

  • New to the forum
  • *
  • Posts: 6
  • Canon Kiss X7 User
Re: Canon 100D / SL1 (Alpha-3a / 24th Apr) All Revisions
« Reply #342 on: April 25, 2016, 07:58:21 PM »
Thx @nikfreak Magic lantern detected on my Canon Kiss X7, i'am using firmware 100D.100C ... It will print "Hello, World" and on bottom of the LCD... I'am wating Fix New Bug... Thanksss all the best :)
Canon Kiss X7 kit User - Canon Kiss x5 kit User - Canon Lens 50mm1.4 - Canon Lens 50mm1.8 STM - Canon Lens EF 17-40 f4L - Stabilizer (DIY) / Glidecam (DIY) / Steadycam (DIY) / Slide (DIY)

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Canon 100D / SL1 (Alpha-3a / 24th Apr) All Revisions
« Reply #343 on: April 25, 2016, 08:11:02 PM »
No need to try test builds (missed deleting 'em). Just read the first post and download from there! Full build is availbale since yesterday.
70D.112 & 100D.101

dickens3d

  • New to the forum
  • *
  • Posts: 2
Re: Canon 100D / SL1 (Alpha-3a / 24th Apr) All Revisions
« Reply #344 on: April 26, 2016, 02:34:57 AM »
Thx @nikfreak for C revision! Installed without any problems and now I'm trying to shoot some RAW video. Everything looks normal except that no images recorded on my SD card... The card is SanDisk Extreme 90 Mb/s, should not have any problems. I watched a lot of youtube videos and I'm sure doing everything right...
EOS 100D.100C

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Canon 100D / SL1 (Alpha-3a / 24th Apr) All Revisions
« Reply #345 on: April 26, 2016, 08:03:27 AM »
sounds weird. I think its a false report caused by user error or whatever. Check the topics about raw recording not only watch youtube videos.

either it writes (be it changes to settings file, silent pictures, screenshots etc.) or it does not.
easiest way to verify would be to use the screenshot function in "Debug Menu" and wait 10s. LED should indicate activity and a VRAM file should be placed onto your scard.
70D.112 & 100D.101

nextlabelindonesia

  • New to the forum
  • *
  • Posts: 6
  • Canon Kiss X7 User
Re: Canon 100D / SL1 (Alpha-3a / 24th Apr) All Revisions
« Reply #346 on: April 26, 2016, 10:54:33 AM »
@nikfreak : Thx! i'am re-download your first post (100D.100C) ... Magic Lantern Succes for Intalled... Thanks a bunch man!  :) GBU!
Canon Kiss X7 kit User - Canon Kiss x5 kit User - Canon Lens 50mm1.4 - Canon Lens 50mm1.8 STM - Canon Lens EF 17-40 f4L - Stabilizer (DIY) / Glidecam (DIY) / Steadycam (DIY) / Slide (DIY)

Felipe

  • Senior
  • ****
  • Posts: 279
Re: Canon 100D / SL1 (Alpha-3a / 24th Apr) All Revisions
« Reply #347 on: April 26, 2016, 03:06:11 PM »
@Nik working great thanks
650D-700D

thieverycorp

  • Just arrived
  • *
  • Posts: 1
Re: Canon 100D / SL1 (Alpha-3a / 24th Apr) All Revisions
« Reply #348 on: April 26, 2016, 08:12:01 PM »
Hi, I am not sure if this question has been asked and answered before, but one thing that I would absolutely really insanely beg and wish for is 4K video. Is this a possible pipeline addition to Magic Lantern for the 100D/SL1? It would be amazing to shoot in 30fps 4k with this little guy.

-The Corporation

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Canon 100D / SL1 (Alpha-3a / 24th Apr) All Revisions
« Reply #349 on: April 26, 2016, 10:16:43 PM »
Sure. Solder 16GB RAM into the cam and code the firmware to recognize the RAM then we might achieve it  :o
70D.112 & 100D.101