Full-resolution silent pictures (silent.mo)

Started by a1ex, July 01, 2014, 05:11:15 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


@DeafEyeJedi: It's @a1ex that did the work, I just provided some apparently needed feedback. :D
I just reset ML to defaults, enabled silent (and mlv_rec or not if saving DNG), but it doesn't behave like yours does.

For one, after it takes a FRSP it shows the picture and says
<path to file.DNG/MLV...>
Saving 5....x2... ( xxx ms, xx Mb/s)
Captured in xxx ms.

While yours doesn't  or it looks like it does really fast. Do you have image review on or something?

Also, you said "hold * seamlessly after taking FRSP pic" but I did not say that, I was just enumerating the cases, not the steps.
You either single press * and get a picture OR you straight hold it, which in my is case is rather painful as I find the button size good enough for a small japanese girl ( target demographic for the M1 maybe? :D ) than for my chubbymanly hands.

And regarding this, while it focuses it just says "Focusing..." on screen, and it stays like that even if you stop pressing, which in your clips I did not see, did I miss it or ?

Sample: https://mega.co.nz/#!oABHHIyb!VNOQugQF-xqmH957FFU4MTHPjZfv2nSugY03P4JFAEU

Regarding movie mode silent snapping see this post: http://www.magiclantern.fm/forum/index.php?topic=12523.msg143308#msg143308


Well I just meant that you actually set the ball rolling to get @a1ex up to speed with the progress in FRSP so I thank you for that.

Anyway yes I did try both with and without image review within Canon Menu. Still doesn't make a difference.

I raw that thread earlier about movie mode snapping... it just worked fine for me on 5D3 during h.264 recording (yes I encounter these crashes before but taking the battery out helped sort it out) which may not be ideal for most users out there but to me I think it can be handy for some situations.

No big deal, really!

Just trying to understand why 5D3 back focus button * works flawlessly whereas the M1 seems to be a bit picky (definitely helps by pressing * immediately after taking the first FRSP and sometimes stays consistent for 2-3 FRSP snaps but then it goes back to taking pic thinking its half shutter pressed (although it would try to FOCUS for a second or two before taking the FRSP photo) so it's definitely focusing on its part but then something is overlapping the M1 into thinking the shutter is being pressed half way when it isn't...

Thanks again!
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109


Looking at your last video, it says 40mm f/2.8, I only have the 18-55 and the 22, and they work ok.
Since you use the EF/S converter (right?) maybe it introduces some sort of delay that messes up the 10 cycles wait time, but since it's native for 5D3 it works faster.

Do you have any EF-M lens to test with?


Actually I did use the Pancake 40 with the EF/S adapter to use for all EF lenses... perhaps that's the culprit of this?

Good catch and will try again with an EF-M 22...

Stand by!



Seems to be the same results? Works but inconsistently... Guess I'll just have to get used to this.

Though I don't think it is our big phat thumbs that are to be blamed for this kind of behavior... lol!

5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109


I can repro this if I disable ExpSim, like you have it in all these M1 videos but not in the 5D3 one, with it on works as expected.


alex wrote:
QuoteThey are saved if you use the MLV format.

Didn't notice they are not present when you save as DNG, since I don't really use this info.

Just for info and to give a feedback:

Yes, exifs are present in mlv and in dng, decoded with mlv_dump. But I noticed, the lensname-tag (or lensmodel, don´t know, what is needed) isn´t covered by my programs. And this lensname seems to be important for automated lens-correction in post-processing.
Tested with darktable, rawtherapee, ufraw, showfoto.
I cannot try the dng-module from dmilligan, because I cannot setup my compiling envirement at the moment.

600D, 6D, openSUSE Tumbleweed


Is lens name recorded properly in regular MLVs?

In theory, it should work, since MLV silent pics reuses the metadata code from mlv_rec.


Block: LENS
  Offset: 0x000001f0
    Size: 96
    Time: 1705.499000 ms
     Name:        'EF100mm f/2.8 Macro USM'
     Serial:      ''
     Focal Len:   100 mm
     Focus Dist:  139 mm
     Aperture:    f/8.00
     IS Mode:     0
     AF Mode:     3
     Lens ID:     0x000000BE
     Flags:       0x00000000

Seems, that darktable and co use another tag for the lensname

600D, 6D, openSUSE Tumbleweed


I readed a bit in darktable.

The lens is recognized by exiv2 and passed to the lensfun-library for len-correction

With a CR2-file I get these lens tags:

edgar@linux-9hqd:~/fullres> exiv2 -pt 5.CR2 | grep -ai lens
Exif.CanonCs.LensType                        Short       1  Canon EF 100mm f/2.8 Macro
Exif.CanonCs.Lens                            Short       3  100.0 mm
Exif.Canon.LensModel                         Ascii      70  EF100mm f/2.8 Macro USM
Exif.Photo.LensSpecification                 Rational    4  100/1 100/1 0/0 0/0
Exif.Photo.LensModel                         Ascii      70  EF100mm f/2.8 Macro USM
Exif.Photo.LensSerialNumber                  Ascii      12  0000000000

Usning a dng-file, decoded with mlv_dump from mlv, I see nothing..

edgar@linux-9hqd:~/fullres> exiv2 -pt 4.dng | grep -ai lens

I really don´t need this lens-stuff for my astro-mlvs, but that´s, what I´ve seen playing with fullres-silent pics.
600D, 6D, openSUSE Tumbleweed


I can't get FRSP to work.

When I set Silent Picture to Full-Res, the Silent tab turns "grey green" I suppose this has something to do with it telling me some setting is not alright. If I put it back to Simple, it turns back to real green.

I have tried taking pictures with Full Res, Half shutter, * and AF ON or what ever button I can press. If I take a normal picture, I see Silent picture taking a picture too before the camera crashes to Error 70.

I always end up with Error 70 what ever way I have tried taking a picture with FRSP.

I basically don't know how to take picture with FRSP, there are only two ways that I have managed to take FRSP and that is with Intervalometer with one of its many ways of activation or by taking a normal picture where I hear the shutter activate and once saw a Full Res Silent pic load right before the camera crashed and I got Error 70.

Please tell me what I am doing wrong or just what has to be done for it to work, I would very much like to do some timelapses without eating up my Shutter.
once you go raw you never go back

Walter Schulz

Delete ML directory and Autoexec.bin from card. Download latest nightly build. Copy extracted nightly build to card. Retry. Results?


Quote from: Kharak on March 31, 2015, 10:42:26 PM
When I set Silent Picture to Full-Res, the Silent tab turns "grey green" I suppose this has something to do with it telling me some setting is not alright.

Correct - read the help and do what it says (just like with most other ML functions).

Trying to take a regular picture and a silent picture at the same time will usually result in race condition, and there's little I can do about it.


@ Walter

Did that.

@ A1ex

I am not trying to take a normal picture and FRSP at the same time, that is one of two ways that I can activate it. The other way is with Intervalometer and its 3 different ways of activation.

If have the camera in P mode and when I scroll over FRSP it says FRSP only works in (M) Manual Photo mode. So I put it in Manual mode with Liveview ON and then it says FRSP only works with M (manual) Photo mode.. I can't or don't know how to take a picture with FRSP. What button do I press? Which one is default? I have Top-Bottom scan, is that not okey?

once you go raw you never go back

Walter Schulz

1.) Prefs tab -> Config files -> Restore ML default
2.) Restart cam
3.) Activate Silent.mo
4.) Restart cam
5.) Put cam to M mode
6.) Activate FRSP (Shoot tab -> Silent Picture -> Silent Mode -> Full-res)
7.) Activate Liveview
8.) Press shutter half




Are you in manual photo mode, or movie? Silent pics are only meant to work in photo mode. I could change that for cameras without a dedicated movie mode, but it's kinda pointless, because the shutter speeds useful with silent pics are not available in movie mode.

Settings that are grayed out should have no effect (if they have, that's a bug).


Quote from: Kharak on April 01, 2015, 06:40:39 PM
If have the camera in P mode and when I scroll over FRSP it says FRSP only works in (M) Manual Photo mode. So I put it in Manual mode with Liveview ON and then it says FRSP only works with M (manual) Photo mode.
Auto ISO. You must also select an ISO; auto ISO is not allowed (every exposure setting must be manual).


Ok, thanks guys for leading me through this.

I never take pictures with my MK III, this is the main reason for my great misunderstanding regarding "photo mode"

What was confusing me was the M Mode and Photo Mode.. When it said Liveview had to be ON I kept putting it on Movie Mode and not pressing the Start button while on Photo mode.

My MK III has 300 pictures taken and 800 Shutter Activations from when I turn the Camera On in Movie Mode ;)

Now to perform some Timelapses and keeping that shutter count low :)
once you go raw you never go back

Walter Schulz

Tab called "Shoot" and icon used may give some hint ...


I found out that raw_twk.mo makes the camera activate the shutter while taking a FRSP and then crashes the camera to Error 70.

I suppose there wont be a fix for this as raw_twk seems more or less unsupported.

Its not something of a world problem, I can just activate/deactivate the module depending on what I want to do. But it would be nice if I didn't have to :)

Atleast its on record now.

once you go raw you never go back


I am very excited by full-res silent pictures, because I have a pretty high shutter count on my camera and love to shoot timelapse.

I have a Canon 60D. I tried installing the latest nightly (Nightly.2015Mar29.60D111), and am running into the following behavior.

- I deleted the existing ML folder and copied over the new one.
- I start up the camera, go to modules, load silent.mo
- I turn off the camera. I turn on the camera after waiting a moment. The "sensor cleaning" icon comes up, and then freezes part way through. After a moment, an error message is displayed in the top display with a blinking "Err: 80" message. The sensor cleaning animation is still frozen.
- Restarting the camera with silent pics not loaded works as expected.

Let me know if I can test, or further clarify. Would love to help get this working on my camera!

Thanks so much! Magic Lantern is so exciting and awesome :)

Walter Schulz

You missed to replace Autoexec.bin.


My M1 is doing the same back button focus thing with the 22/2 and with other lenses on the adapter. I can tell with my sigma lens that it just starts trying to focus then stops when the silent picture starts. Like less than 50ms probably.

550d works normally, both were downloaded tonight. The M1 is the March29 nightly.

edit: It works sometimes if I tap the screen each time but still not entirely consistent.


Thanks a lot for this amazing feature! I'm testing it with my 7d - no issues seen there so far.
I have an Dynamic Perception rig that i would love to use it with. Since the controller do both motor actuations and shutter in perfect sync its preferred not to use ml's intervalometer. But the issue here is the half shutter actuation to take silent pic...
Could you implement a choice somewhere to shutter silent pics on full shutter instead?  8)
EOS 7D | EOS 650D | Sigma 30mm f/1.4 | Canon EF-S 15-85mm f/3.5-5.6 | Canon EF-S 18-135mm f/3.5-5.6 STM | 50D RAW Monster :-D

Walter Schulz

If you have a wizard with a soldering iron at hand: Drop word "4 way switch" to wizard and your problem is gone. All you need is to switch focus button with shutter release button.


Oki, thanks! Hoped for a sw solution  ;) But since i consider myself as an hw wizard i think i can solve this  8)
EOS 7D | EOS 650D | Sigma 30mm f/1.4 | Canon EF-S 15-85mm f/3.5-5.6 | Canon EF-S 18-135mm f/3.5-5.6 STM | 50D RAW Monster :-D