Nightly Builds - try the very latest stuff here

Started by a1ex, October 11, 2012, 01:55:31 PM

Previous topic - Next topic

0 Members and 2 Guests are viewing this topic.

Walter Schulz

Delete ML directory and Autoexec.bin. Copy extracted nightly contents to card.


Just to make sure delete (not format unless you want to use EOScard to make the card bootable again.)
T3i and Kiss X4 (550d (T2i)) Tamron 18-200mm, Sigma 28-70mm f2.8 (need firmware upgrade) Olympus 50mm f1.8  Olympus 28mm f2.8 and Olympus 24mm f2.8
Fancier 370 tripod and LCD hinged loupe. DIY Slider and crane.


I am right in thinking that global draw options can be toggled on or off while recording? I only say this as I just tried 2.3 and I couldn't do it in there either-making sure I deleted all magic lantern files from the card before I started. I can adjust things that I've enabled prior to pressing record, but I can't enable new stuff.

I was sure I could do this but I might have dreamed it :)



I just deleted (not formatted) everything off the card, cleared the user and camera settings and extracted the zip from a fresh download of Nightly.2015Mar26.60D111

The card was still bootable so I could just press the trash can to enter the ml menu, once again to get beyond the initial message.
In movie mode with liveview activated and the ml shooting info visible I press record. I leave record running while I do the rest.
I press trashcan to get into the menu. So I move along to the Overlay menu by pressing the D-pad, and go to the Focus Peak option which is currently greyed out.
At this point I see a red thumb wheel icon in the bottom corner which has a stroke through it to suggest it is disabled.

I press the Info button which brings me to the expanded focus peak options, of course they are greyed out. The settings can be cycled using left and right on the d-pad but are still greyed out.
On the previous page (Overlay) which has the ability to enable the focus peak, I can't make any buttons activate this setting.
When the camera is not recording, this is activated by pressing the SET button, but while recording I have no idea.

Hopefully you guys can help.



Sounds like you forgot to Turn on the modules again?

Do that and restart camera.

5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

Walter Schulz

You don't need modules to run H.264 video recording and that's what he was doing.


Okay my fault for misunderstanding his issues.
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109


Alright folks, full-res silent pictures are now in nightly builds, finally!

The main limitation remains: you can only do fairly long exposures, but even so, it's a very powerful tool for timelapses. You will need a ND filter for daylight usage.

Check the full-res silent picture thread for more details, and please don't complain about overexposure issues.

This feature also comes with major backend changes on the photo RAW backend (for example, at least in theory, tools like ETTR and RAW exposure feedback should be a lot more consistent on 6D and 600D).



Not sure if I should add this here, but after using the nightly with FRSP merged.

MLV recording has become very unstable for me.

I will try newest nightly ( now and see if MLV is working better.

On current build, 29/3. Almost every MLV file has a random pink frame here and there or resolution "jump".
once you go raw you never go back


Are you sure the issues do not happen in the nightly right before merging fullres pics? (2015Mar28 - 5327699)

There were no changes to LiveView RAW backend or to mlv_rec in fullres silent pics, so it's unlikely to be related.

See also


Yes, then it is most likely a build from before 29th.

But I see in the 29th build: 7bc8b4d "mlv_rec: fix compilation" So I assumed this could be the case.

Also: 70743c3:

"mlv_rec: make mlv_dump a bit more defensive with fwrite return values"

4c5829f | g3gg0
mlv_rec: mlv_dump now allows altering the frame rate e.g. for direct playback of full res silent pic shots using mlrawviewer. also rewrite the frame count in MLVI header.

I am not too good at reading in to the actual changes you guys have made. I am not a programmer at all, but those are the only  recent "mlv_rec" module changes I can see in the nightly builds. But the ROM change on the 28th, perhaps?

"5327699 | Alex
ROM autobackup: copy data to RAM before saving (no longer interferes with LiveView)"

I try and revert to older build and see when it starts. But ofcourse if no one else reports this issue on any build since FRSP merge, then I assume I am to blame somehow for this misfortune. Though I am running everything as I usually do when recording MLV.

I have not tried raw_rec, I also want mlv to work cause that is what I use as I need sound.
once you go raw you never go back


Just to update in case anyone else has/d same problems as me.

I tried different things, updated to newest nightly (19. april), I still had same issues after that. Reformatted cards. I deactivated raw_twk module and these broken frames became more rare, but not completely gone.

So I reverted back to a build from February 20th. I believe this is the last build I was using before updating to the merged FRSP build (29. Mar) and I started getting broken frames.

Recorded a lot of long shots with low light, high light, changing light and what not, just different stuff to challenge the sensor, in case that was causing these broken frames to be written to the card and I did not have one dropped frame or broken frame.

I am sorry that I can't give a more technical idea to why I was experiencing these issues. raw_twk was causing the camera to crash everytime I took a picture with FRSP, so the raw_twk module had to be deactivated and the module might have had some kind of interference with mlv_rec too, I don't know.. It seemed like the broken frames were much less occuring after I deactivated the module. Before I did that I experienced broken frames in almost every shot and often several times.

once you go raw you never go back


Maybe this bug has been reported before.
With the latest nightly build, 50D can record MOV video as before (and they are playable on PC/Smart TV etc.) but still can't show it on the LCD screen through MLV player. I did necessary module loading but no success yet.
HOWEVER, 50D can take RAW video and it CAN show it on the LCD screen (I just say WOOOW!).
50D is being able to make fantastic things after 7 years! Thank you ML people! 


Why don't you play MOVs through the Canon preview?


Quote from: Licaon_Kter on May 08, 2015, 02:30:31 PM
Why don't you play MOVs through the Canon preview?
It doesn't exist. Stock 50D (without ML) cannot record video at all. H.264 video recording was something added by ML.


oh, my bad, it crossed my mind but I was lazy enough not to check it :P :-[

on topic, it never played MOVs for me either


will this ML work with latest 1.3.3 canon firmware?



Guys, where are gone mapping G \ M in the last assembly? And something was all monotonous.


Quote from: tolubizer on May 26, 2015, 06:57:58 PM
Guys, where are gone mapping G \ M in the last assembly? And something was all monotonous.
Rephrase please.

Which build: ?

Also, going back to older builds ( press Show Older Builds blue button ), which one works like you want to?

Walter Schulz

Most recent build. Not there for 7D, too.
Tried 7D build #73 (16.03.2014 15:49:22): Same.