Author Topic: AETTR issues with Intervalometer 5D3 1.1.3  (Read 1533 times)

bennir

  • New to the forum
  • *
  • Posts: 4
AETTR issues with Intervalometer 5D3 1.1.3
« on: February 25, 2018, 12:27:13 PM »
Hello,

I dont post much but appreciate all of you putting that much work into ML very much.
Thoroughly searching, I did not find any solution to the problems I am currently facing concerning AETTR.

I read the following topic from 2014: https://www.magiclantern.fm/forum/index.php?topic=11134.0
I have the same problems described in this topic, with RAW ERROR message and everything. AETTR works in Always On / SET, but not with Intervalometer (so probably issues reading the buffer as a1ex suggested there?)

My ML: magiclantern-crop_rec_4k.2018Feb24.5D3113
I shoot raw only, and already reformatted my SD card (ML on SD, no pictures) and CF Card (all pictures RAW to cf)
Global Draw on, everything set as described in AETTR + Intervalometer guide by Renato from 2014 (edit: 2013 even)

I tried exp override ON, tried writing to the SD card, everything to no avail
Also the same on magiclantern-Nightly.2018Feb04.5D3113

I am pretty sure that it once worked so I guess the error has to be on my side
What could I try?

bennir

  • New to the forum
  • *
  • Posts: 4
Re: AETTR issues with Intervalometer 5D3 1.1.3
« Reply #1 on: February 27, 2018, 06:12:33 AM »
To add some more information, it also happens without Intervalometer, and an error message is displayed after each shot (in the 2s image review): "raw error, falling back to yuv overlays"

It is working without problems on my 7D with nighly 2015.Jan29.7D203

I also tried the 5D 113 Nightly from Jan 17 to no avail and resetted all camera settings. I'm at a loss  :'(

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: AETTR issues with Intervalometer 5D3 1.1.3
« Reply #2 on: February 27, 2018, 07:07:11 AM »
Could not reproduce. Enabled Auto ETTR and intervalometer on the current crop_rec_4k build (fresh install) and worked out of the box.

There are many possible causes for "raw error". Some of these are shown in menu (as warnings at the bottom of the screen, before enabling Auto ETTR), others are printed to the console (Debug menu). Anything interesting there?

If not, can you record a video of the camera screen, showing the issue, and also upload a CR2, so I can try to reproduce in QEMU?

bennir

  • New to the forum
  • *
  • Posts: 4
Re: AETTR issues with Intervalometer 5D3 1.1.3
« Reply #3 on: February 27, 2018, 07:24:21 AM »
only "Raw error", "Raw error, falling back to yuv overlays" as messages
console shows
Code: [Select]
Resolution changed: 0x0 -> 5936x3950
Black 5/5: stdev too large (5252/100, ref 698/100)
Black 5/5: stdev too large (5246/100, red 700/100)

Tried uploading, but am currently underway in the middle of nowhere and the 24mb .cr2 would take over 1 hour....
I'll try to upload somewhere else and come back to you, thank you for your efforts

It is working with silentpicture+aettr+interval tho.. but I'm really curious as to why its not working with normal shots
Normal shots are trying to read info from image review, right? With silent pictures it seems to just read from LV?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: AETTR issues with Intervalometer 5D3 1.1.3
« Reply #4 on: February 27, 2018, 07:38:28 AM »
That must be a hot pixel in the optical black area.

Same as https://www.magiclantern.fm/forum/index.php?topic=17579.0 (known issue, need to sit down and update the math). Workaround: try some older build, before April 11, 2016 (this PR is likely the culprit).

Or, if you can compile from source, delete the checks from raw.c, autodetect_black_level (don't return early) to ignore this issue. The resulting black level (used by auto ettr to do the math) will still be skewed by that hot pixel, but hopefully not by much.

Sample CR2 still welcome, but there's no rush.