raw2cdng - almost no info in red in DNG

Started by halal, August 01, 2015, 05:22:51 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I recently shoot some MLV video and I used raw2cdng for batch conversion to DNG. The first N number of videos looked good but then the rest has almost no info in the red channel. I also generated proxy jpg files and they look fine (even better than for the good videos - they look as shot while for the good videos the proxies are really dark) I somehow managed to get good and bad results for one of the videos, but the rest is either bad or good no matter on which computer I convert it. I uploaded the video, the dng files (only first frame) and jpg proxies here:   

The video was the last one to fit on the SD card and as it ran out of space it tried to split the file, therefore there are multiple files for videos, but this is not the issue since I have the same problem with other videos as well.

bnvm in the CinemaDNG discussion (http://www.magiclantern.fm/forum/index.php?topic=5618.275) said: 
QuoteI have seen green shifting with cdng's as well. I believe it is from incorrect color matrix data in the meta data. I tried a sequence in another app and got a green shift, setting the app to not use the color matrix fixed the issue. I guess it is possible that the magenta shifting is from the same issue.
but I am not sure if my problem is the one he is talking about and if so I have no idea how to disable the color matrix.

MLRawViewer doesn't have this problem so I believe the files should have all the info in them. I hope some of you know how to fix this problem. Thanks in advance


Looks like a Black level problem, More info  please .
Camera ?
Nightly Build ?
Raw/MLV Setting ?
Search Black level problem , there lot of info on that topic.
exiftool can fix the black level , Google is your friend here .

Also try a different extractor tool , there again just search the forum.


The color matrices and other meta look correct so my guess is the raw2cdng settings (I have seen this before). Try converting again but set raw2cdng to 16bit CDNG (not maximized) and leave the other settings greyed out.

I've seen this happen 'sometimes' with raw2cdng - if all else fails try older builds back to 1.6.5.
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

andy kh

same problem wit me while converting in 16 bit so i tried converting in 16 bit maximize n it works
5D Mark III - 70D