Author Topic: Canon 6D  (Read 441023 times)

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5634
Re: Canon 6D
« Reply #1125 on: May 13, 2019, 06:34:22 PM »
Cool.
How come 1x3 binning is set in x5 mode?

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1472
  • 6d - Nightly build user
Re: Canon 6D
« Reply #1126 on: May 13, 2019, 06:38:44 PM »
@baladev

This new build contains two 1x3 presets.
I have chosen to put 1216 x 2052 at 25 fps in, since I think this one gives continues recording time, if bit depth option is set to 12 bit (or when in doubt, use 10 bit).

I made the 24 fps 1x3 preset to full width resolution, 1640 x 2144.
The 24 fps has a little more vertical resolution, this is possible of the lower fps (25 vs 24 fps), this 2144 resolution is unfortunately not possible with 25 fps.

Try them out and see if you like them or that you missing something, we can always put more 1x3 presets in this merged build  :D
 

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1472
  • 6d - Nightly build user
Re: Canon 6D
« Reply #1127 on: May 13, 2019, 06:45:07 PM »
Cool.
How come 1x3 binning is set in x5 mode?

In my older crop_rec module, I made the presets for use in x5 mode, not sure why  :P

At the moment you can't even use them in normal 1x zoom mode, although ML preview is perfectly fine.
When recording 1x3 in 1x zoom, you get corrupted frames, not exactly sure why  ???
Probably has something to do with something set in raw.c for EOS-M, because whenever a crop_preset is used, raw menu shows only 1/3 of the vertical resolution available in 1x zoom mode ?
And the text, stretch to 3 in post to get x resolution.
When this is fixed, 1x3 probably works in both modes.

baladev

  • Freshman
  • **
  • Posts: 81
  • 5Dm3 - 6D - 7D - EOS M
Re: Canon 6D
« Reply #1128 on: May 13, 2019, 07:21:35 PM »
Thank you Levas! Will test this new build tomorrow.

1216 x 2052 at 25 fps is good enough for me :). It has a nice 1.5 crop. Just wonder, why isn't 25fps possible with 1640 x 2144?

I film band performances a lot indoors in dark, club like environment. 1216 x 2052 at 25 fps gives me continuous at 14 bit even.
I'm sure even 1640 x 2144 would be continuous with 1264 x 2144 16:9 and 25fps for me. 12bit is very useful outdoors or in bright indoors situations.

I was thinking a couple of day ago - we are SO CLOSE to the sweet 1280x2160, which could give as exactly x2 resolution vertically and 2/3 resolution horizontally, comparing to 1080p.

Levas' original 1:3 preset (1088 x 1842 )was in x1 zoom mode. Later, when he went to higher res, had had to switch to x5 zoom, don't remember why - he mentioned this a few pages back. They still work in x1 zoom mode, just exposure is off, doesn't work properly.

[edit]

Just tested the latest build from Levas, here's what I found:

- 2880x1200 25fps seem to work properly, tested 14/12bit. didn't find anything wrong with it. Couldn't get ML preview though for framing, only Canon LV, which is way off.

1216x2052 1x3 25fps and 1640x2144 1x3 24fps both work properly with ML preview, tried diff bitrates 14/12/10 - no problem there. The only weird glitch I found with both these anamorphic presets is that after about 30-40 sec you get this pink 'fog' that starts at the top of the frame and quickly fills almost the whole frame down to the bottom, making the picture pinkish. You can easily see it in ML preview - just leave the camera for 30 sec and watch the screen. When the screen gets pink, going to ML or Canon menu resets it to normal until it happens again.

Will test 2480x1396 25fps preset a bit later.

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1472
  • 6d - Nightly build user
Re: Canon 6D
« Reply #1129 on: May 15, 2019, 04:45:12 PM »
Just find out, that when processing the MLV's with "mlv_dump_on_steroids.osx" I don't get valid audio wave files anymore (only 2Kb or something), this is since the merged with Danne builds.
Remember reading something recently on the forum that audio is not broken or something and data is inside the MLV, so I tested MLV_app and extracted the dng's and audio files and with MLV_app I do get a valid audio wave file.
I do have a mlv_dump_on_steroids.osx from 2017, do I need a newer version, does that fix the thing with audio wave files, and where to download a precompiled osx version of mlv_dump_on_steroids ?

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5634
Re: Canon 6D
« Reply #1130 on: May 15, 2019, 04:58:06 PM »
Test following:
https://www.magiclantern.fm/forum/index.php?topic=7122.msg215668#msg215668

"--skip-xref"

Didin´t have time to dig into what´s causing this.

Kharak

  • Hero Member
  • *****
  • Posts: 893
Re: Canon 6D
« Reply #1131 on: May 15, 2019, 07:24:17 PM »
once you go raw you never go back

baladev

  • Freshman
  • **
  • Posts: 81
  • 5Dm3 - 6D - 7D - EOS M
Re: Canon 6D
« Reply #1132 on: May 16, 2019, 03:08:24 PM »
Did some more testing of the latest build.

All these presets work properly, I couldn't find any problems:
2480x1396 25fps
2688x1296 25fps
2880x1200 25fps
Framing works well, half shutter press takes to live view x5 for focusing. Very nice.

A couple of things I've noticed while playing with this latest build. 1 the compulsory 2nd and 3rd corrupted frames have disappeared. 2nd it feels more solid overall, hard to break ML preview (in the previous version it was very easy to break it with anamorphic presets)

Great job, Levas and Danne!!!

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5634
Re: Canon 6D
« Reply #1133 on: May 16, 2019, 05:27:27 PM »
Added this:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg216553#msg216553
also for the 6D so hopefully some more headroom:
Commit:
https://bitbucket.org/Dannephoto/magic-lantern/commits/3127edf6890e88d5aaa2b039d6f8bef323d3eccf
(only anamorphic(1x3 binning) modes and with preview set to framing.
Levas confirmed working so let´s wait and see...

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1472
  • 6d - Nightly build user
Re: Canon 6D
« Reply #1134 on: May 16, 2019, 06:56:33 PM »
First tests show that I can't get more vertical resolution in 1x3 presets with the above experiment from Danne.
Still corrupted frames when I increase vertical resolution, so unfortunately it doesn't help us with breaking the current boundaries with vertical resolution, on 6d that is.
Gonna test some more tommorrow.
 

baladev

  • Freshman
  • **
  • Posts: 81
  • 5Dm3 - 6D - 7D - EOS M
Re: Canon 6D
« Reply #1135 on: May 16, 2019, 07:28:42 PM »
Levas

Even if you can't get any more resolution it's ok, you've done amazing work already even with what we have.

Have you had a chance to look into the "pink fog" issue I described above? It's really the only thing that's broken in the latest build that I could find and that prevents anamorphic presets to be useful.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5634
Re: Canon 6D
« Reply #1136 on: May 16, 2019, 07:43:37 PM »
First tests show that I can't get more vertical resolution in 1x3 presets with the above experiment from Danne.
Still corrupted frames when I increase vertical resolution, so unfortunately it doesn't help us with breaking the current boundaries with vertical resolution, on 6d that is.
Gonna test some more tommorrow.
Did you match resolution in mlv_lite.c after increasing in crop_rec.c? Or else it runs without the hack.

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1472
  • 6d - Nightly build user
Re: Canon 6D
« Reply #1137 on: May 16, 2019, 09:07:03 PM »
I did match 6804 resolution in both places (top and bottom table in code below) in mlv_lite.c

Code: [Select]
      if ((PREVIEW_ML) && (cam_eos_m || cam_100d || cam_650d || cam_700d || cam_6d))
      {
    /* Will maybe reduce corruption of frames by freezing liveview while in framing mode. To be tested */
if ((RAW_IS_RECORDING && (shamem_read(0xC0F06804) == 0x79f01ed)) ||
(shamem_read(0xC0F06804) == 0x77701ed) ||
(shamem_read(0xC0F06804) == 0x79f01d4) ||
(shamem_read(0xC0F06804) == 0x79f01e4) ||
(shamem_read(0xC0F06804) == 0x7ef01d4) ||
(shamem_read(0xC0F06804) == 0x88501c2) ||
(shamem_read(0xC0F06804) == 0x8230150) ||
(shamem_read(0xC0F06804) == 0x87f01ba))
{
   EngDrvOutLV(0xc0f383d4, 0x4efffc);
   EngDrvOutLV(0xc0f383dc, 0x42401b2);
}
        bmp_on();
      }
    }
    else
    {
        if (lv_focus_status == 3)
        {
            autofocusing = 1;
        }
        if (get_ms_clock() - last_hs_unpress > 500)
        {
            long_halfshutter_press = 1;
        }
/* trying a fix for stuck real time preview(only affects framing) */
      if ((PREVIEW_ML) && (cam_eos_m || cam_100d || cam_650d || cam_700d || cam_6d))
      {
/* might reduce corruption of frames by freezing liveview while in framing mode. Here we are back to real time preview */
if ((RAW_IS_RECORDING && (shamem_read(0xC0F06804) == 0x79f01ed)) ||
(shamem_read(0xC0F06804) == 0x77701ed) ||
(shamem_read(0xC0F06804) == 0x79f01d4) ||
(shamem_read(0xC0F06804) == 0x79f01e4) ||
(shamem_read(0xC0F06804) == 0x7ef01d4) ||
(shamem_read(0xC0F06804) == 0x88501c2) ||
(shamem_read(0xC0F06804) == 0x8230150) ||
(shamem_read(0xC0F06804) == 0x87f01ba))

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5634
Re: Canon 6D
« Reply #1138 on: May 16, 2019, 09:16:49 PM »
I see. Well, testing on 100D I clearly get a difference. Not neccessarily gonna lead to higher resolutions but will strengthen existing ones.

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1472
  • 6d - Nightly build user
Re: Canon 6D
« Reply #1139 on: May 18, 2019, 08:47:33 PM »
Have you had a chance to look into the "pink fog" issue I described above? It's really the only thing that's broken in the latest build that I could find and that prevents anamorphic presets to be useful.

@Baladev
Did mis that in your first post  :P
Looked at it, and indeed with 1x3 presets, after a while 'pink fog' starts to appear at the top of the frame.
The first time I saw this behaviour was when I made 1x3 presets with max resolution of 1640 instead of 1688, including lower A timer registers.
This was then sort of fixed by adjusting some values in power save timing piece of the crop_rec code.
Will have a look at it, and see if something is wrong.
I couldn't get the whole frame pink, only upper part of the frame becomes pink.
I have only raw histogram activated, no other stuff like zebras, spotmeter and such.
Not sure what you have activated, could be that closing some of these exposure tools stuff helps ?

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1472
  • 6d - Nightly build user
Re: Canon 6D
« Reply #1140 on: May 19, 2019, 03:31:40 PM »
Updated new build for 6d.
Few useful updates, in the previous build, I expect that dual iso module gave error message on screen when activated ?
At least I had on my 6d.
Dual-iso works on my 6d, so I expect it to work on other 6d's too.
More info about the issue and how it is fixed:
https://www.magiclantern.fm/forum/index.php?topic=7139.msg197146#msg197146

And I have changed something that might fix the "pink fog' problem in 1x3 presets, the first timer still had "(fps_timer_b - 1 + reg_timing3)" instead of "(fps_timer_b - 5 + reg_timing3)" in the middle.
Code: [Select]
        adtg_new[7]  = (struct adtg_new) {6, 0x8173, nrzi_encode(fps_timer_b - 5 + reg_timing3) }; /* PowerSaveTiming OFF (6D/700D) */
        adtg_new[8]  = (struct adtg_new) {6, 0x8179, nrzi_encode(fps_timer_b - 5 + reg_timing2) }; /* PowerSaveTiming OFF (5D3/6D/700D) */
        adtg_new[9]  = (struct adtg_new) {6, 0x8197, nrzi_encode(fps_timer_b - 5 + reg_timing2) }; /* PowerSaveTiming OFF (5D3) */

@Baladev
Did test the 1x3 preset for about a minute, I didn't get pink fog in the upper part of the frame, can you test and confirm.
If the pink fog still comes up, I can change some other values too.
To test you can download completely build below, and just replace dual-iso module and crop_rec module with the ones on your card, should work too.

New build:
https://bitbucket.org/Levas_EOS/magic-lantern/downloads/magiclantern-Nightly.2019May19.6D116.zip





baladev

  • Freshman
  • **
  • Posts: 81
  • 5Dm3 - 6D - 7D - EOS M
Re: Canon 6D
« Reply #1141 on: May 19, 2019, 04:00:20 PM »
@Levas

Thank you for the new build, will test it shortly.

For now want to show you how the pink fog worked on my 6D:
Normal frame (actually, if you look closely, there's some pinkness on the very top already):




When it starts:




..it quickly becomes like this and stays so:




BTW, I have nothing activated in the Overlay menu, only GD set to LV

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5634
Re: Canon 6D
« Reply #1142 on: May 19, 2019, 04:28:13 PM »
Are you still getting this in the latest build?
If so you can try and lower the regs pointed to through crop mode sub menu under advanced. That is levas is running the same build I use.

baladev

  • Freshman
  • **
  • Posts: 81
  • 5Dm3 - 6D - 7D - EOS M
Re: Canon 6D
« Reply #1143 on: May 19, 2019, 04:34:26 PM »
@Danne

Haven't tested the latest build yet. The frames above are from the previous build just for the record and so that Levas could compare with his results.

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1472
  • 6d - Nightly build user
Re: Canon 6D
« Reply #1144 on: May 19, 2019, 04:41:03 PM »
With the previous build, I have seen it like Baladev shows in the second picture, only top got pink.
But I have seen the 3d example in test builds  :P

I'm using the crop_rec build from Danne, so he is right, you could play further around with reg_timer registers and see if it helps. (in submenu of crop_record, advanced options shows more register values you can play with)

This is sort of a black box for me, A1ex made the first version of it, it handles register for frame timing.
Code: [Select]
    /* these should work on all presets, on all DIGIC 5 models and also on recent DIGIC 4 */
    if ((1) && (CROP_PRESET_MENU != CROP_PRESET_mv1080p_mv720p_100D) && (CROP_PRESET_MENU != CROP_PRESET_3xcropmode_100D) && (CROP_PRESET_MENU != CROP_PRESET_3x3_mv1080_700D) && (CROP_PRESET_MENU != CROP_PRESET_3x3_mv1080_650D))
    {
        /* assuming FPS timer B was overridden before this */
        int fps_timer_b = (shamem_read(0xC0F06014) & (0xFFFF + reg_timing5));
        int readout_end = shamem_read(is_digic4 ? 0xC0F06088 : 0xC0F06804) >> 16;

        /* PowerSaveTiming registers */
        /* after readout is finished, we can turn off the sensor until the next frame */
        /* we could also set these to 0; it will work, but the sensor will run a bit hotter */
        /* to be tested to find out exactly how much */
        adtg_new[4]  = (struct adtg_new) {6, 0x8172, nrzi_encode(readout_end + 1 + reg_timing1) }; /* PowerSaveTiming ON (6D/700D) */
        adtg_new[5]  = (struct adtg_new) {6, 0x8178, nrzi_encode(readout_end + 1 + reg_timing1) }; /* PowerSaveTiming ON (5D3/6D/700D) */
        adtg_new[6]  = (struct adtg_new) {6, 0x8196, nrzi_encode(readout_end + 1 + reg_timing1) }; /* PowerSaveTiming ON (5D3) */

        adtg_new[7]  = (struct adtg_new) {6, 0x8173, nrzi_encode(fps_timer_b - 5 + reg_timing3) }; /* PowerSaveTiming OFF (6D/700D) */
        adtg_new[8]  = (struct adtg_new) {6, 0x8179, nrzi_encode(fps_timer_b - 5 + reg_timing2) }; /* PowerSaveTiming OFF (5D3/6D/700D) */
        adtg_new[9]  = (struct adtg_new) {6, 0x8197, nrzi_encode(fps_timer_b - 5 + reg_timing2) }; /* PowerSaveTiming OFF (5D3) */

        adtg_new[10] = (struct adtg_new) {6, 0x82B6, nrzi_encode(readout_end - 1 + reg_timing6) }; /* PowerSaveTiming ON? (700D); 2 units below the "ON" timing from above */

        /* ReadOutTiming registers */
        /* these shouldn't be 0, as they affect the image */
        adtg_new[11] = (struct adtg_new) {6, 0x82F8, nrzi_encode(readout_end + 1 + reg_timing4) }; /* ReadOutTiming */
        adtg_new[12] = (struct adtg_new) {6, 0x82F9, nrzi_encode(fps_timer_b - 1 + reg_timing4) }; /* ReadOutTiming end? */
    }

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5634
Re: Canon 6D
« Reply #1145 on: May 19, 2019, 04:50:15 PM »
@Danne

Haven't tested the latest build yet. The frames above are from the previous build just for the record and so that Levas could compare with his results.

Ok, you need to specify exactly what build used since it might very well not be a problem for a a week or two at least.

baladev

  • Freshman
  • **
  • Posts: 81
  • 5Dm3 - 6D - 7D - EOS M
Re: Canon 6D
« Reply #1146 on: May 19, 2019, 04:55:35 PM »
Ok, you need to specify exactly what build used since it might very well not be a problem for a a week or two at least.
Ok, sorry, it's the build from message 1124, which was the previous build posted.
Which is magiclantern-Nightly.2019May13.6D116.zip

Update:

Just downloaded and tried the latest build magiclantern-Nightly.2019May19.6D116.zip
Did a quick test (by looking at the screen) - pink fog thing seem to have gone - couldn't see any. Will do a proper test tomorrow, but looks very good!
Will also test centering for all presets in this build.

Levas, do you want me to test dual iso module?

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5634
Re: Canon 6D
« Reply #1147 on: May 19, 2019, 05:18:31 PM »
Thanks!

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5634
Re: Canon 6D
« Reply #1148 on: May 19, 2019, 05:34:11 PM »
Checking the reg a1ex specified 6D already so good find Levas. I missed it before since I fixed on my 5dIII. Fog should be fixed on 6D.
Code: [Select]
        adtg_new[7]  = (struct adtg_new) {6, 0x8173, nrzi_encode(fps_timer_b - 5 + reg_timing3) }; /* PowerSaveTiming OFF (6D/700D) */       

baladev

  • Freshman
  • **
  • Posts: 81
  • 5Dm3 - 6D - 7D - EOS M
Re: Canon 6D
« Reply #1149 on: May 23, 2019, 05:57:23 PM »
Confirming the fog in anamorphic presets is gone in the latest build by Levas. Filmed for 10 minutes and it didn't occur.