Author Topic: FREE FOR DOWNLOAD: AFX Script for mass converting MLraw DNG files to Video files  (Read 60272 times)

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6458

5DanielMIII

  • New to the forum
  • *
  • Posts: 47
  • -I love JESUS and MagicLantern-
Hi @stevescout

That sounds good!  :D
I have tried to make mlv files with older builds, but still same error when using the script.
I have tried to convert mlv with Mirawviewer and Mystic, but still same error.
I have tried to put less dng folders in the source folder to see if that affects import, same error.

But when I click the actual dng folder as the source, the script imports.
So if I import one folder at a time it works ;)

Anyways, thanks for looking into it!!
I did get to try this script before it acted up on me, and it was such a joy to import Magic Lantern files!
So fast  8)

And I could sure need it as I am in the middle of the jungle in Papua New Guinea, shooting massive amounts of MLV`s.
I am editing on a boat floating in the river outside the village, and I have a tight schedule.
The script would be a lifesaver if working.

Thanks for giving it another go, looking forward to make good use of it!

Regards,
Daniel
I am thankful that Jesus and MagicLantern exist, because they both change lives!

The Director

  • Freshman
  • **
  • Posts: 69
will be cool if somebody write script for AE to fast replace all mov-footage on dng-seqence...

SteveScout

  • Freshman
  • **
  • Posts: 99
Hi, everyone!

The new version of the script is ready! Please try it out, hopefully every error you encounteres is adressed now!!

http://www.alexandsteffen.com/smartimport2.zip

Steffen


Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6458
 Will test soon. Most grateful.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6458
Hi! Some feedback. I,m working on adobes CS 6, OSX Mavericks 10.9.3

So, importing files into AE works. This also works also if I drag and drop several files directly to AE without the script(I have to click ok in ACR but it,s quicker not having to reopen file etc.)

I could not get the rest to follow. No compositions are made and no render queues are started. Not on my computer at least.
I,ll include some pictures.
Thanks you.




SteveScout

  • Freshman
  • **
  • Posts: 99
I´ve seen this behaviour on my machine before as well and I can´t reproduce it. Don´t know if it´s filestructure, names etc. - sometimes it just doesn´t create the comps.

One workaround for the moment would be the use of the Batchprocessor - http://aescripts.com/batchprocessor/

It takes already imported files and creates the comps and output modules, just check if the output filenames are made properly, sometimes, it seems the script counts numbers up etc., so the output file does not match the MLV file name.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6458
Thanks, will try some more. Tried moving files to different location too se if it had to do with file naming structure and so on but couldn,t get the comps created wherevever i, d put them.

ericjolley

  • New to the forum
  • *
  • Posts: 4
Just a quick bug report and fix (maybe this has already been fixed). 

I need to constantly scale up 111% to fit 1920x1080 (I have a 7D).  X would scale but Y would always stay 100%.  I found out why.

Line 577 is :

Code: [Select]
if (uiContainer.etScaleX.text !== '') smartImport.getOptions().compositionOptions.transform.scale.x = parseFloat(uiContainer.etScaleX.text);

But should be:

Code: [Select]
if (uiContainer.etScaleY.text !== '') smartImport.getOptions().compositionOptions.transform.scale.y = parseFloat(uiContainer.etScaleY.text);


Again, please ignore if this has already been fixed.  Love the script BTW, saved me a lot of monotony on a commercial edit.

SteveScout

  • Freshman
  • **
  • Posts: 99
Hey, everyone!

Try to download the newest version, just updated the link: www.alexandsteffen.com/smartimport2.zip

Now there´s a feature to create comps and output modules from already imported material, i.e. if the script failed to generate it automatically you can do it manually now.

cheers,
Steffen

P.S.: thanks, Eric, for the bug report!!

Frank7D

  • Senior
  • ****
  • Posts: 456
This is going to save me a lot of time (previously was using smartimport + batchprocessor).
Is it possible to change the default output module (currently is flv)?
Do I need to edit the script?

5DanielMIII

  • New to the forum
  • *
  • Posts: 47
  • -I love JESUS and MagicLantern-
@stevescout

Thanks for helping the community with this! GREAT! =)
I tried the script and I had some issues with importing folders with some dng`s missing frames.

I got an error and no import happened, just a warning about the missing frames.
This was MLV`s converted with raw2cdng.

Then I tried importing again with dng`s made with Mirawviewer, no problem.

I know there are some missing frames because when I recorded the MLV i got skipped frames.
Just a little strange that one import did not work..

I will test a little more.
Anyways, thanks! =)

Daniel
I am thankful that Jesus and MagicLantern exist, because they both change lives!

SteveScout

  • Freshman
  • **
  • Posts: 99
Yep, this is a behaviour the script can´t correctly deal with as the AFX import routine together with ACR does not allow to "skip" missing frames - a missing frame for AFX tells Adobe Camera Raw  "this is a new sequence". And that´s the only feedback that AFX sends back to the script routines.

That´s why we implemented the warning (earlier versions I was trying out along the way to this one would not even have those, THAT was painful!) so you can manually go into these folders and just duplicate the missing frames. If someone with tons of AFX scripting knowledge knows a workaround we´re more than happy to modify and add those routines, but so far that´s the only chance to import sequences together with ACR.

Steffen

SteveScout

  • Freshman
  • **
  • Posts: 99
@FrankD: Good question. On my machine it´s always the output module as standard that I created last, so definitely never the FLV one. The standard one (fixed setting) can surely be implemented, but for the moment I can´t get hold of "my" programmer anymore, so this is something you´d have to figure out by going through the script.

Frank7D

  • Senior
  • ****
  • Posts: 456
Steve, I am using your script as part of my workflow which also uses MLVFS (http://www.magiclantern.fm/forum/index.php?topic=13354.0) but I am running into an issue with spanned files. The script thinks they are a sequence and tries to import them and, since it can't, it just stops. Is it possible to define a list of valid file types to be imported as sequences and have the script ignore anything else?

Kharak

  • Hero Member
  • *****
  • Posts: 943
Trying to use your script.

I think this could be exactly what I look for when creating proxies if I got it to work.

The very first time I used it, I got it to make a composition and render one dng sequence to a h264 file. But now it only imports the sequences and thats it.

Now there´s a feature to create comps and output modules from already imported material, i.e. if the script failed to generate it automatically you can do it manually now.


How ? you mean manually make a composition for every imported dng sequence in after effects and add it to render queue? I guess you don't mean this, cause that ain't nothing new :)

Other than that, I found out that if I had played the DNG sequence in MLrawviewer, the script will state that there is a missing file. But this is because MLrawviever makes a .mrx file which the script somehow interprets as a missing frame or obstructing its count of frames.

.idx files created by mlrawviever and in camera mlv_play will interfer with the script aswell and make it not import.

So best thing is to have a folder with DNG folders that contain nothing else but DNG's and WAV files, then the import works.

Please let me know how to make compositions and render from already imported sequences.

Thank you.



EDIT: like seriously, 10 seconds after I posted this and looked at the "Selected material" I found out how to use it.. I thought it wasn't working before as I was trying to specify the location of source files of the already imported sequences.

So yeah, just selecting the material in project manager and clicking Run under "Selected Material" worked.

Awesome script! Thank you so much! even though it doens't work on first import, its still so fast to import then select the material in project manager and make the proxies! Exactly what i was looking for!

once you go raw you never go back

Frank7D

  • Senior
  • ****
  • Posts: 456
Hi Steve,

I found a simple change that allows your script to work with spanned files in conjunction with MLVFS.
Would it be possible for you to edit your script so that people who download it don't have to?
The change is:
Line 15 changes from THIS:
Code: [Select]
var videoFileRegExp = /(mov|avi|mpg|m4a|mp4|flv)$/i;to THIS:
Code: [Select]
var videoFileRegExp = /(mov|avi|mpg|m4a|mp4|flv|idx|m00|m01|m02|m03|m04|m05|m06|m07|m08)$/i;
I don't believe this will affect its functionality in any other way.

dmilligan

  • Developer
  • Hero Member
  • *****
  • Posts: 3218
  • 60Da / 1100D / EOSM
just incase there are ever more than .m08 spanned files, use this regex instead (it's also shorter):
Code: [Select]
(mov|avi|mpg|m4a|mp4|flv|idx|m\d{2})$

Frank7D

  • Senior
  • ****
  • Posts: 456
Thanks dmilligan, that certainly seems more robust.

Also, there are a couple of more file types that should probably be added to accomodate MLVFS with Pismo: .XMPs and .INIs

So the new modified line would be:
Code: [Select]
var videoFileRegExp = /(mov|avi|mpg|m4a|mp4|flv|mlv|idx|xmp|ini|m\d{2})$/i;
Edit: Added .MLVs in there as well.

SteveScout

  • Freshman
  • **
  • Posts: 99
Thanks for the contribution, guys! The file is updated, so everyony downloading it will have the latest line (From Frank7D) in.

Frank7D

  • Senior
  • ****
  • Posts: 456
Thanks Steve!

kaco

  • Freshman
  • **
  • Posts: 96
It seems not to be working with the 2014.1 version. No dialog is beaing opened.

SteveScout

  • Freshman
  • **
  • Posts: 99
Really? Since I´m on 14.1 I have problems with the autogeneration of comps, but at least the import works. Unfortunately my programmer left our company, and I´m very bad at scripting, so we need the help of others to keep this script updated.

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3369
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
*feedbacks*

2006 Macbook Pro running Mavricks 10.9.5 using AE CS6 11.0.4 and this is what I'm seeing... I doubt this is the same error you guys were referring to from earlier?



thoughts?
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6458
It says missing frame. Look at the sequence and see if that is the case. You could try renaming the whole sequence with adobe bridge or some other batch renaming program so they end up as a intact seqeunce .