BarracudaGUI for cr2hdr dual iso raw post-processing (Windows XP/7/8)

Started by sepa, October 30, 2013, 07:06:13 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


No useful debugging info.

It crashes as soon as the DNG's are created in the source folder.  As you can see in the screenshot, even just processing 3 files made it crash.  With export folder = import folder, it still crashes.  I tried running with admin privileges, didn't make a difference.

Do you have a debug build?

edit:  With export folder as a different folder to the input, I get the 3 files in the export folder, and I had 2 DNG's left in the input folder.  It would appear that the crash is related to moving files.


Thanks for the shot. The destination path for dng moving looks interesting. Can you set the dng export path to a separate folder (instead of root)?


Check my edit above.

edit:  Yes, looks like it's doing something funky with the destination path.



Canon eos 60d, firmware 1.1.1/sigma 10-20 + ML v2.3.RC2 + Nodal Ninja NN4


Tested with 500 CR2 files in queue - no problem found. Can anyone reproduce this?


Hey Sepa

This is what I tried:

1. I had a space in my output destination folder PathDNGHDROutput=D:\CanonTools\CR2HDR DNG and get the following result:

Both images are converted but only 1 of the images was moved to the output path before program crashes (Note: this works fine in Barracuda 0.3.1)

2. Removed space in my output destination folder PathDNGHDROutput=D:\CanonTools\CR2HDR_DNG and get the following result:

Both files or converted and copied to output destination path before crashing program.

3. Tried 4 images with no spaces in any of the path names, all images are converted but only 2 of the images are moved to the output path before Barracuda program stop working.

Hope this help as this going to be a great little program when all the bugs get worked out!!


Hi beachman, thanks for this testing sequence. I rewrite the file processing section and add some other improvements.
Please check out this testing version


Hello sepa

Tried your 0.3.3 test version with some interesting results. The program still fails but all raw file are converted and only one is moved to the output destination directory. Would it be possible that BarracudaGUI is trying to move files that have not been written to the hard drive completely or the conversion process is still being implemented. I have include the text from the xml crash dump, if you want the other two dump files, let me know as I have them as well. Good luck and let me know if I can help some more!!

<?xml version="1.0" encoding="UTF-16"?>
      <Build>7601 Service Pack 1</Build>
      <Product>(0x1): Windows 7 Ultimate</Product>
      <Flavor>Multiprocessor Free</Flavor>
      <SystemManufacturer>Gigabyte Technology Co., Ltd.</SystemManufacturer>


Your log points to a "System.IO.FileNotFoundException" exeption. But i can't locate the problem. Has anyone the same problem with this version?

combat squirrel

So I am testing this on my intel i5 2.5ghz 4 thread ivy bridge laptop and i have imported ONE Cr2 image file and its been one hour now processing, last info from the program says: using 4 threads............

The cpu usage has remained steady at 40% roughly and its still going.

Has it hanged or does it really take this absurd amount of time per image?! lol

combat squirrel

Just got home and tried this on my desktop i7 ivy bridge at 4.5ghz and it takes about 40 mins to do one CR2 file ? and then the program crashes? is this right ? and 40 mins is the expected time per image?


With the test version, as soon as I hit start processing, it errors out.

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.WindowsAPICodePack.Shell, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
File name: 'Microsoft.WindowsAPICodePack.Shell, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35'
   at BarracudaGUI.frmMain.buttonStart_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

************** Loaded Assemblies **************
    Assembly Version:
    Win32 Version: 4.0.30319.34011 built by: FX45W81RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
    Assembly Version:
    Win32 Version:
    CodeBase: file:///C:/Users/Audionut/AppData/Local/Temp/
    Assembly Version:
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    Assembly Version:
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    Assembly Version:
    Win32 Version: 4.0.30319.34003 built by: FX45W81RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
    Assembly Version:
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the section.
The application must also be compiled with debugging

For example:

    < jitDebugging="true" />

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


Quote from: Audionut on March 26, 2014, 02:35:14 AM
With the test version, as soon as I hit start processing, it errors out.

Please use the download link (include the missing dll) from first post and put the testing version in the same folder.


Every time I attempt to use BarracudaGUI it initially asks me to select a post processing application. I do not understand what it wants me to select. Anyone?


***UPDATE*** I tried selecting CR2HDR as the processing application, it seemed like it was going to work but then I got an error stating that BarracudaGUI has stopped working. Now what?


Stevenbrail +1
Don't know what should I use as posprocessing software and it always crashes.



Still getting a crash here.

It processes 8 files (determined by processing settings), but then crashes after moving the second DNG file.  This is even when the output directory is the same as the input directory.

I actually get the 8 DNG files output, but something is going on with the file management.



That fixed it.  Thanks sepa.
The one I had previously was "Microsoft.WindowsAPICodePack.Shell.dll".

Feature requests:
cr2hdr now contains a command option that matches the white level for all images processed, in a single command line.  --same-levels
Is it possible to provide an option, whereby, all selected images are parsed to the same command line?  Actually, will this already work with multithreaded set to 1, or do you spawn a new command for each file?

What about making some of the command parameters, nice looking toggle buttons, or drop down boxes?


Thanks for testing.  :)

Quote from: Audionut on April 30, 2014, 03:48:07 PM
That fixed it.  Thanks sepa.
The one I had previously was "Microsoft.WindowsAPICodePack.Shell.dll".

Both dll's are needed.
I've updated the v0.3.3.1 zip (first post of this thread) with the missing dll.


I know that it may be super-stupid, but... How do I access settings? :D