Focus sequencing (5D3)

Started by a.sintes, October 25, 2023, 05:26:31 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


UPDATED 2024-01-23


Just released a new focus sequencing feature allowing us to create and manage a list of focus point created via autofocus with specific transition durations, then easily replay the sequence step-by-step while recording a video, using a single button push.

Demonstration video:

The complete documentation (explaining both why it was a challenge regarding the lens calibration and how to use the feature) is available online using this markdown link.

Download link:
5D3 users, 1.1.3 & 1.2.3 pre-builds are available in this GitHub repository, which is basically an up-to-date fork of Danne's repository, including all the modules but also the ultrafast framed preview feature and the SD/CF dual slots free space display.

- does this replace the previous cinematographer module?
yes, it's a complete replacement of it, including a way more user-friendly GUI, a lens calibration process and above all an autofocus-based sequence creation which was not possible before

- why is it running on a 5D3 only as it's mainly a ML module? does a port to other cameras possible?
basically, because a change in the lens.c ML code was required first to get a reliable lens_focus function used by the focus_seq module (explained in the documentation)...
this is why it's currently embedded in the only specific Magic Lantern GitHub repository that provides this function, anyway as the change doesn't impact yet the legacy code a port in other repos for other cameras remains highly possible (pending)

Thanks a lot to @names_as_hard for code review, support & advices, much appreciated!

23-Jan-2024 update:
Following a user (@bigbe3) comment on YouTube, I just fixed the module to deal properly with lenses that doesn't report the focus distance and/or that are stucked at initial calibration step due to a missing forward lens limit detection, typically like the Canon EF 50mm f/1.8 II: the download link above was updated accordingly.
It's too bad she won't live, but then again, who does?

Bruno Moly

Brilliant work. 🇮🇹🇬🇧🏳️
Canon EOS 5D iii Carl Zeiss Jena 58mm Biotar



Code updated today to deal properly with lenses that doesn't report focus distance and/or are stucked at initial calibration step, e.g.: the Canon EF 50mm f/1.8 II lens, as reported by some user on YouTube.
It's too bad she won't live, but then again, who does?


Hi i paste your completed build file to sd card, but the firmware update can't find and install the build. It worked with Danne Build.
Please help a.Sintes.

Walter Schulz

macOS on PC? And ExFAT file system?
Known problem.
1) Format card with "FAT32" file system.
2) Copy extracted build content to card
3) Install ML
After reboot
4) Access Canon menu -> Format card with "Keep ML" option.



PC .
The card is ExFat format.
=> i will follow your guide. tks.

Walter Schulz

Quote from: kytai90 on January 24, 2024, 07:47:38 AM
PC .
Windows or macOS or other?

EDIT: Advice is *only* for macOS combined with ExFAT. If you are not running macOS it - most likely - won't do anything.


Ah I mean window.
I've checked, i can't format  my sd card as FAT format. I need to ask some one with MAC OS. Or find some tool to do that.
Anyone else had the same problem on windows please comment

Walter Schulz

Maybe I have to point it out a third time:
Procedure described above is only helping for macOS + ExFAT.

Your problem is a different one.
Make sure to have this file structure inside your card and proceed with installation:
Click here

You can also start EOScard Utility (as admin), select your card, mark boxes for EOS_DEVELOP and BOOTDISK. Then press Save button.
Card is bootable now. Insert card and startup.


Tks. I' ll try the method with EOS utility.

I tried 2 different sd card (samsung evo and sandisk extreme pro which were sucessful installment of builds on M and 5d3 feb2023 Danne build ), formated them on 5d3 first, then pasted A.sinstes build as the same structure as the photo, switched 5d3 to photo mode and went to update firmware. didn't work .


Just double-checked on my side and it's ok using the following procedure:
- exFAT (quick) format the SD card using Windows (explorer/right-click on SD driver/format)
- download the latest ML build from this repository (1.1.3 target here) then extract and copy the whole zip content to the empty SD card root
- put the SD card in the 5D3 and startup the camera
- go to the regular Canon menu/firmware update and do the update, you may see "Magic Lantern is installing"...
then restart the camera as asked by ML at the end of the firmware update and that's it
It's too bad she won't live, but then again, who does?