Author Topic: Strobo efx in Dual ISO files (Mac)  (Read 569 times)

adrjork

  • Freshman
  • **
  • Posts: 85
Strobo efx in Dual ISO files (Mac)
« on: October 15, 2018, 12:49:36 AM »
Hi everyone,

sorry in advance if this question has yet a well known solution. My problem is that I have Dual-ISO footage (5D3 with ML) and I converted my MLV files with Switch.
I obtained a DNG video with a visible strobo effect (in Davinci).

In THIS page there is a video that shows the solution: fixing the black point with ExiftoolGUI, but this software is for Windows only. I use Mac, which is the procedure to fix this problem in Mac? I tried pyExifToolGUI, but without success. Same thing for ExifToolGUI via Wine.

One solution could be using Exiftool from the terminal, and knowing which is the command line for finding the black level of the first DNG image, and the command line to set that level for all the other DNGs of the folder.

Please, someone can help me?

Thanks a lot.

adrjork

  • Freshman
  • **
  • Posts: 85
Re: Strobo efx in Dual ISO files (Mac)
« Reply #1 on: October 15, 2018, 06:08:53 AM »
I found the solution in ExifTool Forum:

basically I have to use ExifTool in Terminal:

1. knowing the black and white levels of the first DNG frame
Code: [Select]
exiftool -G1 -blacklevel image.dngand
Code: [Select]
exiftool -G1 -whitelevel image.dng
2. setting those values for all the DNG frames of the folder
Code: [Select]
exiftool -blacklevel=xxxx -whitelevel=xxxx -ext dng -r YourDngFolder
This method works: now I have no more strobe efx.

Danne

  • Hero Member
  • *****
  • Posts: 5119
Re: Strobo efx in Dual ISO files (Mac)
« Reply #2 on: October 15, 2018, 07:43:39 AM »
Hm, Switch usually does that work for you. Could you send me that problematic file for me to test?

adrjork

  • Freshman
  • **
  • Posts: 85
Re: Strobo efx in Dual ISO files (Mac)
« Reply #3 on: October 17, 2018, 12:02:16 AM »
Sorry Danne, I've deleted the original MLV after converted into DNGs, and now I have only the corrected DNGs.
But in the next days I will have to repeat the same shot, so if the issue will happen again, I'll post to you the MLV.

Thanks a lot.