Author Topic: Full-resolution silent pictures (silent.mo)  (Read 676440 times)

swinxx

  • Hero Member
  • *****
  • Posts: 602
Re: Full-resolution silent pictures
« Reply #450 on: January 19, 2015, 10:21:09 AM »
hi,
so i downgraded to 1.1.3 with success :)
can somebody please be so kind to post an updated fullres silent pic module for the latest nightly of 1.1.3 5d mk3. thank you
greetings sw

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3401
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Full-resolution silent pictures
« Reply #451 on: January 19, 2015, 03:06:41 PM »
@swinxx -- PM me for a somewhat working copy of FRSP module for 1.1.3 (or 1.2.3) ...
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

swinxx

  • Hero Member
  • *****
  • Posts: 602
Re: Full-resolution silent pictures
« Reply #452 on: January 19, 2015, 03:11:06 PM »
thx. my prob is that i have just no compiling skills

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3401
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: Full-resolution silent pictures
« Reply #453 on: January 20, 2015, 04:40:28 AM »
@g3gg0:

Any chance we could see similar to what you did for the FRSP on 7D 2.0.3 for the 5D3?

1.1.3 or 1.2.3 doesn't matter to me... preferably 1.1.3 if we had to make a choice! lol

but I'm curious because I like what you did for the 7D in terms of choosing Multi-Frame MLV or Single Frame MLV...

that would be a big +1 !
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

Ottoga

  • Member
  • ***
  • Posts: 202
  • The Ox is Slow but the Earth is Patient
Re: Full-resolution silent pictures
« Reply #454 on: January 20, 2015, 08:15:41 AM »
Hi,

DeafEyeJedi was kind enough to forward me a link to this thread and I have tested the full-res silent.mo posted by g33g0 on 2015/01/16.

Below is my feedback on the tests performed:

Just as background, my 7D is running the latest nightly build dated 2015/01/15.

Initially I overwote the files on my CF card with those downloaded from g33g0's links dated 2015/01/16 (autoexec.exe, 7D_203.sym, silent.mo and mlv_rec.mo files).

Upon starting the camera the following errors were displayed and none of the modules loaded. This is similar to DeafEyeJedi's initial experience.

Quote
tcc: err: undefined symbol 'is_native_movie_mode'
tcc: err: undefined symbol 'is_custom_movie_mode'
[E] faqiled to link modules

I then:
  • Formatted the CF card in the camera and retained ML
  • Deleted the autoexec.exe file and all of the modules and settings files from within the ML directories.
  • Then copied the files supplied by g33g0 to their respecitve locations on the cf card.
  • Loaded the card back into the camera and was then able to successfully load the silent and mlv-rec modules. (note that these are the only modules on the card).
Time to test:

Test 1: Silent pics - full-res, DNG format images, no intervalometer.
            Sunny with light clouds, ISO, 100, 200 and 400, f5.6

           Result: failed.  Error message "exposure too long"

           Interesting given that the indicated exposure on the top screen was 500th of a second or greater.
           Reverting back to simple silent-mode resulted in images being captured as expected.

Test 2: Silent pics - full-res, DNG format images, intervalometer enabled.
            Sunny with light clouds, ISO, 100, 200 and 400, f5.6

           Result: failed.  same as test 1, Error message "exposure too long" and no images taken
                                   (note the intervalometer did cycle through it's range as per its paramaters).

Test 3 & 4 : Silent pics - full-res, Multi-MLV and Single_MLV format images, no intervalometer.
                  Sunny with light clouds, ISO, 100, 200 and 400, f5.6

                  Result: failed.  same as test 1, Error message "exposure too long"

I don't have the tools or skill to grab the source codes and recompile a custom build. Any thoughts, on what the issue may be?
(Happy to test any new versions)

Also, I haven't tried to test the MLV-REC.mo yet as I don't know what has changed and as such, don't know what sort of testing is required. If someone can enlighten me I'll put this module through its paces as well.
EOS 7D.203, EFS 55-250mm, EF 75-300 III, Tamron 16-300 DiII VC PZD Macro, SpeedLite 580EX II.

g3gg0

  • Developer
  • Hero Member
  • *****
  • Posts: 3175
Re: Full-resolution silent pictures
« Reply #455 on: January 20, 2015, 12:30:33 PM »
set M mode and retry
Help us with datasheets - Help us with register dumps
magic lantern: 1Magic9991E1eWbGvrsx186GovYCXFbppY, server expenses: paypal@g3gg0.de
ONLY donate for things we have done, not for things you expect!

Toseben

  • New to the forum
  • *
  • Posts: 3
Re: Full-resolution silent pictures
« Reply #456 on: January 21, 2015, 01:02:29 AM »
First post on the forums, sorry that it's a question!
I found a nightly build on the forums for 600D (2014Sep26) with silent.mo which works nicely.
However the aperture seemed to be wide open even with Expo Override on. Is there any known fixes for this?

So after that I decided to try compiling the fullres branch myself to see if it was a issue fixed in a newer release.
I can't seem to be able to compile silent.mo though. All the other modules and core compile just fine.

Basic settings I was using:
Code: [Select]
hg clone https://bitbucket.org/hudson/magic-lantern/
hg update fullres-silent-pics

ARM_ABI=none-eabi
ARM_PATH=~/arm-toolchain/
GCC_VERSION=-4.7.3

CONFIG_TCC = y
CONFIG_MODULES = y
CONFIG_PICOC = y

make clean
make 600D
cd platform/600D.102
make zip

And the error I'm getting:
Code: [Select]
silent.c:1302:21: warning: initialization makes integer from pointer without a cast [enabled by default]
                     "Writes an extra MLV for every picture being taken.\n",
                     ^
silent.c:1302:21: warning: (near initialization for '(anonymous)[2].submenu_width') [enabled by default]
silent.c:1307:9: error: initializer element is not constant
         },
         ^
silent.c:1307:9: error: (near initialization for 'silent_menu[0]')
make: *** [silent.o] Error 1

Any help would be appreciated!

dmilligan

  • Developer
  • Hero Member
  • *****
  • Posts: 3218
  • 60Da / 1100D / EOSM
Re: Full-resolution silent pictures
« Reply #457 on: January 21, 2015, 01:57:42 AM »
delete the comma at the end of line 1301, this is an error that was recently committed to the source

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3401
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Full-resolution silent pictures
« Reply #458 on: January 21, 2015, 06:40:42 AM »
@g3gg0 - Is there a reason for the mlv_rec.mo link that you posted in recent post #444 for 7D 2.0.3 is from 4/18/14 whereas the one from before (@N/A's post #437) that was from 1/16/15? (or was this a mistake?)

Should I be using the new mlv_re.mo (1/16/15) instead of the one from 4/18/14 -- correct?

I'm asking because the one I downloaded from your post (4/18/14) was the one Module that was actually causing the error I posted from earlier post.

So I then decided to compile with the mlv_rec.mo (1/16/15 from @N/A's post) which seemed to be working really well. Strange or normal?

Playback is nice on MLRawViewer... [emoji1]

Just wanted to confirm... Thanks!
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

N/A

  • Hero Member
  • *****
  • Posts: 576
  • Dreaming in 14 bit
Re: Full-resolution silent pictures
« Reply #459 on: January 21, 2015, 04:02:25 PM »
updated silent.mo with this stuff:
 - fixed crash if no intervalometer ran before
 - MLV header now contains frame count (allows playback with MLRawViewer)
 - allow user to choose between DNG, Single-Frame-MLV and Multi-Frame-MLV (disable and re-enable "Silent Pic" from menu to start a new file in Multi-Frame-MLV mode)
Just tested it, works like a champ now. Thanks again. Got a wedding to shoot in a few days, might try it out on some static shots.
What else does FRSP need before it gets pulled into unified?
7D. 600D. Rokinon 35 cine. Sigma 30 1.4
Audio and video recording/production, Random Photography
Want to help with the latest development but don't know how to compile?

g3gg0

  • Developer
  • Hero Member
  • *****
  • Posts: 3175
Re: Full-resolution silent pictures
« Reply #460 on: January 21, 2015, 09:00:06 PM »
@DeafEyeJedi:
indeed. sorry. i accidentally uploaded it using the wrong uploader. my wrong.
fixed.
Help us with datasheets - Help us with register dumps
magic lantern: 1Magic9991E1eWbGvrsx186GovYCXFbppY, server expenses: paypal@g3gg0.de
ONLY donate for things we have done, not for things you expect!

Toseben

  • New to the forum
  • *
  • Posts: 3
Re: Full-resolution silent pictures
« Reply #461 on: January 21, 2015, 09:32:41 PM »
delete the comma at the end of line 1301, this is an error that was recently committed to the source

Cheers! That worked and also seems to be fixed now in the branch.
Also after reading around I realised that the Expo Override not working was because of the lens.
Changed the lens and works nicely. Happy days!

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Full-resolution silent pictures
« Reply #462 on: January 21, 2015, 10:29:39 PM »
What lens is causing trouble with expo override?

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3401
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Full-resolution silent pictures
« Reply #463 on: January 21, 2015, 11:11:21 PM »
@DeafEyeJedi:
indeed. sorry. i accidentally uploaded it using the wrong uploader. my wrong.
fixed.

No worries @g3gg0 -- just thought it was worth noting to prevent snowballs of unnecessary complaints/questions from those who don't enjoy troubleshooting. [emoji6]
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

Toseben

  • New to the forum
  • *
  • Posts: 3
Re: Full-resolution silent pictures
« Reply #464 on: January 21, 2015, 11:59:28 PM »
What lens is causing trouble with expo override?
Was the 600D kit lens (18-55) that I tried originally with. I did try with and without stabilizer and AF incase those have any effect.
Canon 50mm 1.8 works perfectly tho!

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3401
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: Full-resolution silent pictures
« Reply #465 on: January 25, 2015, 08:45:44 AM »
**feedbacks**

This quick test was done on 7D 2.0.3 w latest nightly (v2.3.NEXT.2015Jan12.7D203 fee1d1dd5a2d+ [fulres-silent-pics] tip ) along with custom compile for FRSP (from @g3gg0 & @N/A) which I decided to see what happens with varies of shutter speeds (beyond 1/30th) and here are the results...

'FRSP_7D203_MLV_DNG's'

Included are the orignal MLV file created from FRSP as well as the converted DNG's respectively!
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

g3gg0

  • Developer
  • Hero Member
  • *****
  • Posts: 3175
Re: Full-resolution silent pictures
« Reply #466 on: January 25, 2015, 12:32:23 PM »
general warning:
FRSP are only possible in M mode. in other modes the results are unpredictable
Help us with datasheets - Help us with register dumps
magic lantern: 1Magic9991E1eWbGvrsx186GovYCXFbppY, server expenses: paypal@g3gg0.de
ONLY donate for things we have done, not for things you expect!

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3401
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: Full-resolution silent pictures
« Reply #467 on: January 25, 2015, 06:52:10 PM »
general warning:
FRSP are only possible in M mode. in other modes the results are unpredictable

Was this for me as well?

If so, this test was actually done in M mode and I ONLY use M mode for literally all types of shooting.

**EDIT**

Also has anyone try this? Just manually change the shutter speeds after each take on FRSP during (Non-Timelapse) Multi Frame or Single Frame MLV's and it seems to bypass the limit that FRSP used to have 1/15 or 1/30 whatever it was.

This applies only to the 7D 2.0.3 FRSP (not the 5D3 atm)

Or am I high on Magic Lantern?  :P
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

hawaii75cc

  • Just arrived
  • *
  • Posts: 1
Re: Full-resolution silent pictures
« Reply #468 on: January 26, 2015, 09:21:39 AM »
Hello everyone,
I have a 5dm3 firmware 1.1.3 with magiclantern and the last build january 25, and I want to test full-resolution pictures silent but I can't find the compiled download link.
can someone help me?
thanks

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3401
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Full-resolution silent pictures
« Reply #469 on: January 26, 2015, 10:17:51 AM »
@hawaii75cc -- I believe the last decent FRSP for 5D3 1.1.3 that's currently working (that I know of) is a fixed version compiled with Sept 27th build.

It has been taken offline for safety reasons and hopefully it'll be implemented into the nightlies soon.
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3401
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: Full-resolution silent pictures
« Reply #470 on: January 27, 2015, 07:21:48 AM »
Ladies & Gentlemen:

I'm just a bit jealous of the fact that the 7D 203's FRSP works slightly better than the 5D 113's... (not sure why/how) really frustrating and yet so confusing at times.

Will get to the bottom of this one way or another...

 :P
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

igoriok1994

  • New to the forum
  • *
  • Posts: 4
Re: Full-resolution silent pictures
« Reply #471 on: January 27, 2015, 04:53:10 PM »
Hi. I'm using 550d and last nightly ML build :
Latest Build
magiclantern-Nightly.2015Jan24.550D109.zip
Built on: 2015-01-24 03:22:51 +0200
Changeset: 04a1daf

How can I install full resolution silent picture module? Or where I can get this module compilled? Just don't know how to compile it :)
550D

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Full-resolution silent pictures
« Reply #472 on: January 28, 2015, 11:04:06 PM »
Update: mlv_play now works with those huge frame sizes :)

My free time is slowly returning to normal levels, and this thing is next on the list for including into the nightly builds. Thanks @g3gg0 for fixing the MLV output routines.

swinxx

  • Hero Member
  • *****
  • Posts: 602
Full-resolution silent pictures
« Reply #473 on: January 28, 2015, 11:05:51 PM »
Glad to see you coming back!! Welcome again a1ex!' ;)

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8071
Re: Full-resolution silent pictures
« Reply #474 on: January 28, 2015, 11:11:53 PM »
Yes, our halcyon days are over. See
https://bitbucket.org/hudson/magic-lantern/commits/all
Nice, really nice!