Author Topic: Canon 5D Mark III / 5D3 / Firmware 1.2.3  (Read 1051426 times)

kichetof

  • Contributor
  • Senior
  • *****
  • Posts: 469
  • Take a beer and enjoy it!
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #75 on: March 17, 2014, 09:36:58 PM »
Yeah thanks chris & a1ex !!

After a long follow on bitbucket it's here now !! :)
Great thanks a lot!

Like on bitbucket issues, canon overlay on lv it's always present and dualiso module doesn't change the custom prefix of the file.

I'll investigate to solve these issues :)

ImaXineria

  • New to the forum
  • *
  • Posts: 20
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #76 on: March 17, 2014, 09:55:36 PM »
while the second one is corrupted, meaning I can't convert it with RAWmagic, and I definitely can't use it...

what kind of corruption?

Shield

  • Senior
  • ****
  • Posts: 254
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #77 on: March 17, 2014, 11:04:56 PM »


Uninstallation:
1) Run Firmware Update from your ML card.
2) Follow the instructions.

What's hot:
- bootflag issue solved! (p.s. some bloggers got it wrong, you still enable it in the camera, but you can disable it by uninstalling)


Silly question (maybe?) - I run 1.1.3 and toggle between 1.2.3 prior to this release - no problems.  If I wanted to completely remove the bootflag from my camera can I just install and then uninstall this version?  Then go back to Canon's OEM firmware and there's absolutely no remnants of ML anywhere?  (This is in case I need to send the camera in for repair or decide to sell it).

Thanks!
Shawn

engstrom

  • Just arrived
  • *
  • Posts: 1
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #78 on: March 17, 2014, 11:28:34 PM »
Another silly question; I installed this version from a 16gb sd card to try it out. I tried the uninstall instructions but it just seems to go through the install procedure again...
It does give me 30s to remove the boot flag. Do I need to let this run for it to uninstall correctly?
Using Tapatalk

tron

  • Member
  • ***
  • Posts: 162
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #79 on: March 17, 2014, 11:52:03 PM »
Another silly question; I installed this version from a 16gb sd card to try it out. I tried the uninstall instructions but it just seems to go through the install procedure again...
It does give me 30s to remove the boot flag. Do I need to let this run for it to uninstall correctly?
Yes, wait patiently ... 30 seconds  :)

EXIV

  • New to the forum
  • *
  • Posts: 29
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #80 on: March 18, 2014, 01:52:34 AM »
what kind of corruption?

It is simply impossible to extract the dng files from it. I have tried with RAWMagic and raw2dng but both give me error:

dcac

  • New to the forum
  • *
  • Posts: 4
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #81 on: March 18, 2014, 03:37:45 AM »
Thanks so much! I can now finally use my eye fi cards with my mark iii. You guys are awesome!

applewide

  • New to the forum
  • *
  • Posts: 19
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #82 on: March 18, 2014, 08:56:27 AM »
hi

much appreciate on 1.2.3 alex

i wish you can have modules like sound on the *.raw format

mlv is difficult to process

I am using raw2dng to process, it is very easy to use, i am using komputerbay 1066x, it is fast enough

i tried to use mlv, it has error saying state 4 something

pc_bel

  • Member
  • ***
  • Posts: 132
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #83 on: March 18, 2014, 09:37:44 AM »
Quote
It is simply impossible to extract the dng files from it. I have tried with RAWMagic and raw2dng but both give me error

May be you fill the card with the second shot (the one corrupted)?

pind

  • New to the forum
  • *
  • Posts: 25
  • Canon 5D3 + ML
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #84 on: March 18, 2014, 10:10:29 AM »
Good job ML!!!!! Yupieeeeeeeeeeee
My first RAW with ML  --->  5D3 + ML Canon 28-70mm f2.8 17-35mm f2.8

fcerruti

  • New to the forum
  • *
  • Posts: 3
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #85 on: March 18, 2014, 01:59:50 PM »
Also announced on timelapse.pt facebook page

www.facebook.com/timelapsept

Good job!
Francesco Cerruti - www.timelapse.pt

Canon 5D Mark III - Canon 60D - Canon 16-35mm 2.8 - Zeiss 50mm 1.4 - Hanhel Gica T Pro II - Sponsored by LRTimelapse

alMalsamo

  • New to the forum
  • *
  • Posts: 18
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #86 on: March 18, 2014, 02:11:04 PM »
1)64GB cards are now working for first-time install!!!

(I only had to rename the FIR to 8.3 characters, not less)

Ah, I see why you think it has already answered.  I did notice that my exFAT cards were not working with the March 16th nightly  before the .FIR 8.3 filename fix, so I did the initial install with a 32GB SDHC card and thereafter made my SDXC cards bootable manually.  Since the 8.3 firmware fix, I can take a brand new, unmodified exFAT-formatted SDXC card and put the fixed nightly data onto it, and the .FIR-flashing process makes the card bootable and works great.  I am happy to report that I have tested it multiple times on 4 separate SDXC cards at 128GB capacity, all exFAT.  ML for 1.2.3 runs great from these cards with the new .FIR file to set it up, and it was also running when I made the cards bootable manually via make_bootable.sh/EOSCard.exe after initial installation on-camera with a 32GB SDHC card. 

My problem however is with my Komputerbay 1050x CF card.  I cannot get ML to load from this card.  If I try to make it bootable on my computer *OR* if I try to make it bootable using the .FIR update method (yes, even with the 8.3 filename fix), it creates a completely unusable card.  Whereas it starts as a perfectly mountable/usable exFAT filesystem, after trying to make it bootable via either method, the camera cannot recgonise it and asks to format it.  The laptop fails to mount the partition on the CF card when in the card reader, complaining:

Code: [Select]
ERROR: invalid VBR checksum 0x258ed093 (expected 0x30c2a1c9).
Furthermore, fdisk reports the filesystem to be type "W95 FAT32 (LBA)" after making it bootable.  Before, fdisk correctly read the partition table and detected the filesystem as type exFAT.  I have more SDXC cards around that I can always boot ML from, so I do not strictly need ML bootability from the CF card, but I want to know if there is something wrong with my CF card itself or the ML install process.



2) I bet you have enabled FPS override.

Oops!  You are correct.  Sorry about that.  I changed to 1080p/24fps in the Canon firmware menu and disabled FPS override.  Obviously audio recording is working again!  I just wanted to do my RAW testing with 25 fps + audio, but I guess that's not possible atm...  ???

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12290
  • Emergencies only
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #87 on: March 18, 2014, 03:01:09 PM »
My problem however is with my Komputerbay 1050x CF card.

Anyone else tried this card?

If all Komputerbay 1050x 128GB cards have this problem, I'll probably have to get one and see what exactly is going on. If it's only your card... it may be a bad card.

Since other 128GB cards are working fine... I'm not sure where to look.

chris_overseas

  • Moderators
  • Member
  • *****
  • Posts: 222
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #88 on: March 18, 2014, 03:12:02 PM »
My problem however is with my Komputerbay 1050x CF card.  I cannot get ML to load from this card.  If I try to make it bootable on my computer *OR* if I try to make it bootable using the .FIR update method (yes, even with the 8.3 filename fix), it creates a completely unusable card.

I have a 128GB KomputerBay 1050x CF card formatted as FAT32 and I just tested it, ML boots from it just fine. I haven't tried it as exFAT yet but I presume that will work too. I think I know what your problem is though... how old is your card? The early 1050x cards had a problem that prevented them from booting. Here's the relevant post from KomputerBay support explaining the situation: http://www.magiclantern.fm/forum/index.php?topic=8857.msg83814#msg83814  I emailed KomputerBay in mid-November (a month after that post) and they said that even then Amazon still had some of the old (ie non-booting) cards in stock. As a result I bought mine direct from KomputerBay instead to be sure I was getting a bootable one.

As an aside: why do you want ML on your CF card anyway? I prefer to have it on an SD card that's dedicated to ML. That way I can change & format CF cards at will without worrying about my ML current settings getting lost or whatever. Mind you now that a1ex has added support for retaining ML across a format it isn't quite such a big issue as it once was.
5D Mark IV 1.1.2 | 5D Mark III v1.2.3 | Canon 16-35mm f4.0L | Tamron SP 24-70mm f/2.8 Di VC USD G2 | Canon 70-200mm f2.8L IS II | Canon 100-400mm f4.5-5.6L II | Canon 800mm f5.6L | Canon 100mm f2.8L macro | Sigma 14mm f/1.8 DG HSM Art | Yongnuo YN600EX-RT II

nahlanee

  • New to the forum
  • *
  • Posts: 7
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #89 on: March 18, 2014, 03:32:41 PM »
Anyone else tried this card?

If all Komputerbay 1050x 128GB cards have this problem, I'll probably have to get one and see what exactly is going on. If it's only your card... it may be a bad card.

Since other 128GB cards are working fine... I'm not sure where to look.


I had this card and had to send it back. i couldn't get FULL HD RAW or further, it had a write speed of about 70 MB/s. is there any card that always works? maybe komputerbay 64GB 1000x??

jimmyji32

  • Just arrived
  • *
  • Posts: 1
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #90 on: March 18, 2014, 04:47:39 PM »
Does this somehow allow me to record RAW footage via the HDMI to an external recorder or is that just wishful thinking?

applewide

  • New to the forum
  • *
  • Posts: 19
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #91 on: March 18, 2014, 04:48:49 PM »
i am using komputerbay 128gb 1066x, when i got it in the first time, it was dead, i had to return it, then i rebought it, it is fine until now. very fast card

Stu in Blackpool

  • New to the forum
  • *
  • Posts: 3
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #92 on: March 18, 2014, 04:56:37 PM »
Just wanted to drop by and say thank you.
I Have been watching and awaiting a 1.2.3 release for some time so I could try ML on my 5DM3.

Its here... its installed, and it worked first time. Excited to get out and play with it.

marekk

  • Senior
  • ****
  • Posts: 331
  • www.oddajmisie.com
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #93 on: March 18, 2014, 05:35:58 PM »
I prepared a short video from photo workshops with mlv_rec on 1.2.3 ... no problems and no bad frames at all :)

My video:
http://www.magiclantern.fm/forum/index.php?topic=11031.0

gandhre1011

  • New to the forum
  • *
  • Posts: 6
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #94 on: March 18, 2014, 06:42:23 PM »
Can anyone tell me which file I need to install for 5d mrk iii 1.2.3. From magic lantern??? Thanx buddies....

EXIV

  • New to the forum
  • *
  • Posts: 29
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #95 on: March 18, 2014, 06:48:49 PM »
May be you fill the card with the second shot (the one corrupted)?

Impossible... there was still plenty of space as the card I used was a 32GB Lexar 1000x and both the two clip I shot were about 4.5GB each...

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6862
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #96 on: March 18, 2014, 06:51:19 PM »
Can anyone tell me which file I need to install for 5d mrk iii 1.2.3. From magic lantern??? Thanx buddies....

Top of page -> Downloads -> Browse Nightly Builds -> Choose your flavour ...
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

gandhre1011

  • New to the forum
  • *
  • Posts: 6
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #97 on: March 18, 2014, 06:53:40 PM »
Top of page -> Downloads -> Browse Nightly Builds -> Choose your flavour ...
thnx a lot brother.....

EXIV

  • New to the forum
  • *
  • Posts: 29
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #98 on: March 18, 2014, 06:57:21 PM »
Here is my third test on this new ML version. This time I have decided to make a straightforward comparison between the H264 video coming from the camera and the Magic Lantern RAW. I have edited the footage without grading it, so to make it easier to compare the quality between the H264 and RAW.


tjaja

  • Freshman
  • **
  • Posts: 83
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #99 on: March 18, 2014, 07:10:07 PM »
Wow, h264 holds up really well Exiv. This isn't the drastic difference as I see in other video's.
5DFree, 550D, canon 50mm 1.4