Canon EOS M

Started by jordancolburn, December 30, 2013, 10:21:20 PM

Previous topic - Next topic

0 Members and 3 Guests are viewing this topic.


I'm a new user of ML and have played with it for a few days (usually my best way of learning) and searched the forum and User Guide, but still have a question I hope you can help with.

When trying to use the Magic Zoom (which works) I can't find any way of changing the focus point that it zooms in to. If I use the Canon menu's I can change it by touching the screen and then hitting the zoom icon, but whatever I have selected in the Canon menu gets stuck as the focus point when I go into the ML menus and use Magic Zoom.  I am using old Manual Focus lenses via a non electronic adapter so the camera doesn't think I have a lens attached (if that makes a difference) but again the Canon menus allow me to change the focus point by touching the screen, while the ML menus don't.  I hope I have explained myself clearly.

Am I doing something wrong, or is this not supported?

Thanks, Neil.


DeafEyeJedi asked: Any chance you could show us a footage to see what that particular 3x crop looks like?

Try this:

Note that this is a very early and quick test, focus isn't the best possible, and the shadow at lower left disappeared with a rotation of the lens mount. This lens is old, intended for standard definition ENG cameras, resolution 720x576, so no wonder it's not perfectly sharp.

I have a much better lens, a Canon f 1.8, 12.5 - 75 mm TV zoom, but it's only 5x. No YT demo at the moment, sorry...


Btw, does anyone know the method to start the camera without ML loading? I understand on other camera, it's holding down the set button while powering up, but it doesn't seem to work with EOS-M ML?

Wondering if not loading the ML would help with the shutter bug. It's still happening with my 18-55mm. No shutter bug on the 22mm.


Just change to a card without ML - that's what I do...

Try the low-level format option, the bug disappeared for me using that trick.


Anybody tried out the Tamron 18-200mm EF-M lens with Magic Lantern yet? I was wondering if you get the shutter bug with that lens.

So far it only seems to affect the Canon EF-M IS lenses--meaning all but the 22mm prime. Apparently EF lenses mounted via the adapter won't trigger the shutter bug.


I checked with some owners of the new Tamron 18-200mm EF-M lens. It IS affected by the shutter-bug.



Have they removed the RAW video from the Nightly build for EOS-M? It's not showing up. I heard it was working... but where, how?


It's a module. You have to enable it in Module tab, restart the cam and configure RAW record options in Movie tab.


I got it, but it stops after a couple of seconds. Is there a limit on how long it goes?




Clips all stop at 2.5 seconds, 114,465kb. Is there a way to overcome this? Otherwise it's useless to me.


Which modules are loaded?
Global draw on or off?
Which resolution and frame rate?
How fast is your card? Debug tab -> Benchmarks -> Card R/W benchmark (5 min). Use photo mode, global draw off.


Hi Walter,

The pink dots in RAW were a deal killer.

My other major problem, with EOS-m, is that I can't get any overlay info while shooting. Nothing appears at all when recording, so I can't judge exposure. Is there some trick or module to enable?

Walter Schulz

Maybe you're a bit jumpy?
Are you recording MLV or RAW? If MLV: You may want to set this option in Movie tab -> RAW video (MLV) -> Global Draw


"Maybe you're a bit jumpy?"

No. I'm a filmmaker, not a beta tester.

I turned off raw. It's in movie mode, bit rate 2.5x. The 3.0x wasn't stable at recording. The slower speed seems okay, but no overlays work. Global draw is on for all modes, but as I said, it doesn't appear.

Walter Schulz

Quote from: joeg on February 04, 2015, 10:02:17 PM
I'm a filmmaker, not a beta tester.

Yes, Director McCoy.
You pressed INFO several times to toggle until ML's overlays show up?


Actually I cleared all settings in Canon's menu to try and default it and try again, but now I have a brand new issue.

The screen that allows firmware upgrades has disappeared. I'm trying to just reinstall Canon's 2.02 firmware, but the menu choice is in the ether. Any idea why it disappeared?


Odd happenings, very flaky results. The firmware finally reappeared, but my shutter no longer works in picture mode. The camera won't take pictures, even with a different card without ML. I reinstalled 2.02 firmware, cleared settings (again), but the shutter no worky. Is this a known bug?

Update 2:

Changing to the Canon 18-55 lens got the shutter to work again. The other button in the top right still doesn't though. I'll try changing lenses again.


My "shutter bug" is a bit odd. Shutter works on Canon 18-55, but I can't take stills now with Nikon lenses. Nothing happens.

There is also this:

"Firmware default completely disables bitrate control."

I find myself stuck with "FW default," and have lost the one reason I had for installing ML in the first place. There doesn't seem to be any entry about getting the bitrate control BACK again.


I bemoan the apparent dying of the magic lantern project, but I completely understand it.  I check these forums to see if anything new has happened, but all I ever see are the same questions and ignorant requests.  I don't personally have the talent or knowledge to code and I certainly don't have the patience to deal with questions from people who can't first take the time to understand their tools.  I feel bad that I've never contributed more than money to the project, but I am very grateful for what has been given me and it's ability to help me be a "filmmaker".

Now that I've said that, if you want to use manual lenses you need to set the camera in the menu to release the shutter without a lens attached.  This is not an ML issue.


I'm using Nightly.2015Jan29 but ML menu disappears after a few seconds.

I've found similar situation reported here.

Is there any way to extend the time menu appears?


Quote from: farb on February 09, 2015, 05:52:04 PM
Is there any way to extend the time menu appears?
It seems to reset the timeout if you press a key. Sometimes I hold the <DOWN> key down to keep the menu on screen while I'm figuring out which menu option to choose.

I've had the opposite problem of trying to get rid of the menu more rapidly. Tapping the screen with two fingers does that, I discovered.

Quote from: DeafEyeJedi on February 08, 2015, 09:49:34 PM
The good old EOS-M has been somewhat a deal killer with RAW/MLV (pink dots removal is a PITA)
I use Rawflow.exe to save DNG files for each frame, and exit the program when it starts to save TIFF files (delete any that are saved).

Then, import the DNG files into Photoshop Lightroom and export them as TIF files with no pink dots.
But yes I agree with the fact that the M3 would definitely be a game-changer with ML for the current EOS-M owners!
The M3 has a Digic 6 processor, which has been really hard to port with CHDK. It may take awhile for a Magic Lantern port too.


Quote from: lapser on February 09, 2015, 07:00:27 PM
I've had the opposite problem of trying to get rid of the menu more rapidly. Tapping the screen with two fingers does that, I discovered.

Pressing the shutter halfway should also do the trick.


But I'm on a mac @ lapser -- RawTheraPee is somewhat an OK app. Just don't understand or where to start batch process within this app.

Unless there's a Mac version of  RawFlow? If not then perhaps I'll have to run it within VM ware?
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109