Author Topic: Canon EOS M  (Read 1264732 times)

gary2013

  • Hero Member
  • *****
  • Posts: 660
Re: EOSM-Updated ML for 2.02 firmware
« Reply #100 on: March 16, 2014, 04:45:36 PM »
This was without any module enabled?

(it's important for narrowing down)
yes, no modules were loaded. The camera has been sitting for a few minutes and now it powers up with no modules loaded. I tried three times in a row and all three times it powers up with no modules.

EDIT, after I typed the last message here, I tried again and it's back to not working with the steady red led again. Waited a bit, tried again, it worked. Powered off, waited a bit and the red led hang came back.

cpreston

  • New to the forum
  • *
  • Posts: 23
Re: EOSM-Updated ML for 2.02 firmware
« Reply #101 on: March 16, 2014, 04:50:41 PM »
I have been having the same problem with the EOS-M ML builds.  I've used multiple builds and they all have the same problem.  Try to turn it on and I get a blinking LED or solid LED and the screen never turns on and the power button will not turn it off.  If I pull the battery and try to cycle it a few more times, at some point it will finally power up completely.  I am using a 64GB card with nothing else on it.  I do not load more than the very basic modules.

gary2013

  • Hero Member
  • *****
  • Posts: 660
Re: EOSM-Updated ML for 2.02 firmware
« Reply #102 on: March 16, 2014, 05:01:52 PM »
I just tried going back to ML Mar 11th and everything worked a few times in a row of off and rebooting. I was able to shoot an MLV raw file, but it has no MLV playback.
The splash screen is annoying. It appears we have to wait ten seconds or more for it to shut off. I tried swiping and nothing got it to shut off. isn't there some sort of swipe or button push to shut the splash screen off?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: EOSM-Updated ML for 2.02 firmware
« Reply #103 on: March 16, 2014, 05:10:45 PM »
Normally, the first key press / scrollwheel / whatever should disable the screen right away (at least this is how it works on all other cameras).

For anyone who can reproduce the issue and has basic command-line skills: can you run hg bisect to find the buggy changeset?

gary2013

  • Hero Member
  • *****
  • Posts: 660
Re: EOSM-Updated ML for 2.02 firmware
« Reply #104 on: March 17, 2014, 07:50:13 AM »
Normally, the first key press / scrollwheel / whatever should disable the screen right away (at least this is how it works on all other cameras).

For anyone who can reproduce the issue and has basic command-line skills: can you run hg bisect to find the buggy changeset?
The new magiclantern-Nightly.2014Mar17.EOSM202 works now on the M. The splash also goes away with a single push on the set button. I don't understand the shutter display in the ML display. It says 0.-1, -1818  ?? What happened to the usual 1/48 and 1/64 and so on like the Canon menus show and the TL versions? How do we get the shutter to go to the usual settings for video? I had to go into the Canon menus to set it to 1/50 and 1/60 as needed.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: EOSM-Updated ML for 2.02 firmware
« Reply #105 on: March 17, 2014, 07:58:13 AM »
I've already explained what needs to be done for fixing shutter speeds: http://www.magiclantern.fm/forum/index.php?topic=9741.msg101808#msg101808

also on 700D: http://www.magiclantern.fm/forum/index.php?topic=5951.msg103451#msg103451

but can't do much more without an EOS-M (porting advice is OK).

gary2013

  • Hero Member
  • *****
  • Posts: 660
Re: EOSM-Updated ML for 2.02 firmware
« Reply #106 on: March 17, 2014, 08:40:19 AM »
Well... one has to double-check FRAME_SHUTTER_TIMER and get_current_shutter_reciprocal_x1000.

There is a big quirk here from Canon (all other cameras are well-behaved): EOS-M does not configure LiveView with the real shutter speed while not recording (so the readings will be only relevant while recording). Same for FPS.

So, for standby, one might want to rely on APEX units. Also, if one can't figure out how to fix the bug, just undefine FRAME_SHUTTER_TIMER (don't leave the wrong value) and the code will fallback to APEX (which is portable, but not very exact - Canon does some unusual rounding and ML doesn't copy it - and the APEX method doesn't account for FPS override, for example, but it's easy to fix).

In photo mode, you can set exposure time of 100 seconds?! are you sure about that?
sorry, I just do not understand it. I never had to do math to set the shutter speed for video. I tried making the shutter adjustments and nothing seemed to be changing except the picture display was getting darker. When I checked in the Canon display, it was up over 200 yet the ML display kept showing 0". Is this method something more that still photographers need? Can this be something that could be a user pref setting so we all can choose what method we need? Can anyone tell me why TL is showing the 1/48 and 1/64 and Canon shows settings like 1/50, 1/60 and so on? Is there something wrong with the TL and Canon way of displaying shutter speed that will ruin our video footage? We need to set the shutter in video to be double the frame rate most of the time.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: EOSM-Updated ML for 2.02 firmware
« Reply #107 on: March 17, 2014, 09:05:01 AM »
Here we are programming the cameras, not just using them. Try coding ML without math.

Quote
Can anyone tell me why TL is showing the 1/48 and 1/64 and Canon shows more settings like 1/50, 1/60 and so on?
Sounds like they use the APEX method.

Quote
I also do not understand why it is 1/64 when we need it to be 1/60 for 30 FPS video
You already quoted the answer. We are talking about ML *displayed* values (that is, just printing what Canon gives us).

Why do we need exact values?
1) There is a obscure feature called shutter fine-tuning, which adjusts shutter in 1/50000s increments (or close), which is very useful when filming computer displays (to get rid of flicker).
2) To make sure the shutter speed matches the mains freqency (Canon may print 1/30, but, to avoid flicker, in PAL land you need it to be a multiple of 1/100, that is, 1/50 or 1/33.333). Canon actually does this rounding for you, and ML is supposed to print it properly (but somebody needs to sit down and fix it somehow on the M).
3) When using FPS override, the image gets brighter; you may want to know how much (well, maybe you don't, but I do).
4) ETTR in LiveView. How's this one supposed to work if it doesn't know where it's starting from?

Also... are you suggesting adding a user preference (added complexity) instead of fixing the bug?!

Audionut

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3654
  • Blunt and to the point
Re: EOSM-Updated ML for 2.02 firmware
« Reply #108 on: March 17, 2014, 09:08:28 AM »
I prefer the correct values being printed in ML.  If I want to know what the Canon rounded values are, I look at the Canon feedback.

gary2013

  • Hero Member
  • *****
  • Posts: 660
Re: EOSM-Updated ML for 2.02 firmware
« Reply #109 on: March 17, 2014, 09:34:10 AM »
Canon actually does this rounding for you, and ML is supposed to print it properly (but somebody needs to sit down and fix it somehow on the M).
I understand, thank you for explaining it for me. I wish I could help more on the dev end as you say someone still needs to fix it for the M. 

gary2013

  • Hero Member
  • *****
  • Posts: 660
Re: EOSM-Updated ML for 2.02 firmware
« Reply #110 on: March 17, 2014, 09:40:48 AM »
I prefer the correct values being printed in ML.  If I want to know what the Canon rounded values are, I look at the Canon feedback.
That is what I have been doing, using the Canon menu for shutter setting.

kamaldinov

  • New to the forum
  • *
  • Posts: 3
Re: EOSM-Updated ML for 2.02 firmware
« Reply #111 on: March 18, 2014, 10:09:34 AM »

Fps override + raw. Also can do silent pics.

I want use full camera resolution
And what is silent mode?

DJBellis

  • Just arrived
  • *
  • Posts: 1
Re: EOSM-Updated ML for 2.02 firmware
« Reply #112 on: March 22, 2014, 08:06:14 PM »
Sorry this is a totally noob question, but where do I find the download that actually has the .fir file for the EOS M? I have the nightly build, but the 2.3 release doesn't have it. . . Thanks ahead for help.

gary2013

  • Hero Member
  • *****
  • Posts: 660
Re: EOSM-Updated ML for 2.02 firmware
« Reply #113 on: March 22, 2014, 11:57:27 PM »
Sorry this is a totally noob question, but where do I find the download that actually has the .fir file for the EOS M? I have the nightly build, but the 2.3 release doesn't have it. . . Thanks ahead for help.
http://tl.bot-fly.com/.

huangyanlai

  • New to the forum
  • *
  • Posts: 2
Re: EOSM-Updated ML for 2.02 firmware
« Reply #114 on: March 28, 2014, 06:22:38 AM »
I think ETTR hints on the menu are correct, but the actual feature isn't correct.  I have not tried dual ISO on any camera, so I can't speak to that, but again, my focus is weird menu things, audio/video features before working on dual ISO, raw, etc.

Pink dots are just what this camera does from hardware, the pink dot remover will take care of that.  Raw playback was working (slowly) on TL, so when I get to working on that, it shouldn't be too bad to pull over.

I tested on the nightly build (2014mar27) to try the dual ISO feature. I saw an error message: "ISOLess PH Err (15)". Does "dual ISO" work for EOS-M or not yet available?

cottonlint

  • Just arrived
  • *
  • Posts: 1
Re: EOSM-Updated ML for 2.02 firmware
« Reply #115 on: April 01, 2014, 02:13:06 PM »
Hi EOS M people,

I reported a bug to ML.  I had an issue where the shutter would not work, even the touch shutter.  My camera locks up and I had to remove my battery to restart.  The shutter bug appears when Canon EF-M 18-55mm lens is attached to my EOS M.  Magically, the shutter bug disappears when Canon EF-M 22mm lens is attached to it.

It took me a long time to figure it out since sometime ML worked great, and other times ML would just lock up my Canon EOS M.  For some reason, I decided to switch my lens.  I detached EF-M 18-55mm and put on EF-M 22mm and ML worked as I remembered.  Then I realized that there is something going on with EF-M 18-55mm which ML doesn't like.  With EF-M 22mm attached, I was even able to take continuous shots using ML's intervalometer and the shutter button and touch shutter worked too.

I'm glad that ML isn't completely broken for Canon EOS M.

I hope that this could help resolve someone's pain with their ML issues with EOS M.

veepee78

  • Just arrived
  • *
  • Posts: 1
Re: EOSM-Updated ML for 2.02 firmware
« Reply #116 on: April 02, 2014, 11:51:32 AM »
Hi

Tried to install ML (20140402), but first observation was missing fir file. So I got one from TL package. When trying to run firmware update, it says ML/DATA/FONTS.DAT missing and won't continue. Am I missing something?

edit: borrowed also fonts.dat from tl, and then got it installed.
EOS M

KSphoto

  • New to the forum
  • *
  • Posts: 24
Re: EOSM-Updated ML for 2.02 firmware
« Reply #117 on: April 04, 2014, 04:17:07 AM »
I see audio meters are showing while recording video. This is new, right?

I noticed that the software would not run if I copied it over with the card in my Laptop. I had to use a card reader. I don't understand why that happens but I think other people are having the same problem with the cam not booting up. Please use a separate card reader.
I'm using the TL firmware because I couldn't find it on this site. Others may be having this issue too.
Hope this helps someone.
5DC, 5D2, 5D3, EOS M, too many lenses.

Canon eos m

  • Hero Member
  • *****
  • Posts: 562
  • 5D Mark III, Canon EOS M
Re: EOSM-Updated ML for 2.02 firmware
« Reply #118 on: April 04, 2014, 08:00:16 AM »
I tested on the nightly build (2014mar27) to try the dual ISO feature. I saw an error message: "ISOLess PH Err (15)". Does "dual ISO" work for EOS-M or not yet available?

+1
Canon 5D Mark III, Gopro Hero Blacks with 3D Casing, A Few Lenses, Adobe CC 2014, MacBook Pro, Windows 8 PC, Lots of Video Rig!

Started Nuke. Loved it but then the 15 day trial ran out. Back to After Effects and loving it :-)

nanomad

  • Administrator
  • Hero Member
  • *****
  • Posts: 2918
  • All your websites are belong to us
Re: EOSM-Updated ML for 2.02 firmware
« Reply #119 on: April 04, 2014, 08:07:36 AM »
The current dual iso implementation assumes a constant address in memory for the iso registers, which isn't true for all digic v cameras.
I'll post a build later today with a different address location that may help.
EOS 1100D | EOS 650 (No, I didn't forget the D) | Ye Olde Canon EF Lenses ('87): 50 f/1.8 - 28 f/2.8 - 70-210 f/4 | EF-S 18-55 f/3.5-5.6 | Metz 36 AF-5

Canon eos m

  • Hero Member
  • *****
  • Posts: 562
  • 5D Mark III, Canon EOS M
Re: EOSM-Updated ML for 2.02 firmware
« Reply #120 on: April 04, 2014, 11:41:38 AM »
I tested on the nightly build (2014mar27) to try the dual ISO feature. I saw an error message: "ISOLess PH Err (15)". Does "dual ISO" work for EOS-M or not yet available?

I have noticed that the touch screen is less responsive now with the newer versions of the builds. For example the scroll wheel does not respond as it used to. Plus, where do I get the mlv modules from- especially the player.
Canon 5D Mark III, Gopro Hero Blacks with 3D Casing, A Few Lenses, Adobe CC 2014, MacBook Pro, Windows 8 PC, Lots of Video Rig!

Started Nuke. Loved it but then the 15 day trial ran out. Back to After Effects and loving it :-)

nanomad

  • Administrator
  • Hero Member
  • *****
  • Posts: 2918
  • All your websites are belong to us
Re: EOSM-Updated ML for 2.02 firmware
« Reply #121 on: April 04, 2014, 11:48:19 AM »
There have been no changes to the touch screen code
EOS 1100D | EOS 650 (No, I didn't forget the D) | Ye Olde Canon EF Lenses ('87): 50 f/1.8 - 28 f/2.8 - 70-210 f/4 | EF-S 18-55 f/3.5-5.6 | Metz 36 AF-5

KSphoto

  • New to the forum
  • *
  • Posts: 24
Re: EOSM-Updated ML for 2.02 firmware
« Reply #122 on: April 07, 2014, 03:17:28 AM »
I was shooting intervelometer today and when it was set on pic every 0s (pics like crazy) it would not stop or come out of the cycle no matter what was pressed. Had to pull battery.
5DC, 5D2, 5D3, EOS M, too many lenses.

odik

  • Just arrived
  • *
  • Posts: 1
Re: EOSM-Updated ML for 2.02 firmware
« Reply #123 on: April 07, 2014, 06:24:47 AM »
Mirrorless + http://goo.gl/xpHHt5 + Magic Lantern = winner!
great update guys....

indiejack

  • New to the forum
  • *
  • Posts: 3
Re: EOSM-Updated ML for 2.02 firmware
« Reply #124 on: April 08, 2014, 07:36:50 AM »
Hello all, I'm not new to ML but haven't installed it on anything since the 650d release. Now i'd like to throw it on my EosM but I had a question on the install differences, the 2014Mar13 of TL has the EOSM_202.fir while the recent ML versions do not.

I guess my question is that am I supposed to prep my card using Macboot and just throw it in or is there a logical way to update the firmware on the camera like previous versions? I read through the thread and most of the info was related to RAW video so I'm sorry if this has been covered and I somehow overlooked.

Other than that I'm happy to help out with any testing of nightly features or whatnot, just let me know how I can be of assistance!
Cameras: 650d, Eos-M
Lenses: EF-S 18-55 (kit), 40mm 2.8 STM, EF 85mm 1.8, 22mm 2.0 STM, Adaptor to use EF/EF-S on the Eos-M