Author Topic: Canon EOS M  (Read 990885 times)

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6574
Re: Canon EOS M
« Reply #3325 on: August 30, 2019, 09:38:28 PM »
You'll get used to it ;)

2blackbar

  • Senior
  • ****
  • Posts: 385
Re: Canon EOS M
« Reply #3326 on: August 31, 2019, 12:20:15 AM »
I dont know about it, i get weird stuff happening, locking up, like half shutter magic zoom not working, then 3x crop not wantring to switch off, i feel like this new functionality will scare some people off, it scares me off and i just prefere to downgrade.
I dont know how others feel, i was in more control in previous builds and now im forced to use these new auto modes, i would prefere to have them somewhere as an option and not having to use them as default.2 fingers press doesnt work and i accidentally go to ML menu switching random things by accident like crazy, its convoluted too much , not really simplified for me, i know it was made to make the life simple but i wish it would not be forced but available somewhere if we want to use it occasionally.
 

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6574
Re: Canon EOS M
« Reply #3327 on: August 31, 2019, 12:40:33 AM »
Just turn off what you don't want under customize buttons. Not that hard is it?
Also would help if you gave more datails of freezes etc. Vague descriptions based on feelings won't do.

2blackbar

  • Senior
  • ****
  • Posts: 385
Re: Canon EOS M
« Reply #3328 on: August 31, 2019, 01:40:52 AM »
Ok, gave it a go again with newest build, just disabled that first menu so i have 2 fingers tap again, and everything works well.I can go into magic zoom and its not locking up.
I dont know why it was locking up on me so much previously.
So far its looking good and i see some menu items are moved to different locations, maybe its better this way, one location for changing bit modes  instead of two like before.This way is more polished.
Also kept that dropdown list but under info button, in case i need it cause its handy.Strange how little change can make you perceive something differently.
---
I really dig that new relocation of stuff and dropdown list under info button, finally i dont have to enable all modules and go through menus, i wish it would enable fps override with exact fps when i choose mcm rewire but not a big deal, just my personal preference cause footage looks more snappy with it and less rolling shutter is present.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6574
Re: Canon EOS M
« Reply #3329 on: August 31, 2019, 01:58:18 AM »
Yes, I know what you mean. I tested an older build before and it felt like I missed that too ;).
I only recently noticed there was a two finger button push. Never knew it opened ml menu. I don´t know why it doesn´t work with one finger press relocated. But INFO button fixes it so that´s good.
The fps stuff might be possible to do something about but the few tests I did before was pretty problematic. Good part with this latest build is shutter speeds are now coherent through all of the presets.

2blackbar

  • Senior
  • ****
  • Posts: 385
Re: Canon EOS M
« Reply #3330 on: August 31, 2019, 02:16:52 AM »
Ah about shutter, i see that this old issue with screen flashing in fps override if you go to shutter above 200 is still there, simple to reproduce i guess, just im mcm rewire enable fps override 23.976 go to shutter above 200, its 258 here and screen starts flashing.Not sure if a lof of pople film with such high shutter speeds.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6574
Re: Canon EOS M
« Reply #3331 on: August 31, 2019, 02:37:48 AM »
I don't use fps override so don't have the issue. I'm surprised it works even since there are so many places in crop rec where timers are changed.

henricusmaria

  • Freshman
  • **
  • Posts: 70
Re: Canon EOS M
« Reply #3332 on: August 31, 2019, 02:57:04 PM »
Autofocus is not working as smooth as in former builds (in mcmrewire). Would be great if that returned to normal.
The Iso/Aperture adjustment is a great addition!

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6574
Re: Canon EOS M
« Reply #3333 on: August 31, 2019, 03:35:53 PM »
Tell me exact preset used in older build and what settings used etc. If you have the build working better check date and name.

henricusmaria

  • Freshman
  • **
  • Posts: 70
Re: Canon EOS M
« Reply #3334 on: September 01, 2019, 04:06:18 AM »
The last build I have used where AF worked normal was the aug06 non jip-hop one. Basically AF worked in all builds up to this last one. AF in the aug06 JH build also worked fine when I deactivated the switch menu.
Settings I use is mv1080p mcmrewire (with x3 crop mode) 16:9 14 bit lossless.

Normally when using AF in mcmrewire you get a big focus box square. In the last build when focussing it switches to a different screen with a small focus box square. With the occasional error like this:


Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6574
Re: Canon EOS M
« Reply #3335 on: September 01, 2019, 08:07:48 AM »
Well it works over here when deactivating focus aid which been the case ever since this function was introduced.

EDIT: Unrelated. Uploaded a version which won´t reset customize buttons when switching presets form startoff preset list. Means if you chnage one of the customized buttons the stay changed until reseting them again or running the default reset preset from the list.

henricusmaria

  • Freshman
  • **
  • Posts: 70
Re: Canon EOS M
« Reply #3336 on: September 01, 2019, 11:25:45 AM »
I always deactivate the focus aid when I use my AF lenses. But in the aug31 build I can deactivate all I want but it automatically gets switched back to default mode when I exit the ml menu.

The new build fixes the problem. Thanks!

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3391
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: Canon EOS M
« Reply #3337 on: September 01, 2019, 06:32:49 PM »
Thanks @Danne for the quick fix and prompted a quick download. Because of your work ethic on this project I have bought yet another EOSM body for at a decent deal. $80 on OfferUp. Scored!

Four in total so far. In fact, I'm digging the new quick ISO adjustment feature big time! I'll try my best to get back into this forum while I'm at it. Signed on after seeing your recent PM re: MLV App. ;)
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6574
Re: Canon EOS M
« Reply #3338 on: September 01, 2019, 06:33:40 PM »
Welcome back deafeye!

uEOSM

  • New to the forum
  • *
  • Posts: 5
Re: Canon EOS M
« Reply #3339 on: September 01, 2019, 07:55:04 PM »
Hi guys. Share if anyone has firmware crop_rec_4k_mlv_snd_isogain_1x3_presets_2019Jun10.EOSM202
Can be earlier or later

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3391
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: Canon EOS M
« Reply #3340 on: September 02, 2019, 12:07:41 AM »
Any particular reason(s) specifically why you're asking for this build @uEOSM?
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

Veerle

  • Member
  • ***
  • Posts: 107
Re: Canon EOS M
« Reply #3341 on: September 02, 2019, 11:45:15 AM »
.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6574
Re: Canon EOS M
« Reply #3342 on: September 02, 2019, 12:03:51 PM »
Disable focus aid if using autofocus. The other issues are probably related to this too. If you follow other posts you see that recently this was discussed as well.
Shutters should work the same for all presets now. Not sure what build you are using but be sure to use the latest.

Unable to take photo could be the famous shutter bug issue. It´s unrelated to the build itself. Do some searching on that if you want to know more here.
Thanks for feedback.

yokashin

  • Freshman
  • **
  • Posts: 81
Re: Canon EOS M
« Reply #3343 on: September 02, 2019, 02:53:33 PM »
Hi guys. Share if anyone has firmware crop_rec_4k_mlv_snd_isogain_1x3_presets_2019Jun10.EOSM202
Can be earlier or later

I have copy from 7 and 11 Jul.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7294
Re: Canon EOS M
« Reply #3344 on: September 02, 2019, 03:09:49 PM »
Any particular reason(s) specifically why you're asking for this build @uEOSM?

He is asking for any build ("Can be earlier or later"). Maybe he is not aware of Danne's Bitbucket download folder location?
https://bitbucket.org/Dannephoto/magic-lantern/downloads
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

ygadinthesix

  • New to the forum
  • *
  • Posts: 5
Re: Canon EOS M
« Reply #3345 on: September 02, 2019, 03:28:17 PM »
Hello Everyone!

Is there a build that is optimized for photography for the EOS M? I’ve recently been using it more and more for photos (and very happy with the results.)

In particular, is there something that provides crop modes for photos?

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7294
Re: Canon EOS M
« Reply #3346 on: September 02, 2019, 03:31:59 PM »
In particular, is there something that provides crop modes for photos?

Why?
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

uEOSM

  • New to the forum
  • *
  • Posts: 5
Re: Canon EOS M
« Reply #3347 on: September 02, 2019, 05:42:44 PM »
Thank you all for your answers.
I have copy from 7 and 11 Jul.
Sent PM

Any particular reason(s) specifically why you're asking for this build @uEOSM?
Yes, in the last builds I have a lot of pink frames, in that build there wasn’t one. But unfortunately I did not save the old version and updated to the new one.

He is asking for any build ("Can be earlier or later"). Maybe he is not aware of Danne's Bitbucket download folder location?
https://bitbucket.org/Dannephoto/magic-lantern/downloads
Thanks for the link, I searched there, but unfortunately old versions are already deleted there.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6574
Re: Canon EOS M
« Reply #3348 on: September 02, 2019, 06:41:49 PM »
Please tell me what version is causing you corrupted frames. Also what preset are you using getting corrupted frames.

rinski

  • New to the forum
  • *
  • Posts: 33
Re: Canon EOS M
« Reply #3349 on: September 02, 2019, 06:59:56 PM »
Hello, I would like to know if you really record at 24 fps or at 13 in 4k anamorphic 10 bits 2.35 with a sd extreme pro sandisk 95 mbs and if in the latest versions is no longer present the SD UHS overclock hack module, with 13 fps has not generated any pink box in a test I have done.
Thank you.