Author Topic: MLV PLAY (mlv_play.mo)  (Read 86376 times)

g3gg0

  • Developer
  • Hero Member
  • *****
  • Posts: 3154
Re: MLV PLAY (mlv_play.mo)
« Reply #25 on: November 12, 2013, 10:03:06 AM »
Thanks for feedback!
Help us with datasheets - Help us with register dumps
magic lantern: 1Magic9991E1eWbGvrsx186GovYCXFbppY, server expenses: paypal@g3gg0.de
ONLY donate for things we have done, not for things you expect!

kgv5

  • Hero Member
  • *****
  • Posts: 643
Re: MLV PLAY (mlv_play.mo)
« Reply #26 on: November 12, 2013, 10:25:42 AM »

- Card spanning doesn't seem to offer much improvement though in past versions I had tested, it had given a much better better improvement in frames that could be recorded.

- A beep when recording begins would be useful


I have the same thoughts.
Card spanning which is one of my favourites features and for now the main reason of switching from raw is not so brilliant as it was at the beginning of mlv development. Back than write speed was reaching 110-116 MB and 2,5k 2,35:1 was continous but unfortunatelly there was no tools for processing. Now we have the tools but speed decreased and it is stopping suddenly not reaching expected frames even close.
I believe that this will be polished in some time, for 5d3 file spanning is a breakthrough feature.
With current build 2,5k 2,35:1 23,976fps gives about 25-35 seconds.
Beep on start is useful, we get used to this with raw_rec and now something is missing.
Thanks
www.pilotmovies.pl   5D Mark III, 6D, 550D

MonteNero

  • Freshman
  • **
  • Posts: 63
Re: MLV PLAY (mlv_play.mo)
« Reply #27 on: November 12, 2013, 12:25:34 PM »
did you try it?
the whole effort of the ML crew (in total literally 0,5 full time devlopers) is useless if there is no testing from those who have the setup ;)
The effort of ML's 0.5 full time developer kicks canon's ass though! The playback was the first thing I tested, and it crashes the cam.  If you solve and post it in nightly builds I will be first to try the HDMI playback support!

MonteNero

  • Freshman
  • **
  • Posts: 63
Re: MLV PLAY (mlv_play.mo)
« Reply #28 on: November 14, 2013, 05:46:06 PM »
Hi, g3ggo! Any news on HDMI?

g3gg0

  • Developer
  • Hero Member
  • *****
  • Posts: 3154
Re: MLV PLAY (mlv_play.mo)
« Reply #29 on: November 14, 2013, 06:36:44 PM »
the problem is there:

https://bitbucket.org/hudson/magic-lantern/src/570c301158185f8dd29372ae7260d88bfda49c1c/src/raw.c?at=unified#cl-1527
https://bitbucket.org/hudson/magic-lantern/src/570c301158185f8dd29372ae7260d88bfda49c1c/src/raw.c?at=unified#cl-741

at least *some* problem is there, that causes incorrect memory accesses.
unfortunately these things are quite complex.  at least i dont get it :)
Help us with datasheets - Help us with register dumps
magic lantern: 1Magic9991E1eWbGvrsx186GovYCXFbppY, server expenses: paypal@g3gg0.de
ONLY donate for things we have done, not for things you expect!

g3gg0

  • Developer
  • Hero Member
  • *****
  • Posts: 3154
Re: MLV PLAY (mlv_play.mo)
« Reply #30 on: November 14, 2013, 11:03:22 PM »
fixed the HDMI issues hopefully.
can you redownload, update your autoexec.bin and retry?
Help us with datasheets - Help us with register dumps
magic lantern: 1Magic9991E1eWbGvrsx186GovYCXFbppY, server expenses: paypal@g3gg0.de
ONLY donate for things we have done, not for things you expect!

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5801
Re: MLV PLAY (mlv_play.mo)
« Reply #31 on: November 15, 2013, 12:27:18 AM »
Tried the hdmi on a small monitor. Worked very well. Havn,t used the hdmi before with raw or .mlv. Worked well with playback aswell with the file manager both .mlv and raw. filmed for a minute or so but it worked fine.
Had a frozen monitor image two times after fiddlin in menus. THis was NOT during filming. When getting out of liveview and back again the picture came alive again. Had a hard time reproducing the issue though.
My main concern now with .mlv is that I can,t get 25 fps 1080p continuous  all the time like with raw. Maybe when card is getting warm :)
GReat work g3gg0

MA Visuals

  • Freshman
  • **
  • Posts: 83
Re: MLV PLAY (mlv_play.mo)
« Reply #32 on: November 15, 2013, 12:37:25 AM »
Will test tonight on my SmallHD monitor and report back to you.

gary2013

  • Hero Member
  • *****
  • Posts: 660
Re: MLV PLAY (mlv_play.mo)
« Reply #33 on: November 15, 2013, 01:52:14 AM »
Added color playback support. If it's too slow, press SET to switch back to grayscale.

Do we need a separate thread for mlv_play.mo?
I get an error message when I try to view an MLV file thru the File Manager on my M cam using Nov 13 version. It says "Failed to get a free buffer." I have to pull battery since it freezes thre cam.

Gary

MonteNero

  • Freshman
  • **
  • Posts: 63
Re: MLV PLAY (mlv_play.mo)
« Reply #34 on: November 15, 2013, 03:34:37 AM »
I will extensively  test the HDMI this days and get back with a report. Can' wait to try  ;D

g3gg0

  • Developer
  • Hero Member
  • *****
  • Posts: 3154
Re: MLV PLAY (mlv_play.mo)
« Reply #35 on: November 15, 2013, 09:26:54 AM »
I get an error message when I try to view an MLV file thru the File Manager on my M cam using Nov 13 version. It says "Failed to get a free buffer." I have to pull battery since it freezes thre cam.

didnt try lately.
can you try the current version?
Help us with datasheets - Help us with register dumps
magic lantern: 1Magic9991E1eWbGvrsx186GovYCXFbppY, server expenses: paypal@g3gg0.de
ONLY donate for things we have done, not for things you expect!

gary2013

  • Hero Member
  • *****
  • Posts: 660
Re: MLV PLAY (mlv_play.mo)
« Reply #36 on: November 15, 2013, 11:14:57 AM »
didnt try lately.
can you try the current version?
i have the current version ML. is that what you mean? if not, where is the current version you want me to try.

Gary
I found this=
https://docs.google.com/spreadsheet/ccc?key=0AgQ2MOkAZTFHdHJraTVTOEpmNEIwTVlKd0dHVi1ULUE#gid=0

but i don't know how to use all of that. I was expecting a simple mo file to add to my ML modules folder. I always get the daily builds for the M off of http://tl.bot-fly.com/

g3gg0

  • Developer
  • Hero Member
  • *****
  • Posts: 3154
Re: MLV PLAY (mlv_play.mo)
« Reply #37 on: November 15, 2013, 11:31:08 AM »
i have the current version ML. is that what you mean? if not, where is the current version you want me to try.

just download the mlv_rec package and use the modules from there
Help us with datasheets - Help us with register dumps
magic lantern: 1Magic9991E1eWbGvrsx186GovYCXFbppY, server expenses: paypal@g3gg0.de
ONLY donate for things we have done, not for things you expect!

MonteNero

  • Freshman
  • **
  • Posts: 63
Re: MLV PLAY (mlv_play.mo)
« Reply #38 on: November 16, 2013, 07:46:12 AM »
Hi, g3ggo! Here are some results I've got.
1) HDMI playback doesn't crash the camera, but it doesn't display the recorded raw file either. Here is what I get when playback the file with HDMI

There is some strange playback behind the grey bar.
2) Pressing "info" or "loupe" buttons crash the camera while recording raw with HDMI and without.
I used latest ML build 2013-11-16 5d mark III

g3gg0

  • Developer
  • Hero Member
  • *****
  • Posts: 3154
Re: MLV PLAY (mlv_play.mo)
« Reply #39 on: November 16, 2013, 08:51:40 AM »
which camera?
when you rotate the wheel (on top) does the video file change?
Help us with datasheets - Help us with register dumps
magic lantern: 1Magic9991E1eWbGvrsx186GovYCXFbppY, server expenses: paypal@g3gg0.de
ONLY donate for things we have done, not for things you expect!

gary2013

  • Hero Member
  • *****
  • Posts: 660
Re: MLV PLAY (mlv_play.mo)
« Reply #40 on: November 16, 2013, 08:56:40 AM »
just download the mlv_rec package and use the modules from there
that is what I have been doing. I always get the no free buffer message. i go to ML File manager, navigate to the MLV file i just shot and then select view. It shows building index and then saving index and goes blank and the error message pops up about not getting a free buffer. The M hangs and i have to pull the battery and reboot.

MonteNero

  • Freshman
  • **
  • Posts: 63
Re: MLV PLAY (mlv_play.mo)
« Reply #41 on: November 16, 2013, 09:34:09 AM »
which camera?
when you rotate the wheel (on top) does the video file change?
5d mark iii. Yes, the video file changes if I scroll the top wheel and the grey bar dissappears but there are strange flickering on the top and bottom of the display, if you take a look at the image I posted above you will see pixels and lines on the top and the bottom of the image. Moreover greyscale playback slows down if viewed with HDMI.

MonteNero

  • Freshman
  • **
  • Posts: 63
Re: MLV PLAY (mlv_play.mo)
« Reply #42 on: November 16, 2013, 09:58:47 AM »


Here is the new image.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5801
Re: MLV PLAY (mlv_play.mo)
« Reply #43 on: November 16, 2013, 09:59:20 AM »
Strange. I got everything to play just fine on my 5d mark 3 through hdmi. Playback in color. I downloaded the pre-built version from here, http://www.magiclantern.fm/forum/index.php?topic=7122.0

g3gg0

  • Developer
  • Hero Member
  • *****
  • Posts: 3154
Re: MLV PLAY (mlv_play.mo)
« Reply #44 on: November 16, 2013, 10:06:46 AM »
maybe it depends on the exact resolution.
hdmi playback is slower for reason. the resolution is higher.

Help us with datasheets - Help us with register dumps
magic lantern: 1Magic9991E1eWbGvrsx186GovYCXFbppY, server expenses: paypal@g3gg0.de
ONLY donate for things we have done, not for things you expect!

MonteNero

  • Freshman
  • **
  • Posts: 63
Re: MLV PLAY (mlv_play.mo)
« Reply #45 on: November 16, 2013, 06:57:17 PM »
Strange. I got everything to play just fine on my 5d mark 3 through hdmi. Playback in color. I downloaded the pre-built version from here, http://www.magiclantern.fm/forum/index.php?topic=7122.0
Most likely your monitor is cropping the video! I've just tested the HDMI playback on a cheap small field monitor, the monitor has an options of 480p and 1080i. When I watch it in 480p mode the playback is cropped and I don't get the weird pixel flicker on the top and the bottom of the frame. But if I playback with full HD mode it scales it whole video to fit in the screen, and I see the artifacts. So far I tested the HDMI playback on the field monitors Lilliput an TV logic. Moreover I run couple of tests on a broadcast reference monitor set, finally I tested it on my home TV Samsung Smart, every full HD device give this weird flicker. The exception is the Lilliput monitor that crops  the video in a 480p mode. Also I've noticed that the playback with HDMI is a tiny bit slower that in camera playback. So this is it so far. Hope that will be useful for further development.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5801
Re: MLV PLAY (mlv_play.mo)
« Reply #46 on: November 16, 2013, 07:16:08 PM »
Ok, yes, I get the pixel thingy also but I get the color view at least :)

g3gg0

  • Developer
  • Hero Member
  • *****
  • Posts: 3154
Re: MLV PLAY (mlv_play.mo)
« Reply #47 on: November 16, 2013, 07:44:32 PM »
its just some remaining pixel trash on top and bottom bars?
i can imagine where this comes from.

just a appearance-thingy, no functional problem, right?
Help us with datasheets - Help us with register dumps
magic lantern: 1Magic9991E1eWbGvrsx186GovYCXFbppY, server expenses: paypal@g3gg0.de
ONLY donate for things we have done, not for things you expect!

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5801
Re: MLV PLAY (mlv_play.mo)
« Reply #48 on: November 16, 2013, 08:18:26 PM »
exactly, works perfectly fine here.

MA Visuals

  • Freshman
  • **
  • Posts: 83
Re: MLV PLAY (mlv_play.mo)
« Reply #49 on: November 17, 2013, 01:05:15 AM »
I'm not sure if this is helpful, but here's a short iphone video demonstrating the HDMI playback issue others have observed (5D Mark III, SmallHD DP-4)...

On first playback, the no image message blocks the display.  If you switch to another clip using the top dial, it clears up the "No Image" issue but the image remains cut off on the left side and offset.

Also, the playback speed drops dramatically compared to in-camera playback.  You can get a sense of the playback speed in the video example.