undefined reference to `edmac_copy_rectangle_adv'

Started by Thomas Worth, August 08, 2013, 03:35:24 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Thomas Worth

Just an FYI, I tried compiling the latest source for the 7D (Mac OS X, GCC 4.8.1), but ran into the following error. Compiling 5D3 worked fine. Only when attempting "make 7D" did I run into this:

debug.o: In function `mem_test_edmac_copy_rectangle':
debug.c:(.text+0x304): undefined reference to `edmac_copy_rectangle_adv'
debug.o: In function `run_test':
debug.c:(.text+0xb28): undefined reference to `edmac_memcpy_res_lock'
debug.c:(.text+0xb6c): undefined reference to `edmac_copy_rectangle_adv'
debug.c:(.text+0xbbc): undefined reference to `edmac_copy_rectangle_adv'
debug.o: In function `mem_benchmark_task':
debug.c:(.text+0x3528): undefined reference to `edmac_memcpy'
collect2: error: ld returned 1 exit status
make[1]: *** [magiclantern] Error 1
make: *** [7D] Error 2

Adding edmac-memcpy.o to /src/Makefile.src in the following place (line 127) fixed it:

boot-hack.o \
ico.o \
edmac.o \
menu.o \
edmac-memcpy.o \
debug.o \


EOS 7D Mark II, EOS 7D, EOS 5, EOS 100 + lenses (10mm to 300mm), 600EX, 550EX, YN600EX x 3
EOScard, EOS DSLR firmwares, ARMu, NiControl, etc.: http://pel.hu/down