Author Topic: 7D Raw Thread  (Read 366502 times)

flavediller

  • New to the forum
  • *
  • Posts: 14
Re: 7D Raw Thread
« Reply #2575 on: March 25, 2014, 04:40:29 PM »
So I'm using the mosaic engineering filter now on my 7D. I've heard that it works for the aliasing of course in regular shooting....but when you go to crop mode do you still need the filter or are you better off keeping it OUT of the camera when shooting crop mode? I guess I'm asking if the filter should be used for BOTH modes, or if it should only be used for non-cropped normal shooting. Thanks and keep up the amazing work everyone!

Frank7D

  • Senior
  • ****
  • Posts: 456
Re: 7D Raw Thread
« Reply #2576 on: March 25, 2014, 05:01:47 PM »
Don't use the filter in crop mode. In crop mode there is no line-skipping and so no aliasing which needs to be blurred.

flavediller

  • New to the forum
  • *
  • Posts: 14
Re: 7D Raw Thread
« Reply #2577 on: March 25, 2014, 05:04:37 PM »
That is interesting and frustrating. On a film set it would take too much time to delicately take the filter out of the camera for crop shooting and put it back in for normal shooting. What would be a good workflow do you think? 2 cameras, one with the filter and one not....but of course that gets expensive. Maybe get all the crop shots in a row and all the normal ones after or before...but of course that is difficult depending on the style of the shoot. Hmmm...this one will take some thinkin....

ted ramasola

  • Moderators
  • Hero Member
  • *****
  • Posts: 1250
Re: 7D Raw Thread
« Reply #2578 on: March 25, 2014, 05:07:14 PM »
Frank7D is right. I have the VAF for 5D2 and it can't be used for crop mode and for stills in liveview.
5DmkII  / 7D
www.ramasolaproductions.com
Texas

bischofftep

  • New to the forum
  • *
  • Posts: 17
Re: 7D Raw Thread
« Reply #2579 on: March 25, 2014, 10:35:00 PM »
I'm having trouble with Raw 7D. Here's the skinny:
* 2014 May 25 Nightly Build ML7D.203
* Raw 2.0 (mlv)
* 1532 x 1148 resolution

Most of the frames come out fine. Periodically, though, the following error will creep in (as exported from MLRawViewer 1.1.3 on Mac OS X):


It's a "tearing" of the image (circle added to show where the problem is) during motion. Is this a new issue, or am I missing something which will help avoid these?
Douglas E. Bischoff
Audio/Video Production & Scoring

Frank7D

  • Senior
  • ****
  • Posts: 456
Re: 7D Raw Thread
« Reply #2580 on: March 26, 2014, 12:12:51 AM »
It's a "tearing" of the image (circle added to show where the problem is) during motion. Is this a new issue, or am I missing something which will help avoid these?

This happens under certain conditions (when you overload the camera, is my hypothesis). It has only happened to me when I was using the ml grayscale preview in crop mode. When I use the canon preview there is no issue.

Here are some comments reflecting some test results I got (using a tragic lantern build, btw):
http://www.magiclantern.fm/forum/index.php?topic=7503.2450
http://www.magiclantern.fm/forum/index.php?topic=7503.2475

bischofftep

  • New to the forum
  • *
  • Posts: 17
Re: 7D Raw Thread
« Reply #2581 on: March 26, 2014, 01:37:51 AM »
This happens under certain conditions (when you overload the camera, is my hypothesis). It has only happened to me when I was using the ml grayscale preview in crop mode. When I use the canon preview there is no issue.

Thanks for the reply! I don't use crop mode, and am not sure what you mean by "canon preview." The output came from MLRawViewer... wonder if the problem is there? I can't actually play back on the camera itself: it plays at perhaps 8 fps. (And to answer the next likely question, using a Lexar 1000 32mb card.) I did read something about a "memory hack" which I am NOT using.

Would you mind sharing a "working" magic.cfg config file either here or by PM?

Douglas E. Bischoff
Audio/Video Production & Scoring

Frank7D

  • Senior
  • ****
  • Posts: 456
Re: 7D Raw Thread
« Reply #2582 on: March 26, 2014, 03:51:04 AM »
Thanks for the reply! I don't use crop mode, and am not sure what you mean by "canon preview." The output came from MLRawViewer... wonder if the problem is there? I can't actually play back on the camera itself: it plays at perhaps 8 fps. (And to answer the next likely question, using a Lexar 1000 32mb card.) I did read something about a "memory hack" which I am NOT using.

Would you mind sharing a "working" magic.cfg config file either here or by PM?

If you're not shooting crop mode, then my settings probably won't apply to you (also, you are using a different build from me).
Based on my testing, it looks like anything that strains the camera's processor too much could potentially cause the tearing. Try turning off overlays (Global Draw)and see if that helps. I would do some tests to see what works for you in your mode of shooting. If you shoot some short clips of something with vertical lines filling the frame, and pan back and forth, you will see the issue if it's present (I used the back of a rocking chair). You could try different settings and see what causes it to happen.

ted ramasola

  • Moderators
  • Hero Member
  • *****
  • Posts: 1250
Re: 7D Raw Thread
« Reply #2583 on: March 26, 2014, 04:35:24 AM »
I'm having trouble with Raw 7D. Here's the skinny:
* 2014 May 25 Nightly Build ML7D.203
* Raw 2.0 (mlv)
* 1532 x 1148 resolution

Most of the frames come out fine. Periodically, though, the following error will creep in (as exported from MLRawViewer 1.1.3 on Mac OS X):
It's a "tearing" of the image (circle added to show where the problem is) during motion. Is this a new issue, or am I missing something which will help avoid these?

@ bischofftep,

Since you are using the ML nightly and this tearing is ML nightly specific, I'll direct you to this thread : http://www.magiclantern.fm/forum/index.php?topic=9848.msg108723;topicseen#msg108723

I see you have posted there already.

So you won't get confused since this thread is under tragic lantern section and the tearing problem is not present in recent TL nightlies.

I've also posted there reporting the tearing and pink corruption of the image in fast moving subjects in the ML nightly builds
5DmkII  / 7D
www.ramasolaproductions.com
Texas

bischofftep

  • New to the forum
  • *
  • Posts: 17
Re: 7D Raw Thread
« Reply #2584 on: March 26, 2014, 11:47:49 AM »
Thank you, Ted! Hadn't realized this was a TL thread...
Douglas E. Bischoff
Audio/Video Production & Scoring

Genscher

  • New to the forum
  • *
  • Posts: 2
Re: 7D Raw Thread
« Reply #2585 on: March 26, 2014, 04:14:13 PM »
Hey Guys,

I'm using the TL version from October 3rd and would like to upgrade my firmware version.

Now I am a bit confused (even though I followed this thread closely) which version I should take:
a) TL or ML
b) which revision

Normally I am recording using crop mode. A new thing I would love to test would be recording raw + sound.

Which TL or ML revision should I choose?

Thank you for your help!

nick.p

  • Freshman
  • **
  • Posts: 94
Re: 7D Raw Thread
« Reply #2586 on: March 26, 2014, 11:12:35 PM »
ML doesn't have the fps override yet so if you want to shoot in crop mode you are going to need TL