Author Topic: Canon 650D / T4i  (Read 1383574 times)

davidtlong

  • Freshman
  • **
  • Posts: 89
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #850 on: October 17, 2013, 05:48:39 PM »
Currently, I'm using the Sandisk Extreme Pro 95MB/s like in this post: http://www.magiclantern.fm/forum/index.php?topic=7473.msg73048#msg73048

There's nothing special about this card (it's old and i suppose discontinued), you can use any of them, which bencmarks around 40MB/s
But if you'll get Sandisks 45MB/s, be careful to tell the difference between these two: http://www.magiclantern.fm/forum/index.php?topic=7473.msg72697#msg72697
The one on the right is slow. You should get one with red sticker, not gold.

Thank you so much.  Actually I have the 45 red sticker and was thinking I was not getting good performance as it seems slow to "warm up" if that is the best phrase and peaks in the camera at 36.7. I am going to rerun the ML write test.

But the 95 is still out there and am going to consider.  thanks for supplying those links.  I knew I read them and was  trying to find them again.

dave

Alex N

  • New to the forum
  • *
  • Posts: 4
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #851 on: October 17, 2013, 06:57:51 PM »
I've been running this alpha ML build on my 650D for like 2 months now and using the camera every day, I've only had it lock up once, I'd call that pretty darn stable ^^
I do not know how anyone running Magic Lantern but I was his work on the 650D is not quite satisfied. Magic Zoom skips audio and nedobavili. If you turn off the screen and then climbs through the sensor on the display is what that inscription saves only reboot the machine.

Alex N

  • New to the forum
  • *
  • Posts: 4
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #852 on: October 17, 2013, 07:02:19 PM »
As it foolishly by translators work...

kmcray

  • New to the forum
  • *
  • Posts: 4
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #853 on: October 17, 2013, 09:30:42 PM »
Not sure if anyone is aware of this, but in nightly builds it says "This build failed!". it says this for all builds, not just 650D

spider

  • Member
  • ***
  • Posts: 243

demetrisag

  • Freshman
  • **
  • Posts: 79
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #855 on: October 18, 2013, 09:26:23 AM »
Ok, another good news.
Thanks to mk11174, we found a timer address for 650D (0xFF527E38), and small hacks now fully working.

This gives us another tiny speed increase: 38.5 Mb/s vs previous 37.7
For example, now you can record 1504x640 (2.35:1) continiously.

When I'm using my favorite resolution 1536x640 now recording time before skipping is about 1.5 minutes, previously it was around 42-44 secs.

Rewind the maximum i get with small hacks enabled is 38.1Mb/s. And I have the 32 GB SanDisk Extreme Pro® SDHC™ UHS-I Memory Card 95Mb/s.

How do you get 38.5?

Rewind

  • Senior
  • ****
  • Posts: 356
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #856 on: October 18, 2013, 09:30:32 AM »
Rewind the maximum i get with small hacks enabled is 38.1Mb/s. And I have the 32 GB SanDisk Extreme Pro® SDHC™ UHS-I Memory Card 95Mb/s.

How do you get 38.5?

Even 38.6 now at resolutions higher than 1536 (e.g. 18 secs of 1600x672 just like 6D )

I'm using modified raw_rec from pravdomil's source.
https://bitbucket.org/pravdomil/magic-lantern-hack/commits/all

demetrisag

  • Freshman
  • **
  • Posts: 79
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #857 on: October 18, 2013, 09:32:24 AM »

I'm using modified raw_rec from pravdomil's source.
https://bitbucket.org/pravdomil/magic-lantern-hack/commits/all

Well even though I have no idea how would i do that, at least that gives a good explanation! thanks mate!

Rewind

  • Senior
  • ****
  • Posts: 356
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #858 on: October 18, 2013, 09:40:28 AM »
Well even though I have no idea how would i do that, at least that gives a good explanation! thanks mate!

This version has some interesting features like various interface choices.
I also modified some things regarding resolution choices. Now I just choose vertical and horizontal resolutions separately (multiples of 16) instead of horizontal and aspect ratio.

I will perform some testing, and if the module will work stable, i then can share it with you.
(I just don't want to burn up any cameras other then mine)

demetrisag

  • Freshman
  • **
  • Posts: 79
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #859 on: October 18, 2013, 09:43:15 AM »
This version has some interesting features like various interface choices.
I also modified some things regarding resolution choices. Now I just choose vertical and horizontal resolutions separately (multiples of 16) instead of horizontal and aspect ratio.

I will perform some testing, and if the module will work stable, i then can share it with you.
(I just don't want to burn up any cameras other then mine)

Great stuff there :) Thanks for letting us know mate

davidtlong

  • Freshman
  • **
  • Posts: 89
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #860 on: October 18, 2013, 02:07:30 PM »
Even 38.6 now at resolutions higher than 1536 (e.g. 18 secs of 1600x672 just like 6D )

I'm using modified raw_rec from pravdomil's source.
https://bitbucket.org/pravdomil/magic-lantern-hack/commits/all

Rewind,

Interesting.  I have seen this page before but under branches I do not see the 650D and never came back to look.  So  1) are you using the 60D for example and 2) where on this page is the modified raw_rec.

Thanks

dave

Rewind

  • Senior
  • ****
  • Posts: 356
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #861 on: October 18, 2013, 03:25:34 PM »
Interesting.  I have seen this page before but under branches I do not see the 650D and never came back to look.  So  1) are you using the 60D for example and 2) where on this page is the modified raw_rec.

Not sure if understand you correctly.
1) 60D? No, i'm using this raw_rec for my 650D and in some cases for 550D.

2) This page is code source. You can clone it to your machine and compile for yourself just like you normally do with other sources. If you don't familiar with compiling, you can start from here:
http://www.magiclantern.fm/forum/index.php?topic=6783.0

davidtlong

  • Freshman
  • **
  • Posts: 89
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #862 on: October 18, 2013, 04:49:45 PM »
Not sure if understand you correctly.
1) 60D? No, i'm using this raw_rec for my 650D and in some cases for 550D.

2) This page is code source. You can clone it to your machine and compile for yourself just like you normally do with other sources. If you don't familiar with compiling, you can start from here:
http://www.magiclantern.fm/forum/index.php?topic=6783.0

Yes I did understand that these are source codes but was thinking that I did not see 650D specific (or at least in my quick look) and was wondering if you were blending others.  But I think I understand now.  thanks

davidtlong

  • Freshman
  • **
  • Posts: 89
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #863 on: October 18, 2013, 10:20:31 PM »
Rewind the maximum i get with small hacks enabled is 38.1Mb/s. And I have the 32 GB SanDisk Extreme Pro® SDHC™ UHS-I Memory Card 95Mb/s.

How do you get 38.5?

Well I received my SanDisk Extreme Pro® SDHC™ UHS-I Memory Card 95Mb/s. and ML benchmarked it at 38.1 max.  Recording I get 36.9 max.  This is better than my 45mb Extreme, but do you get 38.1 while recording?

TX

dave

Modification:  I guess I do not fully understand how this works I admit.  At 1280 x 720 recording tops out at 36.8 or 9.  If I go up to say 1344 x 756 and up (just keeping the same aspect ratio 16:9 I get up to 38.7 mb/s for write (only 37.8 for the 45 card).  This is using today's  build.  I did not get this before.  Just curious why the 1280 x 720 is slower?  Anyway very cool for me.

Modification 2: What I notice is that when the settings are ok for continuous recording that the write speed tops at 36.8 or 9, so I guess for my camera that is the optimum speed for continuous.

aguden

  • New to the forum
  • *
  • Posts: 6
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #864 on: October 19, 2013, 01:25:01 PM »
Hello All.

Been out of touch since I had shoulder surgery and been unable to use my T4i.  Wanted to catch up and get back to checking out ML Alpha.  I currently have the Aug 3rd version working and think I understand what I need to do. Download the latest Alpha.  I have 10/18. And then unzip it to the SD card and overwrite any old files.  Then delete the .FIR file in the root of the card.  There are other files from the earlier version still on the card like VRAM*.422, VRAM*.BMP. 

Just wanted to make sure I haven't missed anything since I last visited the forum.
Al Guden
Canon Rebel T4i

blade

  • Member
  • ***
  • Posts: 195
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #865 on: October 20, 2013, 08:58:29 AM »
Hello All.

Been out of touch since I had shoulder surgery and been unable to use my T4i.  Wanted to catch up and get back to checking out ML Alpha.  I currently have the Aug 3rd version working and think I understand what I need to do. Download the latest Alpha.  I have 10/18. And then unzip it to the SD card and overwrite any old files.  Then delete the .FIR file in the root of the card.  There are other files from the earlier version still on the card like VRAM*.422, VRAM*.BMP. 

Just wanted to make sure I haven't missed anything since I last visited the forum.

Just remove your ml folder from the sd card, and place the new versions on the card... and you are done
eos400D :: eos650D  :: Sigma 18-200 :: Canon 100mm macro

aguden

  • New to the forum
  • *
  • Posts: 6
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #866 on: October 20, 2013, 03:57:22 PM »
And do I delete the 650D10~1.FIR from the root of the card?
Al Guden
Canon Rebel T4i

blade

  • Member
  • ***
  • Posts: 195
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #867 on: October 20, 2013, 04:10:32 PM »
And do I delete the 650D10~1.FIR from the root of the card?
Correct
eos400D :: eos650D  :: Sigma 18-200 :: Canon 100mm macro

aguden

  • New to the forum
  • *
  • Posts: 6
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #868 on: October 20, 2013, 04:14:58 PM »
Ok.  Just a bit more.  I did remove the ML folder from the SD card.  When I extracted the files there was an Autoexec.bin that wanted to be replaced.  I assume the answer is yes.  And probably delete everything in the root except for the two Canon folders - DCIM and MISC? The files in the root are a couple of PDF files and a STUBTEST.log, VRAM*.422 & VRAM*.BMP. With the huge warnings I am a chicken! Never had a problem but don't want to start now!  Appreciate your patience! And thank you for you work.
Al Guden
Canon Rebel T4i

blade

  • Member
  • ***
  • Posts: 195
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #869 on: October 20, 2013, 04:17:10 PM »
Ok.  Just a bit more.  I did remove the ML folder from the SD card.  When I extracted the files there was an Autoexec.bin that wanted to be replaced.  I assume the answer is yes.  And probably delete everything in the root except for the two Canon folders - DCIM and MISC? The files in the root are a couple of PDF files and a STUBTEST.log, VRAM*.422 & VRAM*.BMP. With the huge warnings I am a chicken! Never had a problem but don't want to start now!  Appreciate your patience! And thank you for you work.
replace the autoexec.bin,

The other files can be removed... 
eos400D :: eos650D  :: Sigma 18-200 :: Canon 100mm macro

aguden

  • New to the forum
  • *
  • Posts: 6
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #870 on: October 20, 2013, 05:02:22 PM »
Thanks.  Worked perfectly.  I have written up a quick note to myself for next time!  No more bothering you! The updates over the last few months look great. Now to start testing!
Al Guden
Canon Rebel T4i

spider

  • Member
  • ***
  • Posts: 243
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #871 on: October 21, 2013, 12:24:06 AM »
How stable is Dual ISO for 650D atm?
And what about frying the sensor as mentioned by a1ex?  I mean if it works on one 650D it will work on all 650D or is there a little possibility that it wont work on some 650D?

blade

  • Member
  • ***
  • Posts: 195
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #872 on: October 22, 2013, 09:46:32 AM »
How stable is Dual ISO for 650D atm?
And what about frying the sensor as mentioned by a1ex?  I mean if it works on one 650D it will work on all 650D or is there a little possibility that it wont work on some 650D?

It works well on my 650, and i do not see any reason why it should not work on an other 650. Then again, this is alpha software, i you are not comfortable running bleeding edge code...  then wait for the beta... or final. 
eos400D :: eos650D  :: Sigma 18-200 :: Canon 100mm macro

navilink

  • New to the forum
  • *
  • Posts: 2
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #873 on: October 22, 2013, 05:04:16 PM »
Just installed ML on my 650D, feels awesome 8)
But now how do I uninstall it? I Googled for a while seems there's many different ways to uninstall.
What are the clear steps to cleanly uninstall ML on 650D?

satriani

  • Freshman
  • **
  • Posts: 82
Re: Canon 650D/T4i 1.0.4 [Status: Alpha]
« Reply #874 on: October 22, 2013, 11:02:12 PM »
Just run a last firmware update.
Cameras: Canon EOS 70D, Canon EOS 650D
Lenses: 2x CanonEF-S 18-135 IS STM, Sigma 50mm f1.4 DG HSM Art
Daily builds