Author Topic: Canon 650D / T4i  (Read 1078190 times)

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12223
  • Maintenance mode
Re: Canon 650D / T4i
« Reply #2175 on: January 09, 2019, 08:20:46 PM »
Occasionally this (lower right corner) happens to me. Scrollwheel function not affected (or I missed something).
Can I help to corner this one?
Older nightly and experimental builds affected, too.

That only happens in LiveView, I guess. The red icon means the underlying Canon menu (behind ML menu) is no longer there, and the main side effect is that you can no longer use the scrollwheel for ML menu navigation.

Is it related to the menu timeout issue, or rather to certain actions performed by user while in ML menu? (such as switching to some other camera mode, or attempting to change ISO...)

In the experimental builds, is the menu timeout in LiveView still an issue?

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6738
Re: Canon 650D / T4i
« Reply #2176 on: January 09, 2019, 09:49:10 PM »
I haven't been able to find out what triggers it yet. Will look into it, though.

EDIT: First hint: Happens after powersave mode.
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

kidkvn

  • New to the forum
  • *
  • Posts: 1
Re: Canon 650D / T4i
« Reply #2177 on: January 29, 2019, 09:26:27 PM »
Hello everyone,

     First time here. I'm trying to use my DSLR for long term use with the live view. I know that there is a feature for 'Sticky Half Press Shutter' within Magic Lantern. Though I cant seem to find this option in my build of ML. Based on documentation, I am under the impression that it's supposed to be under miscellaneous keys, but upon entering the menu it's not an option. Can someone please point me in the right direction. I'm really hoping there is a build with this option that works on the rebel t4i.

Thank you.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6738
Re: Canon 650D / T4i
« Reply #2178 on: January 30, 2019, 03:11:44 AM »
Not available on 650D: See https://builds.magiclantern.fm/features.html -> Prefs -> sticky_Halfshutter
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

Filmmaker

  • New to the forum
  • *
  • Posts: 6
Re: Canon 650D / T4i
« Reply #2179 on: February 09, 2019, 10:39:48 PM »
Can anyone direct me to a link with instruction for creating bootable cards please. I am running 1.0.4 on a kiss 650/T4i ... thank you in advance.

Filmmaker

  • New to the forum
  • *
  • Posts: 6
Re: Canon 650D / T4i
« Reply #2180 on: February 09, 2019, 10:41:28 PM »
Also, a user guide would be helpful.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6738
Re: Canon 650D / T4i
« Reply #2181 on: February 10, 2019, 12:31:30 AM »
Format card using cardreader.
Follow install instructions for Nightly Builds.
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6738
Re: Canon 650D / T4i
« Reply #2182 on: April 14, 2019, 10:55:27 PM »
I could prepare a preset for testing. Let me know if any interest here 650D users...

Just got informed there is a change of plans and I have some time at hand. Preset welcome!
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5503
Re: Canon 650D / T4i
« Reply #2183 on: April 14, 2019, 11:06:09 PM »
Typically I´m busy atm but will take a look as soon as I can.

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3707
Re: Canon 650D / T4i
« Reply #2184 on: April 18, 2019, 01:53:41 AM »
I was interested in how this experiment would turn out. Looking into it it seems we can try to see if the 700D settings work on the 650D.



Got it all set up on one of my branches but came up with an issue. We're using the latest code which requires finding the FRAME_SHUTTER_BLANKING values.

Walter - if you can find the values for ADTG registers 805f and 8061 using adtg_gui we can move forward with this experiment. I'm not sure if we can find it with QEMU - at least I can't do it using adtg_gui:



By the way, we're a bit stuck here because like those registers in Dual ISO that you've been fighting with these values can change.

Here's the commit that shows the shenanigans I'm doing.

5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

IsaacEE

  • New to the forum
  • *
  • Posts: 2
Re: Canon 650D / T4i
« Reply #2185 on: April 28, 2019, 06:02:03 AM »
@dfort: Here's the values I read for those two registers using crop_rec_4k.2018Jul22.650D104 build and adtg_gui.  If it's not what you need, I can try again with further instruction.

I noticed that both registers flickered between 0x4F0 and 0x4F1, as seen in the screenshots.  These were taken in 1080p24 live view 1x mode.






Using 5x zoom mode, the following are their values:




Rebel T4i, 50 f/1.8 II, 16-35 f/2.8 II DIY repaired.

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3707
Re: Canon 650D / T4i
« Reply #2186 on: April 28, 2019, 03:27:33 PM »
@IsaacEE -- Excellent!

Posted a crop_rec_Bleeding_Edge build for the 650D on my downloads page.

I'll be surprised if it works but it is worth a try. It should function the same as Danne's 700D build. There's a bunch of modules in there that you can also try but to try out the new crop_rec settings start off with just mlv_lite, crop_rec, lua and sd_uhs. Run Danne's cine.lua script to setup the camera for 1x3 sampling (a.k.a. Anamorphic). Run it once -- don't autorun! You can use any MLV processing application -- MLV App automatically adjusts the aspect ratio.

Remember this is bleeding edge stuff. Please report back if you try it out.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5503
Re: Canon 650D / T4i
« Reply #2187 on: April 28, 2019, 03:54:46 PM »
Cool. cine.lua script needs a change though if you want to run that:
Code: [Select]
-- end this script if not eosm
if camera.model_short ~= "EOSM" and camera.model_short ~= "700D" and camera.model_short ~= "100D" then
   display.notify_box("Script only works for eosm/700d/100D")
   menu.set("cinema 2:35.1", "Autorun", "OFF")
  msleep(2000)
   return
end

Add 650D:
Code: [Select]
-- end this script if not eosm
if camera.model_short ~= "EOSM" and camera.model_short ~= "700D" and camera.model_short ~= "100D" ~= "700D" and camera.model_short ~= "650D"  then
   display.notify_box("Script only works for eosm/700d/100D/650D")
   menu.set("cinema 2:35.1", "Autorun", "OFF")
  msleep(2000)
   return
end

Also need to add 650D values here if not done already in crop_rec.c:
Code: [Select]
    /* cmos_vidmode_ok doesn't help;
     * we can identify the current video mode from 0xC0F06804 */
    for (uint32_t * buf = (uint32_t *) regs[0]; *buf != 0xFFFFFFFF; buf += 2)
    {
        uint32_t reg = *buf;
        uint32_t old = *(buf+1);
        if (reg == 0xC0F06804)
        {
   if (is_5D3)
   {
            engio_vidmode_ok = (crop_preset == CROP_PRESET_CENTER_Z)
                ? (old == 0x56601EB)                        /* x5 zoom */
                : (old == 0x528011B || old == 0x2B6011B);   /* 1080p or 720p */
   }
   if (is_100D)
   {
             engio_vidmode_ok =
             (old == 0x45802A1) /* x5 zoom */ || (old == 0x42801ed) /* x3 digital zoom */ || (old == 0x4A701D7 || old == 0x2D801D7);   /* 1080p or 720p */
           }
   if (is_EOSM)
   {
     engio_vidmode_ok =
             (old == 0x4540298) /* x5 zoom */ || (old == 0x42401e4) /* x3 digital zoom */ || (old == 0x4a601d4) /* 1080p */ || (old == 0x2d701d4 /* 720p */); 
   }
   if (is_700D)
   {
             engio_vidmode_ok =
             (old == 0x4540298) ||/* x5 zoom */ (old == 0x4a601d4 || old == 0x2d701d4);   /* 1080p or 720p */
           }
        }
    }

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3707
Re: Canon 650D / T4i
« Reply #2188 on: April 28, 2019, 04:47:17 PM »
Already modified cine.lua but forgot to add the user prompt -- which shouldn't show up on the 650D build.

Using the 700D settings for now so the "is_700D" is applied to the 650D.

Code: [Select]
    else if (is_camera("650D", "1.0.4"))
    {
        CMOS_WRITE = 0x17A1C;
        MEM_CMOS_WRITE = 0xE92D41F0;
       
        ADTG_WRITE = 0x178FC;
        MEM_ADTG_WRITE = 0xE92D43F8;

        ENGIO_WRITE = 0xFF2C0778;
        MEM_ENGIO_WRITE = 0xE51FC15C;

        /* Let's see what happens if we just use the 700D settings on the 650D */

        is_700D = 1;
        crop_presets                = crop_presets_700d;
        crop_rec_menu[0].choices    = crop_choices_700d;
        crop_rec_menu[0].max        = COUNT(crop_choices_700d) - 1;
        crop_rec_menu[0].help       = crop_choices_help_700d;
        crop_rec_menu[0].help2      = crop_choices_help2_700d;

5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5503
Re: Canon 650D / T4i
« Reply #2189 on: April 28, 2019, 05:05:26 PM »
Well. Doubt it will work if you you don´t add the values for the 650D:
Code: [Select]
* we can identify the current video mode from 0xC0F06804 */
Will simply return; and not apply engio changes.

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3707
Re: Canon 650D / T4i
« Reply #2190 on: April 28, 2019, 06:08:47 PM »
Got it -- need to find it with adtg_gui?

@IsaacEE - some more help please?

[EDIT] The values for EOSM and 700D are the same so I'll bet that the value for the 650D is also the same. This might just work.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5503
Re: Canon 650D / T4i
« Reply #2191 on: April 28, 2019, 06:24:32 PM »
Not entirely the same so if not matched it will not work:
Code: [Select]
   if (is_EOSM)
   {
     engio_vidmode_ok =
             (old == 0x4540298) /* x5 zoom */ || (old == 0x42401e4) /* x3 digital zoom */ || (old == 0x4a601d4) /* 1080p */ || (old == 0x2d701d4 /* 720p */);
   }
   if (is_700D)
   {
             engio_vidmode_ok =
             (old == 0x4540298) ||/* x5 zoom */ (old == 0x4a601d4 || old == 0x2d701d4);   /* 1080p or 720p */

To test without this reg trap you can simply comment out following in crop_rec.c:
Code: [Select]
    if (!is_supported_mode() || !engio_vidmode_ok)
    {
        /* don't patch other video modes */
           return; 
    }
Instead do:
Code: [Select]
    if (!is_supported_mode() || !engio_vidmode_ok)
    {
        /* don't patch other video modes */
          // return; 
    }

Felipe

  • Senior
  • ****
  • Posts: 256
Re: Canon 650D / T4i
« Reply #2192 on: April 28, 2019, 11:52:22 PM »
@dfort: Do you have one for 105 to test?
650D-100D

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3707
Re: Canon 650D / T4i
« Reply #2193 on: April 29, 2019, 01:12:09 AM »
Do you have one for 105 to test?

No. I've had a pull request to port the 650D to 1.0.5 up for a long time but there has been very little interest in it so development is continuing on 1.0.4. Should be easy enough to make a 1.0.5 build but I'm away from home on a vacation at this time. Anyone interested in doing it? All you need is on my Bitbucket repository.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

Felipe

  • Senior
  • ****
  • Posts: 256
Re: Canon 650D / T4i
« Reply #2194 on: April 29, 2019, 01:45:54 AM »
Enjoy your trip and make nice videos
Should include the regular 3x crop existing in the previous build, so if needed
650D-100D

IsaacEE

  • New to the forum
  • *
  • Posts: 2
Re: Canon 650D / T4i
« Reply #2195 on: April 29, 2019, 03:46:27 AM »
Posted a crop_rec_Bleeding_Edge build for the 650D on my downloads page.
...
Please report back if you try it out.
Okay, I have some test data.  I downloaded the build from dfort's downloads link and ran the Lua script unmodified.  My camera didn't blow up (or turn into a 1Dx, for that matter...), and it looks like it worked.  I had an event today that I thought I could use as testing: all-dormitory dinner and activities outdoors.  The focus and exposure are off; I was run-and-gunning it handheld.  I won't upload the 20GB+ footage of video clips, but here's a couple.  I "developed" only the first one because my computer is slow and low on memory.

https://drive.google.com/open?id=1Z3feyNVv3fhsJnfs-js7iObPDrG_u_to

I'm sorry for the delay in my response -- this week is my finals week at school.  :-\

Got it -- need to find it with adtg_gui?

@IsaacEE - some more help please?
I finally figured how to have adtg_gui save the log files...  ::) I can't find a register labeled "C0F06804" for 1080p video mode or 10x zoom or 3x crop or 726p -- am I doing something wrong?  I enabled ENGIO Registers and couldn't find it.  I didn't record a video clip, just turned my camera to movie mode and recorded logs.



In 5x zoom mode:
Code: [Select]
c0f06804: 4540298 ISO=100 Tv=50 Av=113 lv=1 zoom=5 mv=1 res=0 crop=0 task=Evf pc=ff56ba78 addr=4285c RAW last line|column. 5D3: f6e|2fe, first 1|18 => 5936x3950
Rebel T4i, 50 f/1.8 II, 16-35 f/2.8 II DIY repaired.

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3707
Re: Canon 650D / T4i
« Reply #2196 on: April 29, 2019, 05:09:04 AM »
1x3 sampling Anamorphic settings using Danne's experimental branch on the 650D. Excellent job @IsaacEE !



 8)

Looks like you're having fun with it. Try out some of the other settings when you get a chance and let us know if anything needs some more work.

Updated the focus pixel map files to include these new crop_rec settings for the 650D.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5503
Re: Canon 650D / T4i
« Reply #2197 on: April 29, 2019, 06:42:56 AM »
@IsaacEE
Nice!
Seems maybe reg 6804 is identical to 700D since you got anamorphic working. Anyway, to make sure you can use adtg_gui which you seems to have sort of got the hang of.
So:
1 - Turn on only adtg_gui module and see to it that crop_rec module is off. You don´t even need mlv_lite module on to check this
2 - Turn your movie mode in mv1080p mode (24fps will do)
3 - Enable adtg_gui and also enable engio registers. Now go into canon menu and back into adtg_gui to apply all engio regs. This is needed very often to refresh adtg_gui


4 - Now select Capture size regs only


5 - Now scroll down to reg 6804 and then write down the register


6 - Now enter x5 zoom and go back and check reg 6804 and write down the number


7 - While we´re at it you can also get the 6804 register for Movie crop mode so let´s get that one too


8 - Lastly we want 6804 for mv720p so go into movie mode in canon menu and select 50 or 60fps mode then go back and check reg 6804
No pic for that reg on eosm since it need camera recording in mv720p mode to get into this mode. This quirk is not present on 650D

Rewind

  • Senior
  • ****
  • Posts: 356
Re: Canon 650D / T4i
« Reply #2198 on: April 29, 2019, 07:58:27 AM »
@Danne, following your instructions I got these values for my 650D:
5. 0x4a601d4 (mv1080p @24fps)
6. 0x4540298 (mv1080p x5 zoom)
7. 0x42401e4 (x5 zoom, movie crop enabled)
8. 0x2d701d4 (mv720p @50fps)

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5503
Re: Canon 650D / T4i
« Reply #2199 on: April 29, 2019, 08:38:37 AM »
Perfect! Thanks.