Author Topic: 50D - 14bit raw video builds and test results  (Read 65847 times)

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: 50D - 14bit raw video builds and test results
« Reply #50 on: June 22, 2013, 05:55:49 PM »
re: raw video

I'm just wondering if hardcoding common aspect ratios might be a better idea as a lot of the current options will likely never be used by anyone and might confuse some users. Maybe just keep SD, HD and Full HD + cinema ratios and x1.33, x1.5 & x2 options for anamorphic shooters?
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: 50D - 14bit raw video builds and test results
« Reply #51 on: June 22, 2013, 06:33:01 PM »
You know, I think I was correct last night.  ::)


skip_left   = 0;
does not work the same as skip_left   = zoom ? 74 : 74;

skip_left   = 0; = Left black border in raw video and frame sizes can be set too large

skip_left   = zoom ? 74 : 74; = works! No borders and frame size limited to 1984 max width. No pink frames either.



Silent Pics (movie mode) photos are pink and frame dimensions are 6px wider
Silent Pics (photo mode - raw rec and H.264 disabled) same

Raw video DNGs are correct with these settings. How to make silent pic dimensions equal raw video dimensions? i.e. 1984 wide instead of 1990? - This should correct pink frames in silent pics photo mode.

Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D - 14bit raw video builds and test results
« Reply #52 on: June 22, 2013, 06:56:34 PM »
Hehe, thanks for saving me time...

Bad idea to hardcode the aspects to "normal' ones... you want to vary height depending on what you can record... Ie 1080 vs 1038 might make difference between continuous recording or not. Esp on other bodies...

If it could just write anything we could just do 1080P and 720P  and call it a day :)

BTW: kip_left   = zoom ? 74 : 74;

is the same as just skip_left  = 74

GregoryOfManhattan

  • Member
  • ***
  • Posts: 170
Re: 50D - 14bit raw video builds and test results
« Reply #53 on: June 22, 2013, 07:06:39 PM »
black point disease is not always cured by blood letting the skip values - applying leeches can make things worse and actually spread bad blacks to other areas.
Andy600 - i am metaphorically trying to say that the black point issue in your zoom mode images has nothing to do with the skip values. changing those values can make things worse in other modes.
looks like the important thing you have highlighted is that the zoom mode video images are different from zoom mode silent pictures images.
a1ex and 1% should be able to sort that out as it may explain what is going on for other cameras - the 5D2 bounced its skip values around this week as well and there are ongoing problems with pink frames and so forth.

the correct value for skip left based on silent picture DNGs (which is the procedure a1ex said to use) is:
Code: [Select]
skip_left = zoom ? 64 : 74;for zoom mode video - the skip value of 0 would seem to apply, if having a too large skip_left value in zoom video mode causes the black point issue then that needs to be addressed.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D - 14bit raw video builds and test results
« Reply #54 on: June 22, 2013, 07:08:23 PM »
Well.. I'm opening a regular pic... skip is  74, really 73 but you cut off 1 line. Actually likely 74.. I'm using ruler in PS

Zoom mode I have to check still... fps override can screw with skips too.

skip_left = zoom ? 64 : 74;

Yea, thats correct.

I notice taking silent DNG with FPS override on causes cockups, esp in zoom mode.

Also notice using FPS override with shutter timer and REAL electronic shutter values stopped producing silent pics in zoom mode that I can't open. But shutters in movie mode need safety so you can't turn past the real ones.


Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: 50D - 14bit raw video builds and test results
« Reply #55 on: June 22, 2013, 07:16:47 PM »
Andy600 - i am metaphorically trying to say that the black point issue in your zoom mode images has nothing to do with the skip values. changing those values can make things worse in other modes.
looks like the important thing you have highlighted is that the zoom mode video images are different from zoom mode silent pictures images.
a1ex and 1% should be able to sort that out as it may explain what is going on for other cameras - the 5D2 bounced its skip values around this week as well and there are ongoing problems with pink frames and so forth.

the correct value for skip left based on silent picture DNGs (which is the procedure a1ex said to use) is:
Code: [Select]
skip_left = zoom ? 64 : 74;for zoom mode video - the skip value of 0 would seem to apply, if having a too large skip_left value in zoom video mode causes the black point issue then that needs to be addressed.

Yes, I know. I get it. I think silent pics and raw video needs to be separated somehow but for now raw video is working for me with no borders or pink frames at resolutions I find useful and I have no need for silent pics but for obviously the issue needs addressing for other users.

I'm not sure if it's relevant but is the sensor itself always being taken into account for these calculations? It's not the same as the 5d2 or later cameras.
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: 50D - 14bit raw video builds and test results
« Reply #56 on: June 22, 2013, 07:23:57 PM »
Well.. I'm opening a regular pic... skip is  74, really 73 but you cut off 1 line. Actually likely 74.. I'm using ruler in PS

Zoom mode I have to check still... fps override can screw with skips too.

skip_left = zoom ? 64 : 74;

Yea, thats correct.

I notice taking silent DNG with FPS override on causes cockups, esp in zoom mode.

Just compiled your latest changes (on a fork of TL totally separate to my unified repo) and set offset again as I suggested. Getting good speeds and no pink frmaes, borders etc but I did have one shot where the playback preview blacked out. Footage was ok though. Getting 360+ frames @1920x1080 25p - 72MB/s
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D - 14bit raw video builds and test results
« Reply #57 on: June 22, 2013, 07:29:29 PM »
Quote
where the playback preview blacked out

I think span files do this.

But I think 64/74 skips are right.. issue is cpu/sync/shutter

This is my most corrupt silent pic now... vs ones that wouldn't open with "canon" shutters and skips of 0





Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: 50D - 14bit raw video builds and test results
« Reply #58 on: June 22, 2013, 07:33:57 PM »
I think span files do this.

But I think 64/74 skips are right.. issue is cpu/sync/shutter

This is my most corrupt silent pic now... vs ones that wouldn't open with "canon" shutters and skips of 0

Maybe it's a fluke but I've taken 100+ silent pics with movie mode enabled/disabled and had no corrupt ones except for them all being pink
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D - 14bit raw video builds and test results
« Reply #59 on: June 22, 2013, 07:35:45 PM »
Also with FPS override?

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: 50D - 14bit raw video builds and test results
« Reply #60 on: June 22, 2013, 07:37:01 PM »
Also with FPS override?

Haven't changed FPS all day. It's on 25 exact. Didn't try with it off though


Update: LOL I just switched FPS override off and had some corrupt silent pics. Switched it back on and also had a few. (movie mode enabled/disabled) only zoomed frames are affected
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D - 14bit raw video builds and test results
« Reply #61 on: June 22, 2013, 07:48:16 PM »
Try using the real shutter commit. I recorded 1080P for like 2gb and going to cineform only issue is standard sensor noise.

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: 50D - 14bit raw video builds and test results
« Reply #62 on: June 22, 2013, 08:15:02 PM »
Try using the real shutter commit. I recorded 1080P for like 2gb and going to cineform only issue is standard sensor noise.

Yeah, works. Same kind of results as with the previous 'don't click me' method. Does this replace that? 
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D - 14bit raw video builds and test results
« Reply #63 on: June 22, 2013, 08:21:47 PM »
The hack works, made it this morning.

Real shutters is about shutter speed in movie mode... those 12" 6" etc exposures don't alter expo or shutter timer. Just need to block off canon menu and Ml menu from turning to invalid ones.

So far getting some real nice stuff at 1038 or 1080P... at least 40-50sec shots with each... They do more or less depending on how the card feels/I stop it/etc.

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: 50D - 14bit raw video builds and test results
« Reply #64 on: June 22, 2013, 08:24:59 PM »
The hack works, made it this morning.

Real shutters is about shutter speed in movie mode... those 12" 6" etc exposures don't alter expo or shutter timer. Just need to block off canon menu and Ml menu from turning to invalid ones.

So far getting some real nice stuff at 1038 or 1080P... at least 40-50sec shots with each... They do more or less depending on how the card feels/I stop it/etc.

So set Canon shutter in the same way as H.264?
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D - 14bit raw video builds and test results
« Reply #65 on: June 22, 2013, 08:32:42 PM »
Kinda.. movie mode real shutter is 1/2x - 1/whatever

But 50D thinks its in photo mode still and lets you chose 30", bulb, etc.

Not having this on builds don't use frame shutter timer and just make stuff up + use canon UI shutters.

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: 50D - 14bit raw video builds and test results
« Reply #66 on: June 22, 2013, 08:38:33 PM »
Kinda.. movie mode real shutter is 1/2x - 1/whatever

But 50D thinks its in photo mode still and lets you chose 30", bulb, etc.

Not having this on builds don't use frame shutter timer and just make stuff up + use canon UI shutters.

Cool, so we should be able to get some funky looking low light shots. Any penalty on temps?

Nice work sir! :)
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D - 14bit raw video builds and test results
« Reply #67 on: June 22, 2013, 08:59:23 PM »
No... its the opposite of what you're thinking.. those shutter speeds did nothing/weren't real.

Temp is actually lower with dialog refresh killed or dropped. I've had no overheating today.


akumiszcza

  • Freshman
  • **
  • Posts: 85
Re: 50D - 14bit raw video builds and test results
« Reply #68 on: June 22, 2013, 10:39:33 PM »
1. While silent pics are turned on, if you open live view and press af-on to get autofocus, the silent pics (burst in this case) is started. All dngs are blank of course, as the mirror is in wrong position.
2. Trying to shoot raw video while in double-zoomed mode (x10?) results in bad blocks, even first frame is bad (at least for mlmod-2013Jun21.50D.109.go.unified.9f26e15d9146.zip).

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D - 14bit raw video builds and test results
« Reply #69 on: June 23, 2013, 12:36:19 AM »
Don't use x10 it is exactly like x5 except for the problem you experience.

JulianH

  • Member
  • ***
  • Posts: 198
Re: 50D - 14bit raw video builds and test results
« Reply #70 on: June 23, 2013, 03:04:03 PM »
re: raw video

I'm just wondering if hardcoding common aspect ratios might be a better idea as a lot of the current options will likely never be used by anyone and might confuse some users. Maybe just keep SD, HD and Full HD + cinema ratios and x1.33, x1.5 & x2 options for anamorphic shooters?
Please leave them in... I love the freedom and creativity it gives. The more the better!
For anamorphic I use lots. 3:2, 4:3, 5:4 at various sizes.

Odd sizes could be in an 'advance' menu maybe if its a problem for others?

Rawolution

  • New to the forum
  • *
  • Posts: 17
Re: 50D - 14bit raw video builds and test results
« Reply #71 on: June 23, 2013, 06:59:25 PM »
Just compiled your latest changes (on a fork of TL totally separate to my unified repo) and set offset again as I suggested. Getting good speeds and no pink frmaes, borders etc but I did have one shot where the playback preview blacked out. Footage was ok though. Getting 360+ frames @1920x1080 25p - 72MB/s

Could you please upload that build with settings file?

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D - 14bit raw video builds and test results
« Reply #72 on: June 23, 2013, 08:42:34 PM »
That offset is wrong wrong wrong :)... it is what it was set to 64/74. I get no pink frames nor black level issues.

Quote
Please leave them in... I love the freedom and creativity it gives.

If anything, more aspect ratios. Different heights will write differently. A few pixels here and there is the difference between stopping and continuous.

GregoryOfManhattan

  • Member
  • ***
  • Posts: 170
Re: 50D - 14bit raw video builds and test results
« Reply #73 on: June 23, 2013, 09:13:22 PM »
https://bitbucket.org/GregoryOfManhattan/magic-lantern/downloads/magiclantern-2013Jun23.50D.109.go.unified.6685347055ba.zip
this is the latest unifeid build - but it will have black margins -
waiting for an
hg backout 5ddc160
to be merged back into the unified branch.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D - 14bit raw video builds and test results
« Reply #74 on: June 23, 2013, 09:29:12 PM »
Its your own repo... just change and commit.