Author Topic: 12-bit (and 10-bit) RAW video development discussion  (Read 470991 times)

aprofiti

  • Contributor
  • Member
  • *****
  • Posts: 174
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1700 on: September 21, 2018, 04:15:28 PM »
the correct stubs should start with 0xFF9 instead of 0xFF1. That means, you should patch some address that Canon code is going to execute, not a mirrored copy.

Make sure the hook is actually executing (add some printf, for example).
Code: [Select]
/** LiveView RAW patches **/
NSTUB(0xff9db254, StartImagePass_x1_SetEDmac)               /* right before the SetEDmac call from StartImagePass_x1/x5 CrawAddr / KindOfCraw */
NSTUB(0xff9dbce8, StartImagePass_x5_SetEDmac)               /* FIXME: why it fails when the hook is placed on the BL instruction?! */

Looks good! I didn't tried to set second stub to BL instruction yet.

Will show up 2 patches in PatchMgr Dialog (lv_x1 and lv_x5) and value returned by raw_lv_get_resolution() in raw_lv_setedmac_patch()i s "1"; also no branch due to errors in patch_hook_function()

timbytheriver

  • Member
  • ***
  • Posts: 246
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1701 on: September 24, 2018, 12:23:46 PM »
Hi

I definitely have a problem!

I've installed @a1ex 's 'tiny present' 10bit build for 5D2 from https://builds.magiclantern.fm/experiments.html

A) I'm not seeing mlv_rec.mo or mlv_snd.mo in that 5D2 build.

B) I'm not seeing 10/12bit Bit-Depth as an option under ML menu : MOVIE/RAW Video/Bit Depth.

C) Should I be loading raw_twk.mo to enable 10/12bit?

Confused! Am I missing some extra files?


Thanks.
Tim
5D3 1.1.3
5D2 2.1.2

benoit

  • New to the forum
  • *
  • Posts: 26
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1702 on: September 24, 2018, 10:18:43 PM »
I just did : delete my old ml directory, copy the new one.
Load the mlv_lite + mlv_play + raw_twk modules and don't forget to restart your 5D2 to see the options  MOVIE/RAW Video/Bit Depth.

TBar15

  • New to the forum
  • *
  • Posts: 2
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1703 on: September 25, 2018, 02:24:37 AM »
In my case, I am missing the raw_twk.mo module. Are we needing to actually compile that module for ourselves, or is it supposed to be included in the experimental build? I have tried compiling, but that is spitting back errors, unfortunately.

reddeercity

  • Contributor
  • Hero Member
  • *****
  • Posts: 2045
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1704 on: September 25, 2018, 04:46:56 AM »
 @TBar15 , What are talking about  ? Everything you need is in the build .
https://builds.magiclantern.fm/experiments.html

Just follow the really sample instructions that's being posted
Load the mlv_lite + mlv_play + raw_twk modules and don't forget to restart your 5D2 to see the options  MOVIE/RAW Video/Bit Depth.
How is this not straight forward ?

timbytheriver

  • Member
  • ***
  • Posts: 246
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1705 on: September 25, 2018, 10:53:41 AM »
Thanks @benoit That fixed it!  :)
5D3 1.1.3
5D2 2.1.2

ch_d

  • Freshman
  • **
  • Posts: 99
  • 5D MII
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1706 on: September 25, 2018, 01:10:01 PM »
Sorry guys - I have to jump in:
When I load mlv_lite + mlv_play + raw_twk I have no sound.
On the audio tab there is this orange writings: "Sound recording is disabled. Enable it from Canon menu."
But it is enabled in Canon menu

Thank you!
5D MII

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12241
  • Maintenance mode
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1707 on: September 25, 2018, 01:30:57 PM »
That message looks outdated; when recording raw video, it should recommend mlv_snd instead.

On this branch, mlv_snd is compatible only with mlv_rec, not mlv_lite.

ch_d

  • Freshman
  • **
  • Posts: 99
  • 5D MII
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1708 on: September 25, 2018, 04:35:50 PM »
OK, I ask differently. Is it possible to record sound with the latest "anniversary build"?
5D MII

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6762
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1709 on: September 25, 2018, 08:25:53 PM »
Yes.
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

Audionut

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3565
  • Blunt and to the point
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1710 on: September 26, 2018, 05:12:41 AM »
On this branch, mlv_snd is compatible only with mlv_rec, not mlv_lite.

When I download the 5D2 build of 10/12-bit RAW video from the experiments page, there is no mlv_snd module in that build.
Do we have to drag mlv_snd module from a different build?
Which build do you recommend getting the mlv_snd module from?
Is it possible to have mlv_snd module built in this branch so that the auto generated builds from this branch have the mlv_snd module automagically?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12241
  • Maintenance mode
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1711 on: September 26, 2018, 09:08:15 AM »
Sorry, didn't notice it was missing; previous feedback appears to reference mlv_rec, so I've assumed it was OK.

Fixed, and also included the 50D (mostly untested, except for the low-level notes from aprofiti).

The error message about sound recording is still outdated; feel free to suggest something better.

timbytheriver

  • Member
  • ***
  • Posts: 246
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1712 on: September 26, 2018, 10:08:06 AM »
@a1ex
 Thanks – but I'm now getting the following errors on boot with that build.
?
5D3 1.1.3
5D2 2.1.2

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6762
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1713 on: September 26, 2018, 10:13:02 AM »
Please read reply #1708
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

ch_d

  • Freshman
  • **
  • Posts: 99
  • 5D MII
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1714 on: September 26, 2018, 12:33:49 PM »
fyi: When I connect my smallHD DP6 I got bad frames every few seconds with mlv_rec + mlv_snd + raw_twk
5D MII

timbytheriver

  • Member
  • ***
  • Posts: 246
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1715 on: September 26, 2018, 02:37:30 PM »
Please read reply #1708

@Walter Schultz I did that. It doesn't appear to refer to my problem at all. Have I missed something?   ::)


5D3 1.1.3
5D2 2.1.2

ch_d

  • Freshman
  • **
  • Posts: 99
  • 5D MII
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1716 on: September 26, 2018, 02:46:27 PM »
@Walter Schultz I did that. It doesn't appear to refer to my problem at all. Have I missed something?   ::)

Try mlv_rec and no mlv_lite.
Just load: mlv_rec, mlv_snd and raw_twk
5D MII

timbytheriver

  • Member
  • ***
  • Posts: 246
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1717 on: September 26, 2018, 02:54:02 PM »
@ch_d Thanks! But I thought mlv_rec wasn't the 10/12bit ? That seems to have fixed it!  :D
5D3 1.1.3
5D2 2.1.2

Audionut

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3565
  • Blunt and to the point
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1718 on: September 27, 2018, 06:24:55 AM »
The error message about sound recording is still outdated; feel free to suggest something better.

May I have a link to the code snippet please?

reddeercity

  • Contributor
  • Hero Member
  • *****
  • Posts: 2045
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1719 on: September 27, 2018, 06:31:56 AM »
Checking the updated 10-12bit 5d2 , mlv_rec + mlv_snd + mlv_play + raw_twk
@24p+ Frame Over ride , everything works, 10 ,12 & 14bit looks good .
HDMI work great @ 1080i while recording raw @ 10bit 1856x1044 , Did notice any pink flickering frames on liveview & HDMI .
Had my Zacuto Evf pass thought to the HDMI Ninja hard drive recorder , Looked perfect ! even if I switch GD to allow for overlays
doesn't miss a beat .
30p is a little more touchy , It has a hard time with Frame Over Ride enabled --
it takes a long time to get to continuous (sometimes is just stays at 9800 frames) 10bit 1856x1044 29.97fps .
Without Frame Over Ride enable it goes continuous pretty quickly .
HDMI with 10bit 30p is a no starter ! Too much overhead to record raw continuously , get around 2500 frames .
12bit 30p is just too much at the current write speed ( maybe in the future it won't be  ;D )

12bit @ 24p is still good to use with Frame Over Ride + HDMI , even had GD allowed for overlays and didn't seem to slow it down  :D
but I only let go for a few minute's .

I did get 2 files with wrong black levels , 1 at 122 (should be 112) & one at 115 , both where at 29.97 fps with HDMI .
All else was fine , Audio is there & good 
 
One last thing the edmac.mo "wrong api version" or something like that was printed on screen .
Would not load , not big deal though .
Oh and the mlv_play.mo & raw_twk.mo work great by the way  :)

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12241
  • Maintenance mode
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1720 on: September 27, 2018, 06:25:38 PM »
May I have a link to the code snippet please?

On the audio tab there is this orange writings: "Sound recording is disabled. Enable it from Canon menu."

Code: [Select]
cd magic-lantern/
grep -nr "Sound recording is disabled. Enable it from Canon menu."

ch_d

  • Freshman
  • **
  • Posts: 99
  • 5D MII
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1721 on: September 27, 2018, 07:57:31 PM »
What I have noticed on the latest build is that the batteries are draining very fast.
Regularly I worked with a 2013 version on my 5DM2 and the batteries lasted longer.

5D MII

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12241
  • Maintenance mode
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1722 on: September 27, 2018, 08:03:10 PM »
Comparison under identical test conditions, please. For example, camera should be in LiveView with both builds (important!), at the same frame rate, with the same overlays enabled, same LCD brightness, same battery, same charging method and so on.

For each build you are going to test:
- Write down the time it takes for the battery to go from say 90% to say 50%.
- Take a screenshot of the battery indicator in the Debug menu at the end of each test (i.e. when the battery indicator reaches 50%)

Run the test a few times to evaluate the repeatability of the results.

reddeercity

  • Contributor
  • Hero Member
  • *****
  • Posts: 2045
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1723 on: September 28, 2018, 07:07:19 AM »
What I have noticed on the latest build is that the batteries are draining very fast.
Regularly I worked with a 2013 version on my 5DM2 and the batteries lasted longer.
I would have to disagree with this , It's the total opposite . I very surprised on how long the battery life is with the new core (2015-2018).
I have 3 batteries , when I go to a shoot & I'm always in standby (HDMI feed to Evf->Montior->Hard drive recorder-backup to Prores) scene set up , focus , exposure , etc. ....
Sometimes up to 30min before I start recording raw video and doesn't move on the battery indicator , when filming I can shoot for more then 30min with around 75% battery life left .
So 3 battery will last me around 5 hours with recording raw & standby mode (depending on the situation & temperature or cam)
Even when I'm developing , using tools like adtg_gui.mo , I can sit there and go thought registers for hours (2-3) before I can totally drain a battery .
If anything since 2013 the battery life has increased a great deal , can't give number right now , but if needed I can do some endurance tests to proof it .

Maybe there a problem with the batteries ? how old are they ? are they Canon batteries ?
I seem problems with aftermarket batteries not lasting , also your charger station , how is it -- working correctly , there again is a Canon charger ?
Maybe there's a problem with the chip in the battery and it's not reporting correctly . 
Do you let the battery drain to near "0" ? e.g. 10% before changing or do you re-charge at something like 50% ? that can cause a bad charge memory .
All deep cycle batteries no matter what the application (Camera's , Cell phone's or automotive ) needs to be conditioned to remember the voltage & amperage
Sorry I when off topic here . Just trying help  :)

benoit

  • New to the forum
  • *
  • Posts: 26
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #1724 on: September 28, 2018, 09:53:39 AM »
5D2212_Video_dual_iso.zip
I haven't tested it on the latest builds like 10-12bit or mlv_lite  but it work fine with plain vanilla builds 14bit , you may have to use a older build .
On 5D2, I just tried your posted module and a1ex 26Sept release : 10bits - Dual iso - MLV no sound - 3x mode (not crop rec) 1984*1074 @24fps. It works  8) But on another clip, I had to pull off the battery. Thanks every one for dual iso 10bits on 5D2!