Author Topic: RAW Video Module raw_rec [Compiling/Installation]  (Read 151425 times)

RenatoPhoto

  • Moderators
  • Hero Member
  • *****
  • Posts: 1509
  • 5DM3 / 7D
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #125 on: May 23, 2013, 02:52:18 PM »
Ok, I use windows compile so I can help you just a bit since I am not a programer or DEV.

Here is my latest Makefile.user for reference and make sure you have all of those CONFIG_XXXX  set right!

GCC_VERSION=4.7.3
ARM_ABI=none-eabi
ARM_PATH=../../../arm-toolchain473
ARM_LIBC_A=../../../arm-toolchain473/arm-none-eabi/lib/libc.a
PYTHON=python2.6
CONFIG_CONSOLE = y
CONFIG_TCC          = y
CONFIG_MEMCHECK     = y
CONFIG_MODULES      = y
CONFIG_TINYPY = Y
CONFIG_PICOC = n

So, make sure you have installed the gcc 4.7.3 otherwise TCC will not compile

Before I go any further what camera are you trying to compile for ?
http://www.pululahuahostal.com  |  EF 300 f/4, EF 100-400 L, EF 180 L, EF-S 10-22, Samyang 14mm, Sigma 28mm EX DG, Sigma 8mm 1:3.5 EX DG, EF 50mm 1:1.8 II, EF 1.4X II, Kenko C-AF 2X

Mayo

  • New to the forum
  • *
  • Posts: 29
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #126 on: May 23, 2013, 03:08:34 PM »
Thanks :)

I compile for 6D.

I figured out the CONFIG_XXXX stuff. raw_rec.mo compiles now.

I'm now trying to figure out how to compile raw2dng (the makefile apparently uses mingw, so i'm doing this now).

RenatoPhoto

  • Moderators
  • Hero Member
  • *****
  • Posts: 1509
  • 5DM3 / 7D
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #127 on: May 23, 2013, 03:19:41 PM »
to get the latest raw2dng.exe just downloaded from here.
https://bitbucket.org/hudson/magic-lantern/downloads
http://www.pululahuahostal.com  |  EF 300 f/4, EF 100-400 L, EF 180 L, EF-S 10-22, Samyang 14mm, Sigma 28mm EX DG, Sigma 8mm 1:3.5 EX DG, EF 50mm 1:1.8 II, EF 1.4X II, Kenko C-AF 2X

Mayo

  • New to the forum
  • *
  • Posts: 29
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #128 on: May 23, 2013, 03:23:30 PM »
Yeah, but I want to modify it, to add support for 10bit and 12bit raw. Almost done ;)

dngrhm

  • Freshman
  • **
  • Posts: 83
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #129 on: May 23, 2013, 04:06:50 PM »
Any idea why building is failing for me?

Makefile.user: http://popspring.com/mldrop/Makefile.txt

Output: http://popspring.com/mldrop/mlfail.txt

I didn't see this answered.  I had the same problem compiling on Mac OS X 10.8 using yagarto with version 4.7.2 for 650D with (CONFIG_CONSOLE = y CONFIG_TCC = y CONFIG_MEMCHECK = y CONFIG_MODULES = y CONFIG_PICOC = n).  The error is saying there is no definition for an abort function, which is defined in picoc, but we are excluding that.  The work around I found by googling and searching the forum a bit (to substantiate, not blame for not searching enough) was to add a dummy abort function.  I created a file in the src dir named dummy.c containing the following code:
Code: [Select]
void abort () {return;}I then added dummy.o to ML_EXTRA_OBJS in the Makefile in platform/650D.101.  I'm not sure if this is the correct way to handle this or not, but it worked for me.

I just thought of this as I was looking up the 650D Makefile.  It may be that I'm using and old version of Makefile.user in the top-level directory.  You could try updating from the default and see if that helps.
EOS 650D + 620 | Canon EF-S 18-135mm f/3.5-5.6 STM + 55-250mm f/4-5.6 | Canon EF 50mm f/1.8
Mac OS 10.9 | PinkDotRemoval Tool | RAWMagic | DaVinci Resolve | FCP X

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #130 on: May 23, 2013, 04:58:12 PM »
Quote
the makefile apparently uses mingw, so i'm doing this now).

Only on wintel

CarVac

  • New to the forum
  • *
  • Posts: 12
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #131 on: May 27, 2013, 09:07:57 AM »
REPOSTED (upon request) from raw video post-processing thread:

I may be the only Linux user asking for help but...

I couldn't get the bash script to run; it complained that there was no "raw2dng".

So I realized I needed that program, but when I tried to compile it it needed two headers.

So I grabbed both headers and the makefile and modified the .c file to not look two directories up for the other header, and it still didn't compile.

Then I decided to clone the whole ML Unified branch and build that, but then I realized I needed the gcc-arm-none thing and got that.

Then, it started to compile, but it stopped:

boot-hack.o: In function `my_init_task':
boot-hack.c:(.text+0x544): undefined reference to `_bss_end'
boot-hack.c:(.text+0x548): undefined reference to `_text_start'
boot-hack.o: In function `my_task_dispatch_hook':
boot-hack.c:(.text+0x5f8): undefined reference to `_task_overrides_start'
boot-hack.c:(.text+0x5fc): undefined reference to `_task_overrides_end'
boot-hack.o: In function `copy_and_restart':
boot-hack.c:(.text+0x7e4): undefined reference to `_bss_start'
boot-hack.c:(.text+0x7e8): undefined reference to `_bss_end'
boot-hack.o: In function `my_big_init_task':
boot-hack.c:(.text+0x8d0): undefined reference to `_init_funcs_start'
boot-hack.c:(.text+0x8d4): undefined reference to `_init_funcs_end'
boot-hack.c:(.text+0x8e8): undefined reference to `_tasks_start'
boot-hack.c:(.text+0x8ec): undefined reference to `_tasks_end'
config.o: In function `config_parse':
config.c:(.text+0x2b8): undefined reference to `_config_vars_start'
config.c:(.text+0x2cc): undefined reference to `_config_vars_end'
config.o: In function `config_save_file':
config.c:(.text+0x440): undefined reference to `_config_vars_start'
config.c:(.text+0x444): undefined reference to `_config_vars_end'
config.o: In function `get_config_vars_start':
config.c:(.text+0x538): undefined reference to `_config_vars_start'
config.o: In function `get_config_vars_end':
config.c:(.text+0x544): undefined reference to `_config_vars_end'
config.o: In function `config_var_was_changed':
config.c:(.text+0x590): undefined reference to `_config_vars_start'
config.c:(.text+0x594): undefined reference to `_config_vars_end'
config.o: In function `config_var_restore_default':
config.c:(.text+0x5dc): undefined reference to `_config_vars_start'
config.c:(.text+0x5e0): undefined reference to `_config_vars_end'
property.o: In function `prop_add_internal_handlers':
property.c:(.text+0x1d0): undefined reference to `_prop_handlers_start'
property.c:(.text+0x1d4): undefined reference to `_prop_handlers_end'
collect2: error: ld returned 1 exit status
make[1]: *** [magiclantern] Error 1


Did I try the right things?

How can I get raw2avi to work on linux?

I'm running Ubuntu 13.04 here, and I don't want to dig out my Windows laptop to do this.

DjJuvan

  • New to the forum
  • *
  • Posts: 47
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #132 on: May 28, 2013, 08:18:29 PM »
I don't know if this was mentioned before, but I have a suggestion to add a feature for "backup files" from CF to SD card. This could be very useful if you don't have a lot of high speed CF cards, but you have a lot of SD card storage and you can simply backup everything on this cards. It would take a while to transfer, but it's better than be stuck outside and don't have any other option. ^^'

leefie

  • New to the forum
  • *
  • Posts: 4
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #133 on: May 29, 2013, 06:53:57 AM »
600D / T3i / Kiss something something  :P
I can't get the raw video to create files.
I have 2.3 plus the nightly build (5-29-13) plus the Tragic Lantern build (800 Fileman)
I keep getting "File Create Error" and record doesn't run. I can shoot regular ML video no problem.
I have a fast card (Sandisk Extreme Pro 10).
I've turned off all enhancements and ML options except raw video and set the size to the minimum.
I've also changed RAW to sRAW in the shoot menu.
But just can't get it to shoot video :-(
Have I missed something obvious?
~~~~~~~~~~~~~~~
leefie*

xNiNELiVES

  • Senior
  • ****
  • Posts: 461
  • 5D II, 17-35mm F2.8L, 50mm F1.4, 70-200 F4L
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #134 on: May 29, 2013, 07:23:56 AM »
Yeah, but I want to modify it, to add support for 10bit and 12bit raw. Almost done ;)

Thank you for working on this!

nanomad

  • Administrator
  • Hero Member
  • *****
  • Posts: 2918
  • All your websites are belong to us
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #135 on: May 29, 2013, 07:34:50 AM »
status
make[1]: *** [magiclantern

Did I try the right things?

How can I get raw2avi to work on linux?

I'm running Ubuntu 13.04 here, and I don't want to dig out my Windows laptop to do this.
Make clean and rebuild. It will magically work
EOS 1100D | EOS 650 (No, I didn't forget the D) | Ye Olde Canon EF Lenses ('87): 50 f/1.8 - 28 f/2.8 - 70-210 f/4 | EF-S 18-55 f/3.5-5.6 | Metz 36 AF-5

greeches

  • Just arrived
  • *
  • Posts: 1
  • Fear and Loathing in Raleigh, NC
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #136 on: May 29, 2013, 10:23:38 PM »
I get the module loaded, and the RAW recording menu option is available.

When I hit the "styles" button to setup the recording dimension, I never see the "Start" option and I have small blue dots by the resolution and other options.  When I hit "Live View" it takes me to live view with a box around the resolution I"ve selected.

It never records the raw images.  If I hit record button, it takes h.264 video.

How do you start recording? 

5Dmk2
ML v2.3NEXT
----------------------------------
5Dmk2 550D GH2

RenatoPhoto

  • Moderators
  • Hero Member
  • *****
  • Posts: 1509
  • 5DM3 / 7D
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #137 on: May 30, 2013, 03:02:17 AM »
I get the module loaded, and the RAW recording menu option is available.

When I hit the "styles" button to setup the recording dimension, I never see the "Start" option and I have small blue dots by the resolution and other options.  When I hit "Live View" it takes me to live view with a box around the resolution I"ve selected.

It never records the raw images.  If I hit record button, it takes h.264 video.

How do you start recording? 

5Dmk2
ML v2.3NEXT

1. Right question wrong Board-
2. Search before you Post
3.  Read:
How to record: -- RAW VIDEO ON 5D3 -- 
http://www.magiclantern.fm/forum/index.php?topic=5451.0
.. I know it is not for 5D2 but the ML menu should be similar....

Short Answer:  I think you have not loaded the RAW video module.

The Bad News.  You have read the Forum rules so you are getting a warning.
http://www.pululahuahostal.com  |  EF 300 f/4, EF 100-400 L, EF 180 L, EF-S 10-22, Samyang 14mm, Sigma 28mm EX DG, Sigma 8mm 1:3.5 EX DG, EF 50mm 1:1.8 II, EF 1.4X II, Kenko C-AF 2X

dandeliondandy

  • New to the forum
  • *
  • Posts: 23
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #138 on: May 30, 2013, 07:12:47 AM »
You're actually probably using the module that records by pressing the joystick-like button near the top right of the screen. That's currently what starts and stops the recording, not the LV button or a "start" in the menu, like it used to.

joshmonie

  • New to the forum
  • *
  • Posts: 4
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #139 on: June 02, 2013, 05:04:53 PM »
Hi Guys,

I just want to get it out there that I'm a total newb before I go any further.

Ok, I'm needing some help on installing this all on my 5D2. As far as I'm aware, I download the current stable ML which is v2.3, unzip it and take just the 5D2-212.fir onto the root of my CF. Where do I find the autoexec.bin and ML folder? Can I just use the autoexec.bin and ML folder from a previous build and copy/paste the raw_rec.mo file into where it should be?

I was going to try this but was worried I'd brick the camera so thought I'd get some expert advice first!

Thanks in advance,
Josh

tjobby

  • New to the forum
  • *
  • Posts: 2
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #140 on: June 03, 2013, 11:22:16 AM »
Hello

I have installed ML and the raw video. I can record Raw video and i can see that it is counting the frames. I can see the video i playback under raw in the ML menu.

The problem is that i can not see any of the files that i recorded in windows when i plug the camera ind with USB. I can see the card is not empty but there are no files under DCIM.

lourenco

  • Member
  • ***
  • Posts: 101
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #141 on: June 03, 2013, 01:14:32 PM »

The problem is that i can not see any of the files that i recorded in windows when i plug the camera ind with USB. I can see the card is not empty but there are no files under DCIM.

I normally use a memory card reader to pull the files off the memory card directly. The camera only has USB 2.0 while my card reader is USB 3.0.  I just plug the camera into the computer. I notice it does not show the raw movie files. I am sure it does not show the file given the file type being  raw and not a actual picture. The memory card reader can see all the files fine. I would recommend buying a memory card reader. USB 3.0 if you have USB 3.0 on  your computer. Makes a difference if you have a fast memory card.
5D Mark III, CF Lexar 1000X 32GB, 24-105 F4L

squig

  • Hero Member
  • *****
  • Posts: 518
  • Crash test dummy MK3
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #142 on: June 03, 2013, 01:19:53 PM »

The problem is that i can not see any of the files that i recorded in windows when i plug the camera ind with USB. I can see the card is not empty but there are no files under DCIM.

Doesn't work, even if it did it would be painfully slow. You have to use a card reader.

RenatoPhoto

  • Moderators
  • Hero Member
  • *****
  • Posts: 1509
  • 5DM3 / 7D
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #143 on: June 03, 2013, 01:43:02 PM »
I was going to try this but was worried I'd brick the camera so thought I'd get some expert advice first!

The experts are doing development work so please read:

RAW video & ML -- Beginners Guide, FAQ & Useful Links -- READ FIRST
http://www.magiclantern.fm/forum/index.php?topic=5520.0;topicseen
http://www.pululahuahostal.com  |  EF 300 f/4, EF 100-400 L, EF 180 L, EF-S 10-22, Samyang 14mm, Sigma 28mm EX DG, Sigma 8mm 1:3.5 EX DG, EF 50mm 1:1.8 II, EF 1.4X II, Kenko C-AF 2X

tjobby

  • New to the forum
  • *
  • Posts: 2
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #144 on: June 03, 2013, 02:13:50 PM »
Doesn't work, even if it did it would be painfully slow. You have to use a card reader.

Thanks a lot. Never got a reason for a card reader until now. I just bought one and it worked! Thanks a lot.

Why would it be slower through the camera?

arian_dd

  • New to the forum
  • *
  • Posts: 6
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #145 on: August 20, 2013, 09:18:03 PM »
The experts are doing development work so please read:

RAW video & ML -- Beginners Guide, FAQ & Useful Links -- READ FIRST
http://www.magiclantern.fm/forum/index.php?topic=5520.0;topicseen

The link to "lourenco" 's compiled version of ML for 5D mk III on google drive is empty. Can anyone help me find the latest version of the raw-rec module for 5D mk III? I don't need the 14 stop dual ISO raw feature yet. Thanks.

aargento

  • Just arrived
  • *
  • Posts: 1
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #146 on: August 23, 2013, 06:58:01 PM »
Updated build for 5D3 as of August 21st. Note this only supports 5D3 with 1.1.3 firmware.
https://drive.google.com/folderview?id=0B7QlH_BH2m32Nm9hVHZpVlpCWU0&usp=sharing

prabhath.mp

  • Freshman
  • **
  • Posts: 69
  • Aspire to be - Photographer & Cinematographer
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #147 on: October 05, 2013, 11:52:31 AM »
Hi All,

I just installed the RAW firmware for 550D and I was trying to find a way to decipher the RAW file on Windows 7 and Ubuntu 13.04.

On Windows 7 I installed RAW2DNG.exe but could not find a way to decipher it. When I click on the app, it just runs in Command prompt and closes away in snap.

Could you please let me know if I am doing anything wrong?

Is there any documentation that I could refer? :)

Thanks so much for all your efforts in creating such a beautiful firmware.

Cheers,
Prabhath MP

Bangalore, India
Knowledge enhances by sharing!
Every moment is a new learning experience!!
I use:-Camera: Canon 550D/T2i  Lens: Canon 50mm 1.8 II ; Canon kit (18-55 non IS) ; 55-250 EFS IS ; Macro converter tubes with AF.

prabhath.mp

  • Freshman
  • **
  • Posts: 69
  • Aspire to be - Photographer & Cinematographer
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #148 on: October 05, 2013, 12:17:13 PM »
Hey All,

I found the answer by searching for some information on YouTube :)


Thanks so much.

Cheers,
Prabhath MP
Knowledge enhances by sharing!
Every moment is a new learning experience!!
I use:-Camera: Canon 550D/T2i  Lens: Canon 50mm 1.8 II ; Canon kit (18-55 non IS) ; 55-250 EFS IS ; Macro converter tubes with AF.

teakwood18

  • New to the forum
  • *
  • Posts: 3
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #149 on: October 08, 2013, 09:40:00 PM »
I cant get the Raw_Rec to load.  Am i missing something. Its loaded before, Before my original card(KBay) crashed.  When i tried today arkanoid came up figured out where the module for raw was but it never gave me the raw video any suggestions for what im missing this time around