Author Topic: card won't eject  (Read 2650 times)

jbuy41

  • Freshman
  • **
  • Posts: 94
card won't eject
« on: May 01, 2013, 06:00:04 PM »
My camera is a Canon 550.

Today when putting the SD card in the camera it seemed to drag on something.  Tried another card and it went in but wouldn't stay.

So got a light and looked in card compartment and didn't see anything.  So I took a long needle and pushed the back of where the card goes in and it seemed to click.  Put my card in and it stayed.  Turned camera on and it worked.  However, the card will not eject.  I have to grab it and pull out manully. 

Is this something I can fix or just leave it alone?

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: card won't eject
« Reply #1 on: May 01, 2013, 06:08:12 PM »
If you're comfortable disassembling the camera then yea, you can probably fix it. Mechanics of the slot are messed up, maybe too many insertions?

jbuy41

  • Freshman
  • **
  • Posts: 94
Re: card won't eject
« Reply #2 on: May 01, 2013, 06:54:19 PM »
I'm comfortable take it apart.  Do you know of any step by step directions?

Luv my ML by the way.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: card won't eject
« Reply #3 on: May 01, 2013, 07:00:41 PM »
This guy has some good pics:

http://ghonis2.ho8.com/rebelmod450d4.html

I think covers a bunch of models.

jbuy41

  • Freshman
  • **
  • Posts: 94
Re: card won't eject
« Reply #4 on: May 01, 2013, 07:31:29 PM »
WOW!  This stuff is great. 

Thank you.