Author Topic: Magic Lantern 2.3 does not display crop marks on 550D & 5D MKII  (Read 10504 times)

TogTobias

  • New to the forum
  • *
  • Posts: 11
Magic Lantern 2.3 does not display crop marks on 550D & 5D MKII
« on: October 30, 2012, 06:57:00 PM »
I realize there's a couple posts already out there on this but they're not helpful at all.  The administrator replies are lacking any useful information about the issue.  I know I'm not the only one with this problem based on a quick search on Google.  Let's get this one cleared up concisely please with detailed actionable responses to users having the issue.  Thank you ahead of time.

Upon fresh install of ML 2.3 onto a freshly formatted SD card as per PDF instructions onto a 550D with firmware 1.0.9 installed, everything seems to work just peachy.  Very nicely done work so thank you to all involved!  However, the crop marks do not function.  Validated their placement and file name structure in the folder as delivered with the ML 2.3 update against published PDF instructions on crop mark usage.  All is at it should be according to documentation.  As a test, I copied the crop mark image files into the root folder on the SD card in case there was some kind of read issue as earlier versions of ML simply had crop mark image files dumped into the root.  This doesn't work on the 550D.  Lastly, a repeat process of a fresh install into a fully formatted card was completed and does not resolve the issue either.

Some users have reported pressing various buttons on the camera itself that somehow magically makes the crop marks appear.  I tried this as well to no avail. 

Verified that Global Draw is on in conjunction with Crop Marks set to on (although it reports N/A when set on).  Tested Global Draw in all of its available settings.  Problem persists.

If there is a resolution to this, please let us know and perhaps update the UserGuide PDF to point out specific steps as they relate to getting crop marks to work consistently as in previous version of ML.

Thank you kindly for anyone's help on this issue!  Magic Lantern is an AMAZING tool and I'm a huge fan!

Best,

Tobias

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12297
  • Emergencies only
Re: Magic Lantern 2.3 does not display crop marks on 550D
« Reply #1 on: October 30, 2012, 07:09:23 PM »
N/A is only displayed when there are no cropmarks in the ML/CROPMKS directory. Don't try other directories.

"The administrator replies are lacking" --> this only happens when ML already tells you what do do (in red!!!) but people don't read it.

TogTobias

  • New to the forum
  • *
  • Posts: 11
Re: Magic Lantern 2.3 does not display crop marks on 550D
« Reply #2 on: October 30, 2012, 07:26:00 PM »
The crop mark image files exist in the folder as delivered and as previously noted in the original post.

This was also just replicated on the 5D MKII.  Same process.


In both cases on both models, there was no warning or indication in red on the LCDs giving direction as to what to do next in this case.



nanomad

  • Administrator
  • Hero Member
  • *****
  • Posts: 2918
  • All your websites are belong to us
Re: Magic Lantern 2.3 does not display crop marks on 550D
« Reply #3 on: October 30, 2012, 07:31:36 PM »
Can you upload a screenshot of the root of  sd card and of the content of the ML/cropmks folder?
EOS 1100D | EOS 650 (No, I didn't forget the D) | Ye Olde Canon EF Lenses ('87): 50 f/1.8 - 28 f/2.8 - 70-210 f/4 | EF-S 18-55 f/3.5-5.6 | Metz 36 AF-5

TogTobias

  • New to the forum
  • *
  • Posts: 11
Re: Magic Lantern 2.3 does not display crop marks on 550D
« Reply #4 on: October 30, 2012, 07:44:06 PM »

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12297
  • Emergencies only
Re: Magic Lantern 2.3 does not display crop marks on 550D
« Reply #5 on: October 30, 2012, 07:47:28 PM »
Looks OK. Can you try with some other cards? Make sure they are formatted in the camera.

TogTobias

  • New to the forum
  • *
  • Posts: 11
Re: Magic Lantern 2.3 does not display crop marks on 550D
« Reply #6 on: October 30, 2012, 09:36:31 PM »
Yes.  I can do that in a little while and I will report the findings back.  Thank you!

TogTobias

  • New to the forum
  • *
  • Posts: 11
Re: Magic Lantern 2.3 does not display crop marks on 550D
« Reply #7 on: October 31, 2012, 12:16:11 AM »
Ok guys.  Repeated format and install process on multiple cards, some brand new out of the box.  The issue persists on both the 550D and the 5D Mark II. 

******
Cards Used:

P - LX series 16GB & 32GB Class 10 micro SD cards.

SanDisk Extreme 32GB Class 10 micro SD cards & CF class 10 & 20 cards.

******
Among all of these cards and both camera models the crop mark problem is replicated.  In all cases the overlay options are set to on for Global redraw and crop marks.  The latter reporting "N/A" but with no warning or instruction in red on the LCD screen anywhere as indicated should be there.  Auditing all cards post install shows the folder structure and presence of crop mark images as previously reported.

Please advise.  Thanks for your continued help on this!


Francis

  • Hero Member
  • *****
  • Posts: 818
Re: Magic Lantern 2.3 does not display crop marks on 550D
« Reply #8 on: October 31, 2012, 12:53:16 AM »
Do you see any of the other ML overlays in Liveview or is it just the normal Canon UI? If it is just the normal display, you have to press DISP on the 550D or INFO on the 5D2 a couple of times to turn off all the Canon overlays. Then the ML overlays (including cropmarks) will show up.

TogTobias

  • New to the forum
  • *
  • Posts: 11
Re: Magic Lantern 2.3 does not display crop marks on 550D
« Reply #9 on: October 31, 2012, 01:10:39 AM »
Thank you Francis. 

Yeah, I was thinking that too after I read that in some other stuff I found.  I tried that, as you described, on both cameras and everything else shows up as far as ML overlays go except for crop marks.  Oddly, when you press the "info" button on the 5D MKII it shows you the help about the crop marks which shows the images as thumbs.  I don't know if that info screen is just one image altogether or if it's actually showing thumbs of the crop mark images from the ML folder on the card or not.  You'd know best.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12297
  • Emergencies only
Re: Magic Lantern 2.3 does not display crop marks on 550D & 5D MKII
« Reply #10 on: October 31, 2012, 07:55:36 AM »
Can you check the 8.3 filenames of the ML/CROPMKS directory? I think you can check with Volkov Commander 4.0 (not the latest) - http://vvv.kiev.ua/download/

If the DOS name of the directory is CROPM~1 or something like this, it won't work.

TogTobias

  • New to the forum
  • *
  • Posts: 11
Re: Magic Lantern 2.3 does not display crop marks on 550D & 5D MKII
« Reply #11 on: October 31, 2012, 06:14:09 PM »
Thank you Alex.  Here's the output from one of the cards.


 Directory of Z:\ML\cropmks

12/31/2009  05:00 PM    <DIR>          .
12/31/2009  05:00 PM    <DIR>          ..
07/23/2012  07:08 PM             7,420 CineSco2.bmp
07/23/2012  07:08 PM            11,560 CrssMtr2.bmp
07/23/2012  07:08 PM            19,748 Passport.bmp
07/23/2012  07:08 PM            12,036 PhiPhoto.bmp
07/23/2012  07:08 PM            12,894 PhiVideo.bmp

TogTobias

  • New to the forum
  • *
  • Posts: 11
Re: Magic Lantern 2.3 does not display crop marks on 550D & 5D MKII
« Reply #12 on: October 31, 2012, 06:27:38 PM »
Figured this out guys.  Though I haven't successfully solved it.

Your crop mark documentation states the BMP's are suppose to be OS/2 24 bit upon save.  None of your BMP's are properly formatted.  They are saved as 32bit BMP in 8bit indexed color.  Converting one of them to true RGB color in 8bit mode and saving as a 24bit BMP (via photoshop) makes the file visible in ML.  However the file doesn't display correctly.  That's more of an issue for you guys to resolve but it's evident now what the problem is.

Let me know your thoughts.  Thanks again for your continued help.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12297
  • Emergencies only
Re: Magic Lantern 2.3 does not display crop marks on 550D & 5D MKII
« Reply #13 on: October 31, 2012, 06:38:48 PM »
The 5D2 instructions are old, I remember deleting them, but somehow they came back.

If none of ML BMP's are not correct... how do you explain that everyone else can use them?!

nanomad

  • Administrator
  • Hero Member
  • *****
  • Posts: 2918
  • All your websites are belong to us
Re: Magic Lantern 2.3 does not display crop marks on 550D & 5D MKII
« Reply #14 on: October 31, 2012, 06:50:09 PM »
Uhm, what are you using to read the CF card? Is it a printer? or card reader? I think the files are getting corrupted somehow
EOS 1100D | EOS 650 (No, I didn't forget the D) | Ye Olde Canon EF Lenses ('87): 50 f/1.8 - 28 f/2.8 - 70-210 f/4 | EF-S 18-55 f/3.5-5.6 | Metz 36 AF-5

TogTobias

  • New to the forum
  • *
  • Posts: 11
Re: Magic Lantern 2.3 does not display crop marks on 550D & 5D MKII
« Reply #15 on: October 31, 2012, 06:53:24 PM »
Alex,
    Stop giving me a hard time.  I'm getting irritated at this point with you.  I'm going out of my way to help you guys here and you're acting like I'm a pain in your ass and a moron.  Cut it out. 
    Let's get back to the issue Alex.  Obviously I've demonstrated there's a problem and replicated it with ease across multiple cams and cards with screenshots.  The files are not formatted properly according to your own documentation.  I'm doing my best to help you resolve the issue by taking time away from my own work to help you.  I'm not the only one having this issue.  Maybe others have found a way to make it work or don't have the issue on other models.  I don't know.  The fact at this point is that is does not work in this situation.  I believe I'm working harder than you are to resolve the issue and I didn't even write this stuff.
    Change your tone and show your users some respect.  Thank you.

Tobias

TogTobias

  • New to the forum
  • *
  • Posts: 11
Re: Magic Lantern 2.3 does not display crop marks on 550D & 5D MKII
« Reply #16 on: October 31, 2012, 06:55:34 PM »
Nanomad,
    A card reader.  I've actually used two card readers at this point.  One a stand alone USB type and another a port on our office printer.  I've gotten the BMPs to read on the camera after changing their format upon save but they won't display properly despite now showing up as selections in the ML crop mark menu.

nanomad

  • Administrator
  • Hero Member
  • *****
  • Posts: 2918
  • All your websites are belong to us
Re: Magic Lantern 2.3 does not display crop marks on 550D & 5D MKII
« Reply #17 on: October 31, 2012, 06:56:54 PM »
Alright, I'll test them again but at this point all I can ask you is to send us a binary image of the CF card.
Cropmarks do work fine here (and on other cameras too) so the issue must be on your end ...

edit: actually, you could try one of the latest nightly builds and see if it works there
EOS 1100D | EOS 650 (No, I didn't forget the D) | Ye Olde Canon EF Lenses ('87): 50 f/1.8 - 28 f/2.8 - 70-210 f/4 | EF-S 18-55 f/3.5-5.6 | Metz 36 AF-5

TogTobias

  • New to the forum
  • *
  • Posts: 11
Re: Magic Lantern 2.3 does not display crop marks on 550D & 5D MKII
« Reply #18 on: October 31, 2012, 06:59:13 PM »
Nanomad,
     I'm happy to do that for you.  Can you recommend a tool that you prefer I use to do that?  Thanks again for your help.

edit** ok, great I will try a new build as well.  Thank you again!

nanomad

  • Administrator
  • Hero Member
  • *****
  • Posts: 2918
  • All your websites are belong to us
Re: Magic Lantern 2.3 does not display crop marks on 550D & 5D MKII
« Reply #19 on: October 31, 2012, 07:03:13 PM »
Before doing the disk image thing, could you upload a picture of the cropmarks sub-menu and of the live view screen? Even a crappy phone-quality picture is ok

You can create a disk image using http://www.winimage.com/download.htm
Then you can compress it using winrar or something similar set for maximum compression
Remember to delete any images from the DCIM folder too  ;)
EOS 1100D | EOS 650 (No, I didn't forget the D) | Ye Olde Canon EF Lenses ('87): 50 f/1.8 - 28 f/2.8 - 70-210 f/4 | EF-S 18-55 f/3.5-5.6 | Metz 36 AF-5

nanomad

  • Administrator
  • Hero Member
  • *****
  • Posts: 2918
  • All your websites are belong to us
Re: Magic Lantern 2.3 does not display crop marks on 550D & 5D MKII
« Reply #20 on: October 31, 2012, 07:06:45 PM »
Also: I'll be in the chatroom if you want to join me there and do things in real-time
http://www.magiclantern.fm/forum/chat/index.php
EOS 1100D | EOS 650 (No, I didn't forget the D) | Ye Olde Canon EF Lenses ('87): 50 f/1.8 - 28 f/2.8 - 70-210 f/4 | EF-S 18-55 f/3.5-5.6 | Metz 36 AF-5

Ithaca

  • Just arrived
  • *
  • Posts: 1
Re: Magic Lantern 2.3 does not display crop marks on 550D & 5D MKII
« Reply #21 on: November 01, 2012, 04:13:05 PM »
Hello! I'm having this issue as well, are there any new procedures as yet to resolve?

Many thanks,

JP

jbuy41

  • Freshman
  • **
  • Posts: 94
Re: Magic Lantern 2.3 does not display crop marks on 550D & 5D MKII
« Reply #22 on: November 02, 2012, 11:18:25 PM »
I have a 550D and have no problems with cropmarks.  Using a nightly build at present.  No problem with regual version, execpt with stack focus.  That was posted without a single reply.