Author Topic: Nightly Builds - try the very latest stuff here  (Read 1032203 times)

sparkplug

  • New to the forum
  • *
  • Posts: 8
Re: Nightly Builds - try the very latest stuff here
« Reply #1100 on: November 24, 2015, 07:46:25 PM »
Working with a Canon 5d Mark ii here with 2.1.2 firmware.

A colleague formatted the camera (even though I warned him) and deleted Magic Lantern. I re-installed the nightly build yesterday and it's working fine, but I've no longer got audio on my livescreen view. I can see levels in the audio menu, but not live. Is there a way to change this so I can monitor levels on the fly?

I'd insert an image here, but it's not entirely obvious how to do so on this forum. I just get getting

sparkplug

  • New to the forum
  • *
  • Posts: 8
Re: Nightly Builds - try the very latest stuff here
« Reply #1101 on: November 24, 2015, 11:10:58 PM »
Ok so after recording a clip I now have audio meters on my display. Explain that one?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Nightly Builds - try the very latest stuff here
« Reply #1102 on: November 24, 2015, 11:20:09 PM »
Try to find a way to reproduce, and report an issue.

andrea73

  • New to the forum
  • *
  • Posts: 4
Re: Nightly Builds - try the very latest stuff here
« Reply #1103 on: December 10, 2015, 11:39:43 PM »
I tryed the last nighty build for the canon 5dmk2 but have a problem:

it drain the battery
i used only the dual iso (thats why i download the nighty build) but its off all the time
i tryed to change the powersetting but still same issue

the normal ml its fine

here the link to the discussion i hope in a reply:
https://bitbucket.org/hudson/magic-lantern/issues/2409/6d-battery-drain-issue

this other topic was for another camera:
https://bitbucket.org/hudson/magic-lantern/issues/2417/canon-eos-550d-battery-drain

andrea73

  • New to the forum
  • *
  • Posts: 4
Re: Nightly Builds - try the very latest stuff here
« Reply #1104 on: December 11, 2015, 05:09:17 PM »
Hello again,
sorry for the incovenience ..
yesterday I reinstalled last stable ML but I want to try the dual iso features again .. can someone tell me wich nigthly build for canon 5dmkii can be considerer stable?
I tryed the last but with my camera it drain the battery even when turned off. Thx

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7951
Re: Nightly Builds - try the very latest stuff here
« Reply #1105 on: December 11, 2015, 05:58:22 PM »
Remove ML directory, remove *.FIR, remove autoexec.bin from card. Copy extracted nightly build contents to card.
Remove battery. Insert battery. Insert card. Startup cam. Test.
Before removing card wait for some seconds after opening card compartment door and after LED activity stops.
Report back. If problem persists please give detailed report what you have done so we can reproduce your steps.

The problem with your reports is that there are lots of things you ommited. You may think we (as nerds) are weird but if you tell "I just downloaded the file and did nothing and battery drains." our mind will translate that to:
- Download files
- Do nothing
- Battery drains. Even batteries not inserted into cam are draining. Even batteries inside charger are draining.
Sounds funny, but this is what you described!

You may take it for granted that everybody knows you transferred files to card, inserted the card into the cam, started up the cam, took photos and all. But! We don't have access to your cam, we could not see the steps you take and are absolutely dependend on every single bit of information to reproduce your issue.
So: If the problem persists, try to find the steps it takes for you to reproduce the issue and report them here.

andrea73

  • New to the forum
  • *
  • Posts: 4
Re: Nightly Builds - try the very latest stuff here
« Reply #1106 on: December 12, 2015, 12:59:43 AM »
Ty for the answer.
I did all this step:
download the last nightly built
formatted the card from the camera x2 ( i have 2 cards)
charged the battery for firmware installation
unzip the file and copy all folder and only the 5dmk2 firmware
put the card into the camera
run the firmware upgrade and saw the fix blue light
restart the camera (put off the battery)
set on the camera and navigated into the new menĂ¹ ( i come from the stable version but i unistall it 1 or 2 month ago)
found the dual_iso module and set to on
restart the camera and did some try with dual iso.
saw the battery red the day after in the morning
recharged the battery and another try yesterday night
it drayned the battery from 100% to 80% only whatching the menu .. i took only 2 images .. and while i was writing in this forum another 3% lost without do nothing.
set off the camer, put offf the battery, the monitor was little warm and i put off the card too  same like the monitor bit warm
retryed again with same issue (monitor and card begin warm) so i deleted the ml NB and installed the stable version and stoped drain

Today after i saw your message i tryed the second card and untill now it drain only 1% from the 8 pm (now are 00:25 for me)
psame procedure as you said before:
on camera set to off put off the memory card and the battery
put in the right card with NB in and the battery
set to on
enjoy

 i followed your procedure on the second card, deleted stable ML .. copy the new NB
put off battery .. enjoy





marcfitt

  • New to the forum
  • *
  • Posts: 2
Re: Nightly Builds - try the very latest stuff here
« Reply #1107 on: December 12, 2015, 07:50:42 AM »
Is it only me but I cannot find the raw option in the menu in this build...

Please help.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Nightly Builds - try the very latest stuff here
« Reply #1108 on: December 12, 2015, 07:59:02 AM »
it drayned the battery from 100% to 80% only whatching the menu .. i took only 2 images .. and while i was writing in this forum another 3% lost without do nothing.

If you were looking at the menu, that means both the display and the CPU were active. Guess what - they both need power!

Try doing a controlled test - do the same thing (for example, record video) with both Canon firmware and ML, and compare the battery drain rates. Tip: ML displays it in the Debug menu.

Quote
restart the camera and did some try with dual iso.
saw the battery red the day after in the morning

If the camera started from the first try, this would suggest old battery.
If the camera did not start from the first try (you had to take the battery out), this means incorrect shutdown, or you removed the card too fast.

capnomade

  • New to the forum
  • *
  • Posts: 4
Re: Nightly Builds - try the very latest stuff here
« Reply #1109 on: December 15, 2015, 02:42:08 PM »
Hi and sorry but I d't know where can I put my post...

I've got a problem with installation of Magic Lantern in my 5D Mark II. I did format my card, I cleared all settings, installed the files downloaded in the website written 212 for my camera, I copyed them on my card and then It appears the version is not the good one while tryning to install it on my camera. Do you have any idea to resolve it? Thanks in advance! And I tryed it with two different cards, one 4GB and one 64GB.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7951
Re: Nightly Builds - try the very latest stuff here
« Reply #1110 on: December 15, 2015, 02:48:46 PM »
Format card in camera. Copy Canon's firmware file version 2.1.2 (5D200212.FIR) to card and run firmware upgrade.
Format card in cam again and start ML installation once again. Report back.

capnomade

  • New to the forum
  • *
  • Posts: 4
Re: Nightly Builds - try the very latest stuff here
« Reply #1111 on: December 15, 2015, 03:09:50 PM »
It stils crashed. Saying "Incorrect Firmware version" Expecting a CANON 5D2, with firmware version 212. Please reinstall Canon Firmware 212 even if you already have this version...

capnomade

  • New to the forum
  • *
  • Posts: 4
Re: Nightly Builds - try the very latest stuff here
« Reply #1112 on: December 15, 2015, 03:16:06 PM »
Thanks Walter Schulz. It looks it's working, I downloaded another version on Canon Website with the name you gave me, and it's updating right now! Thanks a million ;)

andrea73

  • New to the forum
  • *
  • Posts: 4
Re: Nightly Builds - try the very latest stuff here
« Reply #1113 on: December 22, 2015, 03:41:02 AM »
Thank you Alex
I dont know what i did wrong the first time and dont know what I did good on second try but now it working good.
When I told you battery drain I mean in 10 minutes the battery come from 100% to 80% without do anything .. I was typing in this forum, but now its working good .. from 15 december untill now it drain only 2% (I think my battery its bit old, 4 years old exactly) with the camera set to off.
Again thank for your good work keep going and happy holydays to all =)

itsDPmikey

  • Freshman
  • **
  • Posts: 74
  • 5D-Cinematography *_*
Re: Nightly Builds - try the very latest stuff here
« Reply #1114 on: February 23, 2016, 01:35:54 AM »
This is strange, I'm constantly getting this "card/camera really exFAT?" error whenever I format card in canon menu in camera(5DM3).

Some other errors i'm getting is "frame skipped, stopping recording" with 1920x808 23.976fps on lexar 1066x 119gb card, and "this card cannot be read remove card 1"

It seems to me that every time I update to a newer build I get more problems with ML.
I love this &^*$ MAN!

dmilligan

  • Developer
  • Hero Member
  • *****
  • Posts: 3218
  • 60Da / 1100D / EOSM
Re: Nightly Builds - try the very latest stuff here
« Reply #1115 on: February 23, 2016, 03:35:30 AM »
You have enabled the option in MLV menu to not split files at 4GB, but this requires an ExFAT formatted card, and your card is not formatted as ExFAT. Depending on card size, Canon firmware might format the card as Fat32 instead of ExFAT. So either turn off this option or use your computer to format the card as ExFAT.

If you encounter a problem when you update to a new build, figure out how to precisely reproduce it, and then go back and try older builds and see if the problem goes away. If it goes away, please report it and tell the builds where it worked and when it started failing, and exactly how to reproduce it. It's very easy to fix issues if you give and exact build when it first broke, and steps to reproduce. Otherwise, if the problem doesn't go away with older builds, well it was there all along, you just haven't encountered it before, and falsely associated the problem with newer versions.

itsDPmikey

  • Freshman
  • **
  • Posts: 74
  • 5D-Cinematography *_*
Re: Nightly Builds - try the very latest stuff here
« Reply #1116 on: February 23, 2016, 08:38:56 PM »
thanks for the response.

My cards are all formatted as exFAT, ALWAYS, I don't format them any other way.

Also the problem(error) is consistent with and without the 4gb split option.

The Problem started to occur with the latest build. So i'm not sure what to make of it..

I'll do as you suggested, reproduce it and maybe capture the error on video.



I love this &^*$ MAN!

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7951
Re: Nightly Builds - try the very latest stuff here
« Reply #1117 on: February 23, 2016, 08:45:50 PM »
A new card, you said? I suggest to make sure it's really the card you ought to buy ...


If on Windows run h2testw. https://sosfakeflash.wordpress.com/h2testw/
If on OS X: Download F3X https://github.com/insidegui/F3X


dmilligan

  • Developer
  • Hero Member
  • *****
  • Posts: 3218
  • 60Da / 1100D / EOSM
Re: Nightly Builds - try the very latest stuff here
« Reply #1118 on: February 23, 2016, 08:54:54 PM »
My cards are all formatted as exFAT, ALWAYS, I don't format them any other way.
I format card in canon menu in camera(5DM3).
These two statements are in direct conflict.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7951
Re: Nightly Builds - try the very latest stuff here
« Reply #1119 on: February 23, 2016, 08:58:10 PM »
On 650D cards > 32 GB will be formatted as ExFAT in the cam. How does 5D3 handle this?

axelcine

  • Member
  • ***
  • Posts: 217
  • Hi, I'm Axel, editor, journalist and photographer
Re: Nightly Builds - try the very latest stuff here
« Reply #1120 on: February 23, 2016, 09:06:02 PM »
Cards 64 and below are fats. 128 and up are exfats. So the bible says.

But...

I just formatted my Lexar Professional 1066x with exFat on my computer just to verify this post and verified it with 'properties' - exFat. And then reformatted in 5dIII.113... Voila. Back to fat32.
EOS RP, 5dIII.113/Batt.grip, 5dIII.123, 700d/Batt.Grip/VF4 viewfinder + a truckload of new and older Canon L, Sigma and Tamron glass

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7951
Re: Nightly Builds - try the very latest stuff here
« Reply #1121 on: February 23, 2016, 09:09:15 PM »
There is always confusion about GiByte and GByte. So I have to ask: Does a "Lexar 128 GB" (as advertised) card fall into first or second category?

axelcine

  • Member
  • ***
  • Posts: 217
  • Hi, I'm Axel, editor, journalist and photographer
Re: Nightly Builds - try the very latest stuff here
« Reply #1122 on: February 23, 2016, 09:23:54 PM »
My humble card says Lexar Professional 1066x 128 GB UDMA 7 with a clapperboard symbol with 65 in it.

I'm low-formatting my 128 with exFat, takes a while, and then I'll reformat in cam. But, hey, I got this idea: Both my SD cards in 5d113 and 5d123 are fats. So maybe the cam formats the CF in accordance with the SD?

I'll put the CF in cam, take out the SD and reformat CF. If exFat is still there, we might have learned something. I'll get back in a minute or so.

OK. Low level formatted and verified exFat with MSI winX/64. Reformatted in 5d123 without SD-card. CF was returned to fat32.

Next I'll try is to format CF as exFat and NOT reformat in cam, and then go out and produce some footage.

Well, I didn't make Steven Spielberg level footage, but the exfatted card works excellently without in-cam formatting and remains exfat. So: On 5d don't format CF in cam if you really don't have to. Put exFat on in PC.

Next I'll be formatting my 64GB with exFat and let it sit in cam w/o formatting away from exFat.

OK. I formatted the CF 64GB I use in 5d123 > exFat. Then I took out the SD-card with ML, reformatted in PC to exfat, reinstalled ML and fir'red the card in cam without in-cam reformatting. Voila: exFat on 32GB 1000x Lexar Professionel 150MB/s SD-card. With ML running as smooth as a new-born shitting in his diapers.

Did the same with my 5d113 including reinstalling settings. SD is still exFat. And works with ML.

So I wonder why the install instructions in the nightlies keep telling us to format in PC, then in cam and then copy ML to the card. IMHO an exFatted card loaded with ML in the PC and fir'red as usual in cam should do the trick - and you'd escape the annoying return to fat32.

EOS RP, 5dIII.113/Batt.grip, 5dIII.123, 700d/Batt.Grip/VF4 viewfinder + a truckload of new and older Canon L, Sigma and Tamron glass

itsDPmikey

  • Freshman
  • **
  • Posts: 74
  • 5D-Cinematography *_*
Re: Nightly Builds - try the very latest stuff here
« Reply #1123 on: February 24, 2016, 05:04:31 PM »
These two statements are in direct conflict.


Point taken. I did not realize that camera formats in 32 and not exFat. I should have known this tho my fault.
but just an FYI I downgraded to 1.1.3 from 03/27/2014 and everything just works BEAUTIFULLY!
I love this &^*$ MAN!

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7951
Re: Nightly Builds - try the very latest stuff here
« Reply #1124 on: February 24, 2016, 05:17:42 PM »
It would be fine telling us if you are now using ExFAT. I take it for granted your previous error was caused by FAT32 file system vs. ML setting exclusive to ExFAT.