Author Topic: Incorrect frame rate after exporting MLV app? Too hasty footage  (Read 980 times)

BasNL

  • New to the forum
  • *
  • Posts: 9
Hello,

I use the anamorphic crop rec version 4k and installed the software on 5d3.
I used to work with the old software versions that were able to export HD.
However when I use the renewed MLV app i experience a strange issue:
the footage seems to play faster than i would expect based on the fps settings: 23.978fps.
To be sure about this, I filmed a clock. The footage showed the slightly higher speed of the footage compared to the real scene.

For example, a footage of 161 dng frames (after exporting lossless or uncompressed dng from the mlv app) results in a hasty presentation and shorther than expected footage length or time. If i divide 161 by the footage length, it results in about 25-26fps instead the desired 23.978 frames.

At first I thought it was an issue of davinci resolve. Within Davinci, I work with the play, export and attribute settings all 23.978fps.
But i noticed that even when i export .mov files from MLV the footages do have the exact same (too short) length as happened in davinci.
so whatever the export type of MLV is, it seems i somehow create footages that are shorter than the originally recorded time and when I play them, things playslightly too fast.

Is it possible the issue is related to the ML software or settings?
I used these settings:
Or do i do something wrong with exporting from MLV.
PS I also tried frame override (checkbox MLV). Didn't help me either.

FYI: I use
- davinci resolve 15
- MLV app
- canon 5d MARK III/3


Many thanks for your help!
Bas

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7362
Re: Incorrect frame rate after exporting MLV app? Too hasty footage
« Reply #1 on: July 30, 2022, 08:50:49 AM »
Provide footage examples showing the issue visually. Test file?

BasNL

  • New to the forum
  • *
  • Posts: 9
Re: Incorrect frame rate after exporting MLV app? Too hasty footage
« Reply #2 on: July 30, 2022, 12:11:57 PM »
@Danne, thank you for your reply.

Can I upload the original MLV file/footage overhere? How does it work?

The software version crop_rec i use is the one of may 2022.
The footage shows 5.19 sec in the MLV app (before exporting), 140 frames.

I already re-installed the ML software but the problem keeps existing.
Still get footages taken at 23.976 that (if i calculate and even leave the very first frame out of the calculation) result in a frame rate of 24,3-26-something (not constant. Every footage results in a different frame rate)(?)

I tried to append an image but how can I share a footage and image overhere?

Many thanks! Bas

theBilalFakhouri

  • UHS-I
  • Developer
  • Hero Member
  • *****
  • Posts: 996
Re: Incorrect frame rate after exporting MLV app? Too hasty footage
« Reply #3 on: July 30, 2022, 12:20:05 PM »
Disable "Card spanning" from RAW video, record some footage, does the problem still exit?
If not, maybe you are not copying RAW video files to the same folder before opening it in MLVApp.

BasNL

  • New to the forum
  • *
  • Posts: 9
Re: Incorrect frame rate after exporting MLV app? Too hasty footage
« Reply #4 on: July 30, 2022, 12:34:49 PM »
@Danne,
I uploaded some footages :
This one is the original footage from the MLV-app (prores)

Here I uploaded several screenshots with settings.


Many thanks again!
Bas

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7362
Re: Incorrect frame rate after exporting MLV app? Too hasty footage
« Reply #5 on: July 30, 2022, 12:40:42 PM »
I'll check later. Thanks.
Meanwhile. Think theBilal... is on to something regarding card spanning.

If on mac I worked out a little proggie which exports from both sd and cf card directly:
https://bitbucket.org/Dannephoto/switch_mini-git/src/master/

Also added all focus pixel maps included those from bilal and the latest 100d presets. Good stuff.

BasNL

  • New to the forum
  • *
  • Posts: 9
Re: Incorrect frame rate after exporting MLV app? Too hasty footage
« Reply #6 on: July 30, 2022, 01:01:33 PM »
@theBilalFakhouri

I switched off card spanning and made another footage filming the iphone-timer.

The footage (without card spanning):

And some extra info about the export via MLV:

@Danne, ps i'm on windows (10/11). and my software card is extreme 45mb/s, 32gb Sandisk

Many thanks,
Bas

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7362
Re: Incorrect frame rate after exporting MLV app? Too hasty footage
« Reply #7 on: July 30, 2022, 01:57:57 PM »
Hard to draw any conclusion without a testfile. Try record a 15s file on a tripod move your hand in front normally. Shutter speed around 50fps. Then upload it here. Use dropbox or similar.

BasNL

  • New to the forum
  • *
  • Posts: 9
Re: Incorrect frame rate after exporting MLV app? Too hasty footage
« Reply #8 on: July 30, 2022, 02:21:34 PM »
I aligned the footages in resolve (23.976 fps)
I noticed the decimals of the timer and after effects differ!
But round numbers (exact whole seconds (1.00, 2.00 etc.)) can be compared! the timer shows decimal seconds and MLV and davinci show frames (I'm sorry i didn't realize!).
It also explains the 'fluctuating frame rate'.

@theBilalFakhouri it seems the card spanning does the job. The hasty effect seems to be gone! You nailed it.

@theBilalFakhouri @Danne Many thanks again!

The footage aligned:


PS I noticed something else when you export the MLV lossless dng's: with card spanning it creates DNG's containing several frames 3-8. Like it contains sub dng's? I had problems with this since in Davinci Resolve every DNG was perceived as a 'clip' of only a few frames. Camera stabilizing and masking therewith was impossible since it can only be applied to a clip. I had to rename the entire batch dng's before importing to davinci.
It costed me another weekend to get this fixed.
However after disabling card spanning, i can use the original mlv export dng's without renaming: Now it is perceived as one big clip. So also this problem "by accident" seems to be fixed!

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7362
Re: Incorrect frame rate after exporting MLV app? Too hasty footage
« Reply #9 on: July 30, 2022, 03:06:52 PM »
Card spanning works when you assemble all recorded material and put them into the same folder prior to opening them in mlv app.

BasNL

  • New to the forum
  • *
  • Posts: 9
Re: Incorrect frame rate after exporting MLV app? Too hasty footage
« Reply #10 on: July 30, 2022, 03:44:21 PM »
@Danne, @theBilalFakhouri,

I now realize I read your answers too fast. So it indeed is still a problem (i tried filming without card spanning but it doesnt work continuously), so I activated card spanning again.

I need to copy all files to another file?
I have the MISC map and the DCIM map on my storage card.
In the DCIM map i have the 100EOS5D and the  EOSMISC map.
On the other card (sandisk) I don't store anything except software and pictures when i take them.

usually i enter the 100EOS5D map and select all separate MLV files and copy them to another map at my desktop.
Then I click on a MLV file so it automatically will be opened in the MLV app.

What do I do wrong overhere?

Many thanks!
Bas

BasNL

  • New to the forum
  • *
  • Posts: 9
Re: Incorrect frame rate after exporting MLV app? Too hasty footage
« Reply #11 on: July 30, 2022, 03:51:38 PM »
@Danne, @theBilalFakhouri,

I now realize I read your answers too fast. So it indeed is still a problem (i tried filming without card spanning but it doesnt work continuously), so I activated card spanning again.

I need to copy all files to another file?
I have the MISC map and the DCIM map on my storage card.
In the DCIM map i have the 100EOS5D and the  EOSMISC map.
On the other card (sandisk) I don't store anything except software and pictures when i take them.

usually i enter the 100EOS5D map and select all separate MLV files and copy them to another map at my desktop.
Then I click on a MLV file so it automatically will be opened in the MLV app.

What do I do wrong overhere?

Many thanks!
Bas

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7362
Re: Incorrect frame rate after exporting MLV app? Too hasty footage
« Reply #12 on: July 30, 2022, 08:08:40 PM »
@Danne, @theBilalFakhouri,

I now realize I read your answers too fast. So it indeed is still a problem (i tried filming without card spanning but it doesnt work continuously), so I activated card spanning again.

I need to copy all files to another file?
I have the MISC map and the DCIM map on my storage card.
In the DCIM map i have the 100EOS5D and the  EOSMISC map.
On the other card (sandisk) I don't store anything except software and pictures when i take them.

usually i enter the 100EOS5D map and select all separate MLV files and copy them to another map at my desktop.
Then I click on a MLV file so it automatically will be opened in the MLV app.

What do I do wrong overhere?

Many thanks!
Bas

Add the files from cf card and sd card into the same folder. Files will be read automated.

BasNL

  • New to the forum
  • *
  • Posts: 9
Re: Incorrect frame rate after exporting MLV app? Too hasty footage
« Reply #13 on: July 30, 2022, 09:23:37 PM »
@Danne,

thank you for your reply!

Does the SD card also contain recording material? I assumed only software.(?)
So the 'software'card (with all the info (autoexec.bin, ML folder etc.) and the maps on the CF card, under which the submap with the MLV files?

I try to understand why this 'software' card is also relevant to undock from the cam and copy all its data to the PC.
The maps on this card hold the same name als on the CF card. Just merge all those maps?

Thank you again for your help.
Bas

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7362
Re: Incorrect frame rate after exporting MLV app? Too hasty footage
« Reply #14 on: July 30, 2022, 09:43:34 PM »
Yes, card spanning also records onto sd-card. That's the way to get some extra speed.

BasNL

  • New to the forum
  • *
  • Posts: 9
Re: Incorrect frame rate after exporting MLV app? Too hasty footage
« Reply #15 on: July 30, 2022, 09:49:50 PM »
@Danne,

immediately tried, again with the timer :)
IT works! Just awesome!

Thank you very much! Much appreciated!

Kind regards, Bas