Author Topic: Quick erase deletes the wrong photo on 60D  (Read 318 times)

oscaro

  • New to the forum
  • *
  • Posts: 2
Quick erase deletes the wrong photo on 60D
« on: November 27, 2021, 04:08:49 PM »
I installed Magic Lantern onto my Canon 60D and it works great! Love it.

Except I notice that when I use quick erase, it deletes the WRONG PHOTO.

For example, say I have 2 photos, A and B.

I'm reviewing photo B after I hit the "play" button and I want to delete it.

I press SET + ERASE and the photo is deleted.

But actually, photo A was deleted! And photo B is still there.

What's going on? Am I using "quick erase" wrong? Is this a known bug?

Anyway, I am no longer using quick erase because it has deleted the wrong photo on a couple different occasions and I no longer trust it. It would be a nice feature to have, but not if it deletes the wrong photo! It does say in the "Quick Erase" settings that "BE CAREFUL WITH THIS". Lol, no kidding!

I did use Recuva to successfully recover my wrongly deleted photos, so nothing of value was lost.

Thanks.


Canon 60D with 1.1.1 firmware
Latest Build (2018-07-02 22:19)
magiclantern-Nightly.2018Jul03.60D111.zip

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8297
Re: Quick erase deletes the wrong photo on 60D
« Reply #1 on: November 27, 2021, 05:07:35 PM »
One of the features I didn't test back then reviewing Camera Help wiki ...
Left a trail of issue reports going through some less frequently used features.
I'm pretty sure "Be careful with this!" had another intention, though.

But it is true: We have some defunct features for ages. Sorry and glad you managed to get your pics restored!

oscaro

  • New to the forum
  • *
  • Posts: 2
Re: Quick erase deletes the wrong photo on 60D
« Reply #2 on: November 28, 2021, 09:48:16 PM »
Thanks for your comment. Possibly it could be a good thing to add to the wiki about this feature.

And no worries about this bug. Magic Lantern is still a great improvement on my 60D!