Author Topic: Magic Lantern for 5D Mark III - Alpha 3 (1.1.3)  (Read 664162 times)

RenatoPhoto

  • Moderators
  • Hero Member
  • *****
  • Posts: 1509
  • 5DM3 / 7D
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #500 on: January 06, 2013, 02:41:22 AM »
I have followed the developer instructions for windows and got the cygwin compiler working but get an error about not having any rule to construct the object. 

I know the risks and since the dev will not provide Alpha 4 I am willing to try to compile it myself
Here is the last of the error.. sorry in spanish

make[1]: *** No hay ninguna regla para construir el objetivo `cygwin/home/PH/arm                                                                                                    -toolchain462/arm-none-eabi/lib/lirm-toolchain46', necesario para `lib_a-setjmp.                                                                                                    o'.  Alto.
make[1]: se sale del directorio `/home/PH/magic-lantern/platform/5D3.113'
Makefile:70: recipe for target `5D3' failed
make: *** [5D3] Error 2
http://www.pululahuahostal.com  |  EF 300 f/4, EF 100-400 L, EF 180 L, EF-S 10-22, Samyang 14mm, Sigma 28mm EX DG, Sigma 8mm 1:3.5 EX DG, EF 50mm 1:1.8 II, EF 1.4X II, Kenko C-AF 2X

Francis

  • Hero Member
  • *****
  • Posts: 818
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #501 on: January 06, 2013, 04:27:23 AM »
Did you change Makefile.user.default to include the path to your ARM compiler?

nanomad

  • Administrator
  • Hero Member
  • *****
  • Posts: 2918
  • All your websites are belong to us
R: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #502 on: January 06, 2013, 04:44:14 AM »
Do not edit the defaults file,  work on Makefile.user instead
There are a few suggestions for Windows developers in the getting started thread
EOS 1100D | EOS 650 (No, I didn't forget the D) | Ye Olde Canon EF Lenses ('87): 50 f/1.8 - 28 f/2.8 - 70-210 f/4 | EF-S 18-55 f/3.5-5.6 | Metz 36 AF-5

Francis

  • Hero Member
  • *****
  • Posts: 818
Re: R: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #503 on: January 06, 2013, 05:54:06 AM »
Do not edit the defaults file,  work on Makefile.user instead
There are a few suggestions for Windows developers in the getting started thread

Since Makefile.user is not included with the source download anymore, Makefile.inc doesn't have the paths that need to be changed anymore, I had been editing the .defaults file. What is the consequence of this? I have never really gotten a mercurial system to work for me so I have just taken to downloading the source tree from bitbucket.

nanomad

  • Administrator
  • Hero Member
  • *****
  • Posts: 2918
  • All your websites are belong to us
R: Re: R: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #504 on: January 06, 2013, 09:57:33 AM »
Since Makefile.user is not included with the source download anymore, Makefile.inc doesn't have the paths that need to be changed anymore, I had been editing the .defaults file. What is the consequence of this? I have never really gotten a mercurial system to work for me so I have just taken to downloading the source tree from bitbucket.

The user file is not downloaded because it's not strictly needed. It's also explicitly not tracked by mercurial for the reasons below.
The build system reads the defaults file first and the overrides it with values taken from the user file.  The benefit is that
- you keep your user settings during updates (the defaults file may change,  your user file doesn't)
- you don't push your settings to the repository. This creates shorter commits and doesn't break the other's developers build environment every other pull
EOS 1100D | EOS 650 (No, I didn't forget the D) | Ye Olde Canon EF Lenses ('87): 50 f/1.8 - 28 f/2.8 - 70-210 f/4 | EF-S 18-55 f/3.5-5.6 | Metz 36 AF-5

RenatoPhoto

  • Moderators
  • Hero Member
  • *****
  • Posts: 1509
  • 5DM3 / 7D
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #505 on: January 06, 2013, 01:13:41 PM »
Thanks for the tips.  I created the Makefile.user and added the path as suggested; did not change the Makefile.use.defaults.  The Mercurial worked and downloaded some 48 megs into Magic-Lantern. 

I can do a" make clean" and then a "make 5D3"  The compiler spits out some information for about a minute and then it ends with the information posted above.  Some error about not finding a rule for constructing the object.

UPDATE:  I changed the language in cygwn LANG=en_US  here are the results:

-------------------------------------

$ make 5D3
make -C /home/PH/magic-lantern/platform/5D3.113
make[1]: Entering directory `/home/PH/magic-lantern/platform/5D3.113'
[ CPP      ]   magiclantern.lds
[ AS       ]   entry.o
[ CC       ]   boot-hack.o
[ AS       ]   stubs.o
[ VERSION  ]   ../../platform/5D3.113/version.c
[ CC       ]   version.o
[ CC       ]   exmem.o
[ CC       ]   bmp.o
[ CC       ]   fio-5d3.o
[ CC       ]   font-dyn.o
[ CC       ]   config.o
[ CC       ]   menu.o
[ CC       ]   debug.o
[ CC       ]   stdio.o
[ CC       ]   bitrate-5d3.o
[ CC       ]   tweaks.o
../../src/tweaks.c:2122:6: warning: conflicting types for 'zoom_trick_step' [enabled by default]
../../src/tweaks.c:1336:9: note: previous implicit declaration of 'zoom_trick_step' was here
[ CC       ]   lens.o
[ CC       ]   property.o
[ CC       ]   propvalues.o
[ CC       ]   gui.o
[ CC       ]   gui-common.o
[ CC       ]   misc.o
../../platform/5D3.113/misc.c: In function 'display_shooting_info':
../../platform/5D3.113/misc.c:67:9: warning: unused variable 'bg' [-Wunused-variable]
../../platform/5D3.113/misc.c: At top level:
../../platform/5D3.113/misc.c:170:6: warning: conflicting types for 'RedrawBatteryIcon' [enabled by default]
../../platform/5D3.113/misc.c:162:5: note: previous implicit declaration of 'RedrawBatteryIcon' was here
[ CC       ]   picstyle.o
[ CC       ]   cfn.o
[ CC       ]   zebra.o
[ CC       ]   shoot.o
[ CC       ]   chdk-gui_draw.o
[ CC       ]   movtweaks.o
[ CC       ]   my_memset.o
[ CC       ]   menuhelp.o
../../src/menuhelp.c:143:6: warning: conflicting types for 'draw_page_number' [enabled by default]
../../src/menuhelp.c:42:29: note: previous implicit declaration of 'draw_page_number' was here
cd ../../doc; python2.6 menuindex.py
Could not open menuindex.txt, will not rewrite help index files
[ CC       ]   menuindex.o
[ CC       ]   focus.o
[ CC       ]   notify_box.o
[ CC       ]   dialog_test.o
[ CC       ]   vram.o
[ CC       ]   aj_port.o
[ CC       ]   lv-img-engio.o
[ CC       ]   fps-engio.o
[ CC       ]   tasks.o
[ CC       ]   tskmon.o
[ CC       ]   state-object.o
[ CC       ]   hdr.o
[ CC       ]   beep.o
[ CC       ]   audio-ak.o
[ CC       ]   vsync-lite.o
make[1]: *** No rule to make target `cygwin/home/PH/arm-toolchain462/arm-none-eabi/lib/libc.a', needed by `lib_a-setjmp.o'.  Stop.
make[1]: Leaving directory `/home/PH/magic-lantern/platform/5D3.113'
Makefile:70: recipe for target `5D3' failed
make: *** [5D3] Error 2

-------------------------------------------

Thanks for all of your replies.

Renato
http://www.pululahuahostal.com  |  EF 300 f/4, EF 100-400 L, EF 180 L, EF-S 10-22, Samyang 14mm, Sigma 28mm EX DG, Sigma 8mm 1:3.5 EX DG, EF 50mm 1:1.8 II, EF 1.4X II, Kenko C-AF 2X

nanomad

  • Administrator
  • Hero Member
  • *****
  • Posts: 2918
  • All your websites are belong to us
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #506 on: January 06, 2013, 02:43:06 PM »
I've pushed a patch for something related. Try pulling and updating your local copy and see if it helps
EOS 1100D | EOS 650 (No, I didn't forget the D) | Ye Olde Canon EF Lenses ('87): 50 f/1.8 - 28 f/2.8 - 70-210 f/4 | EF-S 18-55 f/3.5-5.6 | Metz 36 AF-5

RenatoPhoto

  • Moderators
  • Hero Member
  • *****
  • Posts: 1509
  • 5DM3 / 7D
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #507 on: January 06, 2013, 03:34:46 PM »
Used: hg pull and then hg update

No improvement!

My  Makefile.user is:
ARM_ABI=none-eabi
ARM_LIBC_A=cygwin/home/PH/arm-toolchain462/arm-none-eabi/lib/libc.a
PYTHON=python2.6

I noticed that some instructions say to copy Makefile.user.default and to change the paths.  That file is totally different so which one should I use?

There is also some references to update the path in Makefile.inc and Makefile.user.defaults..  Is this also needed or by using the ARM_LIBC_A=......  is enough to pass all this information to other files.

Thanks
Renato
http://www.pululahuahostal.com  |  EF 300 f/4, EF 100-400 L, EF 180 L, EF-S 10-22, Samyang 14mm, Sigma 28mm EX DG, Sigma 8mm 1:3.5 EX DG, EF 50mm 1:1.8 II, EF 1.4X II, Kenko C-AF 2X

RenatoPhoto

  • Moderators
  • Hero Member
  • *****
  • Posts: 1509
  • 5DM3 / 7D
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #508 on: January 06, 2013, 11:33:51 PM »
Any help?
http://www.pululahuahostal.com  |  EF 300 f/4, EF 100-400 L, EF 180 L, EF-S 10-22, Samyang 14mm, Sigma 28mm EX DG, Sigma 8mm 1:3.5 EX DG, EF 50mm 1:1.8 II, EF 1.4X II, Kenko C-AF 2X

Pelican

  • Contributor
  • Senior
  • *****
  • Posts: 406
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #509 on: January 06, 2013, 11:44:24 PM »
I had a same problem.
Follow my instructions in the starting as a developer topic.
This line is the key:
ARM_LIBC_A=../../../arm-toolchain462/arm-none-eabi/lib/libc.a
You should give a relative path.
EOS 7D Mark II, EOS 7D, EOS 5, EOS 100 + lenses (10mm to 300mm), 600EX, 550EX, YN600EX x 3
EOScard, EOS DSLR firmwares, ARMu, NiControl, etc.: http://pel.hu/down

scrax

  • Contributor
  • Hero Member
  • *****
  • Posts: 1543
  • Code monkey
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #510 on: January 06, 2013, 11:48:01 PM »

I've moved some stuff from the 7D info screen.
Pelican, what are the green boxes for? And the number after the battery?
I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus | EOS 5D MLbeta5- EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX, PS, LR, RawTherapee, LightZone -no video experience-

RenatoPhoto

  • Moderators
  • Hero Member
  • *****
  • Posts: 1509
  • 5DM3 / 7D
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #511 on: January 06, 2013, 11:49:33 PM »
I had a same problem.
Follow my instructions in the starting as a developer topic.

I have gone over it many times.  Cannot solve the problem.

thanks
http://www.pululahuahostal.com  |  EF 300 f/4, EF 100-400 L, EF 180 L, EF-S 10-22, Samyang 14mm, Sigma 28mm EX DG, Sigma 8mm 1:3.5 EX DG, EF 50mm 1:1.8 II, EF 1.4X II, Kenko C-AF 2X

Pelican

  • Contributor
  • Senior
  • *****
  • Posts: 406
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #512 on: January 06, 2013, 11:50:55 PM »
I have gone over it many times.  Cannot solve the problem.

thanks
I've just edited my answer. Read it again.
ARM_LIBC_A=cygwin/home/PH/arm-toolchain462/arm-none-eabi/lib/libc.a
EOS 7D Mark II, EOS 7D, EOS 5, EOS 100 + lenses (10mm to 300mm), 600EX, 550EX, YN600EX x 3
EOScard, EOS DSLR firmwares, ARMu, NiControl, etc.: http://pel.hu/down

Pelican

  • Contributor
  • Senior
  • *****
  • Posts: 406
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #513 on: January 06, 2013, 11:55:47 PM »
Pelican, what are the green boxes for? And the number after the battery?
The green/gray boxes are the battery performance.
The number is the actually used battery from battery history table.
If you register your batteries there are 1-6 battery info in the battery history.
You can see the same info on Battery info menu, but you should navigate through the Canon menu system to see it.
I have 4 batteries and when I put one of them into the camera I can see right then which one is inserted.
EOS 7D Mark II, EOS 7D, EOS 5, EOS 100 + lenses (10mm to 300mm), 600EX, 550EX, YN600EX x 3
EOScard, EOS DSLR firmwares, ARMu, NiControl, etc.: http://pel.hu/down

scrax

  • Contributor
  • Hero Member
  • *****
  • Posts: 1543
  • Code monkey
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #514 on: January 07, 2013, 12:08:37 AM »
The green/gray boxes are the battery performance.
The number is the actually used battery from battery history table.
If you register your batteries there are 1-6 battery info in the battery history.
You can see the same info on Battery info menu, but you should navigate through the Canon menu system to see it.
I have 4 batteries and when I put one of them into the camera I can see right then which one is inserted.

Ok so this is stuff that works only on camera with chipped battery I'm supposing, no XXXD cameras support that.
I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus | EOS 5D MLbeta5- EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX, PS, LR, RawTherapee, LightZone -no video experience-

RenatoPhoto

  • Moderators
  • Hero Member
  • *****
  • Posts: 1509
  • 5DM3 / 7D
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #515 on: January 07, 2013, 02:31:07 AM »
I had a same problem.
Follow my instructions in the starting as a developer topic.
This line is the key:
ARM_LIBC_A=../../../arm-toolchain462/arm-none-eabi/lib/libc.a
You should give a relative path.

Thanks Pelican, that worked!!

Now I can compile the autoexec.bin which I found under \platform\5D3.113

What are the steps to follow?  Since this is not a release the steps are unclear and I do not want to brick my 5D3!

My guess is:

1.  Copy the "5D3-113-bootflag.fir" and the "autoexec.bin" to the CF card.   Does this card have to be 32Gig or less?
2.  Get the ML directory (some where) and copy it to the card.  Where do I get it?  Can I use one of the old ones supplied with Alpha 2?
3.  Install the card and turn camera on.
4.  Rotate your mode dial to Manual (M) position
5.  Restore your camera to default settings (Clear all camera settings)
6. Launch the Firmware Update process.
7.  If all goes well  you see the green confirmation screen, restart your camera. Done

I will wait to confirm these instructions before I do this.

Thanks in advance for all your help.

Renato
http://www.pululahuahostal.com  |  EF 300 f/4, EF 100-400 L, EF 180 L, EF-S 10-22, Samyang 14mm, Sigma 28mm EX DG, Sigma 8mm 1:3.5 EX DG, EF 50mm 1:1.8 II, EF 1.4X II, Kenko C-AF 2X

Pelican

  • Contributor
  • Senior
  • *****
  • Posts: 406
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #516 on: January 07, 2013, 03:40:00 AM »
You should make your card bootable... (EOScard). I used a 16 GB.
EOS 7D Mark II, EOS 7D, EOS 5, EOS 100 + lenses (10mm to 300mm), 600EX, 550EX, YN600EX x 3
EOScard, EOS DSLR firmwares, ARMu, NiControl, etc.: http://pel.hu/down

HotGates

  • New to the forum
  • *
  • Posts: 8
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #517 on: January 07, 2013, 11:28:47 AM »
I read that there is also a multiple exposure feature in ML for the Mark III, as the 5D III already has this feature but where is it in ML? also once the Alpha 4 comes out with focus staking and so on I will donate for sure thanks;)

jodykirton

  • Just arrived
  • *
  • Posts: 1
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #518 on: January 08, 2013, 12:39:04 AM »
Hi Alex/Team,
its been mentioned a few times about either removing the 29min 59sec record limit (which i know youve stated that you dont want to provide that option due to legalities, which is fair enough, but i cant find an option on this ML for my 5D3 for an auto restart.
Is that option available?

The reason why i ask is that i shoot alot of live music performances, aswell as still photography (hence using dslr instead of dedicated camcorders) and sometimes the dslr can be in a place where i cant get to it easily without asking the drummer mid set to stop haha!
I also use a 60d, 600d and 7d for more angles, which i will dl the ML for them too.

Any help would be great!

Oh and ill donate too, great work your doing! this is my first time with ML tonight! :-D

vbcoen

  • New to the forum
  • *
  • Posts: 16
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #519 on: January 08, 2013, 01:24:46 AM »
The auto re-start is a normal Canon function to a max od 30 mins - 1 sec.

See page 232 of the Canon EOS 5D3 manual.

Note that you will lose up to a couple of seconds of video depending on Mem card speed.
5D3, 24 - 105, 16 - 35, Tamron f2.8 70-200, 580Ex II, Yongnuo 622C flash units, Cokin filters

vbcoen

  • New to the forum
  • *
  • Posts: 16
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #520 on: January 08, 2013, 01:27:36 AM »
Ignore previous msg from me.

Total rubbish, well not answering the question.

However, one reason for keeping a time limit is a very serious risk of overheating the sensor.

5D3, 24 - 105, 16 - 35, Tamron f2.8 70-200, 580Ex II, Yongnuo 622C flash units, Cokin filters

scrax

  • Contributor
  • Hero Member
  • *****
  • Posts: 1543
  • Code monkey
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #521 on: January 08, 2013, 01:57:50 AM »
That function will restart recording when it stops without being stopped by you, so if buffer get full or 30min or 4GB file.
Restart means like if you were restarting it right after stop, so you will have gap in the two video (time camera takes to stop a rec and start another).
If you have multiple video sources you can start them at different times, record audio with an external recorder and them mount the clip to cut the gap with other point of view.

However, one reason for keeping a time limit is a very serious risk of overheating the sensor.
Or maybe is just to don't sell it as a camcorder in EU (with different tax rate)
I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus | EOS 5D MLbeta5- EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX, PS, LR, RawTherapee, LightZone -no video experience-

mnteddy

  • New to the forum
  • *
  • Posts: 20
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #522 on: January 08, 2013, 03:52:59 AM »
i cant find an option on this ML for my 5D3 for an auto restart.
Is that option available?
+1 for Auto Restart
 
I'd love to see an auto restart option in ML, even if it means there's a couple second gap between the clips. I've become so accustomed to having auto restart on my ML 60D and T2i. I miss it so dearly.  ::)

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12390
  • Quarantined
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #523 on: January 08, 2013, 09:43:06 AM »
As mentioned a few times, this feature is surrounded by some legal uncertainity. On 5D3 and probably on all DIGIC V cameras, the only purpose of this feature would be to bypass the 30-minute legal limit (because Canon already removed the 4GB one). Bring some lawyers to prove that it's OK, and I'll enable it.

MoiraOBrien

  • New to the forum
  • *
  • Posts: 8
Re: Magic Lantern for 5D Mark III - Alpha 3 + DevKit
« Reply #524 on: January 08, 2013, 07:53:44 PM »
The green/gray boxes are the battery performance.
The number is the actually used battery from battery history table.
If you register your batteries there are 1-6 battery info in the battery history.
You can see the same info on Battery info menu, but you should navigate through the Canon menu system to see it.
I have 4 batteries and when I put one of them into the camera I can see right then which one is inserted.

I can't see a way of registering batteries within Canon menus.  How have you done this?

Moira
5D3, 5D2, 7D
5D3, 5D2, 7D, FCPX