Author Topic: Danne's crop_rec_4k experiments for EOS M  (Read 154785 times)

ctfire

  • Freshman
  • **
  • Posts: 53
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3050 on: August 18, 2021, 06:16:40 PM »
So the test build still causes corrupt frames?
solve the problem when turning on fps override.

ctfire

  • Freshman
  • **
  • Posts: 53
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3051 on: September 24, 2021, 06:21:13 PM »
is it can be any progress yet with  2.8 modes with hdmi out to monitor , or maybe it possible to make 16:9  48fps mode ? In one of old build's i had  once almost perfectly working 16:9 48fps mode

clubsoda

  • New to the forum
  • *
  • Posts: 30
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3052 on: October 04, 2021, 10:39:08 AM »
A test version is up here:
https://bitbucket.org/Dannephoto/magic-lantern_jip_hop_git/downloads/crop_rec_4k_mlv_snd_raw_only_2021Jun26.EOSM202.zip

Might work or might not work better with HDMI out in usage. I added this change according to theBilalFakhouri:
https://www.magiclantern.fm/forum/index.php?topic=25784.msg235805#msg235805

Primarily test hdmi out and see if it gives less corrupted frames in general. If better then go on and test general recordings and check if files are fine as well without hdmi out. Check for focus pixels and other anomalies in the image.


I have used this test build yesterday. I then used the camera to take some pictures in photo mode. I got graphical glitches / pixels in the photos (both jpeg and raw). The Feb04 build seems fine though. I thought i would write it here! Sorry if this has been written / reported before. ;D

ctfire

  • Freshman
  • **
  • Posts: 53
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3053 on: October 05, 2021, 01:38:09 PM »

I have used this test build yesterday. I then used the camera to take some pictures in photo mode. I got graphical glitches / pixels in the photos (both jpeg and raw). The Feb04 build seems fine though. I thought i would write it here! Sorry if this has been written / reported before. ;D

TRY it too, yes there is glitches in photo mode

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7240
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3054 on: October 05, 2021, 02:31:18 PM »
So probably due to changing stream for video mode. Maybe could chnage back to old stream when in photo mode. Very little time for this atm though. Thanks for reports.

0xanon

  • New to the forum
  • *
  • Posts: 6
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3055 on: October 07, 2021, 06:36:26 AM »
Are old binary builds of experimental versions available anywhere? I can only find the 2021 June 26 and February zip files on bitbucket.

And what version would you recommend for shooting 25fps 720p (or downscaled to 720p), from reading the thread it seems that "anamorphic" 1x3 binning would be the best to avoid moiré and to be able to use regular EF-M lenses, so that means shooting 1728 x 2916, the "5K anamorphic" mode and then downscaling to 1280x720? I'll be filming a music concert (with camera on a tripod) so fast preview isn't necessary. (Actually, I don't really need Raw video either, just want to be able to fix any low light problems in post)

Edit: from what I can see, almost everything has been wiped from bitbucket, not just danne's builds? So ML is pretty much dead now? As the only way to try things out is to build from scratch and apply patches, which is difficult to begin with if you are not the original developer, and most documentation and code hints are gone as well?

far.in.out

  • Freshman
  • **
  • Posts: 64
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3056 on: October 07, 2021, 03:55:32 PM »
EOS M (was 600D > 50D)

2blackbar

  • Senior
  • ****
  • Posts: 492
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3057 on: October 08, 2021, 07:22:06 PM »

pjkulev

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3058 on: October 13, 2021, 06:26:27 PM »
Good day to all, I'm new to this forum. I have a question for you, maybe someone came across a similar problem and knows how to solve it. I use canon eos m with the latest release from danne in raw 1280x960 mode with 3x crop mode an aspect ratio of 4:3 and when I open mlv files in the mlv app, there is a strip on the files on top of the frame that bothers me. I am attaching screenshots of the problem
ps there is also a problem in live view in the camera itself, probably somewhere I made a mistake with the settings, I will be glad to any support from you

here the links with images of my problem
( sorry, i dont know how to add images correctly to this forum)
https://ibb.co/vJP7spN
https://ibb.co/4pKhH2q

RhythmicEye

  • New to the forum
  • *
  • Posts: 3
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3059 on: November 20, 2021, 01:22:09 AM »
Tested the previous Feb build. Got dropped frames in 1080 mode.

2.5K/2.8k look good on the monitor as the EOS M Liveview, no purple frame issues on the monitor.

They look nice and clean, although "INFO1" button for framing when connected to the monitor doesn't work. ML Framing doesn't work in general with monitors.

Firstly a big thanks to Danne and all who contribute!

Zeek have you ever experienced this in the 26/06/2021 build (see image)? I've got 2.5k 1:1 Centered HDMI 2.35:1 2520 x 1072 working beautifully now but I get a black bar with a vertical faint red line on the right edge of frame. Am I doing something wrong? I'm using MLV app for post processing.

I'm using a Neewer 5.5" HDMI monitor, nice reference monitor for the price.
https://drive.google.com/file/d/1zghk98pk67xzmD8A_JKC4n7NC9WiYpxP/view?usp=sharing

Update: problem solved - after further testing I discovered this issue is caused by trying to force 24fps in camera. Easily resolved by capturing @23.976 and conforming to 24fps in MLV app
 

ZEEK

  • Senior
  • ****
  • Posts: 329
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3060 on: November 24, 2021, 10:53:11 PM »
Great!
 FPS override doesn't work too well with all modes unfortunately, especially when using monitors. 2.5K HDMI is a nice mode 👌
EOS M

ML700D

  • Member
  • ***
  • Posts: 147
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3061 on: November 25, 2021, 04:07:17 AM »
Great!
 FPS override doesn't work too well with all modes unfortunately, especially when using monitors. 2.5K HDMI is a nice mode 👌

Hi zeek.. I watch some of your video in youtube, you did great footage video. 
EOS 700D

RhythmicEye

  • New to the forum
  • *
  • Posts: 3
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3062 on: November 25, 2021, 04:54:32 AM »
Great!
 FPS override doesn't work too well with all modes unfortunately, especially when using monitors. 2.5K HDMI is a nice mode 👌

Yeah it's my favourite and being able to use FPS override is very useful for keeping audio in sync so it can be used as a guide track without timeline drift. There is a workaround for everything though and 1080 and 5K modes are simply awesome.

Indeed we all owe you a debt of gratitude for your many great videos over the years. Thank you mate, much appreciated.


clubsoda

  • New to the forum
  • *
  • Posts: 30
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3063 on: January 14, 2022, 11:17:24 AM »
Is it possible to recenter the 2k frtp mode? It is one of the most useful but i noticed it is not fully centered on some c mount lenses that i use. When i use the 1080 mode with 3x crop the lens is perfectly centered. In 2k some lens vignette on one side.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7240
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3064 on: January 14, 2022, 09:40:20 PM »
I think so. Not been into modifiyng regs for a while but you could check how it's done following this thread and modify numbers from crop rec sub menu.
Check into @2blackbar here:
https://www.magiclantern.fm/forum/index.php?topic=25781.msg224029;topicseen#msg224029

Nibby99

  • New to the forum
  • *
  • Posts: 5
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3065 on: January 15, 2022, 04:05:21 PM »
@Danne Not sure what the heck might be going on but I had been using the camera successfully with my Feelworld F5 pro and I think the newest crop_rec build for a few months at least. Up until a few days ago I could get 1080p / 2k 1:1 FRTP / 2.5k HDMI /5k FRTP all working properly on the monitor.

I was having some trouble with some settings and I just said, heck with it, I'll reformat the card and reinstall ML. Suffice to say suddenly my 2.5K HDMI and 2K 1:1 modes suddenly on the right half of the screen are distorted and the left side appears squashed but visible? I used the latest build but now I'm wondering if I had some older obscure build on that maybe that is why it was working all this time (as a side not when I first got the monitor even the 1080p live view was freezing, at some point it started working maybe because I tried a later build)
I've posted some screenshots below to demonstrate the issue, so far I've put the latest build on both my EOS-M's and tried two different cables, initially I thought it could be monitor related but I have pretty much ruled that out when I tried hooking it up to one of my Desktop 27" Benq monitors and the distortion is identical on that. 1080P and 5K still show proper on the monitor.

I'm starting to wonder if it's some obscure Canon based setting that might be doing this as I often use the cameras for photography as well with a really old build of ML. I have tried two different SANDisk Extreme Pro 64MB cards and that changed nothing. I'm not familiar with the mechanism by which Magic Lantern loads but from how I understand it it simply sets a boot flag in the firmware of the camera that then points to the SD card to load ML. I was worried that somehow it was keeping a previous setting so I re-flashed the firmware in the canon GUI/camera settings. Basically if I have the newest ML build on the SD card it should only pick up settings from there. I have cleared the cameras settings and custom function settings to no avail. I'm utterly at a loss as to what might be going on. @Zeek had mentioned not to use FPS override or fine tuning but nothing of that is set. Ideas?  ???


Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8257
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3066 on: January 15, 2022, 04:12:14 PM »
Help tab -> Bottom lines
There you will find the version info.
https://wiki.magiclantern.fm/faq#which_magic_lantern_build_is_running_on_my_camera

Nibby99

  • New to the forum
  • *
  • Posts: 5
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3067 on: January 15, 2022, 04:41:45 PM »
Help tab -> Bottom lines
There you will find the version info.
https://wiki.magiclantern.fm/faq#which_magic_lantern_build_is_running_on_my_camera

Thank you, for the likes of me I didn't see that in there. I'm hoping Danne is able to help diagnose my problem with the monitor distortion happening in 2.5K HDMI and 2K 1:1 presets.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8257
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3068 on: January 15, 2022, 05:03:43 PM »
?
All builds have their build information there.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7240
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3069 on: January 15, 2022, 11:40:54 PM »
Sorry. Never use monitors. Try ask ZEEK maybe?

Corallaro

  • New to the forum
  • *
  • Posts: 14
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3070 on: January 19, 2022, 09:31:51 AM »
Hi
I have the same problem of Nibby99 with my new Lilliput A5 with "crop_rec_4k_mlv_snd_raw_only_2021Jun26.EOSM202"
Later i try some old release.
If anyone found a solution.....

Corallaro

  • New to the forum
  • *
  • Posts: 14
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3071 on: January 20, 2022, 10:47:51 PM »
Hi
I have tested "M RAW 2021 JUNE26 Settings.zip" from Zeek (Danne release with Zeek configs) and with 2k preset on external monitor (my Lilliput A5) is ok but 2.5 preset NO.
Then i have tested "EOS-M Zeek Settings [Danne Build FEB04].zip" and with 2.5 k preset is OK.
At this point i will test the "crop_rec_4k_mlv_snd_raw_only_2021Feb04.EOSM202.zip"

ZEEK

  • Senior
  • ****
  • Posts: 329
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3072 on: January 21, 2022, 08:32:12 AM »
At this point i will test the "crop_rec_4k_mlv_snd_raw_only_2021Feb04.EOSM202.zip"

Tap the screen to access quick presets and use 2.5K HDMI Preset. The original 2.5K will cause lots of dropped fames. 5K FRTP or 1080 should be okay too with Danne's latest build. I use the Feelworld F5/F6 Plus and also Portkeys. 2.5K HDMI is my favourite with monitors. 
EOS M

Corallaro

  • New to the forum
  • *
  • Posts: 14
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3073 on: January 21, 2022, 09:07:53 AM »
Many many thanks Zeek,
Later I test it.

Ciao
Giovanni

Corallaro

  • New to the forum
  • *
  • Posts: 14
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #3074 on: January 23, 2022, 01:36:21 AM »
Hi Zeek....
I certainly don't have understand what ho to do and wich release i need to use.
My test is failed.
Can you tell me how to do, step by step?
Many thanks
Giovanni