Author Topic: Danne's crop_rec_4k experiments for EOS M  (Read 85377 times)

benoit

  • New to the forum
  • *
  • Posts: 30
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2850 on: October 23, 2020, 10:37:58 AM »
WHAOU !! Danne thanks a lot, just what I'm talking about in post #4417 !
One month later, you do it !
Congratulations !
David   :D

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7188
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2851 on: October 23, 2020, 11:00:05 AM »
Yes. Still possible to dig out treasures from A1ex code. Uploaded a new build addressing some pink frame issue and a few more fixes.

ZEEK

  • Senior
  • ****
  • Posts: 320
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2852 on: October 23, 2020, 11:03:06 AM »
Congrats! Just tested it, works like a charm. Much more pro-looking now 😎🔥🔥 Cheers 👌
EOS M - EOS M2 - 5D2

benoit

  • New to the forum
  • *
  • Posts: 30
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2853 on: October 23, 2020, 01:49:59 PM »
Yes, one thing for more pro-looking would be to fix the focal equivalent indicator with take in account the speed booster coefficient (1; 0.71; 0.64) and the ratio (sensor resolution / raw recording resulution).
The full real time preview is a revolution on EOSM !
Thanks again.
David

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1859
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2854 on: October 23, 2020, 02:06:01 PM »
Yes, one thing for more pro-looking would be to fix the focal equivalent indicator with take in account the speed booster coefficient (1; 0.71; 0.64)
This is already working. The Viltrox speedbooster converts the lens metadata, so e.g. a 16mm lens @f/2.8 is shown as 11mm f/2.0 on the EOSM screen.
5D3.113 | EOSM.202

ctfire

  • Freshman
  • **
  • Posts: 53
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2855 on: October 23, 2020, 05:45:25 PM »
can't download the last build , the link is broken (

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8072

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7188
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2857 on: October 23, 2020, 06:07:56 PM »
Ah, yes updated the link again. Download should work again.
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

benoit

  • New to the forum
  • *
  • Posts: 30
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2858 on: October 24, 2020, 09:29:22 AM »
@masc yes you 're right about lens conversion. I missed that.
I think it will be better to display to focal equivalent with multiplying with the ratio sensor/raw capture.
Now with my 24mm EF lens on viltrox it displays 17mm eq instead for 2.5K mode : 24x0.71x5184/2500 = 35mm !
Perhaps I missed something again, tell me.
Thanks
David

ctfire

  • Freshman
  • **
  • Posts: 53
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2859 on: October 24, 2020, 12:03:42 PM »
Ah, yes updated the link again. Download should work again.
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959
Now it works , thank you, try to test it today

Kgncom

  • New to the forum
  • *
  • Posts: 18
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2860 on: October 24, 2020, 08:08:04 PM »
Is there MLV pixel maps out for the 5kfrtp mode Yet? Just shot some stuff but realized the built in focus pixel removing tool wasn’t having an effect. My resolution is 1120x1890, should I post a framegrab fo you guys?
70D | EOSM

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7188
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2861 on: October 24, 2020, 08:19:12 PM »
You need the latest map files. Add them inside mlv app.
https://bitbucket.org/Dannephoto/mlv_app_compiler-git/downloads/

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7188
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2862 on: October 24, 2020, 10:01:49 PM »
Yet another build:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

Added 2k 1:1 crop frtp(uncropped realtime preview) built by theBilalFakhouri. Took a while getting ratios working here. Also took a dive to see if I could understand how to exclude bvram cached cropmarks?? 16:9 cropmarks always reappearing after finishing recording. Cannot find out how to exclude them so now I am using some workarounds including clrscr(); and whatnot to ba able and get a somewhat clean 1:1 1920x1280 preview :).

2blackbar

  • Senior
  • ****
  • Posts: 480
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2863 on: October 24, 2020, 10:04:47 PM »
Ill test this build but in one before it i still have problems with full sensor pink frames:
in HD 1080
- turn off aspect ratio so its full sensor recording.
-12 bits
- fps override exact fps 23.976.

I get quite a lof pink frames with that.
no histogram , no digic sharpening etc. just these above changed.
I recorded full sensor quite a bit about year ago, never had so many pink frames.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7188
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2864 on: October 24, 2020, 10:22:29 PM »
Seek what is working. I would not trust fps override with those settings. My suggestion is you test:
1 - Set only to 24 fps in canon menu and leave it there
2 - Try to record with 14bit.
If those settings are working try also 12bit. If still working without corruption it´s time to test to use fps override.

Sorry, I really can´t work with reports what was working a year ago. I just tested and my suggestion 1 and 2 works without corruption. Also 12bit works. Didn´t try fps override cause I know it sometimes fails, sometimes works with crop rec.

if you are having corruption still without fps override enabled let me know as well.

EDIT: Also helps to get sample mlv files to check what was filmed and so on.

EDIT: Tested fps override and still no corrupted frames.

oercruz

  • New to the forum
  • *
  • Posts: 3
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2865 on: October 25, 2020, 02:17:33 AM »
Hi People.
 Im pretty new to ML. Never installed in any camera.
I´ve bought a EOS M to test. But it came with 2.0.3 and I understand theres no build for that FW.
So, I wanted to bother, and ask for guidance.

1. Is there a way to downgrade to 2.0.2?
2. Is there some sort of way to install the ML in 2.0.3?

Thanks in advance for your help.
My goal is to install that too in a 6D, but just after test on EOS M.
Thanks for any possible help!

OC.


Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8072
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2866 on: October 25, 2020, 08:41:17 AM »
1): Via Canon firmware upgrade.
2): Yes, there is a custom build for 2.0.3.
      But newest developments are for 2.0.2 and have not been ported to 2.0.3.

oercruz

  • New to the forum
  • *
  • Posts: 3
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2867 on: October 25, 2020, 05:16:00 PM »
Thanks Walter!
Glad to know that theres both options.
But, as I stated... Im pretty knew to this. Can you point me in the right direction?
Not sure what is the best, as I read you I think it'll be to down grade to 2.0.2 and use the ML to that FW... What do you think?

If thats so... Do you have some info about that way?

Thanks a lot for your help!

OC.

names_are_hard

  • Developer
  • Senior
  • *****
  • Posts: 407
  • 200D idiot
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2868 on: October 26, 2020, 02:28:25 AM »
Yes, you can downgrade to 2.0.2, and this is the best plan for testing ML.  You can always upgrade to 2.0.3 later if you want (this will make ML designed for 2.0.2 stop working).

Download the official Canon "upgrade" for 2.0.2 and install it in the usual way.

vstrglv

  • Member
  • ***
  • Posts: 246
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2869 on: October 27, 2020, 08:42:40 PM »
My test 5k anamorphic frtp 1280X2160, 10bit, Danne's build 2020oct23EOSM202
1. MLVApp 1.11-exposure, contrast, saturation, white balance, Width and Height Stretch -1.0. Exported as ProRes 4444.
2.Topaz Video Enhance Al 1.6.1, Artemis HQ, 200%(2560X4320), png(8bit lossless).
3a Adobe premiere pro v.14.5. Sequence 2560X1440, Scale Height 33.3%, Scale Width 100%. Export 2560X1440
3b Adobe premiere pro v.14.5. Sequence 1920X1080, Scale Height 33.3%, Scale Width 100%. Export 1920X1080. This is 1920x1080 crop from the previous 2560X1440 video.The resolution is good for me. Thank you very much Danne.
Canon 5D3,1.1.3; Canon EOS M,202,  CF-SanDisk Extreme PRO,160MB/s, 256GB, SD-SanDisk Extreme Pro, 170MB/s, 128GB.

Art1203

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2870 on: October 28, 2020, 04:04:55 PM »
So I tried search feature and couldn't find so I'm gonna ask.

Has anyone found out how to get a Canon M50 update to get a clean HDMI out with autofocus and disable the 30 minute timeout

oercruz

  • New to the forum
  • *
  • Posts: 3
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2871 on: October 31, 2020, 05:32:23 AM »
Hi again.
Now, I did managed to downgrade to 202 and I have the ML ready to install. But I read something about ML "persistent changes"... So, I wanted to ask, what means "persistent" specifically.

Seems that ML is more complex to use than I imagined and its taking me a hard time.
Thanks in advance guys.


yokashin

  • Member
  • ***
  • Posts: 116
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2872 on: October 31, 2020, 06:36:09 AM »
70D.112 [main cam] | M.202 | S110 [CHDK]

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8072
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2873 on: October 31, 2020, 07:31:49 AM »
But I read something about ML "persistent changes"... So, I wanted to ask, what means "persistent" specifically.

50D will be enabled to do video. And this will be persistent.

rev787

  • New to the forum
  • *
  • Posts: 6
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2874 on: October 31, 2020, 09:43:23 AM »
Tried dual iso again, but got purple stripes across over exposed sun. Both cr2hdr and mlvapp gave me same result. Is this a known issue?
1 frame sample: https://mega.nz/#!k0JFHAhI!fB0cCZTVDRxPiId9ilx-JvNkWNZPZW1HmWxiCLuEinQ