Author Topic: 5D MKii Won't turn on or off with power swtich but with battery door  (Read 8568 times)

jfro

  • New to the forum
  • *
  • Posts: 4
I've gotten (on occasion) a ML message saying I turned off 5d wrong. 

Now, 100% of time, it doesn't matter which position I have  the on/off switch, the camera is always on when the battery door is closed and it's off when the battery door is open.

I was on a trip (photo only with 5d) and I was able to use it, but I wasn't able to shoot in manual mode and change the fstop with the dial.  Shutter speed works, but not  the fstop.  I usually shoot in manual mode, but for this trip I shot in P mode, and  set the exposure via the menu and then set my shutter speed and let the camera pick the fstop.    It worked, but was a bit cumbersome.

I've tried removing the internal camera battery, and pressed the shutter to drain any left over power.  No help.

I also tired updating from the Flash card and letting it sit for 60 seconds to uninstall ML.

I also put the ML files from my server back on (the files that I saved after the ML update) and did a ML install to no avail and then the ML de-install. 

I also updated firmware with Canons 2.1.2 firmware.

Any help will is  appreciated. 




a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12562
Re: 5D MKii Won't turn on or off with power swtich but with battery door
« Reply #1 on: September 17, 2016, 03:16:21 PM »
Sounds like the on/off switch needs some cleaning.

As a workaround, you can turn off the camera cleanly by opening the card door. Opening the battery door does a forced shutdown (still clean for DryOS, I think, but not for ML).

jfro

  • New to the forum
  • *
  • Posts: 4
Re: 5D MKii Won't turn on or off with power swtich but with battery door
« Reply #2 on: September 18, 2016, 01:54:06 AM »
That was my first thought and it is possible, but I've seen the message about Magic Lantern not being shut down properly a couple times.  Also, not sure the off/on switch being stuck on would explain why my dial doesn't work to change the aperture in manual mode or  other modes, but does work when I'm viewing images. 


I ran the camera this way for 6-7 days at the end of a trip shooting over 1,000 shots. 
 
Today, I tried using the flash card door to shut down the camera.    After about 4-5shots, I got a message saying I couldn't shoot in this mode (auto) and  to turn off the camera.  Tried to shut down with off/on switch to no avail.  Not sure which order, but either used the compact flash door or  the battery door to try to shut down and now I'm bricked.

When I put either a Canon battery in or a clone battery in, my red light flashes and the information on the top led comes up for a few seconds, then blanks and I get an empty flashing battery signal.  Noting works at that point. If I let it sit for a while, camera appears to go to sleep as the battery icon disappears and there is no indication on the camera that anything is working...

Tried removing the internal battery to no avail.  Stumped and maybe hosed....

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12562
Re: 5D MKii Won't turn on or off with power swtich but with battery door
« Reply #3 on: September 18, 2016, 11:20:24 AM »
Hm, so it no longer works? It's probably time to make a copy of your ROM if you didn't already (you'll find it under ML/LOGS on your card).

Then, from a ML card, delete ROM*.BIN from ML/LOGS and start the camera to have them re-created. From your description, I understand the camera internals are running, so this will probably work.

If the logs are not re-created, you may try this dumper: http://www.magiclantern.fm/forum/index.php?topic=16534.0
but I'm not sure it will actually work on a 5D2 (I'll try later).

If that won't work, we'll probably need to use a photodiode to get the current (bad) ROM contents (the CHDK soundcard method).

Once we have a good copy of your ROM, and also the current - probably bad - copy, I can prepare a test binary to check the buttons. These are handled by a separate CPU (aka MPU), so I'll print the events from there, to make sure the hardware is working properly. I'll also be able to run your ROM in QEMU, but this may take a while (I need to implement CF emulation, but I have it half-working).

BTW, turning off the camera by opening the card door is unlikely to have caused bad shutdowns or further problems. I always use this method instead of the power switch, and on 5D2 I believe it's actually safer (see the bug about removing the card too fast - it's impossible to trigger it if you shut down the camera from the card door, and leave the main switch on).

jfro

  • New to the forum
  • *
  • Posts: 4
Re: 5D MKii Won't turn on or off with power swtich but with battery door
« Reply #4 on: September 18, 2016, 06:02:14 PM »
I'm a bit overwhelmed. 

I'm pretty sure this whole episode started by me pulling out the battery or shutting down too soon after taking a photo.

Before my trip, after updating ML on my 5Dmkii, I copied the files from the flash card to my server.  I have since formatted my card (more than once and tried another card) and put the saved files from my servier on them.   

There is no log folder or or ROM.bin that I can find.

When I got back from my trip, I did the load new firmware with ML card in camera and then waited the 60 seconds for it to uninstall (did this twice).    It said to shut the door and  I had  to use my open the battery door method to shut it down. 

I'm 99% sure, I uninstalled ML before the episode of getting a an error message about not saving or writing image to card type message that has now resulted in a few seconds of seeing the correct led messages and then going to the blinking battery frame... 

Appreciate the help, but will need a little more guidance to follow your recovery test. 

Moving on, I quickly read your dumper thread and will re-read it, but right now, not sure  what or how to do that.  I'm not a programmer.

I also don't know what the CHDK souncard method is to ROM contents.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12562
Re: 5D MKii Won't turn on or off with power swtich but with battery door
« Reply #5 on: September 19, 2016, 12:23:41 PM »
When I got back from my trip, I did the load new firmware with ML card in camera and then waited the 60 seconds for it to uninstall (did this twice).    It said to shut the door and  I had  to use my open the battery door method to shut it down. 

After uninstalling ML, it asked you to "shut the door"? Which door? How did the message look like?

Right now, do you have ML installed on the camera? If not, can you access Canon menu to install it?

If you uninstalled ML before getting the error, and you cannot reinstall it, I'm afraid I have no way to execute code on the camera...

jfro

  • New to the forum
  • *
  • Posts: 4
Re: 5D MKii Won't turn on or off with power swtich but with battery door
« Reply #6 on: September 20, 2016, 01:43:56 AM »
After uninstalling it asked me to turn off the camera and since my on/off switch didn't work, (both times) I opened the battery cover to shut down. 

I'm pretty sure ML is not installed anymore. 

I cannot access anything at this point.  The lcd info panel on top right lights up as normal, but just for 2-4 seconds.  Then it goes blank except for a blinking empty battery outline where the battery level is normally shown.

I"m afraid my 5D may be toast.  Any idea what  Canon might charge to fix it in the U.S.A.?


Curt

  • New to the forum
  • *
  • Posts: 4
Re: 5D MKii Won't turn on or off with power swtich but with battery door
« Reply #7 on: July 25, 2018, 06:37:57 AM »
Did you ever get this fixed? I’m having the same issue now.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7879
Re: 5D MKii Won't turn on or off with power swtich but with battery door
« Reply #8 on: July 25, 2018, 09:08:30 PM »
No offense but we had several instances of "I'm having the same issue" being quite different, indeed.
Describe your issue in detail, please.

Curt

  • New to the forum
  • *
  • Posts: 4
Re: 5D MKii Won't turn on or off with power swtich but with battery door
« Reply #9 on: August 03, 2018, 08:11:20 PM »
Excellent point! Here's a quick video of my issue where I try to outline all of it, but if I left any important information, let me know and I'll answer.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7879
Re: 5D MKii Won't turn on or off with power swtich but with battery door
« Reply #10 on: August 03, 2018, 08:19:09 PM »
Remove battery, remove card (if any). Close card compartment door. Insert battery. Close battery compartment door.
Retry and report results.

Do you have ML installed on this cam?

Curt

  • New to the forum
  • *
  • Posts: 4
Re: 5D MKii Won't turn on or off with power swtich but with battery door
« Reply #11 on: August 04, 2018, 12:00:48 AM »
I just did all of that and the result is the same. Any other thoughts?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12562
Re: 5D MKii Won't turn on or off with power swtich but with battery door
« Reply #12 on: August 04, 2018, 09:16:52 AM »
I believe the power switch is just stuck in the "on" position. This has nothing to do with ML; it's a hardware issue (a minor one, in my opinion). You can still turn off the camera by opening the card door.

On 5D2 it's actually safer that way. The camera will no longer wake up when you open the card door, so you no longer need to wait 5 seconds before removing the card. If you turn off the camera by opening the card door, you can remove the card as soon as the LED stops blinking.

Curt

  • New to the forum
  • *
  • Posts: 4
Re: 5D MKii Won't turn on or off with power swtich but with battery door
« Reply #13 on: August 04, 2018, 09:46:30 PM »
I opened the back of the camera and I can se that the switch is functioning properly. Any thoughts on how to make it work right?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12562
Re: 5D MKii Won't turn on or off with power swtich but with battery door
« Reply #14 on: August 05, 2018, 07:35:08 AM »
How exactly did you see that it's working properly?

This switch is connected to the MPU (a secondary processor that handles all button events, including the power switch, card and battery doors, and forwards them - well, only some of them - to the main CPU). Were you able to identify this connection and measure the signal(s) from the power switch?

To debug at software level:
- https://www.magiclantern.fm/forum/index.php?topic=7531 (get a log from the TXDMPU pin, likely some UART). I'd expect it to print something when buttons are pressed (based on firmware strings), but I've never seen how exactly this log looks like.
- if that log is not enough, we may need to learn to program the TX19A MPU (documentation available, but very time consuming) and modify its firmware to get more detailed logs.

Caveat: I've never tried to debug a dSLR at hardware level (never opened one), so take the above with a grain of salt.

cosmo.lv

  • New to the forum
  • *
  • Posts: 26
Re: 5D MKii Won't turn on or off with power swtich but with battery door
« Reply #15 on: March 30, 2019, 11:07:06 PM »
Hi there on old topic, i got the same problem and it is nothing to do with ML. Still digging on that Switch always on and no matter it is on or off. I even change whole ribbon cable with switch and problem is still there. I presume there are some hardware issues. Maybe ribbon cable connector on Main board or some problems with Power board. I checked all Fuses there and they are ok - "i think i checked all of them"

So... Have the author "jfro" solved it and where are the problem? Will be nice to know because i cannot get it to work. :(
5D Mark II

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12562
Re: 5D MKii Won't turn on or off with power swtich but with battery door
« Reply #16 on: March 30, 2019, 11:28:39 PM »
May I ask what problem you have? What are the symptoms?

Reason: in the past, when other user said "I have the same problem", in about 90% of cases they had a different problem.

n8

  • Just arrived
  • *
  • Posts: 1
Re: 5D MKii Won't turn on or off with power swtich but with battery door
« Reply #17 on: December 17, 2019, 03:20:33 PM »
I've been searching the web trying to find a solution to this problem. I'm experiencing the same issue as described by the OP:
  • Using Canon 5D Mark II
  • Using Firmware 2.1.2
  • Camera remains on even after switch is turned off
  • Tried troubleshooting steps mentioned here to include removing battery and card, reformatting, cleaning switch.

Has a solution been found?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12562
Re: 5D MKii Won't turn on or off with power swtich but with battery door
« Reply #18 on: December 17, 2019, 06:09:33 PM »
You may use this to see if the camera reacts to the power switch at all:
https://builds.magiclantern.fm/jenkins/view/Experiments/job/startup-log-mpu/

Other than that, probably a multimeter could tell more. I didn't disassemble a 5D2 myself, so I'm not sure what's the expected state of that button, or where exactly it's wired, but others did. If you can take a few high-res pictures of the switch internals and the cable, I might be able to tell you more.

But if the camera is working properly, except for the power switch, I'd recommend leaving it alone (details on reply #12).