Author Topic: My new 50D does not work like my old 50D! Please help me!  (Read 1275 times)

EVZML

  • New to the forum
  • *
  • Posts: 39
My new 50D does not work like my old 50D! Please help me!
« on: June 09, 2019, 12:05:36 AM »
Hello,
I'm not sure if this is the right part of the forum or not. If not, please move to the right place!

So.. I was using my Canon EOS 50D for shooting photos for 4 years now, with Magic Lantern.
2 Weeks ago, my camera was stuck on a Error which is expensive to repair, so I bought another used 50D from a photo store for 150€. The camera looks nearly new and shutter count is only 10.000.

I have 2 problems with this 50D, and I'm not sure if the problem is the 50D itself, or just a setting problem, or maybe because this 50D does not have Magic Lantern.
My old 50D had Magic Lantern and it was perfect, the "new" (but used) 50D does not have Magic Lantern installed.

So here are my 2 problems.

Problem 1 (and this is the big problem):
90% of the time, the LiveView shows exactly what the photo will be looking like.
But in 10% of the time, the LiveView shoes a much much different lightning.
For example:
I use the LiveView to set my brightness (aperture, exposure time, ISO), then I switch to Viewfinder, make some photos using Viewfinder, and look at the photos if everything is right.
In 10% of the time, I see a super bright view in the LiveView, but the photo is very very dark.
I have set all settings to the same as my old 50D, so I can not explain it to myself, why this happens.
Does anybody has a idea?!
Does Magic Lantern has something to do with a better LiveView?! But I also have one of these cheap 1200D (a very basic Canon DSLR), and even this camera always shoes the exact image in LiveView, and it also does not have Magic Lantern installed.

Problem 2:
Sometime I try to make a photo, but the shutter does not make the photo. It doesn't even focus.
First, I thought it's a focus problem.
But know I have the idea, that maybe just the shutter button doesn't work as easy as my old one and maybe I need try to press it harder.
I definitely need to test this first.
But my question is, does Magic Lantern has a function that let the camera focus better?

Sorry that my english is not the best, I'm from Germany.

I'm very thankful for every help!
Appreciate every tip.

Thanks!

EVZML

garry23

  • Contributor
  • Hero Member
  • *****
  • Posts: 2218
Re: My new 50D does not work like my old 50D! Please help me!
« Reply #1 on: June 09, 2019, 06:59:38 AM »
It's not clear if you have loaded ML on your second 50D.

It sounds if you are setting exposure by looking at LV. If you are, don't.

Do you have back button focus set up? If not, then set it up ;-)

russellsnr

  • Member
  • ***
  • Posts: 148
Re: My new 50D does not work like my old 50D! Please help me!
« Reply #2 on: June 09, 2019, 09:33:23 AM »
Hello,
I'm not sure if this is the right part of the forum or not. If not, please move to the right place!

So.. I was using my Canon EOS 50D for shooting photos for 4 years now, with Magic Lantern.
2 Weeks ago, my camera was stuck on a Error which is expensive to repair, so I bought another used 50D from a photo store for 150€. The camera looks nearly new and shutter count is only 10.000.

I have 2 problems with this 50D, and I'm not sure if the problem is the 50D itself, or just a setting problem, or maybe because this 50D does not have Magic Lantern.
My old 50D had Magic Lantern and it was perfect, the "new" (but used) 50D does not have Magic Lantern installed.

So here are my 2 problems.

Problem 1 (and this is the big problem):
90% of the time, the LiveView shows exactly what the photo will be looking like.
But in 10% of the time, the LiveView shoes a much much different lightning.
For example:
I use the LiveView to set my brightness (aperture, exposure time, ISO), then I switch to Viewfinder, make some photos using Viewfinder, and look at the photos if everything is right.
In 10% of the time, I see a super bright view in the LiveView, but the photo is very very dark.
I have set all settings to the same as my old 50D, so I can not explain it to myself, why this happens.
Does anybody has a idea?!
Does Magic Lantern has something to do with a better LiveView?! But I also have one of these cheap 1200D (a very basic Canon DSLR), and even this camera always shoes the exact image in LiveView, and it also does not have Magic Lantern installed.

Problem 2:
Sometime I try to make a photo, but the shutter does not make the photo. It doesn't even focus.
First, I thought it's a focus problem.
But know I have the idea, that maybe just the shutter button doesn't work as easy as my old one and maybe I need try to press it harder.
I definitely need to test this first.
But my question is, does Magic Lantern has a function that let the camera focus better?

Sorry that my english is not the best, I'm from Germany.

I'm very thankful for every help!
Appreciate every tip.

Thanks!

EVZML
It sounds as like Garry23 has said except for the shutter button not focusing that the camera has already been set up for back button focus and that is why the shutter button will not focus first then take an image. Russ.

garry23

  • Contributor
  • Hero Member
  • *****
  • Posts: 2218
Re: My new 50D does not work like my old 50D! Please help me!
« Reply #3 on: June 09, 2019, 09:54:23 AM »
Just to reenforce my quick post.

Never use LV to set exposure. Best to use the histogram and second best the Canon exposure meter.

Of course, THE best approach is to use ML’s ETTR + ML’s RAW histogram + ML’s RAW spotmeter, all tuned to your needs.

Splitting off focus setting from the shutter button, ie by using BBF, is another no brainier IMHO.

Bottom line: get a new camera and put ML on your latest 50D  ;) :)