Author Topic: Help 5Dm2 stills focus is soft!!  (Read 179 times)

vudiemphuongchi

  • New to the forum
  • *
  • Posts: 1
Help 5Dm2 stills focus is soft!!
« on: April 18, 2019, 05:04:05 PM »
Hello,

I am not sure what could be the problem, but it seems that whenever I start my camera with ML I get soft focus in my still shots. Regardless if I am on a tripod or handheld and shooting moving or still subjects  my focus is somewhat soft and whashed out. This is particularly visible in the eye shots.

My kit: 5dm2 with 24-105 L and 70-200 L f4 lenses. I am shooting raw.  I have micro adjusted lenses as they were a bit back focusing.

Initially I blamed my technique and followed a bunch of guides on getting sharp focus. Nothing helped, so I've read about problems with canon 5dm2 and some people were having soft focus issues. However, I've seen enough shots on the net and from my friends 5d mark 2 to think that its probably not the cam. I then blamed the lens, but after some research it also seems unlikely.

So, yesterday I started the cam without ML (for the first time since buying the cam) and wow! A perfectly sharp and crisp focus from the first time. So, I went and made a few shots of moving things like bees and stationary objects like brick walls. The result is I seems to get soft focus images when cam is running ML and pretty sharp focus without ML.

I am using default ML settings apart from enabling raw video v2 module.

Could someone point me in the right direction please. I would like to continue using ML as it has tons of cool features but I need to correct the soft focus issue.

Thanks for any tips.

whitelight

  • New to the forum
  • *
  • Posts: 39
Re: Help 5Dm2 stills focus is soft!!
« Reply #1 on: April 18, 2019, 10:51:30 PM »
Hi, I would start with reinitializing Canon settings and then proceed to load ML modules one at a time testing the outcome before and after every new module load. But that´s just my non-expert advice, don`t know if it makes sense

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12171
  • Maintenance mode
Re: Help 5Dm2 stills focus is soft!!
« Reply #2 on: April 18, 2019, 11:46:54 PM »
Focus in photo mode happens on the MPU (i.e. a secondary CPU that's not under our control). It doesn't even care about what the main CPU is doing - even if it's locked up, autofocus would still work as usual.

Other than AF microadjustment (which is only done if you load the dot_tune module and run the calibration procedure, and operates only on the settings available in Canon menu), ML has absolutely no way to influence the autofocus process in photo mode (outside LiveView). We simply cannot change its speed or other parameters without reprogramming the MPU or modifying the EEPROM contents (and we don't do any of these at the time of writing).

Therefore, unless you can provide a clear proof that ML is causing autofocus problems in photo mode, I believe the issue is... placebo.