Author Topic: 650d Noise Artifacts  (Read 663 times)

croxxingphotography

  • New to the forum
  • *
  • Posts: 5
650d Noise Artifacts
« on: January 24, 2019, 05:20:05 PM »
Hello

My previous post has been awaiting approval for several days so I'm posting again hoping this will be approved. These large dashes appear when shooting in low light and cannot be removed using ACR. They are not dead pixels as they change from frame to frame. Can someone enlighten me on what they are and how they can be removed? I'm using Mac. Thank you!




Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6790
Re: 650d Noise Artifacts
« Reply #1 on: January 27, 2019, 03:26:56 PM »
Sample, please!
And some details about settings and postprocessing
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

croxxingphotography

  • New to the forum
  • *
  • Posts: 5
Re: 650d Noise Artifacts
« Reply #2 on: February 03, 2019, 09:05:32 AM »
Sorry, meant
sample = footage (unprocessed)

Oh thanks for replying so quickly :D I actually figured out what caused the problems after typing my previous post. It's the 2x2 chroma smoothing in MLVFS... it removes the focus dots, but introduces artefacts in low light shots. The MLV file can be found at https://www.dropbox.com/sh/33i9w17kbtbqtky/AABrvhT2hahqoiJ9ia3UzPSya?dl=0.

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1271
Re: 650d Noise Artifacts
« Reply #3 on: February 03, 2019, 12:01:46 PM »
Do you have the right focus pixel maps installed for MLVFS? MLVApp seems to have them included (in code), because I don't see such artifacts when opening the clip with it. No need for Chroma Smooth. And Chroma Smooth 2x2 won't clean focus dots (as far as I know), you need at least 3x3. On the other side, the artifacts you showed with your picture do not look like focus pixels.

5D2.212 | EOSM.202

croxxingphotography

  • New to the forum
  • *
  • Posts: 5
Re: 650d Noise Artifacts
« Reply #4 on: February 03, 2019, 04:08:01 PM »
Do you have the right focus pixel maps installed for MLVFS? MLVApp seems to have them included (in code), because I don't see such artifacts when opening the clip with it. No need for Chroma Smooth. And Chroma Smooth 2x2 won't clean focus dots (as far as I know), you need at least 3x3. On the other side, the artifacts you showed with your picture do not look like focus pixels.



Honestly I'm not too sure about the focus pixel maps, I just downloaded the OSX version of MLVFS from the website. The developer did say that 2x2 chroma smoothing can remove the focus dots and it worked for my previous videos. But it seems to introduce the artifacts which are not focus/dead/hot pixels in low light shots. mlv_dump with 2x2 chroma smoothing works fine, but I prefer MLVFS because it results in a faster workflow.

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3718
Re: 650d Noise Artifacts
« Reply #5 on: February 03, 2019, 05:27:31 PM »
Definitely a problem in MLVFS. I didn't get many 650D samples when working on the map files and assumed that it would be the same as the 700D.





There may be other issues coming into play here. What build was used? I believe that some versions had a bug where the crop/pan metadata sometimes slipped.

I won't be able to get to this today but in the meantime, try shooting another test with the latest crop_rec_4k build from the experiments download page.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3718
Re: 650d Noise Artifacts
« Reply #6 on: February 03, 2019, 10:23:55 PM »
Mystery solved, my map files are fine but the files that ship with MLVFS are outdated.

I keep a full set of map files in the ML Focus Pixels project repository. You can either pick and choose the ones you want, this is one is 80000301_1808x1189.fpm or you can download the entire repository via the downloads page.



Put them in your working MLVFS package. On a Mac you'll find it in ~/Library/Services/MLVFS.workflow/Contents or just Control click on the app icon and pick "Show package contents" then go into the Contents folder.

There is a pull request I submitted over a year ago to get these into MLVFS but the developer hasn't merged them in yet. I think it was because some of the resolutions I was supporting were still rather new. Today we're still in the same situation with even more new resolutions showing up almost daily.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

croxxingphotography

  • New to the forum
  • *
  • Posts: 5
Re: 650d Noise Artifacts
« Reply #7 on: February 04, 2019, 01:40:18 PM »
Mystery solved, my map files are fine but the files that ship with MLVFS are outdated.

I keep a full set of map files in the ML Focus Pixels project repository. You can either pick and choose the ones you want, this is one is 80000301_1808x1189.fpm or you can download the entire repository via the downloads page.



Put them in your working MLVFS package. On a Mac you'll find it in ~/Library/Services/MLVFS.workflow/Contents or just Control click on the app icon and pick "Show package contents" then go into the Contents folder.

There is a pull request I submitted over a year ago to get these into MLVFS but the developer hasn't merged them in yet. I think it was because some of the resolutions I was supporting were still rather new. Today we're still in the same situation with even more new resolutions showing up almost daily.

Thank you for your help! I just tried and the artifacts are still there :(