Author Topic: Canon 650D and firmware 1.0.5  (Read 1331 times)

pol99

  • Just arrived
  • *
  • Posts: 1
Canon 650D and firmware 1.0.5
« on: October 03, 2018, 03:22:16 PM »
Dear sirs,

I have a Canon 650D but with original firmware 1.0.5 (not 0.4 as your requirements tutorial)

The question is..

Do you know if there's any problem if I update to Magic Latern with 1.0.5 firmware?

We'll keep in touch,
POL

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6873
Re: Canon 650D and firmware 1.0.5
« Reply #1 on: October 03, 2018, 06:12:02 PM »
Please lookup the meaning of the word "requirement".
Follow instructions on
Top of page -> Downloads -> Download nightly builds -> 650D / Rebel T4i 1.0.4 -> Installation

Or visit dfort's repository where you will find a build for 650D.105:
https://bitbucket.org/daniel_fort/magic-lantern/downloads/
Pro: Works
Con: No participation in experimental builds without downgrading to 1.0.4
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

saulbass

  • Freshman
  • **
  • Posts: 86
Re: Canon 650D and firmware 1.0.5
« Reply #2 on: October 03, 2018, 06:20:36 PM »
Depending on your requirements it's very easy to switch between 104 and 105 firmware on the 650D - either stay conservative and use 104 or if you want to try other more experimental builds try 105. I'm back on 104 - functionally there's very little difference between stock 104 and 105.

Photographybyjameswood

  • Just arrived
  • *
  • Posts: 1
Re: Canon 650D and firmware 1.0.5
« Reply #3 on: January 05, 2019, 06:05:40 PM »
So if I am using 1.0.5 then I just "update" to 1.0.4 as if it's a higher firmware?