Author Topic: Danne's crop_rec_4k, 5DIII  (Read 166223 times)

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7236
Re: Danne's crop_rec_4k, 5DIII
« Reply #950 on: July 09, 2021, 06:40:47 AM »
Why 2:1 ratio? Don't touch the ratios from raw video menu. Instead use the presets from crop rec sub menu. Under raw menu out ratios to max if set to off in crop rec menu.

Please test to see if other ratios works for instance 2:39.1 etc.
Always seek what's working and then try to find a breaking point from there.

stef7

  • New to the forum
  • *
  • Posts: 13
Re: Danne's crop_rec_4k, 5DIII
« Reply #951 on: July 09, 2021, 07:57:06 AM »
Always used 2:1 ratio. And until recently it worked without any problem
Here is a test with 2.35:1 ratio set in presets:

https://ibb.co/SB4jt9B
https://ibb.co/XzWNQDc

Still bad. Thought that breaking point is card spanning. But it's not.  Tested 3K crop, anamorphic 2.35:1 ratios.  All bad even when using only the CF card
Only 1080p normal mode works OK.
It's really strange. Will try to reset everything later and start again from scratch. 

P.S. Will wait some time to clear my head, then reset everything and start from scratch.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7236
Re: Danne's crop_rec_4k, 5DIII
« Reply #952 on: July 09, 2021, 02:40:59 PM »
Might be your card reader. Transferring issues.

wib

  • Member
  • ***
  • Posts: 116
Re: Danne's crop_rec_4k, 5DIII
« Reply #953 on: July 09, 2021, 03:06:27 PM »
Be sure to use a fast reader, at least USB 3.0 and "UDMA7 cards" compatible.
EOS 5D3 123 crop_rec_4k_mlv_snd_isogain_1x3_presets_2020Dec11.5D3123

stef7

  • New to the forum
  • *
  • Posts: 13
Re: Danne's crop_rec_4k, 5DIII
« Reply #954 on: July 09, 2021, 04:10:24 PM »
You are absolutely right ! Nothing wrong with recording. It played OK in camera, no damaged frames. Card reader is OK actually, when plugged to a fast USB 3.0 port it works OK
Problem was when card reader was on a slow USB2 port. Never had a problem with this USB 2 port. It was slow but worked.
 
Anyway, thanks for the help and apologies for bugging you with something that is way off ML
But sometimes it's just a bad day and my brain doesn't work as it should :)

By the way with kill global draw 3584x1730 (2:1 my favorite ratio) at 10 bit recording times are excellent. Way more that expected !
Again thanks a lot for your work and help.


wib

  • Member
  • ***
  • Posts: 116
Re: Danne's crop_rec_4k, 5DIII
« Reply #955 on: July 09, 2021, 04:43:23 PM »
I do the same, 2:20 ratio, 14bits lossless in raw menu and 10 bits in movie menu (I guess it override ?) 3.5K in 3584x1630 with kill global draw option, card spanning and sd overclocked, it's marvelous.
EOS 5D3 123 crop_rec_4k_mlv_snd_isogain_1x3_presets_2020Dec11.5D3123

kpn

  • New to the forum
  • *
  • Posts: 8
Re: Danne's crop_rec_4k, 5DIII
« Reply #956 on: July 18, 2021, 02:13:31 PM »
Amazing work Danne, the anamorphic 5.5k preset is great!
Just a one small request, is it possible to format the card yet keep the Magic Lantern as in the nightly builds?

wib

  • Member
  • ***
  • Posts: 116
Re: Danne's crop_rec_4k, 5DIII
« Reply #957 on: July 18, 2021, 03:55:38 PM »
that would help also the bug on mac catalina with the folder’s « bit »
EOS 5D3 123 crop_rec_4k_mlv_snd_isogain_1x3_presets_2020Dec11.5D3123

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7236
Re: Danne's crop_rec_4k, 5DIII
« Reply #958 on: July 18, 2021, 04:21:35 PM »
Conflict when sd_uhs patch is used when formatting. Sorry, won't change back.
If someone adds a safeguard turning off sd_uhs patch selecting format it could be an option added.

Peperoros

  • New to the forum
  • *
  • Posts: 10
Re: Danne's crop_rec_4k, 5DIII
« Reply #959 on: July 19, 2021, 04:20:00 PM »
I ran into the problem with flickering when using this build, anamorphic 1:3 binning, 14bit, dual iso, v1.2.3. If I have understood this correctly, it's the dual iso that's the culprit.
ONLY happened when I recorded clouds. Several recordings between are all normal.

https://streamable.com/8vp8z4

I'm unsure if this is the correct thread to report this. Saw that there was flickering reported for the eos-m version of this build, so I'm hoping I'm not mistaken.

Digidagi

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k, 5DIII
« Reply #960 on: September 09, 2021, 01:06:54 PM »
Hey everyone,
I've been following and experimenting with magic lantern for a while. Gotta say it's amazing and thank you for the hard work.

I'm on build crop_rec_4k_mlv_snd_isogain_1x3_presets_2021Apr01.5D3113
As of today which crop modes support real-time correct framing? So far I could make 1920 1:1 work. Any chance for any of the ones with raised resolution?

Thank you for your answers.

GullRaDriel

  • New to the forum
  • *
  • Posts: 45
Re: Danne's crop_rec_4k, 5DIII
« Reply #961 on: September 09, 2021, 09:36:08 PM »
Hi Danne,
I'm willing to contribute but I'm unable to make a build from source.
Can you give me some pointers on how to build https://bitbucket.org/Dannephoto/magic-lantern_dannephoto_git/src on Linux Debian or Windows 10 (msys2 or cygwin) ?
Or do you have a pinned forum post explaining exactly this ?

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7236
Re: Danne's crop_rec_4k, 5DIII
« Reply #962 on: September 09, 2021, 10:32:48 PM »
What changes did you add?
Sorry, but unable to help but there are several guides on this forum about compiling.

names_are_hard

  • Developer
  • Senior
  • *****
  • Posts: 448
  • 200D idiot
Re: Danne's crop_rec_4k, 5DIII
« Reply #963 on: September 10, 2021, 12:13:14 AM »
GullRaDriel - walking you through building a repo is probably better suited for Discord.  You're likely to have a few problems along the way and it's slow fixing them one at a time on a forum.  I can walk you through build problems.  I don't know if cygwin works.  Debian definitely does, I use that.  Pretty sure WSL is known to work also.

trapshitkalci

  • New to the forum
  • *
  • Posts: 17
Re: Danne's crop_rec_4k, 5DIII
« Reply #964 on: September 13, 2021, 04:28:28 PM »
Having problem with the display preview in anamorphic mode. Latest built : 2021 Apr. 1 ,  LCD display preciew. Stays distorted whatever I try. I am on firmware 1.2.3. Can that be the problem ?  Was anamorphic mode tested on 1.2.3 ?
In RAW video submodule  Preview is set to Framing but the green icon in front is simply faded. Is that a bug in 1.2.3 which doesn't appears on 1.1.3 ?

Nnow tried it with firmware 1.1.3 and problem is solved ! I didnt pressed the INFO button enough times for getting the Magic Lantern view on my LCD display. To find this out it really needed e the 1.1.3. version cause the info bar on the bottom of the Framing Preview didnt said it  with the 1.2.3 It said couldn't able framing preview due to GlobalDraw.
5D MK3 1.1.3 and Danne's latest build with Sandisk Extreme CF card (120mb/sec reading speed, writing is less of course), 60D Nightly Build

GullRaDriel

  • New to the forum
  • *
  • Posts: 45
Re: Danne's crop_rec_4k, 5DIII
« Reply #965 on: September 15, 2021, 10:59:45 PM »
Danne: I did not make any change but following the guides led me to some errors. May be my fault/ bad arm version / etc

Okay, as stated I'm going to seek help on discord. See you in a few days !

ShittyWebsite

  • New to the forum
  • *
  • Posts: 26
Re: Danne's crop_rec_4k, 5DIII
« Reply #966 on: November 05, 2021, 07:34:14 PM »
Does silent pics works? i've tryied full res lv but it says it needs crop rec to be loaded (it dosent show any modules)

Maybe i did something wrong? (1.1.3)

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8254
Re: Danne's crop_rec_4k, 5DIII
« Reply #967 on: November 05, 2021, 07:36:34 PM »
Which file option is selected? DNG or MLV?

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7236
Re: Danne's crop_rec_4k, 5DIII
« Reply #968 on: November 05, 2021, 07:51:13 PM »
Does silent pics works? i've tryied full res lv but it says it needs crop rec to be loaded (it dosent show any modules)

Maybe i did something wrong? (1.1.3)
Crop rec is on always. I enabled most modules default and not as an option to the user to turn on or off in this build.

ShittyWebsite

  • New to the forum
  • *
  • Posts: 26
Re: Danne's crop_rec_4k, 5DIII
« Reply #969 on: November 05, 2021, 08:56:37 PM »
I'm using full-res LV, MLV

It says:

Full-res LV requires the crop_rec module loaded


Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7236
Re: Danne's crop_rec_4k, 5DIII
« Reply #970 on: November 05, 2021, 09:43:36 PM »
Did you try it to see if it works?

ShittyWebsite

  • New to the forum
  • *
  • Posts: 26
Re: Danne's crop_rec_4k, 5DIII
« Reply #971 on: November 05, 2021, 09:46:39 PM »
I also tryied using the experimental build

No files on the folder  :-[

Maybe a problem with the camera settings?

ShittyWebsite

  • New to the forum
  • *
  • Posts: 26
Re: Danne's crop_rec_4k, 5DIII
« Reply #972 on: November 05, 2021, 09:52:18 PM »
I also tryied using the experimental build

No files on the folder  :-[

Maybe a problem with the camera settings?

I just fully reset the camera and now everything works


Dammmn I'm stupid

ShittyWebsite

  • New to the forum
  • *
  • Posts: 26
Re: Danne's crop_rec_4k, 5DIII
« Reply #973 on: November 05, 2021, 10:33:07 PM »
ok.. the experimental build works for full res lv


danne's build works, but not full res (2080x1318)

https://imgur.com/a/HfFSA0G


edit:
maybe i should try to update to 1.2.3?




Thoracius

  • New to the forum
  • *
  • Posts: 3
Re: Danne's crop_rec_4k, 5DIII
« Reply #974 on: November 06, 2021, 12:19:31 AM »
I'm curious.. is 3x3 binning of the whole sensor possible (e.g. 1920x1280) or would that be too heavy to achieve reasonable frame rates?