Author Topic: Magic Lantern Cinema Camera - Dual ISO without aliasing & without quality loss!  (Read 33104 times)

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6933
Sorry, I still can't follow. You vaguely describe what you do and seemingly mix builds. One test says frozen other corruption.
If I undeestand clearly what you do maybe I can help.
Advice. Search the web for how to post most useful info reporting bugs and how to do helpful testing.

IDA_ML

  • Hero Member
  • *****
  • Posts: 864
Thank you! The main problem of this build (20Jul2019) is frozen preview.

I will try to explain this preview freezing issue in some more detail: 

It happens when focusing.  Unfortunately, focusing while in video mode is not reliable enough. To achieve precise focus (absolutely important !!!), I switch to photo mode.  This allows me to get a very detailed 10x magnification and I can focus precisely either manually or by pressing the back button.  Once I have achieved perfect focus, I switch back to video mode to start recording and here is where the trouble happens.  Preview changes to stretched and freezes upon pressing the record button.  The only way out of this situation is to turn camera off and on again.  This wastes a lot of time and the moment is gone.

Another bug:
========

Camera freezes badly when trying to switch to Dual ISO while in video mode.  Not even a battery pull helps.  The only possibility to activate Dual ISO is to turn camera off, switch to photo mode, turn it on again, activate Dual ISO, turn it off again, switch to video mode, turn it on again and then you can start recording in Dual ISO.   

Both of the above instabilities are well reproducible.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6933
New builds 5D3:
https://www.magiclantern.fm/forum/index.php?topic=23041.msg216899#msg216899

- Reduces 1x3 preset fps to 17fps to get rid of compression errors.
Can´t reproduce any freezes or other instabilities described.
If testing this build do not mix modules from other builds.



I will try to explain this preview freezing issue in some more detail: 

It happens when focusing.  Unfortunately, focusing while in video mode is not reliable enough. To achieve precise focus (absolutely important !!!), I switch to photo mode.  This allows me to get a very detailed 10x magnification and I can focus precisely either manually or by pressing the back button.  Once I have achieved perfect focus, I switch back to video mode to start recording and here is where the trouble happens.  Preview changes to stretched and freezes upon pressing the record button.  The only way out of this situation is to turn camera off and on again.  This wastes a lot of time and the moment is gone.

Another bug:
========

Camera freezes badly when trying to switch to Dual ISO while in video mode.  Not even a battery pull helps.  The only possibility to activate Dual ISO is to turn camera off, switch to photo mode, turn it on again, activate Dual ISO, turn it off again, switch to video mode, turn it on again and then you can start recording in Dual ISO.   

Both of the above instabilities are well reproducible.
I cannot reproduce any of above described issues. Are you sure you aren´t thinking of your 100D?
- AF works while recording(but I would never use it. Way to slow)
- No freezes at all doing whatever with dualiso module

Instead of arguing please upload a screen recording of your exact steps reproducing your issues. Saves me a lot of testing time.
I would advice you to use the x10 focus aid instead of going in and out of photo mode using back focus button etc.

IDA_ML

  • Hero Member
  • *****
  • Posts: 864
Danne,

I experienced the described issues all the time with the July 20-th build.  As described, they are clearly reproducible here, at least most of the time.  I am not arguing and not thinking of the 100D.  Nor do I mix modules.  I used the build as downloaded from your download area.  Will test your today's build as soon as the 5D3 is available again. 

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6933
Screenrecordings of exact steps needed. Not old tests reported in a complete new context. Confusing.

IDA_ML

  • Hero Member
  • *****
  • Posts: 864
I can now confirm that Danne's latest 5D3 build (Oct. 13-th) works very well with Dual ISO.  Camera remains stable when switching Dual ISO on and off in video mode. 

@Danne
It would be very helpful if you activate also the "Slow shutter" option, (currently working only on the EOS-M and the 100D).  This function is of crucial importance to silky smooth timelapse videos since it allows very low shutter speeds - down to 2,5 s/frame.  Currently, the slowest 5D3 shutter speed is limited to 1/33s.  In view of the beautiful fall colors outside, I am sure that many 5D3 users, willing to create beautiful timelapse videos, will greatly appreciate the Slow shutter function.

Thanks.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6933
Slow shutter is applied to presets with reduced fps when enabled. Could be tested by enabling it and 1x3 17fps preset. Shutter shgould be able to go as slow as 17fps. Slow shutter can be reached from the crop mode sub menu.

Correction: Enable "Shutter range" to full range. Slow shutter is only applied to eosm and 100d, different context.

IDA_ML

  • Hero Member
  • *****
  • Posts: 864
Slow shutter is applied to presets with reduced fps when enabled. Could be tested by enabling it and 1x3 17fps preset. Shutter shgould be able to go as slow as 17fps. Slow shutter can be reached from the crop mode sub menu.

Correction: Enable "Shutter range" to full range. Slow shutter is only applied to eosm and 100d, different context.

I am not sure I understand what you are saying.  On the 100D, when I selected 4k/1fps in the Full-Res LV mode, the shutter speed was reduced to 0,8 s. or similar - very close to 1 s.  I was unable to do the same on the 5D3.  It all the time defaults to 1/33 s.  Is it possible to achieve 1 s. shutter speed on the 5D3 and if yes, do I have to use the 1x3 17fps preset for that?  Even if it may be possible to go down to 17 fps as you suggested, this is still too fast.  Something between 5 and 1 fps is needed for Full-res LV and going even further down to 0,4 fps for low-light timelapses would be highly desirable.   

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6933
What you ask for is already working.
1 - select a preset
2 - enable fps override to whatever
In movie modes generally you can't go below 1/30s but:
3 - set 'Shutter override' to Full range and it will go as slow as fps override is set to.

Don't forget. Canon menu button is your friend so don't forget to push that once or twice.

IDA_ML

  • Hero Member
  • *****
  • Posts: 864
OK,  I understand now.  I was just too scared to touch fps override.
Right now I am at work but have not returned the 5D3 yet.  Good opportunity to test this wonderful feature.  Thanks a lot, Danne!

theBilalFakhouri

  • Contributor
  • Hero Member
  • *****
  • Posts: 537
  • I am not active currently
The problems:
-Very stretched LiveView

Spoiler Alert.
700D 1.1.5 | no more ISOless LV err 8 / SDR104 @ 240 MHz - Constant! | Fixed Scrambled LiveView in Higher resolution | Real-Time correct framing in the Way

Grognard

  • New to the forum
  • *
  • Posts: 24
It means you have fixed the liveview in 1x3... :o
What a great periode for ML!

ArcziPL

  • Contributor
  • Member
  • *****
  • Posts: 148
theBilalFakhouri have you already tried finding a way to enable the 3x3 binning on 700D? :D
70D.112 | M50.102 | M.202

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6933
theBilalFakhouri have you already tried finding a way to enable the 3x3 binning on 700D? :D
3x3 binning, mv1080p?

Teamsleepkid

  • Member
  • ***
  • Posts: 244
The goat
EOS M

theBilalFakhouri

  • Contributor
  • Hero Member
  • *****
  • Posts: 537
  • I am not active currently
It means you have fixed the liveview in 1x3... :o
What a great periode for ML!

Yes, but at 1504x1782 resolution ~2.50:1 AR , that's the sweet spot for the preview.
700D 1.1.5 | no more ISOless LV err 8 / SDR104 @ 240 MHz - Constant! | Fixed Scrambled LiveView in Higher resolution | Real-Time correct framing in the Way

theBilalFakhouri

  • Contributor
  • Hero Member
  • *****
  • Posts: 537
  • I am not active currently
theBilalFakhouri have you already tried finding a way to enable the 3x3 binning on 700D? :D

Instead of Line Skipping? Like 5D3 1080p 3x3?
700D 1.1.5 | no more ISOless LV err 8 / SDR104 @ 240 MHz - Constant! | Fixed Scrambled LiveView in Higher resolution | Real-Time correct framing in the Way

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6933
With unstretched 1x3 binning h264 should look the same? Too bad h264 doesn't record in x5 zoom. This leaves us wondering if we could unstretch footage in 1x3 starting from movie crop mode as done with eosm.

EDIT: The same question but when HDMI monitor is used. Maybe possible to record aliasing free?

theBilalFakhouri

  • Contributor
  • Hero Member
  • *****
  • Posts: 537
  • I am not active currently
The preset doesn't work in mv1080 mode, only works in x5 Mode, we can't record H.264 there, in LiveView it looks oversampled it gives fake aliasing, same when using HDMI, I think this could be fine-tuned by these registers for fixing pixelated LiveView after stretching.
700D 1.1.5 | no more ISOless LV err 8 / SDR104 @ 240 MHz - Constant! | Fixed Scrambled LiveView in Higher resolution | Real-Time correct framing in the Way

theBilalFakhouri

  • Contributor
  • Hero Member
  • *****
  • Posts: 537
  • I am not active currently
However we can nail the focus using the fake aliasing in LiveView, better than focus peaking :D
700D 1.1.5 | no more ISOless LV err 8 / SDR104 @ 240 MHz - Constant! | Fixed Scrambled LiveView in Higher resolution | Real-Time correct framing in the Way

Teamsleepkid

  • Member
  • ***
  • Posts: 244
Love the live view so far. How’s it going with the black bar on the right? Not complaining I’ve been using a smaller 16x9 frame and it seems to fit without going into the black bar area. Anything that we can try regarding the 1x3 anamorphic mode? Did you get it unstreched?
EOS M

theBilalFakhouri

  • Contributor
  • Hero Member
  • *****
  • Posts: 537
  • I am not active currently
Love the live view so far. How’s it going with the black bar on the right? Not complaining I’ve been using a smaller 16x9 frame and it seems to fit without going into the black bar area. Anything that we can try regarding the 1x3 anamorphic mode? Did you get it unstreched?

No luck yet with solving black bar issue, I got 1x3 anamorphic mode unstretched :D
700D 1.1.5 | no more ISOless LV err 8 / SDR104 @ 240 MHz - Constant! | Fixed Scrambled LiveView in Higher resolution | Real-Time correct framing in the Way

theBilalFakhouri

  • Contributor
  • Hero Member
  • *****
  • Posts: 537
  • I am not active currently
New Modes with Correct Preview:

1- 1x3 Anamorphic *1504x1782 ~2.50:1 AR (4512x1782 After de-squeezing):


- *1504x1782 is the sweet spot for the preview.
- I call this the Quality Mode.

Well, Have fun :D 1x3 Binning with un-stretched correct preview :D

Edit: 17-9-2020:
1- With the recent developments now we can get full SD UHS overclock, max write speed on 700D would be ~68 MB/s in video mode, also we can record at 10-bit lossless using the Analog Gain too, that means continuous recording at some high resolution presets.
2- Recently I worked on LiveView especially the Preview part, now there is new 1x3 mode with Correct Un-Stretched Preview, you can find it Here.
700D 1.1.5 | no more ISOless LV err 8 / SDR104 @ 240 MHz - Constant! | Fixed Scrambled LiveView in Higher resolution | Real-Time correct framing in the Way