Author Topic: MLTools (OsX utility to manage ML install, files import and scripts conversions)  (Read 60298 times)


  • Member
  • ***
  • Posts: 144
  • 5D2
.R00 is not yet implemented, will look at it too.
You may want to take a look at THIS (and the following posts. Since the problem about spanned files has been solved there.
5D2 ML RAW + VAF-5D2b:


  • New to the forum
  • *
  • Posts: 4
i am having trouble using the .sh script files created by ML when doing HDR
osx 10.8 macbook pro2012
xcode installed
command line tools installed

when i run them in terminal i get :

Last login: Wed Jul  3 18:46:24 on ttys001
/Users/macbook/Desktop/jpeg_backyard_6_24_13\ 3/HDR_0496.SH ; exit;
FullSail-W89240P8644:~ macbook$ /Users/macbook/Desktop/jpeg_backyard_6_24_13\ 3/HDR_0496.SH ; exit;
/Users/macbook/Desktop/jpeg_backyard_6_24_13 3/HDR_0496.SH: line 5: align_image_stack: command not found
/Users/macbook/Desktop/jpeg_backyard_6_24_13 3/HDR_0496.SH: line 6: enfuse: command not found
rm: HDR_AIS_0496*: No such file or directory

[Process completed]

and when i open MLTools:

pippip already installedalign_image_stackalign_image_stack is missingenfuseenfuse is missingconvertconvert already installedwgetwget already installedufraw-batchufraw-batch already installedmplayermplayer already installednumpynumpy already installed PILPIL is missing prepare.Lion.scpt: execution error: AppleScript Runner got an error: "username" doesn’t understand the «event panSdlog» message. (-1708) Import file: nothing

do i misunderstand what MLTools does? i thought i would make the .sh files run correctly?

please help
thanks a bunch i know everyone working on ML and MLTools is doing it for free on their own time any help you can give me is going above and beyond


  • New to the forum
  • *
  • Posts: 4
I think i've found the easy solution to my question at least for anyone running 10.8 or in my case 10.8.4 . sorry if somewhat unrelated to ML tools original post but in my search of how to make to bash scripts for hdr from ml work this is the only thread that even got close to dealing with the subject.

Big ups to my boy suds who is a wizzard with many programming things that make this look like nothing :

What you need to do is first set your environment variables.

1) Open Terminal
2) type `cd` and press enter, this will take you to your users home directory
3) type `sudo open -t .bash_profile`, this may ask you for your password
4) Copy in the text below

export PATH="<path_to_hugin_tools>/bin:$PATH"

5) Save the file and close it

That should be all you have to do. You will need to restart terminal if you want to run the scripts directly from terminal, if you run the scripts from finder using terminal, you should be good.

the hugin tools referenced here come from the latest distro of hugin for osx and it is referring to the hugin folder that is the command line tools.

i saw another post before mine with similar issues specifically with a library that is resident in osx that isn't up the the same version as what hugin uses if you set the environment variables correctly it will reference the lib that is included in the hugin tools.
hope this helps someone.


  • Just arrived
  • *
  • Posts: 1
Ahh, thank you leebeau!!

That was the last missing piece.

For the record, you need to
1. Download Hugin:
2. Set your terminal environment variables to include the path to HuginTools folder
    I have everything from the 2013 Hugin download in a folder called "Tools" in my Applications folder, so I added the following to my .bash_profile

export PATH="/Applications/Tools/HuginTools:$PATH"

This should enable the use of align_image_stack, enfuse, … everything you need to run the shell scripts

Also, for the record you can run the shell scripts by cd'ing to the folder you have then and running

or whatever the file is named obviously


  • New to the forum
  • *
  • Posts: 32
I have little trouble using the MLP.

I've copied all my RAW files to my LACIE disk, but then i right click i don't get the Services tab. When i right click on a random folder on my desktop, i do however get the Services tab.

I only see the Services if i right click a folder from the Desktop. If i go inside that folder and right click i don't get Services.

Why is that?