Camera looks like bricked? First things to try for restoring it.

Started by scrax, August 20, 2012, 09:56:52 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


If your camera is having failure when using ML there are some standard procedure to do for solving and investigate the problem.

bad shutdown
Switch camera Off, remove: battery, card and lens.
Reattach lens, close card slot, reinsert battery and switch camera On again

card failure
Restart camera without any card,
if camera starts ok format the card on Pc and then try it on camera

bad ML config
restart camera (default settings start-up)

Startup mode problem
Try to start up the camera in every dial mode

I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus | EOS 5D MLbeta5- EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX, PS, LR, RawTherapee, LightZone -no video experience-


I installed magic lantern and then when removing the memory the camera stop working.
Now is ok but I can't install again the ML because when I put the memory with the firmware the camera does not turn.

Do you know how I can fix it?
Sorry my English.


reformat the card in the computer,
then put it back in the camera and format it in the camera,
then use EOSCard or macboot to set the bootflag on the card
then put the ML files on the card

if it still doesn't work you might have damaged the card, try another one.

You don't need to 'reinstall' ML b/c you already have the camera bootflag set.


hey guys, first post so don't bash too hard.

so i think i bricked my 7D after using ML for a few days, tried all the above steps and the camera is completely unresponsive. if anyone has any advice it would be greatly appreciated!!
There are 10 types of people in this world, those that understand binary and those that don't.

Walter Schulz

Okay, basics first:
You're absolutely sure your battery is ok? You have removed battery and reinserted it? Tried different batteries? No battery grip involved?
Startup without card inserted.

If you insert a card, close compartment and turn the cam on is the LED flashing?

Sorry, if you already tried this but please try again.


hey Walter,

thank you for getting back to me so quickly. sorry for the scare but it turned out my battery had died. what threw me off was that i do have a battery grip, and thinking maybe one battery had died i had tried the second battery, but didn't think about the fact that they both could be dead. so i charged one up and threw it in and viola! it works perfectly.

thanks again for helping me out though  :)
There are 10 types of people in this world, those that understand binary and those that don't.


Hi there,
My first try with ML firmware on my 5D Mk2 was scary - I downloaded the 2nd-to-latest nightly build as the latest link wasn't going anywhere.
I extracted the zip file and as instructed, copied the resulting folder onto the formatted memory card.
When I tried updating firmware the camera told me I need to have a firmware file on the card.
Next I tried copying the files a level down to the card, but must have mucked something up, as when installing I got the error message: (something like) can't see the CROPMKS folder.
The screen went black and stayed that way no matter what I tried. It has been a fairly stressful Sunday afternoon, :'( but this is what finally worked:

1/ Remove small memory battery (take tiny screw out first!!!)
2/ Remove main battery and CF card and close all doors on camera (not the house)
3/ Switch camera on and push every button on it one by one to help discharge residual power
4/  On my computer I opened the magiclantern-Nightly.2015Apr28.5D2212 folder that I downloaded and extracted (the second time I used Stuffit Expander instead of Zipeg) and copied everything WITHIN that folder to the CF card: (ML folder and 2 other files)
5/ I inserted the CF card, plugged in the small memory battery, put the main battery in.
6/ I switched the camera on, and was so relieved to be able to set the date / time, etc, and then use the camera.

Sadly, the 2 things I wanted the firmware update for: Auto ISO on Manual, and Auto focus when filming were both not there.
I thought someone would have figured this out by now.

Walter Schulz

1: Completely unnecessary. It's clock battery.
3: Unnecessary, too.

To sum it up: After you followed instructions it worked.

And you might want to explore module

dushyant bhatt

hello all I bricked my 5D Mark III 2020 sep 28,. I was on ML 1.1.3 but it turns on at times at time it is unresponsive.. I was lucky to upgrade it to 1.2.3.. but still the camera is not responding most times,. it work at times / most times it wont turn on... I badly want ML on my camera & which works ... Can someone please help ??

Walter Schulz

Remove cards, remove battery.
Insert battery. Do not insert cards. Close compartment doors.
Try to startup cam. Are you able to start cam in this mode?

If camera stucks most of the time but you are able to get the cam started after several attempts: Do not turn off cam. Don't even touch power switch! Just open battery slot, remove battery. Insert battery and close hatch. The cam should startup normally. Right? Repeat procedure a few times!
Report back, please.

John Latter

Quote from: scrax on August 20, 2012, 09:56:52 PM
If your camera is having failure when using ML there are some standard procedure to do for solving and investigate the problem.

...bad ML config
restart camera (default settings start-up)...

This is the one that worked for me - thank you so much for the info :)

I had been particularly worried because I had tried to insert the SD card the wrong way around in my 600D the day before I discovered my camera was dead and thought I had done some physical damage to the card slot.

So relieved that I hadn't! (mind you, I wouldn't mind updating my 600D to something with GPS, WiFi, touch screen, etc., etc. - just gotta find the pennies first.)

John Latter


Hi guys, I am not sure whether this forum is still active but I would be very grateful if anyone sees this and would lend a helping hand or just any advice would be great.

I may have bricked my canon 70D, it happened after i turned off the camera and immediately switch it back on and off again (because i was blurred and thought i did not switch it off).
And, i believe i have CARD WARM UP turned on....not sure if that was the culprit...Also a bit of context i have been using ML for around 2 months, everything was fine this is the first incident.

It just doesnt start at all anymore. Unlike what i have read over here, there is nothing on display, no error messages, no nothing.
Once in a while when i put the battery in the card slot it would blink ONE time. That's it, but all still blank.

Tried and failed:
1) I read the forum and tried removing card, battery and lens, reattaching lens to turn on without the card. No avail, now not even a single blink on the card slot.
2) I tested my battery and card on another 70D from a friend, both working fine, the pictures are also still there in the memory card.
3) I have tried using another battery and card from my friend as well, the camera still show no response.

I understand i may need to upload a log file for better troubleshooting, if anyone sees this please let me know what files should i upload. Thank you in advance...

Walter Schulz