Author Topic: MLV App 1.11 - All in one MLV Video Post Processing App [Windows, Mac and Linux]  (Read 418119 times)

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1593
In the ML menus, the black level is always set to "0" even if I change the bit depth. Is it still setting the correct value in the metadata then?
Sry, no idea what your talking about. Where do you see or set the black level in ML menu? "0" will never be correct (with a Canon cam) and will lead to pink shadows.
5D3.123 | EOSM.202

Milk and Coffee

  • Freshman
  • **
  • Posts: 81
Sry, no idea what your talking about. Where do you see or set the black level in ML menu? "0" will never be correct (with a Canon cam) and will lead to pink shadows.
Its in "Movie">"Image Fine-Tuning." Whats the use of changing the black level in ML menus?

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1593
Its in "Movie">"Image Fine-Tuning." Whats the use of changing the black level in ML menus?
This is an offset to the coded black level. You can adjust it, if you think you have a better value. The adjusted blacklevel is then automatically in all MLVs you record, and you mustn't adjust it in every single clip in post.
5D3.123 | EOSM.202

Milk and Coffee

  • Freshman
  • **
  • Posts: 81
I see! Thank you. I don’t see an advantage for it. Is it probably best to leave it at “0”?

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1593
I see! Thank you. I don’t see an advantage for it. Is it probably best to leave it at “0”?
Only you can answer this question. Please record a MLV, open it and watch the darkest shadows. If they are black: leave it as is. If they are pink or green: adjust it.
5D3.123 | EOSM.202

ilia3101

  • Moderators
  • Hero Member
  • *****
  • Posts: 921
This setting represents black level offset, and I think it only affects normal video. It can be used to make your videos look awful, works great in combination with edge emphasis.

motionSOUL

  • Freshman
  • **
  • Posts: 52
Do someone has succeeded in using Cinelog-C from MLV App?
This is my primary tool to get log files from After Effects but my workflow is a bit cumbersome:

Canon 5DMKIII -> MLV Files -> Switch.app -> DNG Files -> After Effects / Cinelog-C -> ProRes4444 Files -> Let's start working or go to sleep ;-)

Thanks,

S/.

adrjork

  • Member
  • ***
  • Posts: 175
Hi everyone, my dual-iso clips have lines and flickering also after the conversion (MLV to DNG)... ???
When I upload the dual-iso clip, MLV-App's dual-iso panel is grey. The only button I can clic is “Force”. So, I clic on Force and then on ON. I tested both Interpolation_Mean + Alias_Off and Interpolation_AMaZE + Alias_ON. The result is that after the onversion from MLV to DNG, lines are still visible together with flickering.
I tried also Swicth (all defaults, but 15 dualiso automation enabled) and the result is the same...
Any advice, please?
Thanks in advance.

Luther

  • Senior
  • ****
  • Posts: 313
Do someone has succeeded in using Cinelog-C from MLV App?
Cinelog-C is proprietary. MLVApp can't legally put their DCP in there...

Hi everyone, my dual-iso clips have lines and flickering also after the conversion (MLV to DNG)... ???
Which camera and build are you using? Also, if possible, provide a MLV sample...

ilia3101

  • Moderators
  • Hero Member
  • *****
  • Posts: 921
Cinelog C is a log colourspace with Cineon curve and Alexa RGB primaries right? MLV App can do the Alexa RGB gamut. Only it doesn't do the Cineon log curve, supposedly it's best for shadows, but all log curves look the same to me.

So I think you can get close enough. Only difference with using mlv app is that your using mlv app and not Adobe camera raw, which has better noise handling I think. But compare and decide for yourself.

adrjork

  • Member
  • ***
  • Posts: 175
Which camera and build are you using? Also, if possible, provide a MLV sample...
My cam is a 5D3, and build should be Nightly.2017Feb12.5D3123
HERE the link of the MLV-dualiso (it's a 6GB file I compressed in .7z with Keka). If you want, I can also upload some frames/dngs of the conversion. Anyway, converting into both dngs or mov give the same result: horizontal lines are reduced but still visible (mainly on the ancient stone columns in the image), and flickering is evident.
More or less, all my dual-iso shots have the same issue, and it seems not to be an MLV-App's specific issue because also Switch gives a very similar result (lines, flickering...)
Thanks a lot.

Luther

  • Senior
  • ****
  • Posts: 313
My cam is a 5D3, and build should be Nightly.2017Feb12.5D3123
You're using a very old build. Try the lastest @Danne's build.

adrjork

  • Member
  • ***
  • Posts: 175
You're using a very old build.
Thanks Danne, I'll change the build. But what about my old dual-iso shots? Unusable?

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6622
You're adressing Luther? But it's my build.
I havn't checked your file. Sorry. Left the dualiso movie wagon long time ago.

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1593
My cam is a 5D3, and build should be Nightly.2017Feb12.5D3123
HERE the link of the MLV-dualiso (it's a 6GB file I compressed in .7z with Keka). If you want, I can also upload some frames/dngs of the conversion. Anyway, converting into both dngs or mov give the same result: horizontal lines are reduced but still visible (mainly on the ancient stone columns in the image), and flickering is evident.
More or less, all my dual-iso shots have the same issue, and it seems not to be an MLV-App's specific issue because also Switch gives a very similar result (lines, flickering...)
Thanks a lot.
I downloaded your clip and tried my luck. Something is really wrong with it, but I can't tell exactly what. Vertical Stripes Fix completely fails with it and dualiso as well. If you disable Vertical Stripes Fix and if you set dualiso to "Preview" it looks not too bad. For flickering you'll have to search another solution.

You should try a new build.

But what about my old dual-iso shots? Unusable?
You should always test your settings before you record important clips. Otherwise you might get into trouble and you'll have to search for very difficult solutions.
5D3.123 | EOSM.202

adrjork

  • Member
  • ***
  • Posts: 175
I downloaded your clip and tried my luck. [...]
First of all, thanks really a lot for your help and your time. In the future I'll surely follow your advice of testing builds first. (For the flickering I have in mind a couple of solutions: perhaps Davinci deflicker could work, or perhaps a little workflow's detour towards LRTimelapse...)
You're adressing Luther? But it's my build.
Actually, Luther very kindly advised me to change my old build for your newer build (that's what I'll surely do!)
Anyway, finally I've found out that my two problems (dual-ISO here in this topic, and the case of the different DNGs from the same MLV in Switch topic) are actually one single issue: simply my dual-ISOs. I've posted a screen record HERE, as you asked me.

reddeercity

  • Contributor
  • Hero Member
  • *****
  • Posts: 2215
@adrjork check your clip you posted and I had no problem converting the Dual ISO file with MLVFS on my win7 desktop , It's Cross platform (PC/Mac)
There no lines/stripes etc. .... 
That all I use when comes to Dual ISO .

Here the dng extracted with MLVFS
P3.borso-180911-1011zR.DI_000000.dng

I ran it thought UFRaw to do a quick adjustment , it uses dcraw in the backend , it's also cross platform .



link to full res (1920x1080) png P3.borso-180911-1011zR.DI_000000.png
also here the P3.borso-180911-1011zR.DI_000000.ufraw that UFRaw export with the save PNG .

One last thing , The flicker you have in the dual iso "could" have been fixed if you would has turn on the de-flicking in dual iso module .
edit: I'll keep the link up to the files for a 7 days 

adrjork

  • Member
  • ***
  • Posts: 175
Really thanks reddeercity for your help.
But... It sounded too good to be true in a “usable” way: after your post I tried immediately MLVFS and the result is: dual-ISO “Full” on-the-fly crashes/stops Davinci, only dual-ISO “Preview” works on-the-fly (on my machine at least). I tried also setting dual-ISO “Full”, then copying the DNG-folder to save it as “offline”, and then importing into Davinci (it works, but the result is apparently not SO different from Preview).
Anyway, the result is almost unusable: some frames are good, but the flickering is horrible, and the worst thing is that during the “flicks” you can clearly see the horizontal lines suddenly appear (it's like an old damaged CRT TV... it looks like young Chris Cunningham set my camera...)
I tried to use Davinci's deflicker to limit the problem, and it does something, but not too much...
This is the result:
I think that perhaps I could export deflickered DNGs from Davinci, and then trying to do a final adjustment in LRTimelapse, but even if it improves brightness stability, there are still the lines that appears time to time (the “flicks”). Any other idea is very welcome :)

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1593
The dual iso processing algorithms between MLVFS and MLVApp are mostly identical, as far as I know.
5D3.123 | EOSM.202

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1632
  • 6d - Nightly build user
Strange, the difference in results between MLVFS/MLVApp/Switch
Downloaded the big dualiso MLV file and loaded it with MLVFS on my mac...doesn't look as good as the frame reddeercity posted  ???
Still got the horizontal black lines...

Now I'm wondering, where does MLVFS get his cr2hdr source.
Can't find it in the contents folder, or is it baked in in the mlvfs file itself ? 

Further I'm wondering, could it be that reddeercity has somehow a different version of cr2hdr (baked in his version of mlvfs) then other people are using ?

EDIT and if so, I want that particular cr2hdr version reddeercity is using, but macOS ofcourse  ;D

70MM13

  • Senior
  • ****
  • Posts: 413
i just tuned in to this discussion and i am wondering if this is the same issue i ran into when i shot some footage using dual iso in one of my ttt episodes last year...

if so, it is possible to "cherry pick" good frames where the problem is not visible.

could that be what's happening here?

if memory serves, i very slightly improved the problem in the footage by using cr2hdr with the command line and forcing some setting i cannot remember.  but it didn't fix the footage, it only slightly improved it.  i have never used dual iso since.  it might be useful for certain footage but the results are not great on detailed and important scenes, and it is not enjoyable to wonder if the footage will be good or not!

it's a sad thing because it has a lot of promise as a feature.

of course, YMMV...

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1632
  • 6d - Nightly build user
I've lately had the same problem as you describe, a few dual-iso's that are bad. But you could "cherry pick" some good frames out of it.
So some frames are good, most are really bad...

But that's not what is happening here, reddeercity posts frame P3.borso-180911-1011zR.DI_000000.dng, so the very first frame of the MLV file.
I have downloaded that same MLV file, opened it with MLVFS (on macOS) and I don't get the good results reddeercity is getting, while looking at the same frame (000000.dng)
I get the same shit adrjork posts  :P

So something weird is happening, reddeercity is able to get normal results out of a dual-iso MLV file, while most others here on the forum can't get any usable frames out of it ???
What is happening here ?

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6622
Could we get a shortened file, maybe 20 frame mlv?

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1632
  • 6d - Nightly build user
Converted with mlvdump to 20 frames MLV file (76Mb)
http://drive.google.com/file/d/1GCa_Y3dczpVH2zjoDkiQJnK4D1xH4XwG/view?usp=sharing

EDIT, clicking on my own link, to check, and what...google shows a preview of the MLV file format  :o

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6622
Wtf! Google decodes MLV. Cool!